21:03:43 <ttx> #startmeeting
21:03:44 <openstack> Meeting started Tue Jun 12 21:03:43 2012 UTC. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:44 <bcwaldon> ttx: fire him!
21:03:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:53 <ttx> bcwaldon: can't, he is my boss.
21:04:03 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:04:14 <ttx> #info 3 weeks left until the milestone-proposed cut for Folsom-2 (July 3)
21:04:26 <ttx> #topic Actions from previous meeting
21:04:33 <ttx> * ttx to point Swift distro packagers to required config changes in Swift 1.5.0: DONE
21:04:52 <ttx> For completeness: see https://lists.launchpad.net/openstack/msg12754.html
21:04:58 <ttx> * bcwaldon to set assignees for glance-client-parity and streaming-server specs: DONE
21:05:02 <ttx> * jog0 to update status for general-host-aggregates bp: DONE
21:05:06 <ttx> * ttx to fix jgriffith access to bp updating: DONE
21:05:12 <ttx> * lzyeval to update status of ec2-id-compatibilty bp: DONE
21:05:21 <ttx> * vishy to contact assignees for config-drive-v2, delete-in-any-state and user-configurable-rbac and confirm F3 targeting
21:05:39 <ttx> looks DONE now
21:05:44 <ttx> #topic Keystone statu
21:05:47 <ttx> s
21:05:49 <ttx> :)
21:05:53 <ttx> heckj: o/
21:05:53 * heckj waves
21:06:03 <ttx> welcome back :)
21:06:04 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-2
21:06:16 <ttx> Got a few questions for you
21:06:20 <heckj> shoot
21:06:24 <ttx> * https://blueprints.launchpad.net/keystone/+spec/stop-ids-in-uris (Guang Yee)
21:06:36 <ttx> How is that going ? termie said last week he didn't understand why that was needed, or "essential"...
21:07:10 <termie> ttx: the best description i have run into was that people are worried about token ids leaking in logs
21:07:10 <heckj> That blueprint will be dealt with in the V3 API, shouldn't be listed as essential. Certainly won't be done by this milestone at the rate we're going.
21:07:20 <heckj> termie: correct
21:07:31 <ttx> heckj: downgrade to "High" ?
21:07:46 <heckj> ttx: done
21:07:49 <ttx> cool
21:07:52 <termie> while i feel like that is probably nice to think about, i also don't think our tokens are long-lived enough for that to matter much
21:08:00 <ttx> * https://blueprints.launchpad.net/keystone/+spec/implement-v3-core-api (heckj)
21:08:11 <ttx> how is it going so far ?
21:08:20 <ttx> ...and how likely is it to be completed within the next 3 weeks ?
21:08:38 <heckj> ^ still working through draft updates, so no initial work has started here. Given the timing, I suspect it's not going to be done this milestone, and we'll need to delay it
21:08:38 <uvirtbot> heckj: Error: "still" is not a valid command.
21:08:54 <heckj> will retarget the BP
21:08:54 <bcwaldon> uvirtbot: thanks for the update
21:08:55 <uvirtbot> bcwaldon: Error: "thanks" is not a valid command.
21:09:21 <heckj> one of these days I'm going to have figure out what that thing does
21:09:34 <bcwaldon> heckj: it's a bender
21:09:50 <markwash> insert girder?
21:09:59 <bcwaldon> 31 degrees, 32 degrees
21:10:01 <ttx> * https://blueprints.launchpad.net/keystone/+spec/keystone-ipv6-support (ayoung)
21:10:19 <ttx> Not started either ? Any chance /that one/ will be in F2 ?
21:10:35 <ayoung> ttx, my vote is no
21:10:37 <heckj> ttx: no progress as yet, expected as documentation on a deployment option in documentation. Quite possibly.
21:10:51 <heckj> Or not, if ayoung says...
21:10:55 <ttx> heh
21:11:06 <ayoung> ttx, IPv6 support is not there yet in upstream Eventlet. I suggest that if someone wants it, they use HTTPD for the near term
21:11:19 <heckj> will retarget that too
21:11:23 <ttx> note that you're preparing yourself a large F3 plate, which is not really the best idea in the world :)
21:11:40 <heckj> didn't say I'd retarget that to F3
21:11:51 <ttx> ayoung: if the implementation of that bp depends on ipv6 support in eventlet... sounds a bit far away to me
21:11:59 <ttx> heckj: ack
21:12:06 <heckj> removed from any milestones or series for now
21:12:14 <ttx> * https://blueprints.launchpad.net/keystone/+spec/rbac-keystone (dolphm)
21:12:22 <ttx> Slow progress, does that mean it might miss F2 too ?
21:13:12 <ttx> ..or that there are still 3 weeks left after all ?
21:13:17 <heckj> That will likely split per this mornings keystone meeting
21:13:46 <ttx> cool. Split is good, couldn't actually figure what work was involved in this one
21:13:52 <ttx> heckj: anything else ?
21:13:54 <heckj> The implementation of an API supporting RBAC will be tied to V3 API, but we'll also be documenting and setting some defaults, suggested values for policy.json and implementing a policy engine in keystone itself
21:14:10 <ttx> so APIv3 is the big blocker IIUC
21:14:31 <heckj> Quite a bit of the desired feature work is dependent on it
21:14:52 <ttx> heckj: any other comment ?
21:15:05 <heckj> nope
21:15:08 <ttx> Anyone else, questions about Keystone ?
21:15:19 <ayoung> ttx, BTW, that blueprint should really be for IPv6 support across all Openstack projects that are based on Eventlet
21:16:07 <ttx> ayoung: should probably be filed as separate blueprints... since there is no need to roll it all out at the exact same moment
21:16:25 <ttx> #topic Swift status
21:16:32 * chmouel waves
21:16:33 <ttx> chmouel: yo
21:16:47 <ttx> I just had a question about the python-swiftclient split, how far is it from completion ?
21:17:09 <chmouel> it's done since bcwaldon merged the review on glance
21:17:25 <chmouel> there seem to be some problem with the functional tests
21:17:30 <chmouel> which I am going to work on
21:17:34 <ttx> chmouel: was the client lib removed from swift proper ?
21:17:38 <chmouel> yes
21:18:03 <ttx> devcamcar: does that affect horizon ?
21:18:09 <chmouel> I have logged a bug on horizon to have a look at it so they can switch from cloudfiles
21:18:11 <ttx> or did you anticipate it ?
21:18:19 <ttx> ok.
21:18:20 <chmouel> they are not using swift.common.client
21:18:22 <chmouel> but python-cloudfiles
21:18:23 <devcamcar> ttx: no, we've been using python-cloudfiles
21:18:35 <ttx> oh, so that's actually good news for you :)
21:18:40 <devcamcar> we do plan to move to python-swiftclient when this all settles
21:18:54 <chmouel> well python-cloudfiles is somewhat slower than swiftclient :)
21:19:25 <ttx> chmouel: could you post to the ML when the final bits land ? This will affect distros
21:19:45 <chmouel> ttx: yes I was planning to do that just after this meeting
21:19:45 <ttx> they should anticipate the work, before 1.5.1 is released
21:19:49 <ttx> awesome
21:19:58 <chmouel> so another thing
21:20:02 <chmouel> There has been some discussion to have devstack gating on swift commits
21:20:03 <ttx> #action chmouel to post about python-swiftclient separation to the ML
21:20:26 <chmouel> and we still need to look over how's that going to work
21:20:57 <chmouel> so I am going to get in touch with the CI to understand how's that going to work with the swift specifics
21:21:06 <Ravikumar_hp> question: any documentation on python-swiftclient
21:21:25 <chmouel> Ravikumar_hp: there is none
21:21:26 <Ravikumar_hp> list of APIs and how to call
21:21:39 <chmouel> is there any documentation for other *clients library btw: ?
21:21:41 <bcwaldon> chmouel: isn't it the same as the old swift.client docs?
21:21:50 <bcwaldon> chmouel: yes, current glance client
21:22:18 <ttx> #action chmouel to discuss with CI on enabling swift in devstack-gate
21:22:40 <chmouel> Ravikumar_hp: oh yeah actually they should get auto generated soon we have just merged a commit but I am not sure where this is going to be exposed
21:22:42 <ttx> chmouel: Anything else ?
21:22:51 <chmouel> noip
21:23:08 <ttx> Other questions on Swift ?
21:23:39 <ttx> #topic Glance status
21:23:43 <ttx> bcwaldon: o/
21:23:46 <ttx> #link https://launchpad.net/glance/+milestone/folsom-2
21:24:01 <ttx> Looking at the road to api-v2, looks like continuous progress...
21:24:04 <bcwaldon> indeed
21:24:14 <bcwaldon> we've come up with some more bps in the past week or two
21:24:19 <ttx> api-v2-links depends on api-v2-refactor-schemas, which in unassigned / unknown status ?
21:24:19 <bcwaldon> but we are making steady progress
21:24:32 <bcwaldon> ttx: you should really stop caching that info before the meetings
21:24:49 <bcwaldon> ttx: I've gotten efficient at updating it just as the meeting starts :)
21:24:56 <ttx> sigh
21:25:03 <bcwaldon> le sigh indeed
21:25:23 <ttx> Actually it's http://wiki.openstack.org/releasestatus/ that is not refreshed at the right time :)
21:25:27 <bcwaldon> aha
21:25:49 <bcwaldon> I don't have anything to report
21:26:16 <ttx> bcwaldon: you still have an essential depending on a medium :P
21:26:25 <bcwaldon> why yes I do
21:26:38 <bcwaldon> I've created a paradox!
21:26:39 <ttx> well, that makes it essential as well :)
21:26:53 <bcwaldon> fixing it right now
21:26:54 <ttx> or the other just pretends to be essential.
21:27:12 <ttx> Did you hear from dprince about swift-tenant-specific-storage ?
21:27:20 <bcwaldon> negative
21:27:23 <bcwaldon> or I forgot
21:27:24 <ttx> How essential is this ?
21:27:32 <bcwaldon> not as essential as I thought
21:27:41 <bcwaldon> could be Med or High
21:27:47 <ttx> make it high :)
21:28:04 <bcwaldon> k
21:28:05 <ttx> Also had a question about essential stuff being targeted to folsom-3...
21:28:12 <chmouel> I can help if dprince want
21:28:12 <ttx> I understand why you absolutely need separate-client and glance-client-parity...
21:28:26 <bcwaldon> chmouel: I'll keep that in mind, thanks :)
21:28:26 <ttx> But shouldn't https://blueprints.launchpad.net/glance/+spec/streaming-server be "High" priority instead ?
21:28:36 <ttx> Sounds like something you'd really like to have, rather than something we can't release without.
21:28:42 <bcwaldon> ttx: true
21:28:46 <bcwaldon> done
21:28:49 <ttx> thx
21:28:54 <ttx> bcwaldon: Anything else you wanted to mention ?
21:29:00 <bcwaldon> no sir
21:29:09 <ttx> Cool. Questions on Glance ?
21:29:32 <Ravikumar_hp> Python-glanceclient - Folsom-3?
21:29:47 <bcwaldon> Ravikumar_hp: yes
21:30:54 <ttx> #topic Quantum status
21:30:59 <ttx> danwent: hey
21:31:06 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-2
21:31:06 <danwent> ttx: hello
21:31:21 <danwent> you'll noticed i flagged a couple things with slow progress to highlight them :)
21:31:36 <danwent> the good news is that we got the bulk of the API stuff merged
21:31:42 <ttx> ooh.
21:31:49 <ttx> Good thing I refreshed
21:32:04 <ttx> So now that's done, should we consider that Melange as a separate project is dead ?
21:32:32 <danwent> from a folsom release perspective, yes. there may still be people that use the essex version
21:32:39 <ttx> sure.
21:33:01 <danwent> ok, so the two big issues are DHCP and the Quantum/Nova integration
21:33:18 <danwent> DHCP: the folks working on this say they are still confident with the F-2 date
21:34:05 <danwent> but I haven't seen much yet. Will be trying to kick this work into high gear this week. Otherwise, we potentially need to revisit what we think we'll be able to do with the F-2 deliverable (my goals was that basic uses cases would be functionally complete by F-2)
21:34:14 <ttx> that's how I understand the "Slow progress" you have there
21:34:32 <ttx> In other news, can authorization-support-for-quantum be considered 'Implemented' ?
21:34:39 <ttx> I saw the change landed
21:34:48 <danwent> ttx: one patch landed, but there's one more coming
21:34:53 <ttx> oh, ok
21:35:04 <danwent> kevin's making good progress on that though, so i'm not worried about it.
21:35:29 <danwent> i am worried about the nova/quantum integration, as it looks like tr3buchet may no longer be able to work on that in F-2
21:35:32 <ttx> Could you look into and set the priority and series goal for https://blueprints.launchpad.net/quantum/+spec/cisco-plugin-v2-api-support (proposed for F3) ?
21:35:48 <danwent> ttx: ah, i think that's a new one. hadn't seen it yet.
21:35:51 <danwent> will do.
21:36:13 <danwent> done
21:36:18 <ttx> danwent: could you explain what that nova/quantum integration blueprint will cover exactly ?
21:36:35 <ttx> Nova QuantumManager for quantum v2 ?
21:36:38 <danwent> ttx: nova will use the v2 quantum apis when VMs are created and destroyed
21:36:49 <danwent> meaning that quantum will take care of IPAM as well.
21:37:04 <danwent> and that you can now create networks directly using the quantum API, rather than using nova-manage
21:37:06 <ttx> ok, yes, would have been good to have that in F2
21:37:17 <danwent> ttx: indeed, its quite central.
21:37:18 <ttx> so that it sees some mileage
21:37:35 <danwent> so if I can't get someone to work on it, i'll probably drop my other F-2 stuff and do it myself :(
21:38:11 <ttx> #help volunteer needed to help with improved-nova-quantum-integration
21:38:24 <danwent> other than that, things are going wel though. lot of good code being written an reviewed. a few new core devs.
21:38:30 <ttx> danwent: I think it might be worth it
21:38:41 <danwent> ttx: agreed.
21:38:42 <ttx> (drop the other things to get that into F2)
21:38:53 <ttx> danwent: Anything else ?
21:38:59 <danwent> don't think so.
21:39:03 <ttx> Questions on Quantum ?
21:39:34 <ttx> #topic Nova status
21:39:52 <ttx> So we don't have vishy, i'll just ask a few questions just in case the assignees can answer
21:39:59 <ttx> #link https://launchpad.net/nova/+milestone/folsom-2
21:40:07 <ttx> Plan & progress looks good to me
21:40:21 <ttx> Quick review of the status on the essential stuff:
21:40:34 <ttx> * https://blueprints.launchpad.net/nova/+spec/general-host-aggregates (jog0)
21:40:44 <ttx> * https://blueprints.launchpad.net/nova/+spec/finish-uuid-conversion (mikal)
21:41:06 <ttx> jog0, mikal: if you're around, a quick update on status for those BPs ^
21:41:15 <ttx> jgriffith: around ?
21:41:32 <jgriffith> Yep
21:41:49 <jog0> ttx: making good progress. Working with Citrix guys to keep xen hv_pools working.
21:41:50 <jgriffith> ttx: Things are looking good on cinder
21:41:58 <ttx> jgriffith: do you know how volume-decoupling goes ?
21:42:11 <ttx> jog0: thx, still on track for F2, then ?
21:42:24 <jgriffith> ttx: Yeah, alot of what I'm doing this morning is part of that:
21:42:38 <jgriffith> Between sleepsonthefloor and myself we've about got it done
21:42:45 <ttx> cool
21:42:47 <jgriffith> I'm just finishing some ec2 compat issues
21:42:47 <ttx> jgriffith: What's left to do before Cinder becomes a first-class citizen ?
21:43:01 <jgriffith> ttx: It already is in my book :)
21:43:04 <jog0> ttx: yes. Not sure if every part will be in by F2 (such as reming duplicate metadata concepts). but most will be ready
21:43:06 <jgriffith> ttx: Fix the ec2 stuff
21:43:19 <jgriffith> ttx: add some tests to devstack
21:43:35 <ttx> jgriffith: Is there anything that will get broken in F2 by the completion of this ?
21:43:37 <jgriffith> We're just about fully functional...
21:43:43 <ttx> Like horizon, which has switch-to-cinder-client targeted to F3 now ?
21:43:53 <jgriffith> That's up to everybody else (ie vish)
21:44:09 <jgriffith> We have it now so everything is turned on/off by flags
21:44:15 <jgriffith> So you can go nova-volume or cinder
21:44:23 <jgriffith> this includes devstack as well as "nova"
21:44:43 <ttx> jgriffith: we'll probably make the decision post-F2 to do the full switch or not
21:44:45 <jgriffith> I have a couple of challenges to get this to work correctly in nova api's but I should get there
21:44:51 <ttx> together with the core confirmation
21:44:55 <jgriffith> ttx: The only other concern is TESTS
21:45:04 <ttx> jgriffith: TESTS are good
21:45:13 <jgriffith> ttx: the majority of the existing tests aren't so good though
21:45:20 <jgriffith> ttx: Most are all using fakes for everything!!
21:45:30 <ttx> heh
21:45:39 <ttx> nothing like a test that can't fail.
21:45:43 <jgriffith> :)
21:45:49 <ttx> jgriffith: anything else ?
21:46:14 <jgriffith> ttx: Not unless anybody is interested, or better yet wants to help out :)
21:46:26 <jgriffith> It's been me and sleepsonthefloor and that's about it
21:46:32 <annegentle> jgriffith: what updates to the Compute docs do you expect you'll need?
21:46:35 <ttx> #help Cinder needs more useful test coverage
21:46:50 <ttx> Questions on Nova/Cinder ?
21:46:53 <jgriffith> ttx: bahhh
21:46:54 <jgriffith> docs
21:46:56 <annegentle> #help Cinder needs documentation
21:47:12 <jgriffith> I'll have to tackle that in force after this week
21:47:22 <jgriffith> annegentle: I'll make a note to link up with you
21:47:24 <ttx> ok, great
21:47:30 <ttx> #topic Horizon status
21:47:31 <annegentle> jgriffith: maybe you and sleepsonthefloor can tell me more about it
21:47:35 <devcamcar> o/
21:47:35 <annegentle> jgriffith: sounds good
21:47:36 <ttx> devcamcar: hey
21:47:41 <devcamcar> ttx: howdy
21:47:47 <ttx> devcamcar: we'll talk about a stable/essex point release after the quick folsom-2 status
21:47:51 <jgriffith> perhaps I'll send a note out to the ML just to update folks???
21:47:52 <devcamcar> ok
21:47:54 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-2
21:48:01 <ttx> jgriffith: good idea
21:48:07 <jgriffith> ttx: KO
21:48:08 <devcamcar> F2 blueprints are generally progressing well
21:48:13 <ttx> #action jgriffith to update the ML with Cinder progress
21:48:19 <devcamcar> https://blueprints.launchpad.net/horizon/+spec/nova-volume-optional may get bumped to F3
21:48:26 <devcamcar> when we make the rest of the cinder client changes
21:48:39 <devcamcar> in fact, i'm going to do that now, been meaning to move it
21:48:44 <ttx> devcamcar: Two blueprints were added to F2 without having their series goal confirmed, would be good to look into those and set Priority and Series goal accordingly:
21:48:48 <ttx> * https://blueprints.launchpad.net/horizon/+spec/use-common-jsonutils
21:48:51 <ttx> * https://blueprints.launchpad.net/horizon/+spec/automatic-secure-key-generation
21:49:30 <devcamcar> ttx: will fix the series goal now
21:49:36 <ttx> Last question, about the "Essential" blueprints in Folsom-3 (I don't really like to have essential stuff left on the last milestone):
21:49:45 <ttx> * https://blueprints.launchpad.net/horizon/+spec/switch-to-cinder-client
21:49:50 <ttx> I understand why this one is essential, and work is started, so we should be alright there...
21:49:59 <ttx> * https://blueprints.launchpad.net/horizon/+spec/quantum-workflow-integration
21:50:11 <ttx> This one has no assignee, should it just be assigned to "Nebula" team ?
21:50:41 <ttx> This sounds like a risky thing to consider "Essential"... Could you explain why we can't release Folsom without that feature ?
21:51:26 <devcamcar> ttx: we can probably downgrade that to "high"
21:51:35 <ttx> sounds like a plan.
21:51:37 <devcamcar> it will be a poor user experience without it though
21:51:57 <ttx> well, "High" should still definitely get done :)
21:52:08 <devcamcar> ttx: true enough ;)
21:52:12 <ttx> So, second subject, Horizon 2012.1.1
21:52:25 <ttx> The process is usually as simple as designating a commit ID as your candidate
21:52:40 <ttx> But the tarballs are currently not generated for stable/essex and we need to clean that up first
21:52:46 <devcamcar> ttx: yes, we've gotten a number of back ports into stable/essex that are helpful, so as soon as one more lands, we can tag it
21:52:54 <devcamcar> ttx: ok
21:53:02 <ttx> I'll discuss with markmc and see how we'll proceed here exactly
21:53:20 <ttx> (markmc is the release team member that handles stable release updates)
21:53:43 <devcamcar> for the record, a few stable/essex reviews here would help: https://review.openstack.org/#/c/7730/
21:53:58 <ttx> fwiw, here is how he handled the 2011.3.1 releases: http://wiki.openstack.org/StableBranchRelease
21:54:01 <devcamcar> #help need reviews on https://review.openstack.org/#/c/7730/
21:54:14 <ttx> devcamcar: so, i'l discuss with him, fix CI and come back to you
21:54:20 <devcamcar> ttx: sounds good
21:54:37 <ttx> #action ttx to clarify Horizon 2012.1.1 release process and fix CI to match
21:54:47 <ttx> devcamcar: Anything else ?
21:54:53 <devcamcar> ttx: nope
21:54:57 <ttx> Questions for Horizon ?
21:55:39 <ttx> #topic Other Team reports
21:55:46 <ttx> annegentle, jaypipes, mtaylor: ?
21:56:48 <annegentle> doc team met yesterday - here are notes:
21:57:00 <annegentle> #link http://eavesdrop.openstack.org/meetings/openstack-meeting/2012/openstack-meeting.2012-06-11-20.03.html
21:57:21 <annegentle> I didn't hire an intern for the summer, sorry folks. 4 final candidates took other positions.
21:57:34 <annegentle> Need to start in March not April next year.
21:57:44 <ttx> intern drought in Texas
21:57:52 <ttx> Any other team lead with a status report ?
21:57:58 <annegentle> I'm testing chinese language output through the maven plugin
21:58:04 <annegentle> Will report back on progress.
21:58:21 <annegentle> Looking for writers for http://etherpad.openstack.org/EssexOperationsGuide
21:58:39 <annegentle> And reviewers for the high availability document draft https://review.openstack.org/#/c/8139/
21:59:03 <ttx> #help <annegentle> Looking for writers for http://etherpad.openstack.org/EssexOperationsGuide
21:59:05 <annegentle> Also, the CI team is working on a doc-related consistency project
21:59:10 <ttx> #help <annegentle> And reviewers for the high availability document draft https://review.openstack.org/#/c/8139/
21:59:31 <annegentle> maybe mtaylor or jeblair or clarkb can explain better
21:59:43 <ttx> #topic Open discussion
21:59:51 <ttx> Anything else, anyone ?
22:00:36 <ttx> Quick glance at the effect of the BugTriage day on Nova: http://webnumbr.com/untouched-nova-bugs
22:01:05 <ttx> Now we need to discuss how to make that more permanent :)
22:01:09 <ttx> #endmeeting