16:02:52 <jgriffith> #startmeeting
16:02:53 <openstack> Meeting started Wed Jun 13 16:02:52 2012 UTC.  The chair is jgriffith. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:07 <jgriffith> sleepsonthefloor: Hey
16:03:36 <jgriffith> Ran into git troubles trying to get my stuff pushed to your Drafts :(
16:03:41 <jgriffith> rebase problems
16:04:02 <jgriffith> Think I've got most of it in now and will finish after the meeting
16:04:35 <jgriffith> rnirmal: You here?
16:05:02 <rnirmal> yeah sort of :)
16:05:11 <rnirmal> probably just listening in
16:05:23 <jgriffith> rnirmal: whatever else you're doing can't possibly be as interesting or important  :)
16:05:52 <rnirmal> yeah you bet
16:06:07 <jgriffith> alrighty... likely have some stragglers as usual but it's 5 after so I'm going to run through status updates
16:06:17 <jgriffith> #topic cinder-status
16:06:32 <jgriffith> Good progress over the last week
16:06:42 <DuncanT> hi
16:06:54 <jgriffith> sleepsonthefloor finished up a lot of work to get Keystone auth working
16:07:08 <jgriffith> also misc extensions for attach/detach etc
16:07:16 <rnirmal> awesome
16:07:18 <jgriffith> devstack is also coming along
16:07:36 <jgriffith> I finished up some euca work yesterday
16:07:53 <jgriffith> I'll be adding it to the review drafts that sleepsonthefloor has already created
16:08:00 <jgriffith> after today you should be able to:
16:08:20 <jgriffith> 1. patch a devstack install (with the review drafts)
16:08:35 <jgriffith> 2. run nova using cinder as the volume service
16:08:49 <jgriffith> 3. run euca tools having them use cinder volume service
16:09:15 <jgriffith> If folks have time this week it would be great to get some eyes/testing on this
16:09:33 <jgriffith> There are some outstanding items I'll cover
16:09:54 <jgriffith> I'm planning to send an update email to the OS ML later today
16:10:07 <jgriffith> This will include some instructions on how to get a devstack env setup and running
16:10:14 <jgriffith> List all the patches needed etc
16:10:31 <jgriffith> Any folks interested in playing with it this week?
16:10:54 <clayg> yes, I'd like too
16:11:08 <clayg> ... but I haven't made the time yet :(
16:11:23 <jgriffith> #action clayg spin up devstack/cinder and give feedback
16:11:29 <DuncanT> Same
16:11:32 <clayg> burn! :)
16:11:41 <rnirmal> the notes would be really helpful.. I can't promise but will try
16:11:49 <jgriffith> #action DuncanT spin up devstack/cinder and give feedback
16:12:04 <jgriffith> Ok, so DuncanT and clayg you're on the hook to at least try it out this week at some point
16:12:07 <liamk> I'll help DuncanT as well
16:12:20 <jgriffith> I'll get the email with some instructions out later today/tonight
16:12:26 <DuncanT> (Liam is a collegue of mine on the HP block store team)
16:12:40 <liamk> thx for the intro duncan
16:12:49 <jgriffith> liamk: How ya been?  Not sure but I think we worked together briefly on a Linux driver?
16:13:15 <clayg> jgriffith: will do
16:13:25 <jgriffith> clayg: excellent!
16:13:27 <liamk> Ah yes - wouldn't have made the link but yeah right I think
16:13:38 <jgriffith> liamk: :)  Small world!
16:13:44 <liamk> indeed!
16:14:00 <jgriffith> alrighty... any questions about status?  Anybody want some more detail?
16:14:33 <clayg> jgriffith: sorry I missed the start of the meeting - you got euca working with cinder?
16:14:49 <jgriffith> clayg: Yes for the most part
16:14:59 <clayg> jgriffith: awesome
16:15:00 <jgriffith> create/describe volumes/snapshots
16:15:15 <jgriffith> There's a problem I ran into this morning with delete that I have to look at
16:15:28 <jgriffith> Also need to look at attach/detach but I think we're in pretty good shape
16:15:43 <jgriffith> Also fixed an issue I introduced in the uuid conversion:
16:16:05 <jgriffith> If you created a volume with cinderclient/novaclient, you wouldn't be able to find it with euca-descrive
16:16:10 <jgriffith> describe!!
16:16:28 <jgriffith> Anyway, that's set and should be good
16:17:03 <jgriffith> If there's nothing specific on what we CAN do today, I'll go ahead and open it up to what's planned the rest of this week?
16:17:30 <jgriffith> #topic Plans for this week
16:17:48 <jgriffith> Unit tests!
16:18:33 <jgriffith> We've got a number of patches in gerrit that are pretty close to ready with exception of unit tests
16:19:05 <jgriffith> sleepsonthefloor is working on some of those, anybody with spare cycles/time it would be great if we could get some more folks writing tests
16:19:38 <jgriffith> I'm planning to write some devstack exercises to use euca (surprisingly nothing there currently)
16:19:45 <jgriffith> WRT volumes tha tis
16:20:00 <DuncanT> We've actually got some of those
16:20:13 <sleepsonthefloor> jgriffith - I added tests to most of the patches.  nova is the one most lacking.
16:20:16 <DuncanT> Can publish a tree and let you have a look
16:20:26 <jgriffith> DuncanT: great, thanks!
16:20:34 <jgriffith> sleepsonthefloor: awesome
16:20:47 <jgriffith> The nova ones are the ones I started last week and will be interesting
16:21:07 <jgriffith> I talked with clayg about this, but maybe others have input/suggestions
16:21:24 <jgriffith> I created a "fake" volume api to use for tests
16:21:46 <jgriffith> I had "hoped" to just set a flag to tell nova to use my fake for all of the unit tests
16:22:16 <jgriffith> The idea was that there would be something global for everybody to use writing tests going forward
16:22:34 <jgriffith> Also the hope was to be able to leverage as much of the existing tests as possible with minor tweaking
16:23:02 <jgriffith> Any thoughts on this approach?
16:23:33 <jgriffith> I can tell you some of the problems I've had with it.... maybe somebody has ideas
16:23:41 <sleepsonthefloor> jgriffith, do the original tests pass?
16:24:04 <jgriffith> Original tests pass if we don't change the volume service
16:24:27 <jgriffith> So all of the original tests for the most part are using their own fakes and direct DB calls
16:24:29 <DuncanT> I assume your 'fake' driver will have to maintain enough state to spot errors like detaching something not attached etc?
16:24:41 <jgriffith> DuncanT: So there's the first problem
16:24:52 <jgriffith> Yes, that was how I set it up... but!
16:25:03 <jgriffith> But for example:
16:25:22 <jgriffith> We have ec2/api tests that would call the api set stuff up etc etc
16:25:54 <jgriffith> Those tests then call ec2/cloud.py (for example) which instantiates a new instance of the API
16:26:11 <jgriffith> So there's no shared state between them which breaks the test model I had in mind
16:26:27 <jgriffith> Unless I do some temp DB specifically for the tests to share?
16:27:12 <jgriffith> Which makes me understand why folks did a lot of Stubs and Fakes in the current test suite :)
16:27:54 <jgriffith> Anyway... that's the challenge I ran in to
16:28:10 <DuncanT> I've not fully thought it out, but can't you just keep the state in a driver module variable (singleton pattern style) and add a call to reset it where necessary?
16:28:39 <jgriffith> singleton is what we would want....
16:28:42 <DuncanT> It isn't destroying the whole python vm each test, is it?
16:28:57 <jgriffith> DuncanT: Oh.. no, that's not what I meant
16:29:33 <jgriffith> DuncanT: Singleton pattern would work, but would have to figure out how to tweak volume/__init__ etc
16:30:04 <jgriffith> big thing is I don't even know if this is the best approach?
16:30:12 <jgriffith> It seemed good to me... but
16:30:27 <jgriffith> was interested in other views?
16:30:29 <DuncanT> I think that the current approach to stubbing misses many validation opportunities
16:31:09 <DuncanT> So I'd like to see a smarter fake driver instead. I can definitely see real value to it.
16:31:19 <jgriffith> DuncanT: The thing is we're still kinda stubbing, we just have a framework to use that makes it a bit cleaner and more robust IMO
16:31:41 <jgriffith> We're just stubbing via abstraction :)
16:32:05 <DuncanT> Yeah, but the stub is less stubby and can do a bit more validation if it is common and getting reused
16:32:12 <jgriffith> hehe exactly
16:32:28 <jgriffith> makes tests MUCH more straight forward
16:32:47 <jgriffith> FYI I'll want to do the same thing in Cinder itself at some point as well
16:33:07 <DuncanT> Sounds like an excellent idea
16:33:25 <jgriffith> Ok, I'll stick with the plan unless somebody thinks of something better
16:34:05 <jgriffith> If anybody sees a good way to make a singleton pattern of a fake API served up from volume/__init__.py let me know
16:34:51 <jgriffith> Ok, anything on plans for the week?
16:35:04 <jgriffith> More importantly anybody have something they want to tackle this week?
16:35:54 <jgriffith> booooo
16:35:58 <jgriffith> :)
16:36:29 <jgriffith> #topic F2 items
16:36:58 <jgriffith> So remember we plan to have functional equivalent of nova-volume ready by F2
16:37:06 <jgriffith> I think we're on track for that still
16:38:15 <jgriffith> https://blueprints.launchpad.net/cinder/+spec/python-cinder-client
16:38:47 <jgriffith> https://blueprints.launchpad.net/nova/+spec/extract-nova-volumes
16:39:15 <jgriffith> These two pretty much encompass the majority of it
16:39:32 <jgriffith> Both are being worked on and moving along well
16:40:24 <jgriffith> Any thoughts/questions about F2?
16:41:35 <jgriffith> #topic open-discussion
16:41:43 <jgriffith> Alright, anybody have anything?
16:42:21 <jgriffith> jmckenty: Just saw your email...  sounds good.
16:42:41 <jmckenty> thanks
16:42:50 <jgriffith> I'm just a little confused about folks that have "begun" the blueprint process and working on things?
16:42:53 <jmckenty> there were some major storage stakeholders who I knew were interested,
16:42:57 <jmckenty> but are VERY late to the table
16:43:01 <jgriffith> Haven't heard/seen any of this since the summit
16:43:04 <jmckenty> I know
16:43:13 <jmckenty> they don't really know how to get involved in a public discussion yet
16:43:15 <jmckenty> I yelled at them
16:43:18 <jgriffith> :)
16:43:23 <jmckenty> and basically said if they didn't join in Cinder this week,
16:43:24 <jgriffith> cool
16:43:28 <jmckenty> they were never going to be a part of openstack
16:43:39 <jmckenty> And considering they're paying a lot of money to be in the foundation,
16:43:43 <jmckenty> they ought to get involved
16:44:00 <jgriffith> jmckenty: Great, thanks for the help!
16:44:14 <jgriffith> Ok, if nobody has anything I'm going to wrap it up
16:44:17 <jmckenty> we aim to please
16:44:32 <jgriffith> I'm always around so if you think of something, have questions grab me on IRC
16:44:49 <jgriffith> Keep an eye out for reviews to start hitting
16:45:00 <jgriffith> and I'll get the status email out shortly
16:45:02 <clayg> thanks jgriffith
16:45:05 <winston-d> jgriffith, hi, I'd like to help with cinder development.
16:45:16 <winston-d> jgriffith, didn't know where to start
16:45:26 <jgriffith> winston-d: Great!  Perhaps we can chat after the meeting?
16:45:33 <winston-d> jgriffith, sure.
16:45:38 <jgriffith> Excellent
16:46:05 <jgriffith> Alrighty... winston-d I'll ping you in a few minutes
16:46:19 <jgriffith> everyone else, thanks for showing up this week
16:46:28 <jgriffith> Keep an eye out for reviews to start hitting
16:46:36 <jgriffith> Thanks, and see you next week!
16:46:41 <jgriffith> #endmeeting