16:00:03 <nijaba> #startmeeting
16:00:03 <nijaba> #meetingtopic Ceilometer
16:00:03 <nijaba> #chair nijaba
16:00:03 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
16:00:04 <openstack> Meeting started Thu Jun 21 16:00:03 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:08 <openstack> Current chairs: nijaba
16:00:22 <dhellmann> present
16:00:23 <nijaba> #info dachary will unfortunately not be able to join us this week for work related reasons, he asked me to present his excuses.
16:00:32 <nijaba> jd___: around?
16:00:37 <nijaba> anyone else?
16:00:49 <jd___> i'm here
16:01:04 <nijaba> #topic actions from previous meetings
16:01:17 <nijaba> #topic  nijaba: to point to the calculator in the blueprint
16:01:17 <nijaba> this is done.  Available at
16:01:17 <nijaba> #link http://wiki.openstack.org/EfficientMetering#Volume_of_data
16:01:31 <nijaba> any comments on this?
16:01:42 <jd___> nope
16:01:46 <nijaba> #topic dhellmann: start mapping API queries to database engine methods
16:02:01 <dhellmann> we ran a few different numbers through the calculator. it's a good tool for estimating for us.
16:02:13 <nijaba> thanks dhellmann :)
16:02:21 <dhellmann> I posted a proposed API to the list but haven't seen any feedback. Did anyone have a chance to review it?
16:02:58 <nijaba> dhellmann: I did, and I am quite happy with your proposal.  I don;t have any clean solution for the problem you stated though
16:03:21 <dhellmann> maybe when we start the implementation the solution will become more clear
16:03:33 * nijaba crosses his fingers
16:03:49 <jd___> dhellmann: probably
16:04:11 <nijaba> ok, moving on then :)
16:04:14 <nijaba> #topic dhellmann: look at existing plugins and pick one of each for examples in docs and email info on examples to nijaba
16:04:15 <nijaba> I can confirm this was done and I received dhellmann's email
16:04:15 <jd___> dhellmann: that seems at least as a good boilerplate
16:04:40 <nijaba> thanks for this dhellmann
16:05:00 <dhellmann> thank you for volunteering to bootstrap the documentation :-)
16:05:16 <flacoste> dhellmann: why don't you want to make the two parameters optionals and add an assert at the start of the method?
16:05:34 <dhellmann> flacoste, because then the user of the API has to know about the internal rules
16:06:01 <flacoste> there is another possibility
16:06:34 <flacoste> have DB.get_raw_events_by_user() and DB.get_raw_events_by_project() be thin wrapper around DB._internal_get_raw_events(project, user)
16:07:42 <dhellmann> flacoste, yes, we could implement it that way. Whether or not that makes sense is left up to the engine author. I was trying to create an API  that was consistent from the outside perspective without considering implementation details.
16:08:27 <nijaba> dhellmann: and I think you achieved this goal quite well
16:08:41 <flacoste> dhellmann: then what you have is probably good enough
16:08:54 <nijaba> should we move on?
16:09:00 <dhellmann> we'll implement one or two and see if we can improve on the API after that
16:09:04 <dhellmann> yes
16:09:09 <nijaba> #topic nijaba: to prime the doc once info received from dhellmann
16:09:09 <nijaba> I unfortunately did not have time to complete this task.  Reassigning to next week
16:09:09 <nijaba> #action nijaba: to prime the doc on plugins
16:09:34 <nijaba> sorry, did have to cover an event this week, which hate a lot of my time
16:09:47 <jd___> s/hate/ate/ I hope
16:09:56 <nijaba> righhhhhtttt
16:10:01 <jd___> ;-)
16:10:04 <dhellmann> depends on the event :-)
16:10:09 <nijaba> hehe
16:10:14 <nijaba> moving on
16:10:27 <nijaba> #topic nijaba: to prepare incubation application for review at the next meeting
16:10:27 <nijaba> so I did prepare this, you can review my work at:
16:10:27 <nijaba> #link http://wiki.openstack.org/Projects/IncubatorApplicationCeilometer
16:10:27 <nijaba> any comments, suggestions or remarks?
16:10:53 <dhellmann> I haven't had a chance to review it, yet. I will try to do that this week.
16:10:59 <nijaba> so I am going to give you a few minutes so that you have time to read
16:11:15 <nijaba> or should we mark it as an action for next week?
16:11:40 <dhellmann> can we discuss next week? or do we need to submit it before then?
16:11:50 <nijaba> nope, no hurry I think
16:12:44 <nijaba> #action during next week meeting we will vote on the Incubation application
16:13:08 <nijaba> #topic dachary: talk to Dragon about SystemData / ceilometer and try to create cooperation
16:13:08 <nijaba> dachary not beeing around I'll push this to next week's meeting
16:13:22 <nijaba> #action dachary: talk to Dragon about SystemData / ceilometer and try to create cooperation
16:13:32 <nijaba> #topic dhellmann: to talk to Quantum devs about integration with ceilometer
16:14:03 <dhellmann> I have discussed this with my coworker privately, but have not approached the Quantum devs publicly, yet.
16:14:13 <dhellmann> #action dhellmann: talk to Quantum devs about integration with ceilometer
16:14:29 <nijaba> #topic dachary: to talk to swift devs about integration with ceilometer
16:14:29 <nijaba> dachary not beeing around I'll push this to next week's meeting
16:14:45 <nijaba> #action  dachary: to talk to swift devs about integration with ceilometer
16:14:57 <nijaba> #topic nijaba: to talk to cinder devs about integration with ceilometer
16:14:57 <nijaba> I did start the discussion with them on the ML.  jgriffith said he would be joining the meeting today to start discussing
16:15:13 <nijaba> jgriffith: ping?
16:16:27 <nijaba> ok, it seems that he is not around atm.  We'll come back to it eventually
16:16:47 <nijaba> #topic jd___: to talk to glance devs about integration with ceilometer
16:17:08 <jd___> I did it at https://lists.launchpad.net/openstack/msg13331.html
16:17:30 <jd___> conclusion is that we seem to doing the right thing so far :)
16:17:48 <nijaba> yes, I saw that.  Thank for the email template I reused for initiating the conversion with cinder, btw ;)
16:17:57 <jd___> hehe I saw that too :-)
16:18:11 <nijaba> any comments on this?
16:18:40 <dhellmann> did I see someone suggest tying in via the client library? or did I misunderstand a response?
16:18:58 <nijaba> dhellmann: that was about cinder I believe
16:19:24 <dhellmann> ah, ok
16:19:45 <dhellmann> I've been dealing with some local issues, so I'm a little behind on email. Did you explain why that wouldn't work?
16:19:56 <nijaba> dhellmann: we could poll cinder via the client library, but volume creations/del could be nice events to catch
16:20:13 <dhellmann> ah, polling via the client does make some sense, if it gives the data we need
16:20:57 <nijaba> we just need to check that the client lib does have the requested data ;)
16:21:05 <dhellmann> ok, it sounds like things are moving in the right direction. -- true :-)
16:21:23 <nijaba> I would agree
16:21:42 <nijaba> #topic Status of the essex compatibility effort that jd is leading
16:22:30 <jgriffith> nijaba: sorry, was stuck in a meeting
16:22:47 <dhellmann> that may get easier, once we move to the openstack.common RPC libraries (in addition to the other parts of common we're already using)
16:22:56 <nijaba> jgriffith: np.  Let's finish on this topic and we'll come back to you in a sec
16:23:37 <nijaba> jd___: do you have an update about essex compat?
16:24:22 <jd___> yeah, my patches for testing have been merged
16:24:32 <jd___> but i'm not sure they are set up in the real jenkins yet
16:24:38 <nijaba> cool! any blockers found?
16:24:49 <jd___> not so far, for the part being tested at least :)
16:25:07 <nijaba> any action on that topic for next week?
16:25:40 <jd___> we should add some more tests, at least simulating the daemon launch because I know this is going to fail on essex
16:26:03 <jd___> and checks that my openstack-ci stuff are working :)
16:26:19 <nijaba> jd___: Feel free to add  #action for this :)
16:26:31 <dhellmann> jd___ can we crib test infrastructure from the nova tests for Service?
16:26:49 <jd___> dhellmann: I hope so!
16:26:56 <dhellmann> :-)
16:27:00 <jd___> #action jd___ check that openstack-ci runs the tests for Essex
16:27:11 <jd___> #action jd___ add some tests on daemon launching
16:27:25 <nijaba> thanks.  Shall we get back to cinder?
16:27:42 <jd___> yep
16:27:49 <nijaba> #topic discussion about cinder integration
16:27:59 <nijaba> jgriffith: thanks for joining!
16:28:21 <jgriffith> Sure... sorry I was late
16:28:46 <nijaba> jgriffith: so, we think we could build a ceilmoter agent that would poll the cinder client for volume usage per user
16:29:01 <nijaba> jgriffith: any pointer on what call we should make?
16:29:21 <jgriffith> So I think that would be doable in terms of the client.  We might want to just implement a specific call via extension?
16:29:38 <jgriffith> That way providers that are worried about security etc can choose to not load
16:30:06 <nijaba> oh, you mean that the call would be open to anyone?
16:30:37 <jgriffith> Yeah, probably...not sure how else to implement it
16:30:43 <dhellmann> this is more of an "admin" feature for internal use, although I can see the information being useful to end-users if they are restricted to asking about their own account(s)
16:30:59 <nijaba> I would rather find something that would not expose this data by default to somthing else than ceilometer
16:31:03 <jgriffith> dhellmann: got ya, but not sure how you'd limit that, unless you do it via the context?
16:31:23 <dhellmann> jgriffith, we're getting into an area of OS I
16:31:26 <dhellmann> 'm not familiar with
16:31:39 <jgriffith> nijaba: I would prefer that as well
16:31:40 <dhellmann> I know there is a way to separate the public and admin APIs, but I don't know how
16:31:44 <jd___> jgriffith: context is probably fine, you use a policy engine too?
16:31:53 <jgriffith> dhellmann: Ok, I can look into that
16:32:03 <jgriffith> jd___: Yes, we could set that up as well.
16:32:21 <jgriffith> might be best to get some input from folks on the best way to coordinate and make this happen
16:32:37 <jgriffith> also, need to be honest about resources on the cinder team... they're a bit thin
16:32:52 <nijaba> I guess the ml would be the best place to ask for this?
16:32:58 <jgriffith> So depending on how heavy a lift we're looking at on the cinder side it could dictate timelines
16:33:18 <jgriffith> nijaba: Yes, I think it's best to get it out on the ML
16:33:20 <dhellmann> jgriffith, I'm sure we could contribute resources for implementation if it comes down to that
16:33:37 <jgriffith> nijaba: It's painful at first with all of the feedback but it should give us some good direction
16:33:43 <jgriffith> dhellmann: excellent
16:33:59 <dhellmann> we're expecting to do that for all of the integration work, to varying degrees
16:34:02 <nijaba> who wants to take the action to bring the question to the ml?
16:34:44 <nijaba> ok, I guess it will be me then?
16:34:58 <dhellmann> unless jgriffith can do it?
16:36:00 <nijaba> #action nijaba to question best method to authenticate admin client calls from ceilometer to cinder (and other projects)
16:37:13 <nijaba> jgriffith: another point that we could want to capture are volume events, such as creation/deletion etc...  do you publish them currently somewhere?
16:37:32 <jgriffith> nijaba: No, we don't
16:38:03 <jgriffith> So we keep things in the db like creation/deletion time but don't actually capture the events anywhere that I'm aware of
16:38:06 <nijaba> ok, so that would be something else we would have to look into
16:38:19 <dhellmann> is that a conscious decision, or something you just haven't gotten to yet?
16:38:37 <dhellmann> IOW, if we contributed some patches to emit notifications, would that be OK?
16:40:52 <nijaba> jgriffith: would you like us to join one of your meeting to discuss this further?
16:42:35 <nijaba> ok, I think jgriffithmaybe experiencing some technical difficulties
16:42:50 <nijaba> should we tab this and move it to the ml as well?
16:43:14 <dhellmann> yes
16:43:15 <flacoste> +1
16:43:37 <nijaba> #action nijaba to include adding events to cinder to previous action
16:43:42 <jgriffith> sorry... booted out
16:44:09 <jgriffith> nijaba: Maybe next wed, let's talk offline between now and then and have a game plan though
16:44:44 <nijaba> jgriffith: sounds good to me.
16:44:53 <jgriffith> nijaba: great
16:44:58 <nijaba> jgriffith: when is your meeting on wed?
16:46:01 <nijaba> #link http://wiki.openstack.org/NovaVolumeMeetings
16:46:19 <nijaba> so same time as ours, but on wed
16:46:33 <nijaba> who will be able to join?
16:47:13 <dhellmann> I should be able to join a little late
16:47:24 <nijaba> ok great.  I'll be there too
16:47:41 <nijaba> let's move on to Open Discussion
16:47:55 <nijaba> #topic open discussion
16:48:16 <nijaba> anything else someone wants to bring up?
16:48:24 <jd___> nope
16:48:25 <jgriffith> nijaba: 1600 UTC
16:48:58 <dhellmann> jd___, how goes the pep8 / conf patch work?
16:49:09 <jd___> dhellmann: did not check yet :(
16:49:18 <dhellmann> ok
16:49:20 <jd___> I need to upgrade pep8
16:49:27 <jd___> and for whatever reason my pip fails!
16:49:32 <nijaba> jgriffith: great, so dhellmann and I will be joining and I'll initiate a private thread between the 3 of us. thanks
16:51:26 <nijaba> #action  dhellmann and nijba will be joining and nijaba will initiate a private thread with jgriffith
16:51:44 <nijaba> ok, looks like we are done with the agenda for today
16:51:50 <nijaba> thanks everyone for joining!
16:52:07 <dhellmann> good meeting, we ended early :-)
16:52:14 <nijaba> #endmeeting