21:02:03 <ttx> #startmeeting
21:02:04 <openstack> Meeting started Tue Jun 26 21:02:03 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:11 <bcwaldon> ttx: done
21:02:17 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:22 <vishy> o/
21:02:28 <ttx> Teaser: If you stay until the end, we'll discuss the "G" name then.
21:02:43 <ttx> #info We have one week left before F2 is cut, we'll therefore review remaining objectives and defer what needs to be
21:02:53 <ttx> #topic Actions from previous meeting
21:03:01 <ttx> * notmyname to pursue discussion on enabling swift in devstack-gate
21:03:07 <ttx> notmyname: how is that going ?
21:03:19 <notmyname> ttx: I talked to jeblair about it
21:03:20 <devcamcar> o/
21:03:37 <notmyname> he enabled it in devstack and it seemed to pass the devstack-gate gate
21:04:02 <ttx> notmyname: is it enabled now ?
21:04:03 <notmyname> usefulness in devstack is a different question, but I think the current action is done
21:04:08 <ttx> ok.
21:04:18 <ttx> * jgriffith to update the ML with Cinder progress: DONE
21:04:26 <notmyname> ttx: not sure. I think he just proposed it. not sure if it was merged or set to WIP
21:04:35 <ttx> * ttx to rename bp-issues.py script to ttx.py: DONE
21:04:42 <ttx> * heckj to repurpose stop-ids-in-uris wrt implement-v3-core-api: DONE
21:04:51 <ttx> * ttx to raise a new thread about Nova bug triaging
21:05:03 <ttx> That was DONE, although I'd like more input from the PTL so that we can start implementing actions on that
21:05:12 <ttx> vishy: care to chime in on that thread ?
21:05:31 * vishy goes back to find it
21:06:00 <ttx> #action vishy to comment on Nova bug triaging thread so that we can start doing sth about it
21:06:09 <ttx> #topic Keystone status
21:06:13 <ttx> heckj: o/
21:06:20 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-2
21:06:32 <ttx> Looks like you're almost there, on what's left ?
21:07:00 <heckj> code reviews, which I'm kicking about
21:07:20 <heckj> there's also good progress towards some of the folsom-3 deliverables as well (PKI)
21:07:30 <ttx> It's probably a good time to target high-impact bugs to the milestone as well, if any
21:07:49 <ttx> You currently already have 6 targeted bugs, a few of them look abandoned:
21:08:05 <ttx> bug 890411, bug 983304, bug 996912
21:08:08 <heckj> one is up for code-review, another is in progress (dev docs related) and was discussed at the keystone meeting this morning
21:08:08 <uvirtbot> Launchpad bug 890411 in keystone "Tenant role conflicts/overlaps can be a security issue" [Medium,In progress] https://launchpad.net/bugs/890411
21:08:12 <uvirtbot> Launchpad bug 983304 in keystone "Implementation of tenant,user,role list functions for ldap" [Medium,In progress] https://launchpad.net/bugs/983304
21:08:13 <uvirtbot> Launchpad bug 996912 in keystone "Wrong exception caught for admin checking in ec2" [Medium,In progress] https://launchpad.net/bugs/996912
21:08:31 * heckj will review
21:08:35 <ttx> heckj: those 3 looked abandoned to me when I checked them a couple hours ago
21:08:49 <ttx> maybe un-targeting them if nobody will work on them yet
21:09:01 * heckj nods
21:09:08 <ttx> quick look into folsom-3, since some F2 targets were deferred there...
21:09:11 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-3
21:09:26 <ttx> * https://blueprints.launchpad.net/keystone/+spec/rbac-keystone-api : any idea who is going to work on that ?
21:10:20 <heckj> dolphm on that one - its focused on implementing the RBAC in V3 API
21:10:42 <ttx> ok, will assign if you don't
21:10:42 <heckj> might be me, or another volunteer though
21:11:01 <ttx> assignments can change :)
21:11:12 <ttx> The last thing I wanted to discuss is implement-v3-core-api... When do you expect the implementation work will start, and how much time do you think it will take ?
21:11:29 <ttx> I'm asking because if it lands too late in the cycle it might hurt more than it helps... and/or introduce risk
21:12:08 <heckj> I'm hoping we can start implementation within the next 2 weeks. Planning on taking bcwaldon's advice and leaving spec open to tweaks as we attempt to implement it.
21:12:35 <heckj> there will be a draft 3 that we will work from to start implementation
21:12:47 <ttx> heckj: what is the impact on other projects ? Do they need to do something about it after you're done ?
21:12:58 <ttx> or will they just continue to use v2?
21:13:11 <heckj> Nothing - V2 will remain operational through the release. We are NOT breaking backwards compatibility
21:13:42 <ttx> so you don't expect any of them to switch to v3 for Folsom ?
21:13:42 <bcwaldon> heckj: yay!
21:14:35 <heckj> I'm leaving that open, no expectation at this point. It's taken much longer than anticipated to nail down the V3 api, so I don't want to impose heavy change unless it's solid and the other PTLs are interested in taking advantage of newer features
21:15:21 <ttx> heckj: ok, thx. I guess we can rediscuss that once implementation will be started. Anything else ?
21:15:32 <heckj> nope
21:15:39 <ttx> Other questions about Keystone ?
21:16:18 <ttx> #topic Swift status
21:16:23 <ttx> notmyname: hey
21:16:24 <notmyname> hi
21:16:29 <ttx> Saw you announced tentative date for 1.5.1 to Jul 16 ?
21:16:34 <notmyname> correct
21:16:48 <ttx> Is your goal to have https://blueprints.launchpad.net/swift/+spec/keystone-middleware complete in it ?
21:17:39 <notmyname> I'm not sure yet. ideally, yes. but I don't think it should prevent the release. that being said, we still have 2 weeks to get it in. I hope it happens
21:18:01 <notmyname> mostly it depends on reviewers
21:18:09 <ttx> Other goals for that release that would not be tracked at https://launchpad.net/swift/+milestone/1.5.1 yet ?
21:18:42 <notmyname> as the date gets closer I'll make sure the LP is updated. I've got a tentative changelog. hang on...
21:19:04 <notmyname> https://github.com/notmyname/swift/blob/1.5.1-changelog/CHANGELOG
21:19:26 <ttx> #link https://github.com/notmyname/swift/blob/1.5.1-changelog/CHANGELOG
21:19:29 <notmyname> needs some review and ordering, but that's what's happened so far since 1.5.0
21:19:47 <ttx> notmyname: OK thx. Anything else you wanted to mention ?
21:20:09 <notmyname> we're a little behind on reviews, it seems. all help is appreciated :-)
21:20:19 <ttx> Questions on Swift ?
21:20:38 <ttx> #help Swift could use some extra reviews, please help
21:21:09 <ttx> #topic Glance status
21:21:13 <ttx> bcwaldon: o/
21:21:16 <ttx> #link https://launchpad.net/glance/+milestone/folsom-2
21:21:17 <bcwaldon> hello there
21:21:25 <ttx> bcwaldon: Looks like this won't all be completed in the next 7 days :)
21:21:40 <ttx> bcwaldon: anything that should be deferred already to concentrate on the rest ?
21:21:46 <bcwaldon> ttx: a good amount of it will get done
21:21:53 <ttx> Like swift-tenant-specific-storage ?
21:22:08 <bcwaldon> we cand efer tenant-specific swift accounts
21:22:20 <ttx> ok, will push to F3
21:22:27 <bcwaldon> ttx: we really do have patches up that should close out a bunch of these
21:22:38 <bcwaldon> ttx: and push back 'Ability to authorize...'
21:22:50 <ttx> ok
21:22:53 <ttx> You have one F2-targeted bug, which looks abandoned though:
21:22:57 <ttx> * https://bugs.launchpad.net/keystone/+bug/996912
21:22:59 <uvirtbot> Launchpad bug 996912 in keystone "Wrong exception caught for admin checking in ec2" [Medium,In progress]
21:23:07 <bcwaldon> wrong bug!
21:23:18 <ttx> https://bugs.launchpad.net/bugs/994609
21:23:22 <uvirtbot> Launchpad bug 994609 in glance "wsgi.Server() starts but is broken on osx (test_multiprocessing never ends)" [High,In progress]
21:23:27 <ttx> that one ^
21:23:38 <bcwaldon> yes, I haven't heard back from Patrick
21:23:42 <bcwaldon> but it is definitely still a bug
21:23:50 <ttx> maybe should be untargeted from F2 ?
21:23:55 <bcwaldon> sure, push back to F3
21:24:13 <bcwaldon> it got half fixed already
21:24:17 <bcwaldon> and its only affecting tests
21:24:21 <bcwaldon> so not very high profile
21:24:24 <ttx> Anything else that *must* be fixed before the milestone hits ?
21:24:34 <bcwaldon> not that I know of
21:24:53 <ttx> bcwaldon: Anything else ?
21:25:00 <bcwaldon> ttx: nope :)
21:25:05 <ttx> Questions on Glance ?
21:25:24 <ttx> bcwaldon: busy week ahead :)
21:25:31 <bcwaldon> ttx: for sure
21:25:38 <bcwaldon> ttx: we've got several reviews approved and ready to land
21:25:44 <bcwaldon> ttx: waiting for the gate to get fixed
21:26:07 <ttx> bcwaldon: do you expect client projects like horizon or nova to switch to v2 ? They have to, right ?
21:26:22 <bcwaldon> ttx: I'm working on the nova integration
21:26:29 <bcwaldon> and I think the horizon integration is already done
21:26:37 <ttx> bcwaldon: ok, great.
21:26:40 <ttx> #topic Quantum status
21:26:41 <bcwaldon> ttx: and they dont have to switch to the v2 api, but they do have to switch to python-glanceclient
21:26:56 <ttx> bcwaldon: understood
21:26:59 <ttx> salv-orlando: hey
21:27:02 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-2
21:27:02 <salv-orlando> Hi I'm replacing day today
21:27:17 <ttx> salv-orlando: Looks like you might make it, though there is still a lot of work to do ?
21:27:32 <salv-orlando> So, we have 6 open blueprints on quantum + 1 on nova
21:27:43 <salv-orlando> 2 essentials, 2 high, 2 medium
21:27:50 <ttx> Could you comment on the status of the two essential ones ?
21:28:03 <salv-orlando> Quantum-Nova integration:
21:28:13 <salv-orlando> https://blueprints.launchpad.net/quantum/+spec/improved-nova-quantum-integration
21:28:20 <salv-orlando> code under review both in Nova and Quantum
21:28:31 <salv-orlando> the Quantum patch has plenty of cores looking after it
21:28:39 <salv-orlando> The Nova patch will need love from some Nova core
21:29:00 <salv-orlando> Nova patch available at: https://review.openstack.org/#/c/8916
21:29:29 <salv-orlando> For Quantum DHCP (https://blueprints.launchpad.net/quantum/+spec/quantum-dhcp)
21:29:44 <salv-orlando> the last update from markmcclain yesterday was that he was going to push code by the end of today
21:30:19 <salv-orlando> Do you want an update also on the "High" bps
21:30:21 <salv-orlando> ?
21:30:25 <ttx> no, thx
21:30:34 <vishy> Salv-orlando: it looks like that branch is causing test failures. Missing dependency perhaps?
21:30:58 <salv-orlando> I think Yong is already looking at it.
21:31:13 <ttx> salv-orlando: On the bugs side: 9 open bugs targeted to F2 so far
21:31:16 <salv-orlando> The previous patch (#4) passed Jenkins tests
21:31:23 <salv-orlando> yep
21:31:23 <ttx> If you know who is working on bug 1017760 and bug 1016308, please set assignees for them
21:31:26 <uvirtbot> Launchpad bug 1017760 in quantum "devstack support for v2 nova/quantum integration" [High,Confirmed] https://launchpad.net/bugs/1017760
21:31:28 <uvirtbot> Launchpad bug 1016308 in quantum "support v2 API "reserved ranges" in db_base_plugin" [Medium,Confirmed] https://launchpad.net/bugs/1016308
21:31:36 <ttx> so that we know who to nag for updates
21:31:50 <salv-orlando> bug 1017760 we are looking for a taker. If we don't find one by EOD today, I am the taker
21:31:54 <salv-orlando> so that one is covered
21:32:17 <ttx> salv-orlando: ttx.py picked up the following:
21:32:20 <ttx> * https://blueprints.launchpad.net/quantum/+spec/quantum-nec-openflow-plugin
21:32:20 <ttx> Not in series goal while targeted to a series milestone (folsom-3)
21:32:34 <ttx> salv-orlando: might want to consider it for addition to the Folsom series goal
21:32:49 <salv-orlando> Definitely, but we need to sync up with the nec team first, I guess
21:33:01 <ttx> sure
21:33:06 <salv-orlando> as the other way of solving the issue is to untarget from folsom-3
21:33:13 <ttx> Also https://blueprints.launchpad.net/quantum/+spec/remove-v1-related-code has no assignee and no priority.
21:33:26 <ttx> salv-orlando: Anything else you wanted to mention ?
21:33:47 <salv-orlando> This is because we will discuss in early stages of Folsom-3 whether we can get rid of the v1 code by folsom or support but deprecate it
21:34:01 <salv-orlando> The only risky item we had, horizon integration, has been moved to folsom-3
21:34:09 <salv-orlando> that is all from the Quantum side.
21:34:21 <ttx> salv-orlando: understood, and thanks
21:34:25 <ttx> Questions on Quantum ?
21:34:55 <ttx> #topic Nova status
21:35:01 <ttx> vishy: hey
21:35:04 <ttx> #link https://launchpad.net/nova/+milestone/folsom-2
21:35:14 <vishy> hi
21:35:14 <ttx> vishy: We'll probably have to defer a lot of stuff in 7 days. Anything we already know won't make it ?
21:35:25 <ttx> trusted-messaging perhaps ?
21:35:25 <vishy> just deferred a couple of things
21:35:35 <vishy> ttx: refresh :)
21:35:48 <ttx> this game never gets old
21:36:05 <bcwaldon> ttx: this is the first week in quite a while I didnt do that to you
21:36:37 <ttx> vishy: so everything else has still a decent chance of making it into F2 ?
21:37:09 <ttx> Wanted to look a bit more specifically into the essential stuff, as always:
21:37:20 <ttx> * https://blueprints.launchpad.net/nova/+spec/general-host-aggregates (jog0)
21:37:24 <vishy> ttx: cool
21:37:29 <ttx> I see the first part might land in time, but there is more coming...
21:37:35 <ttx> should we split the blueprint between folsom-2 and folsom-3 goals ? Or just defer the whole thing to folsom-3 ?
21:37:46 <vishy> ttx: I think we can just move the whole thing
21:38:14 <ttx> ack
21:38:17 <jog0> ttx: Sounds good to me too, but I will still aim on getting first part for folsom-2
21:38:25 <ttx> jog0: sure
21:38:39 <ttx> jog0: land as much as you can that still makes sense separately
21:38:45 <ttx> * https://blueprints.launchpad.net/nova/+spec/finish-uuid-conversion (mikal)
21:38:57 <ttx> vishy: Any news on that ? Pinged mikal but no news yet
21:39:28 <vishy> I thought he was done with that last review
21:39:29 <vishy> b
21:39:31 * ttx 's overlap with Australia is not that great
21:39:45 <vishy> ut based on the email he sent asking about db migration mb there is one more in the pipe?
21:40:07 <ttx> vishy: try to ask him towards the end of your day ?
21:40:18 <vishy> ttx: sure I will try
21:40:24 <ttx> Looking at F2-targeted bugs now, only 2 of them so far:
21:40:35 <ttx> Anyone interested in picking up https://bugs.launchpad.net/nova/+bug/964055 ? otherwise maybe we should untarget
21:40:36 <uvirtbot> Launchpad bug 964055 in nova "Remove nova-manage user list and project list as they are confusing in a Keystone world" [Wishlist,Confirmed]
21:41:25 <ttx> Also, any suggestion on bugs that should be fixed before we cut F2 ?
21:42:20 <ttx> ok, I guess that's a no
21:42:25 <ttx> vishy: Anything else ?
21:42:38 <ttx> (will untarget that bug with nobody on it)
21:42:54 <vishy> ttx: hopefully that goes out with the remve deprecated auth blueprint from bcwaldon
21:43:11 <vishy> ttx: have a couple of bugs which i've fixed recently but i think they will both be in very quickly
21:43:19 <ttx> vishy: hmm, will link to the blueprint
21:43:21 <vishy> ttx: I would love more people working on fixing bugs
21:43:36 <ttx> vishy: we could organize a bug squashing day after F2
21:43:49 <vishy> ttx: we have had quite a few nasty ones reported and tracking them down and fixing them can take some effort from core
21:43:52 <ttx> like we did for Essex at the start of the last milestone
21:44:29 <ttx> vishy: does that sound like a good thing to do ? Or would you rather target a list of bugs and hunt down people to fix them all ?
21:44:56 <ttx> (bug squashing day is more about the low hanging fruit you can fix in one day)
21:45:08 <vishy> ttx: a day would be great
21:45:29 <vishy> ttx: as I just mentioned in my response to your email, it would be nice to have a way for triagers to mark bugs for review by nova-core
21:45:37 <ttx> #action ttx to look into organizing a bug squashing day like we did for Essex
21:45:44 <vishy> ttx: then nova-core could have a duty to help out with those...
21:45:54 <vishy> ttx: maybe it is mark it critical?
21:45:54 * ttx will link 964055 to the bp you suggested
21:46:34 <ttx> vishy: importance should reflect the impact... priority is more reflected by milestone targets
21:46:45 <ttx> vishy: I'll follow-up
21:46:56 <ttx> Questions on Nova ?
21:47:48 <ttx> #topic Horizon status
21:47:53 <ttx> devcamcar: hey
21:47:59 <devcamcar> hoyoo
21:48:03 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-2
21:48:24 <ttx> ooo, recent updates
21:48:25 <devcamcar> all in all we are looking good
21:48:30 <ttx> looking very good
21:48:41 <ttx> You also have 20+ bugs targeted. Looks like a busy week ahead :)
21:48:42 <devcamcar> we moved quantum support to F3 but it should land early in the cycle
21:48:48 <devcamcar> indeed
21:49:03 <devcamcar> most of the bugs are actually trivial fixes so i think we're ok
21:49:16 <ttx> devcamcar: don't have any question on that, looks pretty clear and on track to me
21:49:19 <devcamcar> a few of the ux related ones may be deffered to f3
21:49:23 <devcamcar> yep things are happy
21:49:26 <ttx> devcamcar: Anything you wanted to mention ?
21:49:58 <devcamcar> welcome tihomir as our newest core contributor!
21:50:03 <ttx> yay
21:50:03 <gabrielhurley> huzzah!
21:50:05 <devcamcar> other than that, i'm good for today
21:50:09 <ttx> Anybody has questions about Horizon ?
21:50:32 <ttx> #topic Other Team reports
21:50:40 <ttx> annegentle, jaypipes, mtaylor: anything on your mind ?
21:51:13 <ttx> Any other team lead with a status report ?
21:51:50 * heckj wants to know about cinder status
21:52:04 <ttx> jgriffith_: around ?
21:52:19 <jgriffith_> Yep
21:52:23 <ttx> heckj: my understanding was that it's pretty much ready and lives in parallel with nova-volume
21:52:30 <heckj> nice, thanks.
21:52:32 <jgriffith_> Sorry.. in a meeting
21:52:43 <ttx> jgriffith_: is that a fair summary ?
21:52:46 <Daviey> ttx: ready for folsom-2 or ready for final?
21:53:03 <ttx> ready to be published as of F2
21:53:14 <jgriffith_> ttx: Yes will be ready for F2
21:53:20 <ttx> and considered for core (as an existing projecty split) just afterwards
21:53:22 <Daviey> superb.
21:53:36 <jgriffith_> Should be there tonight, just finishing ec2 compat in tests
21:54:08 <ttx> #topic Open discussion
21:54:19 <ttx> #info Now that we know the next summit will be in San Diego, looks like we need a Californian city/county starting with G
21:54:28 <ttx> "vern" compiled a nice list of candidates on the wiki:
21:54:33 <ttx> #link http://wiki.openstack.org/GNames
21:54:45 <ttx> Some pretty good candidates in there, like "Granite", "Grizzly" or "Gazelle"
21:55:13 <ttx> I should soon start a Launchpad poll about it, so you can start advocating for your preferred candidate now :)
21:55:26 <jtran> Guantanamo
21:55:41 <jtran> can i ask an open question ?
21:55:45 <ttx> jtran: hardly in California :)
21:55:48 <ttx> jtran: yes
21:55:50 <jtran> there's a bug release that i'd like to see if we can get into diable-stable branch:  https://bugs.launchpad.net/nova/+bug/900031, i understand we don't backport to diablo anymore, however my organization still uses diable-stable in our env extensively and was hoping we could get a few critical patches backported
21:55:51 <uvirtbot> Launchpad bug 900031 in nova "Limitation in security group rules " [Wishlist,Fix released]
21:56:24 <ttx> jtran: we do backport to diablo still. There is a diablo-stable-maint team that still cares about it
21:56:43 <Daviey> o/
21:56:43 <ttx> (or at least should care)
21:56:48 <ttx> ah, there he is
21:56:53 <annegentle> I'll be on vacation until 7/9 starting Thursday.
21:57:07 <annegentle> Will run the doc team meeting the Monday I get back :)
21:57:14 <ttx> jtran: you should be able to get the bugs you care about at least targeted to the diablo series
21:57:19 <jtran> i followed the process outlined in http://wiki.openstack.org/StableBranch#Proposing_Fixes which is to simply tag in launchpad the 'diable-backport'
21:57:31 <Daviey> jtran: it's less aggressive than current released stable, but still a valid target, yes
21:57:48 <jtran> Daviey, should i just pm u for  more detail?
21:57:55 <ttx> Daviey: do you plan to review the diablo-backport bugs and target to the series where it makes sense ?
21:58:33 <ttx> is Ravikumar from HP around ?
21:58:35 <Daviey> jtran: Well, i hoped to make it more developer centric.
21:58:59 <Daviey> ttx: ie, diablo-stable-maint is more of a review team, than a backporting team.
21:59:31 <Daviey> Which means that proposed changesets  stand a better chance of landing than tagged bugs.
21:59:33 <ttx> Daviey: the trick is "normal" people can't target to the series not nominate for it, someone has to do that, thanks LP
21:59:47 <Daviey> ttx: Yeah, got that.
21:59:48 <ttx> s/not/nor
22:00:11 <ttx> so you also have to "accept" them. Doesn't mean you should do the backport work yourself though
22:00:16 <Daviey> ttx: I'm happy to 'review for acceptance' by targeting tags to series, if people want blessing before undertaking dev work
22:00:32 <ttx> Daviey: sounds good to me
22:00:44 <Daviey> I'll add that as one of my daily tasks.
22:00:58 <ttx> weekly would do it :)
22:01:01 <ttx> Anything else, anyone ?
22:01:31 <ttx> I guess we are done, then
22:01:34 <ttx> #endmeeting