21:02:26 <ttx> #startmeeting
21:02:27 <openstack> Meeting started Tue Jul  3 21:02:26 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:29 <ttx> awesome
21:02:35 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:45 <ttx> #info F2 will be cut at the end of the day.
21:02:54 <ttx> #info In this meeting we'll review what's left to do, defer stuff that won't make it, get the PTL sign-off and refine the F2-targeted bug lists.
21:03:12 <ttx> #topic Actions from previous meeting
21:03:21 <ttx> * vishy to comment on Nova bug triaging thread so that we can start doing sth about it
21:03:34 <ttx> Was DONE, nova-bugs team is now open so anyone can help with http://wiki.openstack.org/BugTriage
21:03:49 <ttx> * ttx to look into organizing a bug squashing day like we did for Essex
21:04:00 <ttx> This was DONE as well. Proposed date is Thursday next week, July 12th:
21:04:04 <ttx> #link http://wiki.openstack.org/BugDays/20120712BugSquashing
21:04:15 <ttx> If you want to organize a real-life event, you can add it to the wiki page
21:05:01 <ttx> #topic Keystone status
21:05:07 <ttx> heckj: o/
21:05:13 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-2
21:05:38 <ttx> All targets are implemented, so I suppose we are OK to cut the milestone-proposed branch in ~10 hours ?
21:05:50 <heckj> ttx: yep
21:05:58 <ttx> Looking at the F2-targeted bugs... there are 3 of them.
21:06:12 <ttx> At this point we need to refine that list so that it only contains "milestone publication blockers":
21:06:16 <heckj> we're getting some bugfixes in - they've just been approved by our newest core member and are flowing through the system now
21:06:26 <ttx> (which we'll fix and backport to milestone-proposed)
21:06:44 <ttx> * https://bugs.launchpad.net/keystone/+bug/1019498
21:06:45 <uvirtbot> Launchpad bug 1019498 in keystone "update keystone to pep8 1.3 " [Wishlist,In progress]
21:07:04 <ttx> I think this one is nice-to-have, but not blocking... I'm fine with it landing today, but I don't think it should be considered a blocker ?
21:07:26 <heckj> if it doesn't flow through the approval perfectly, I'll pull it. It's literally in-progress in the gates now
21:07:41 <ttx> * https://bugs.launchpad.net/keystone/+bug/1016171
21:07:43 <uvirtbot> Launchpad bug 1016171 in keystone "Keystone API is forcing Content-Transfer: chunked on responses" [Wishlist,In progress]
21:07:46 <heckj> If any of these don't make it in by 5pm PST tonight, I'll pull em
21:07:58 <ttx> OK
21:07:59 <heckj> (3 more hours)
21:08:39 <ttx> then anything you taregt to F2 will mean that we cannot publish the milestone until the fix is in.
21:08:58 <ttx> heckj: Is there any other bug that should be fixed before we finally publish Keystone F2 ?
21:09:08 <ttx> Was wondering about https://bugs.launchpad.net/keystone/+bug/1020109
21:09:10 <uvirtbot> Launchpad bug 1020109 in keystone "User role deletion is broken" [High,Fix committed]
21:09:19 <ttx> ooo. Fixed
21:09:24 <heckj> :-)
21:09:40 <heckj> Do you have a script that lines up all the fix-committed, or do I need to do that manually?
21:09:46 <ttx> well then, you have all the correct answers, I'm forced to let you go
21:10:14 <ttx> heckj: I have a script that turns FixCommitted into FixReleased + milestone
21:10:23 <heckj> perfect
21:10:29 <ttx> that I run as part of the MP cut process (tomorrow morning)
21:10:43 <ttx> Wednesday morning bugmail spam
21:10:48 <ttx> heckj: anything else ?
21:10:56 <heckj> not from me - I'm good
21:11:00 <ttx> Questions about Keystone ?
21:11:31 <ttx> #topic Swift status
21:11:42 <ttx> notmyname is traveling this week, asked me to paste a bit of update
21:11:48 <ttx> #link https://twitter.com/notmyname/status/219941711927980032
21:11:59 <ttx> "although I haven't updated LP yet, everything is on track for the 1.5.1 release in 2 weeks AFAIK."
21:12:51 <ttx> So let's move to another F2-affected project, unless someone has questions on Swift ?
21:13:36 <ttx> #topic Glance status
21:13:41 <ttx> bcwaldon: o/
21:13:44 <bcwaldon> ttx: hello
21:13:46 <ttx> #link https://launchpad.net/glance/+milestone/folsom-2
21:13:58 <bcwaldon> ttx: pretty, eh?
21:14:00 <ttx> Was a bit scary this afternoon, but now looks like you're all set!
21:14:24 <bcwaldon> ttx: I wouldn't say it was 'scary'...
21:14:29 <bcwaldon> ttx: it needed some grooming
21:14:36 <bcwaldon> ttx: and that's all done now :)
21:15:10 * ttx thinks bcwaldon will need more than grooming to complete all his F3 targets
21:15:22 * vishy resists the urge to change the blueprints out from under ttx
21:15:31 <ttx> vishy: try me
21:15:34 * bcwaldon also enjoys speaking the third person
21:15:40 <bcwaldon> crap!
21:15:45 <ttx> Anyone has a bug that we shouldn't publish F2 with ?
21:15:55 <ttx> (Glance F2, I mean)
21:16:14 <ttx> bcwaldon: Anything else on your mind ?
21:16:28 <bcwaldon> ttx: well, I've been feeling like I need to get some coffee
21:16:43 <bcwaldon> ttx: other than that, no
21:16:52 <ttx> coffee good
21:16:53 <ttx> Raise your hand if you've a question on Glance...
21:17:19 <ttx> (when I prepared this meeting earlier today, it looked a lot more busy)
21:17:22 <heckj> bcwaldon: coffee ++
21:17:36 <ttx> #topic Quantum status
21:17:42 <ttx> danwent: yo
21:17:44 <danwent> hi
21:17:46 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-2
21:17:55 <ttx> On the blueprints side, 2 targets left:
21:17:58 <danwent> btw, you'll want to refresh for status on a couple bugs that i updated 15 mins ago
21:18:04 <danwent> yes, dhcp is our key focus
21:18:06 <ttx> * https://blueprints.launchpad.net/quantum/+spec/quantum-dhcp
21:18:10 <danwent> we're very close on that.
21:18:11 <ttx> Pending on https://review.openstack.org/#/c/9064/ ?
21:18:39 <danwent> yes.  -1s are style issues right now.  needs final testing though.
21:18:46 <ttx> * https://blueprints.launchpad.net/quantum/+spec/provider-networks
21:18:47 <danwent> i'm confident this will get in.
21:18:53 <danwent> (comment was about dhcp)
21:18:57 <ttx> Looks like this one is still a bit far away. The change up for review only partially implements it. Defer ?
21:19:10 <danwent> the provider-networks stuff will almost certainly not make it.
21:19:19 <danwent> unless we decide to backport to milestone proposed
21:19:32 <danwent> he will have a review tonight, but I don't think its critical to push.
21:19:37 <ttx> danwent: I'd prefer not to backport feature code
21:19:59 <danwent> ttx: yes, that's my feel as well.  I'm fine bumping it right now if you prefer.
21:20:04 <danwent> you're pulling branches in 3 hours?
21:20:09 <ttx> Are you OK with me cutting the F2 branch in ~10 hours with what will be in there ? Or is quantum-dhcp a must-have-in-F2
21:20:23 <ttx> ~10hours, I need some sleep
21:20:41 <danwent> we'll have it in less than 10 hours
21:20:57 <ttx> danwent: sure, but in case I wake up and it isn't ? I hear Ci sometimes fails
21:20:58 <danwent> should have it pushed in a few, as author is on east coast
21:21:29 <danwent> hehe.  please hold if its not in.  its important, and i'll my best to make sure it is in, CI be damned.
21:21:45 <ttx> OK
21:21:49 <danwent> but I will email you to let you know if we somehow can't get CI working.
21:21:58 * ttx refreshes bug list
21:22:11 <ttx> 5 bugs on the F2 target list
21:22:15 <danwent> all in progress bugs are in review.
21:22:32 <ttx> * https://bugs.launchpad.net/bugs/1019462
21:22:34 <uvirtbot> Launchpad bug 1019462 in quantum "devstack support for quantum DHCP" [High,Confirmed]
21:22:36 <danwent> two of the 5 issues are devstack, which isn't something that makes the tarball
21:22:37 <ttx> isn't that a devstack bug ?
21:22:58 <danwent> yes, but for sanity I track it in quantum (ducks)
21:23:09 <ttx> danwent: we should find a way for you to track outside bugs that doesn't involve creating fake bugs :)
21:23:18 <danwent> i would love that
21:23:54 <danwent> we should probably also just defer #1019899
21:24:10 <ttx> #action ttx to see how danwent could track bugs outside quantum without creating noise
21:24:36 <danwent> i need to track changes to nova, devstack, horizon as well as quantum
21:24:52 <ttx> danwent: at the EOD can you refine that list so that it only contains stuff you intend to backport and that you don't want to release F2 without ?
21:24:55 <danwent> no easy to to do that sanely on launchpad without "shadow" bugs
21:25:08 <salv-orlando> bug 1019899 is 5 minutes from push
21:25:09 <uvirtbot> Launchpad bug 1019899 in quantum "add support for requested_networks extension to Nova/Quantum v2 code" [High,Confirmed] https://launchpad.net/bugs/1019899
21:25:19 <danwent> salv-orlando: ah, still up :)
21:25:21 <ttx> danwent: you can search for tags at openstack superproject level
21:25:40 <ttx> danwent: we'll talk about that another day :)
21:25:43 <danwent> ttx: ok, will explore that.
21:25:58 <ttx> danwent: at the EOD can you refine that list so that it only contains stuff you intend to backport and that you don't want to release F2 without ?
21:26:04 <danwent> salv-orlando: please propose soon, as we'll need to find nova core devs for that one (ducks again..)
21:26:15 <danwent> ttx: yes, will have bug lists pruned.
21:26:23 <danwent> all of that stuff will move if the reviews done clear today
21:26:27 <danwent> don't
21:26:37 <ttx> danwent: Awesome. Anything else ?
21:26:42 <danwent> one thing
21:27:08 <danwent> so with v2 quantum there are a lot of changes in how you invoke quantum that will be the result of F-2 and F-3 work.
21:27:25 <danwent> we've had a lot of trouble getting eyeballs on quantum-related reviews for devstack
21:27:51 <danwent> so we're trying to work with devstack leads on how we can get some quantum team members core reviewers status for devstack to help with the load
21:28:07 <ttx> danwent: right, that sounds like the good way to solve that
21:28:11 <danwent> this is also important for devstack gating
21:28:20 <danwent> we've had reviews for that hanging for weeks
21:28:56 <ttx> danwent: ok, keep us posted on the outcome
21:29:07 <danwent> I'll loop you into the existing email thread.
21:29:10 <danwent> that's all from me
21:29:16 <ttx> Questions on Quantum ?
21:29:50 <ttx> #topic Nova status
21:29:56 <ttx> vishy: hey
21:30:00 <ttx> #link https://launchpad.net/nova/+milestone/folsom-2
21:30:04 * ttx refreshes
21:30:05 <vishy> hi
21:30:09 <vishy> i didn't break it :)
21:30:19 <ttx> 7 targets left, looks like massive defer-to-F3 is in order :) let's review them...
21:30:37 <ttx> * https://blueprints.launchpad.net/nova/+spec/finish-uuid-conversion
21:30:45 <ttx> Status a bit unclear on that one ?
21:30:56 <vishy> ttx: turns out there is a bit more, so lets defer it
21:31:08 <vishy> bcwaldon: this is done, right? https://blueprints.launchpad.net/nova/+spec/integrate-python-glanceclient
21:31:13 <bcwaldon> vishy: no
21:31:22 <ttx> bcwaldon: what's left to do ?
21:31:22 <bcwaldon> vishy: I did all the work to be able to do that
21:31:27 <bcwaldon> actually do it
21:31:43 <ttx> bcwaldon: how much time does actually doing it take ?
21:32:00 <ttx> is that compatible with F2 ?
21:32:01 <bcwaldon> ttx: more than I would have for f2
21:32:07 <ttx> ack
21:32:12 <bcwaldon> bar
21:32:34 <ttx> bcwaldon: what about https://blueprints.launchpad.net/nova/+spec/remove-deprecated-auth ?
21:32:42 <bcwaldon> ttx: I've been totally ignoring that one
21:32:53 <bcwaldon> ttx: f3
21:32:56 <ttx> (finish-uuid-conversion pushed to F3)
21:32:59 <vishy> bcwaldon: wth, its not like you have anything else to work on
21:33:06 <vishy> :o
21:33:11 <bcwaldon> vishy: I know :(
21:33:39 <ttx> * https://blueprints.launchpad.net/nova/+spec/quantum-nova-network-api
21:33:49 <ttx> Pending on https://review.openstack.org/#/c/8916/ ?
21:33:58 <ttx> which was merged..
21:34:01 <ttx> so complete ?
21:34:05 <vishy> yup
21:34:17 <ttx> * https://blueprints.launchpad.net/nova/+spec/nova-image-cache-management-2
21:34:49 <ttx> remove-deprecated-auth, integrate-python-glanceclient -> F3
21:35:09 <vishy> defer
21:35:16 <vishy> that one got stuck in review
21:35:29 <vishy> i think mikal switched to uuid stuff and will get back to it later
21:35:31 <ttx> deferred
21:35:45 <ttx> * https://blueprints.launchpad.net/nova/+spec/instance-type-extra-specs-extension
21:35:53 <ttx> Review @ https://review.openstack.org/#/c/8089/
21:36:07 <ttx> Looks almost there, would be good to push it in today
21:36:31 <ttx> though the last comment by jog0 makes me wonder a bit
21:37:20 <ttx> vishy: ?
21:37:25 <vishy> ttx: i think it is ok. We are moving from capabilities specified
21:37:30 <vishy> in flags to host aggregates
21:37:48 <vishy> his patch is just adding more filtering based on capabilities
21:38:07 <ttx> OK, so good to have,n but won't block F2 MP cut if not in in 10hours
21:38:27 <ttx> last one: https://blueprints.launchpad.net/nova/+spec/per-user-quotas
21:38:34 <ttx> Review @ https://review.openstack.org/#/c/8388/
21:38:53 <ttx> Also looks almost there, would be good to push it in today
21:39:33 <vishy> ttx: i will approve that one
21:39:45 <vishy> I was almost finished with the review
21:39:46 <ttx> OK. I had a question about https://blueprints.launchpad.net/nova/+spec/multi-process-api-service (which is marked "Implemented")
21:39:55 <ttx> Looks like https://review.openstack.org/#/c/8228/ is part of it though ?
21:40:39 <ttx> so should it be considered still in progress ? and how likely is this to end in F2 ?
21:41:40 <vishy> ttx: no that should be abandoned
21:41:48 <vishy> jerdfelt rewrote that patch and it merged
21:42:06 <ttx> good stuff
21:42:12 <ttx> On the bugs side, no F2 targets. Anything that we should definitely fix before we cut F2 ?
21:42:25 <ttx> I noted bug 1018721, maybe
21:42:27 <uvirtbot> Launchpad bug 1018721 in nova "Launching with source groups under load produces lazy load error" [High,Triaged] https://launchpad.net/bugs/1018721
21:42:42 <ttx> though if its a corner case it doesn't matter that much
21:43:04 <vishy> ttx: it isn't a corner case and it is really nasty in essex as well. I just don't have a real fix, just the workaround
21:43:51 <vishy> ttx: should i prop the workaround? I would really like to know what is causing it, because I expect it will come back in another form eventually
21:44:43 <ttx> vishy: would be good to avoid the condition using the workaround... and open another bug to make sure we don't lose track of the more permanent fix
21:45:09 <vishy> ttx: yeah, although the repro case will be hard :)
21:45:18 <ttx> (maybe targeting it to F3 so that it stay on scope)
21:45:48 <ttx> so yes, I'd prop it for f2
21:45:54 <ttx> should I target that bug ?
21:46:12 <vishy> yes
21:46:23 <ttx> anything else that looks really bad and we shouldn't have on the milestone ? Apart from the two CVEs that were pushed today ? ;)
21:47:26 <ttx> vishy: Anything else ?
21:48:07 <ttx> vishy: i'll cut F2 with what's in master tomorrow morning, and defer the last two BPs in case they didn't make it
21:48:15 <vishy> yes
21:48:24 <vishy> I need reviews on host_aggregates patch too
21:48:44 <ttx> that's for F3, right ?
21:49:07 <ttx> Questions on Nova ?
21:49:09 <gabrielhurley> ttx, vishy: question: while we're in the nova-volume/cinder transitional period when there are bugs about volumes (api, attachment, etc.) should those bugs be targeted against nova, cinder, or both on Launchpad?
21:49:30 <ttx> gabrielhurley: single bug, two tasks
21:49:46 <gabrielhurley> ttx: so add each project on the same bug report
21:49:56 <ttx> gabrielhurley: that's how I would do it yes
21:49:59 <gabrielhurley> k
21:50:25 <vishy> gabrielhurley: probably both
21:50:29 <ttx> vishy: the host_aggregates patch is for F3, right ?
21:50:44 <vishy> ttx: final is for f3, i was hoping to get part 1 if f2
21:50:52 <vishy> but i guess it isn't super-urgent
21:50:54 <ttx> vishy: ok
21:51:10 <ttx> #help reviews wanted on host_aggregates patch
21:51:17 <ttx> #topic Horizon status
21:51:21 <ttx> devcamcar: hey
21:51:25 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-2
21:51:32 <gabrielhurley> ttx: be sure to refresh the page... ;-)
21:51:40 <ttx> 1 target left :)
21:51:50 <ttx> * https://blueprints.launchpad.net/horizon/+spec/nova-volume-optional
21:51:56 <ttx> Looks like it's "almost there" with https://review.openstack.org/#/c/9038/ ?
21:52:19 <gabrielhurley> ttx: devcamcar will reappear here, I'm sure, but yes. just needs a second +2
21:52:26 <gabrielhurley> no controversy
21:53:07 <ttx> gabrielhurley, devcamcar: in the unlikely case that it's not merged at the end of the day..; should I block or cut F2 MP without it ?
21:53:27 <gabrielhurley> ttx: cut without it. it was moved up from F3 'cuz it was done.
21:53:38 <ttx> ok, thx
21:53:50 <ttx> Looking at the F2-targeted bugs... 4 left
21:54:12 <ttx> devcamcar, gabrielhurley: Should they all be considered final F2 publication blockers ?
21:54:28 <gabrielhurley> ttx: I'm just gonna keep talking until someone tells me to shut up... my two will be merged today but aren't blockers. as for the other two:
21:54:48 <gabrielhurley> bug 982590 isn't a blocker but I don't know who has the power to fix it
21:54:49 <uvirtbot> Launchpad bug 982590 in horizon "Repo description on github talks about old name django-openstack" [Low,Confirmed] https://launchpad.net/bugs/982590
21:54:54 <gabrielhurley> and it'd be nice to get that fixed.
21:55:01 <ttx> hmm, probably openstack-ci
21:55:13 <gabrielhurley> ‏‎bug 1016085
21:55:15 <uvirtbot> Launchpad bug 1016085 in horizon "Directories not included during install" [High,Confirmed] https://launchpad.net/bugs/1016085
21:55:20 <gabrielhurley> that one is probably a blocker
21:55:27 <gabrielhurley> it had an assignee until recently
21:55:28 <ttx> this one looks like something we would backport the fix for
21:55:32 <gabrielhurley> they abandoned it
21:55:32 <ttx> agreed
21:55:40 <gabrielhurley> so it needs to be fixed. I'll probably have to do it today
21:55:43 <gabrielhurley> :-/
21:56:05 <ttx> gabrielhurley: you still have tomorrow, we can backport the fix until early Thursday
21:56:24 <ttx> devcamcar, gabrielhurley: Anything else you wanted to mention ?
21:56:25 <gabrielhurley> it mostly only affects the downstram packagers, but it needs resolution, for sure. I'll see what I can do.
21:56:34 <gabrielhurley> ttx: that's it for me...
21:56:36 <ttx> Questions for Horizon ?
21:56:51 <ttx> #topic Other Team reports
21:56:57 <devcamcar> and i'm back! perfect timing :)
21:57:01 <ttx> annegentle, jaypipes, mtaylor: ?
21:57:01 <devcamcar> thanks gabriel
21:57:05 <ttx> devcamcar: heh
21:57:11 <ttx> devcamcar: anythign you wanted to add ?
21:57:32 <ttx> devcamcar: just in time for the best topic of the meeting
21:57:32 <jgriffith> ttx: can Cinder be "other team"
21:57:33 <devcamcar> looks like you guys have it under control
21:57:39 <ttx> jgriffith: certainly :)
21:58:08 <jgriffith> ttx: We'll hit F2 with what was planned after today I believe
21:58:24 <jgriffith> 6 or 7 folks here at Piston today working on Cinder
21:58:33 <ttx> jgriffith: unless you tell me otherwise i'll cut F2 branch from master in ~9 hours
21:58:49 <jgriffith> ttx: That works
21:59:00 <ttx> jgriffith: anything else ?
21:59:24 <jgriffith> Nope
21:59:25 <ttx> #topic Open discussion
21:59:32 <ttx> Time has come for us to choose the name of the "G" release !
21:59:37 <devcamcar> hizzah!
21:59:38 <ttx> You should all be able to cast your vote at:
21:59:42 <ttx> #link https://launchpad.net/~openstack/+poll/g-release-naming
22:00:00 <ttx> Poll will close at 21:30 UTC Tuesday next week
22:00:06 <ttx> I cleaned up the options according to the rules of play at http://wiki.openstack.org/ReleaseNaming
22:00:07 <devcamcar> gerber? really? :x
22:00:15 <ttx> heh
22:00:17 <heckj> oooh! Now I like that one!
22:00:21 <ttx> Still pretty good names in there, like Gazelle, Glenn or Guadalupe
22:00:23 <devcamcar> baby cloud
22:00:35 <ttx> "gerber" means "to throw up" in French.
22:00:44 <devcamcar> lol
22:00:49 <ttx> #action ttx to formally announce the poll on ML/twitter etc.
22:00:52 <devcamcar> its a brand of baby food over this way
22:01:06 <ttx> there must be a story behind that
22:01:11 <devcamcar> i'd love to hear it
22:01:18 <bcwaldon> ttx: Grizzly is Grizzly Flats, right?
22:01:33 <ttx> bcwaldon: Grizzly is no longer an option
22:01:37 <bcwaldon> no!
22:01:42 <bcwaldon> that's it
22:01:45 <bcwaldon> I'm quitting
22:01:51 <ttx> we only accept single words
22:01:59 <ttx> that's the rules !
22:02:03 * devcamcar turns over a table
22:02:15 * ttx hides
22:02:44 <ttx> I guess that means the meeting is over ?
22:02:49 <bcwaldon> +1
22:03:00 <ttx> Awesome.
22:03:02 <ttx> #endmeeting