#openstack-meeting Meeting

Meeting started by heckj at 18:01:24 UTC (full logs).

Meeting summary

  1. Folsom Release and general planning (heckj, 18:02:10)
    1. http://wiki.openstack.org/FolsomReleaseSchedule (heckj, 18:02:39)
    2. https://launchpad.net/keystone/+milestone/folsom-3 (heckj, 18:04:17)
    3. PKI Status: https://gist.github.com/3085149 (heckj, 18:06:03)
    4. PKI work items/actions: https://gist.github.com/3085149 (heckj, 18:07:01)
    5. V3 draft3 https://docs.google.com/document/d/1VP-bTBbwsn6q-rDzuS9CEKb2ubE1VjbWRFd4BkkjoOY/edit (heckj, 18:07:42)
    6. ACTION: : heckj to create tags and bugs with an initial work breakdown (heckj, 18:11:32)
    7. ACTION: heckj to drop all dependent pieces on V3 API implementation from Folsom series (heckj, 18:13:39)

  2. rate limiting middleware - feedback and corner cases (heckj, 18:19:02)
    1. https://blueprints.launchpad.net/keystone/+spec/keystone-rate-limiting (rafaduran, 18:19:56)
    2. https://github.com/rafaduran/keystone/tree/bp/keystone-rate-limiting (rafaduran, 18:20:35)
    3. https://github.com/rafaduran/keystone/tree/bp/keystone-rate-limiting (heckj, 18:21:05)
    4. ACTION: rafaduran to write up design questions for rate limiting (ayoung, 18:28:30)
    5. ACTION: rafaduran to write up design questions for rate limiting (heckj, 18:28:45)
    6. https://github.com/rafaduran/keystone/tree/bp/keystone-rate-limiting (rafaduran, 18:35:11)
    7. https://github.com/rafaduran/keystone/blob/bp/keystone-rate-limiting/keystone/contrib/rate/core.py#L283 (rafaduran, 18:37:51)
    8. ACTION: auth_token middle populates request context with data from signed token so it does not have to be fetched multiple times. (ayoung, 18:46:00)

  3. open discussion (heckj, 18:47:53)
    1. If you have a BP that you think can get done in the next 4 weeks, let heckj know and we'll link the BP's back up (heckj, 18:48:37)


Meeting ended at 18:59:03 UTC (full logs).

Action items

  1. : heckj to create tags and bugs with an initial work breakdown
  2. heckj to drop all dependent pieces on V3 API implementation from Folsom series
  3. rafaduran to write up design questions for rate limiting
  4. rafaduran to write up design questions for rate limiting
  5. auth_token middle populates request context with data from signed token so it does not have to be fetched multiple times.


Action items, by person

  1. heckj
    1. : heckj to create tags and bugs with an initial work breakdown
    2. heckj to drop all dependent pieces on V3 API implementation from Folsom series
  2. rafaduran
    1. rafaduran to write up design questions for rate limiting
    2. rafaduran to write up design questions for rate limiting


People present (lines said)

  1. heckj (67)
  2. rafaduran (43)
  3. ayoung (35)
  4. dtroyer (3)
  5. openstack (2)


Generated by MeetBot 0.1.4.