21:02:20 <ttx> #startmeeting
21:02:21 <openstack> Meeting started Tue Jul 10 21:02:20 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:28 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:48 <ttx> #info First meeting of the F3 era, we'll have a look at sanitizing plans so that they are a realistic view of what we're likely to achieve
21:03:04 <ttx> Will also talk about the upcoming bug squashing day on Thursday... and give out the results of the G poll... will the Bear Revolt win ?
21:03:16 <ttx> (or will order prevail)
21:03:25 <mtaylor> GO GRIZZLY OR GO HOME!!!
21:03:29 <bcwaldon> MUTINY
21:03:32 <creiht> what? order never prevails with openstack ;)
21:03:37 <heckj> GRIZZLYYY
21:03:37 <koolhead17> mtaylor, :P
21:03:41 <ttx> #topic Actions from previous meeting
21:03:48 <ttx> * ttx to see how danwent could track bugs outside quantum without creating noise
21:03:54 <ttx> Not done yet, postponing
21:03:55 <creiht> I was hoping for gristle
21:04:02 <creiht> :)
21:04:03 <ttx> #action ttx to see how danwent could track bugs outside quantum without creating noise
21:04:16 * ttx makes mental note: do not let creiht pick /any/ name
21:04:28 <ttx> * ttx to formally announce the G poll on ML/twitter etc.
21:04:39 <ttx> DONE, you have 41 minutes left to cast your vote for the G release name:
21:04:41 <creiht> I gave up on picking sane names after the first vote :)
21:04:47 <ttx> https://launchpad.net/~openstack/+polls
21:05:06 <ttx> #topic Keystone status
21:05:14 <ttx> heckj: o/
21:05:17 <vishy> creiht: which was your first vote?
21:05:18 <heckj> o/
21:05:20 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-3
21:05:34 * heckj used the ttx.py script to clean things up this morning
21:05:45 <heckj> I think it needs a french accent next
21:05:48 <ttx> o0
21:05:57 <ttx> le ttx.py
21:06:21 <ttx> heckj: I see you recently removed some targets ?
21:06:24 <bcwaldon> le definitely
21:06:50 <ttx> heckj: like... no more v3 ?
21:06:53 <heckj> We reviewed the work pending for F3, and there was just way too much that it was clear we weren't going to get done
21:06:56 <zul> no no...en francais
21:07:28 <ttx> heckj: ++
21:07:36 <heckj> V3 is still the focus, as it's a dependency on many of the desired pieces, but I don't want to set the expectation that other projects should start using V3 API at the end of a F3 milestone timeframe
21:08:05 <ttx> heckj: so the idea is to have a partial v3 implementation in Folsom ?
21:08:12 <heckj> I'll be sending email about my un-linking of the BP's to the mailing list too - if more commits come in, I'll link them back up.
21:08:56 <heckj> ttx: My goal is to have V3 fully implemented by the milestone, but given the rate of change lately, I don't think it's likely to be fully there. Something will be - it may be partial, or not fully fleshed out.
21:09:18 <ttx> but definitely alpha/beta in all cases.
21:09:24 <heckj> ttx: yes
21:09:34 <ttx> sounds reasonable.
21:09:48 <ttx> Other projects: does that create red flags somewhere ?
21:09:52 <ttx> or general relief ?
21:09:53 <gabrielhurley> heckj, ttx: how do these changes around the v3 implementation affect RBAC/policy implementations across the stack as a whole?
21:10:22 <gabrielhurley> (that being the biggest piece that doesn't exist in v2)
21:11:13 <heckj> gabrielhurley: policy will still be there, and there's a BP to consolidate a "suggested deployment" setup for all of them. Getting policy CRUD implemented in the API should be there, but we'd be greatly pressing to get the full integration will all the projects there in the next 4 weeks.
21:11:46 <gabrielhurley> so it becomes more of a Grizzly thing to really make that solid, then?
21:11:48 <ttx> my understanding is that it will make folsom a bit of a transitional release for Keystone, but I'm pretty sure most people can live with that
21:11:50 <heckj> gabrielhurley: the big V3 related change in policy is sourcing it in keystone. That should be possible, and we can even focus on making that happen earlier rather than later
21:12:06 <gabrielhurley> heckj: yeah, the sourcing is what's important to Horizon
21:12:10 <gabrielhurley> if that happens I think I'm happy
21:12:21 <heckj> gabrielhurley: noted
21:12:32 <ttx> heckj: ok good, anything else ?
21:13:21 <heckj> that's it for me
21:13:33 <ttx> Questions about Keystone ?
21:14:05 <ttx> #topic Swift status
21:14:10 <notmyname> hi
21:14:10 <ttx> #link https://launchpad.net/swift/+milestone/1.5.1
21:14:21 <ttx> notmyname: Hi! Target date was pushed back to July 30 ?
21:14:27 <notmyname> yes it was
21:14:34 <ttx> Anything specific you wait the completion of ?
21:14:47 <notmyname> we won't be able to get the additional QA this week that we normally have, so I pushed it back
21:15:06 <notmyname> it's (slightly) possible that we may have it sooner, but I pushed it 2 weeks to be sae
21:15:08 <notmyname> safe
21:15:17 <ttx> oh, so it's more a QA sync issue than a missing needed feature ?
21:15:21 <notmyname> y
21:15:22 <notmyname> ya
21:15:43 <notmyname> and I hope, long-term, the recently proposed swift integration into tempest will help alleviate that
21:15:48 <ttx> Would you include https://blueprints.launchpad.net/swift/+spec/keystone-middleware in it if it's ready by then ?
21:16:01 <notmyname> absolutely
21:16:20 <ttx> Sounds good.
21:16:34 <ttx> notmyname: anything else you wanted to mention ?
21:16:41 <notmyname> ya, let me find a link
21:17:26 <notmyname> #link WIP 1.5.1 changelog until LP is updated https://github.com/notmyname/swift/blob/1.5.1-changelog/CHANGELOG
21:17:49 <ttx> cool, thx
21:18:11 <notmyname> one more thing
21:18:43 <notmyname> I'll be talking to the swift core devs this week about integrating swift with the devstack gates. nothing to say there, just stuff being done
21:19:01 <ttx> Noted. Other questions on Swift ?
21:19:37 <ttx> #topic Glance status
21:19:43 <ttx> bcwaldon: o/
21:19:49 <bcwaldon> ttx: hey hey
21:19:49 <ttx> #link https://launchpad.net/glance/+milestone/folsom-3
21:19:55 * ttx preventively refreshes
21:20:01 <bcwaldon> ttx: you're safe today
21:20:16 <ttx> OK, so there are (still) several things I don't really like here :)
21:20:22 <bcwaldon> ttx: I know :(
21:20:31 <ttx> First, the 5 essential blueprints make me a bit nervous.
21:20:44 <bcwaldon> ttx: BUT I was working on https://launchpad.net/python-glanceclient !
21:20:49 <ttx> but I guess if the ETA on them is reasonable it's not such a big deal
21:21:03 <bcwaldon> ttx: I'm going to spend my afternoon figuring out what can happen in F3
21:21:21 <bcwaldon> ttx: what's the OS policy on features after F3?
21:21:44 <ttx> essential stuff gets post-F3 pre-RC1 exceptions
21:21:46 <vishy> we have a STONITH protocol for features after f3
21:21:53 <ttx> and each of those exceptions lowers the general quality of the release
21:22:01 <bcwaldon> vishy: I don't appreciate that
21:22:07 <bcwaldon> vishy: define: STONITH
21:22:28 <bcwaldon> ttx: ok, just wanted to make sure we were on the same page
21:22:35 <vishy> Shoot the other node in the head (in this case the other node is the new feature)
21:22:35 <heckj> STONITH: Shoot The Other Node In The Head
21:22:40 <bcwaldon> :|
21:22:43 <vishy> STNFITH
21:22:47 <bcwaldon> :|
21:23:04 <bcwaldon> ttx: SO, it will look better within 24 hours, I promise
21:23:06 <ttx> bcwaldon: so if any of those look like they might not get completed before the end of the month... I would go the heckj route and question whether they should really be in Folsom
21:23:18 <bcwaldon> ttx: some of them are planned refactorings
21:23:39 <ttx> yes, the glance client stuff is clearly on hte map... and the rest is V2 stuff afaict
21:23:41 <bcwaldon> ttx: I just need to look at each one and classify whether it can or can't get done after F3
21:24:27 <ttx> bcwaldon: default answer is "cannot".
21:24:34 <bcwaldon> ttx: ok
21:24:57 <bcwaldon> ttx: I did want to talk about python-glaneclient
21:24:58 <ttx> I really would like if we could not have feature freeze exceptions unless Murphy strikes
21:25:14 <ttx> i.e. keep the option for spectucular failures rather than business as usual
21:25:28 <bcwaldon> ttx: since we aren't releasing client libs on the same schedule, they aren't really affected by FF and milestones
21:25:34 <ttx> indeed.
21:25:48 <bcwaldon> ttx: ok, and I think we need to decide who has the power to release client libs
21:25:55 <bcwaldon> ttx: as I now want to do it
21:25:58 <heckj> bcwaldon: ++ would like to see that nailed down
21:26:06 <ttx> bcwaldon: the PTL should decide when it makes sense
21:26:14 <bcwaldon> ttx: I've already decided that
21:26:18 <bcwaldon> ttx: i just need to be able to push a button
21:26:23 <ttx> bcwaldon: the ptl /could/ ask me if I see any reason why that's a bad idea just now
21:26:25 <bcwaldon> ttx: are you going to be that button?
21:26:52 <bcwaldon> ttx: I'm fine with whatever, I just want to get moving
21:26:54 <ttx> bcwaldon: no, normally taylor shall give you the ability to push tags to gerrit, which is all it takes
21:26:56 <gabrielhurley> bcwaldon: ++ to PTLs having their finger on the button and not having a bottleneck/bus factor to contend with...
21:27:09 <ttx> mtaylor*
21:27:19 <bcwaldon> ttx: hmm, so if mtaylor isn't around, we can't release?
21:27:31 <bcwaldon> ttx: or do I just need to get him to add me to some magical group
21:27:45 <ttx> bcwaldon: no ;) mtaylor just adds you to magic group once and for all
21:27:59 <ttx> bcwaldon: so pushing a release is just a command away for you
21:28:03 <bcwaldon> ttx: ok, works for me
21:28:12 <bcwaldon> ttx: ATTENTION PTLs! Read that ^
21:28:21 <bcwaldon> ttx: that's all for me, then :)
21:28:35 <ttx> bcwaldon: again, asking me before doing it can't hurt. Like some security issue might be near the end of the tube
21:28:43 <bcwaldon> ttx: definitely
21:28:44 <mtaylor> works for me
21:28:44 <ttx> but it's not blocking
21:28:59 <bcwaldon> ttx: best effort will be given
21:29:00 <ttx> so if tere is anythign urgent, you can do it
21:29:19 <ttx> bcwaldon: had another remark about the F3 plan...
21:29:21 <ttx> The second thing I don't like is the unassigned stuff. At this point, if nobody committed to doing the work, it won't get done.
21:29:29 <ttx> Or do all those mean "I'll do them if nobody signs up for them" ?
21:29:36 <mtaylor> ttx: do you want all PTLs just to be in openstack-release?
21:29:44 <mtaylor> ttx: or you want me to make a separate group?
21:29:52 <ttx> mtaylor: I'd prefer not. You could reuse the drivers group
21:29:55 <bcwaldon> ttx: I'm going to do as many of them as I can if nobody picks them up
21:29:56 <mtaylor> ttx: or you want me to add each ptl to each project
21:30:02 <ttx> or just make a group with the PTL only
21:30:03 <bcwaldon> ttx: I have soft commitments for some of them
21:30:11 <mtaylor> ttx: k. glance-drivers gets tag push on glance and python-glanceclient then?
21:30:27 <ttx> mtaylor: if bcwaldon is ok wit hit.
21:30:31 <ttx> or with it
21:30:47 <ttx> bcwaldon: would be good to have hard commitments at least for the essential one :)
21:30:55 <bcwaldon> I'm not glance-drivers makes sense
21:31:06 <bcwaldon> sure*
21:31:22 <ttx> ok, done with Glance...
21:31:26 <ttx> bcwaldon: Anything else ?
21:31:28 <bcwaldon> mtaylor: at a minimum, I would like PTLs and release team to be able to do it
21:31:30 <bcwaldon> ttx: no sir
21:31:37 <mtaylor> bcwaldon: release team has it everywhere
21:31:44 <bcwaldon> mtaylor: lets talk about this later
21:31:46 <mtaylor> bcwaldon: I'll give ptl the magic power per-project
21:31:46 <ttx> mtaylor: sssh, that's our secret.
21:31:48 <mtaylor> bck
21:31:54 <mtaylor> oops
21:32:15 <ttx> the idea is to retsrict it to people that actually know that pushing a tag will trigger a PyPI upload.
21:32:33 <ttx> somehow some people ignore that, go figure.
21:32:38 <ttx> Questions on Glance ?
21:33:11 <ttx> #topic Quantum status
21:33:16 <ttx> danwent: yo
21:33:19 <danwent> hey
21:33:21 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-3
21:33:27 <danwent> don't let your eyes bulge too much
21:33:33 <ttx> OK, so this one clearly falls in the "optimistic" category, with 31! targeted blueprints
21:33:39 <ttx> As a data point, you completed 16 in F1+F2 :)
21:33:49 <danwent> yup, but our team is much bigger now.
21:33:55 <danwent> just focus on things that are essential or high
21:34:00 <ttx> heh, ok
21:34:14 <danwent> anything at medium is not critical to the project, but someone said they were going to do it, so I'm taking them at their word and am targeting it for F-3
21:34:24 <ttx> danwent: there were a number of them that weren't  inthe series goal = Folsom, you should spot them using ttx.py
21:34:37 <danwent> i think i cleaned those all up this morning with ttx.py
21:34:41 <ttx> ok
21:34:43 <danwent> unless someone has added more since then
21:34:47 <danwent> (always possible)
21:34:52 <danwent> will do another pass
21:35:17 <ttx> danwent: ok, I guess we'll refine as we close the F3 deadline
21:35:33 <ttx> as we get closer to, I mean
21:35:52 <danwent> yeah.  we're going to be more demanding about people creating specs up front for any high or above item, which should help us keep tabs on the progress those issues are making early in the milestone period.
21:36:11 <ttx> and publicly shame those who said they would do it but didn't
21:36:25 <danwent> that's the idea (which reminds me, i need to finish my spec....)
21:36:42 <ttx> Looking at the 3 remaining essential blueprints...
21:36:42 <gabrielhurley> ttx: SDD - Shame Driven Development
21:36:59 <ttx> danwent: Would like to make sure those will be delivered "early enough" in this milestone timeframe. Do you have an ETA for quantum-v2-public-networks and quantum-l3-fwd-nat ?
21:37:02 <danwent> sounds like a great book
21:37:23 <ttx> gabrielhurley: I actually do Sarcasm-driven development
21:37:36 <danwent> I'm hoping for a review 3 weeks into the cycle on those.
21:37:56 <danwent> likely the l3 BP will be split into several, with non-essential items being handled separately
21:38:02 <ttx> so..; before the end of the month ?
21:38:30 <danwent> at the end of the month, yes :)
21:38:33 <ttx> danwent: sounds good to me. Anything else ?
21:38:40 <danwent> i doubt it will be much before :)
21:39:05 <ttx> Questions on Quantum ?
21:39:22 <ttx> #topic Nova status
21:39:27 <ttx> #link https://launchpad.net/nova/+milestone/folsom-3
21:39:46 <ttx> vishy: o/
21:39:53 <ttx> 22 blueprints targeted, compared to 20 implemented during F1+F2
21:40:07 <ttx> That said, lots of those are actually Low-prio or globally in progress so it's not as bad as it looks ?
21:40:23 <vishy> yes i think it is ok. the high/essential ones look pretty good
21:40:25 <bcwaldon> vishy: remove-deprecated-auth is almost done! All the changes are in review (gate failing right now)
21:40:33 <vishy> they are mostly done
21:40:47 <ttx> Ideally we would move a few "High" to "Medium" to better rank their priorities, but meh
21:41:01 <ttx> A few highlights from ttx.py:
21:41:02 <vishy> the only one that I'm particularly concerned about are no-db-messaging / no-db-compute
21:41:16 <ttx> yes, not much progress there and a bit lae in the cycle for that anyway
21:41:28 <ttx> These two need to have their priority set and series goal set to "Folsom" if you approve them:
21:41:34 <ttx> * https://blueprints.launchpad.net/nova/+spec/add-support-for-pci-passthrough-and-sr-iov
21:41:40 <ttx> * https://blueprints.launchpad.net/nova/+spec/network-adapter-hotplug
21:41:51 <vishy> russelb promised to work on that during this milestone now that the roc stuff is done.
21:41:59 <ttx> (that last one has no assignee, so I wonder if it's serious)
21:42:49 <ttx> vishy: please assess them before next week
21:43:09 <vishy> did it now
21:43:12 <vishy> put them both low
21:43:15 <ttx> vishy: Anything else ?
21:43:46 <ttx> #info Cinder was just promoted to core project so it will get its own topic starting next week
21:43:49 <vishy> nope
21:44:00 <ttx> jgriffith: you'll have to become a regular for this meeting now :)
21:44:07 <ttx> Questions on Nova ?
21:44:20 <jgriffith> ttx: Have been anyway
21:44:24 <ttx> heh
21:44:29 <ttx> #topic Horizon status
21:44:32 <gabrielhurley> ttx: \o     (I'm filling in for devcamcar)
21:44:36 <ttx> gabrielhurley: awesome
21:44:42 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-3
21:45:02 <gabrielhurley> I think we're looking pretty realistic.
21:45:03 <ttx> Plan looks good, realistic and clear :)
21:45:09 <gabrielhurley> why thank you :-)
21:45:11 <ttx> I don't really have concerns here. Anything you wanted to mention ? Help needed somewhere ?
21:45:32 <gabrielhurley> the only thing to mention is the policy/rbac blueprint which is dependent on keystone as we discussed earlier: https://blueprints.launchpad.net/horizon/+spec/ext-roles
21:45:44 <gabrielhurley> (currently marked as "blocked")
21:46:03 <gabrielhurley> heckj and I are gonna work on making it happen, though
21:46:13 <ttx> ok
21:46:19 <gabrielhurley> more help is always good ;-)
21:46:23 <ttx> Questions for Horizon ?
21:47:03 <ttx> #topic G naming results
21:47:09 <ttx> And the winner is...
21:47:21 <ttx> Rules are here to be broken, let's go with "Grizzly" 	88/46
21:47:49 <ttx> bcwaldon: you win
21:47:55 <bcwaldon> LIKE A BOSS
21:48:01 <gabrielhurley> viva la bear flag revolt!
21:48:07 <jk0> grizzly like the chew, or grizzly like the yamaha atv?
21:48:19 <bcwaldon> grizzly like the jk0
21:48:21 <clarkb> grizzly like the flats
21:48:22 <ttx> Gazelle was the other pick but people chose chaos over order
21:48:24 <jk0> \o/
21:48:25 <_0x44> Keep in mind, that per the last "bear" release we had... "ZZ" is silent.
21:48:36 <_0x44> Grizzly Hills is actually pronounced "Greely Hills"
21:48:47 <_0x44> s/Hills/Flats/
21:48:59 <jk0> we should have went with Gort
21:49:26 <creiht> gristle
21:49:48 <jgriffith> creiht: +1 :)
21:50:01 <jgriffith> creiht: alas... too late
21:50:05 <ttx> bcwaldon: I'll amend the rules so that order can be restored
21:50:17 <bcwaldon> ttx: call it the 'waldon clause'
21:50:26 <ttx> #info G stands for Grizzly
21:50:31 <bcwaldon> ttx: or the 'bill of brians'
21:50:38 <ttx> or the Waldon exception
21:50:46 <bcwaldon> fine with me
21:50:49 <ttx> #topic Other Team reports
21:50:59 <ttx> annegentle, jaypipes, mtaylor: anything you wanted to mention ?
21:51:28 <annegentle> held the doc meeting yesterday, notes available at http://eavesdrop.openstack.org/meetings/openstack-meeting/2012/openstack-meeting.2012-07-09-20.03.html
21:51:47 <ttx> anything particular you want to highlight ?
21:52:02 <annegentle> couple of items - the DocImpact flag isn't working, my test of it failed. clarkb and the CI team suspects we need a better mailing list to handle incoming notifications
21:52:37 <annegentle> - please review the prototype docs translation process posted to the mailing list yesterday (thanks jaypipes for input!)
21:53:29 <annegentle> - I've uncovered a problem with old html files remaining that Google sinks its hooks into, https://bugs.launchpad.net/openstack-manuals/+bug/1022712, working it myself
21:53:29 <uvirtbot> Launchpad bug 1022712 in openstack-manuals "About 111 orphaned HTML files still can come up in Google searches" [High,Confirmed]
21:53:44 <mtaylor> ttx: I'm working on getting setuptools-git rolled out everywhere
21:53:56 <mtaylor> ttx: and pre-versioning rolled out to the server projects
21:53:57 <ttx> mtaylor: sounds like the right moment.
21:54:25 <annegentle> - also will send a note to the mailing list to discuss info architecture around three basics of OpenStack - Compute | Storage | Networking and how to shape docs
21:54:28 <ttx> mtaylor: does that make us free from Final=True ?
21:54:56 <mtaylor> ttx: yup
21:55:07 <mtaylor> ttx: I've got a patch pending for glance, will update the one for nova rsn
21:55:29 <ttx> annegentle: ok, anything else ?
21:55:31 <mtaylor> ttx: it also puts most of the logic from create-tarball into the projects themselves
21:55:55 <annegentle> Final note: we need more documentation updates for folsom - essex looks great now, but without the DocImpact flag I'm having difficulty scoping and prioritizing work for Folsom.
21:56:13 <annegentle> My request is that you log doc bugs in openstack-manuals for specific known needed updates.
21:56:24 <clarkb> annegentle: did oubiwann get the info he needed to create that new list?
21:56:29 <annegentle> Until we get DocImpact working. Does that sound reasonable?
21:56:41 <ttx> annegentle: certainly.
21:56:41 <mtaylor> ttx: oh - also, I've got some stuff coming up for review for folks releated to global dep list
21:56:59 <annegentle> clarkb: was that request via email or IRC? I didn't' catch it, sorry oubiwann
21:57:04 <ttx> mtaylor: sounds good
21:57:09 <mtaylor> ttx: I did a pass comparing what we install via packages for devstack vs. what we say we require in the pip-reuqires
21:57:11 <mtaylor> it's not hte same
21:57:18 <mtaylor> bcwaldon: ^^ you're going to love it :)
21:57:28 <bcwaldon> awesome
21:57:33 <ttx> #topic Bug squashing day
21:57:35 <mtaylor> yeah. I was thrilled
21:57:40 <ttx> We'll have a bug squashing day, all day Thursday.
21:57:46 <annegentle> yay bug squash! Join me at Tech Ranch in Austin.
21:57:47 <ttx> Join us on #openstack-bugday on that day !
21:57:53 <ttx> #link http://wiki.openstack.org/BugDays/20120712BugSquashing
21:57:59 <ttx> We'll try to close as many bugs as possible, either by fixing or marking them Invalid
21:58:11 <annegentle> #link http://www.meetup.com/OpenStack-Austin/events/72740812/
21:58:15 <ttx> annegentle mentioned the in-person meetup in Austin, maybe others ?
21:59:03 <ttx> #topic Open discussion
21:59:21 <ttx> last words before I close ?
21:59:36 * creiht sighs
21:59:40 <creiht> ttx: that was for you :)
21:59:54 <creiht> glad you missed me :)
22:00:01 <ttx> jeblair: you need to send that flag design to Todd Morey so that we have it on the next summit T-shitrs
22:00:05 <ttx> creiht: heh
22:00:12 * creiht hopes everyone realizes the above was a joke
22:00:28 <jeblair> hi
22:00:43 <jeblair> that's the highest res picture i can find online.  :(
22:01:00 <ttx> jeblair: I'm sure that won't stop an artist like you.
22:01:06 <jeblair> (sadly, the original flag was burned in the fire that followed the 1906 earthquake)
22:01:31 <ttx> and on those sad words
22:01:33 <ttx> #endmeeting