21:03:12 <ttx> #startmeeting
21:03:13 <openstack> Meeting started Tue Jul 24 21:03:12 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:20 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:32 <ttx> #info We are halfway through F3, so will look into progress, especially on essential stuff
21:03:40 <ttx> #info Will also look into upcoming Swift 1.5.1
21:03:49 <ttx> #topic Actions from previous meeting
21:03:56 <ttx> * ttx to see how danwent could track bugs outside quantum without creating noise
21:04:01 <ttx> Sent an email explaining options
21:04:19 <danwent> ttx: yeah, sorry, i've been behind following up on that.
21:04:21 <ttx> gabrielhurley: standing in for devcamca- ?
21:04:26 <gabrielhurley> ttx: yessir
21:04:29 <gabrielhurley> sorry I'm late
21:04:37 <ttx> awesome. Nobody replacing heckj yet ?
21:04:47 <ttx> #topic Swift status
21:04:54 <ttx> #link https://launchpad.net/swift/+milestone/1.5.1
21:05:02 <ttx> notmyname: hello!
21:05:06 <notmyname> howdy!
21:05:13 <ttx> notmyname: I targeted a few existing blueprints to 1.5.1 based on https://github.com/notmyname/swift/blob/1.5.1-changelog/CHANGELOG
21:05:22 <notmyname> thanks
21:05:33 <notmyname> so, about 1.5.1
21:05:34 <ttx> Was wondering if blueprints should be retroactively created for Illumos compatibility or logger UDP support ?
21:05:44 <ttx> or are those minor features ?
21:05:45 <notmyname> ya, I was planning on creating those
21:05:50 <ttx> ok, cool
21:05:54 <notmyname> we want to call this swift 1.6.0
21:06:32 <notmyname> based on the amount of changes and the significance of some of the changes
21:06:37 <ttx> notmyname: sounds ok to me, just need to rename the milestone
21:06:50 <ttx> notmyname: should I do so now ?
21:06:57 <notmyname> yes, please
21:07:15 <ttx> #info Renamed to https://launchpad.net/swift/+milestone/1.6.0
21:07:21 <notmyname> thanks
21:07:26 <ttx> heckj: you're next ;)
21:07:27 <heckj> o/ (sorry I'm late)
21:07:52 <notmyname> we will start the testing/QA process for the release tomorrow
21:07:55 <ttx> notmyname: you should probably bump the version to 1.6.0/False before
21:08:33 <notmyname> ttx: I should be able to get the final commit hash by friday pm or on the weekend so you can cut the release on monday am
21:08:58 <notmyname> ok, good call on the version bump
21:09:01 <notmyname> I'll take care of that
21:09:05 <ttx> notmyname: sounds good. When you have the commitid you sent to QA, I'll cut milestone-proposed from it
21:09:12 <ttx> so that others can do QA as well
21:09:21 <notmyname> I should have that tomorrow
21:09:44 <ttx> #action notmyname to retroactively create some blueprints to cover 1.6.0 main features
21:09:56 <ttx> I see one 1.6.0-targeted bug: bug 1026830
21:10:11 <ttx> Should it be considered blocking 1.6.0 right now ?
21:10:32 * jgriffith wonders if he's still in IRC?
21:10:33 <creiht> maybe he put his keyboard on mute? ;)
21:10:40 <uvirtbot> Launchpad bug 1026830 in swift "replication will never reload the ring file if it is initially empty" [High,In progress] https://launchpad.net/bugs/1026830
21:10:55 <creiht> holy irc lag batman
21:10:59 * creiht hides again
21:11:16 <notmyname> that's been committed
21:11:35 <ttx> notmyname: bug status didn't catch up yet. Will update
21:11:35 <notmyname> sorry, dealing with customer issues at the same time...
21:11:52 <ttx> notmyname: anything else ?
21:12:04 <notmyname> ah I see what happened
21:12:16 <notmyname> The linked patch was abandoned and a different one was merged instead
21:12:27 <notmyname> I probably forgot the bug number in the updated patch commit message
21:12:36 <ttx> ok, can you set FixCommitted ? (and maybe link to the commit of the patch)
21:12:42 <notmyname> no, I have nothing else. questions?
21:13:26 <ttx> #topic Keystone status
21:13:31 <ttx> heckj: o/
21:13:34 <heckj> o/
21:13:35 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-3
21:13:53 <ttx> heckj: Looks like slow progress overall...
21:14:10 <heckj> yep - good on the PKI stuff, but others need to get seriously re-evaluated
21:14:12 <ttx> Especially the 3 "not started" blueprints sound a bit unlikely to make it now ?
21:14:41 <heckj> The AD based backend is still likely to get some traction, but the temp objects is suspect
21:15:08 <heckj> Liemnn is moving on to other projects, and has had to defer our the policy documentation work beyond what he's already done
21:15:37 <heckj> I'll be reviewing this this week and marking things out of the F3 milestone where there's no sign or hope of progress.
21:15:39 <ttx> heckj: is it still worth keeping that target in ? https://blueprints.launchpad.net/keystone/+spec/document-deployment-suggestions-policy ?
21:16:14 <ttx> Sounds like doc that could be done post-F3, fwiw
21:16:33 <heckj> I'm going to make a call for help on that - I feel from a deployment point of view, it's very important and needs to be done. It's somewhat doc related, so I'll try and sync with Anne to see what I can find there
21:17:03 <ttx> heckj: still working on an alpha-level v3 API ?
21:17:21 <heckj> ttx: yep, just not much progress with OSCON last week
21:17:50 <ttx> heckj: anything else ?
21:18:26 <heckj> that's it from me
21:18:29 <ttx> Questions about Keystone ?
21:19:06 <ttx> #topic Glance status
21:19:10 <ttx> bcwaldon: o/
21:19:16 <ttx> #link https://launchpad.net/glance/+milestone/folsom-3
21:19:18 <bcwaldon> ttx: hey
21:19:31 <ttx> General progress looks good...
21:19:39 <ttx> Let's look into the essential stuff in more detail:
21:19:45 <bcwaldon> ok
21:19:51 <ttx> * https://blueprints.launchpad.net/glance/+spec/api-v2-store-access (Not started)
21:20:01 <ttx> How complex is that ? Still doable in time ? ETA for code proposal ?
21:20:18 <bcwaldon> I've been in some offline conversations about it
21:20:24 <bcwaldon> we can get the basic functionality in easily
21:20:29 <bcwaldon> and it absolutely will be for f3
21:20:37 <bcwaldon> trying to determine what the best approach is
21:20:52 <ttx> ok
21:20:55 <ttx> * https://blueprints.launchpad.net/glance/+spec/api-v2-links
21:21:13 <bcwaldon> markwash should be able to knock that out pretty easily
21:21:25 <bcwaldon> he's been pulled in a bunch of different directions and hasn't had time to get back to it
21:21:28 <ttx> Would be good to knock everything we can as early as possible :)
21:21:30 <bcwaldon> I can pick it up if he can't
21:21:36 <bcwaldon> yes, I'm going to sync up with him after this
21:21:41 <ttx> * https://blueprints.launchpad.net/glance/+spec/separate-client
21:21:51 <ttx> That's blocking on https://blueprints.launchpad.net/python-glanceclient/+spec/glance-client-parity , right ? How close is that ?
21:21:52 <bcwaldon> I've got code for it, just waiting on the nova piece
21:21:58 <bcwaldon> which I am also working on
21:22:03 <bcwaldon> everything is slowly falling into place
21:22:05 <ttx> nova ?
21:22:08 <bcwaldon> I'm at the *last* blocker
21:22:20 <bcwaldon> yes, we need to rewrite the glance client code in nova to talk to new client
21:22:28 <bcwaldon> wait!
21:22:29 <bcwaldon> wrong bp
21:22:42 <bcwaldon> we need to port over the client ssl code from old glance client
21:22:45 <bcwaldon> thats the last thing
21:22:49 <bcwaldon> for glance-client-parity
21:23:24 <ttx> Hmm.. so separate-client is blocked on... what ?
21:23:52 <bcwaldon> well, it's soft-blocked on nova integration
21:23:58 <bcwaldon> integrate-glance-client
21:24:07 <bcwaldon> ...I think thats the proper name
21:24:43 <ttx> Hmm, do you agree to set the status of this one to Blocked until the Nova part is solved ?
21:24:53 <bcwaldon> if that makes you happier, sure!
21:25:21 <ttx> Will make my life simpler. This is not the only blueprint I track :)
21:25:57 <ttx> ETA for integrate-glance-client ?
21:26:15 <bcwaldon> I started it a couple of times and realized there was more python-glanceclient work to be done
21:26:29 <bcwaldon> that work just landed yesterday, so I am now shooting for the end of this week
21:26:41 <ttx> Is glance-client-parity the last thing blocking python-glanceclient 1.0 release ?
21:26:53 <ttx> You talked several time about curtting a release for the client code
21:27:02 <ttx> but I haven't seen it yet ;)
21:27:07 <bcwaldon> yes, that is the blocker
21:27:11 <ttx> ack
21:27:14 <bcwaldon> bar
21:27:37 <ttx> * https://blueprints.launchpad.net/glance/+spec/api-v2-image-caching
21:27:42 <ttx> Will this be complete once https://review.openstack.org/#/c/9930/ is in ?
21:27:44 <bcwaldon> in review right now
21:27:45 <bcwaldon> yes
21:28:05 <ttx> Sounds good, hopefully most of those will be in better shape a week from now
21:28:23 <ttx> a.k.a. "before the end of the month"
21:28:29 <ttx> bcwaldon: Anything else ?
21:28:54 <bcwaldon> ttx:  I might go a different path with python-glanceclient versioning
21:29:12 <bcwaldon> ttx: different as in releasing all the work Ive been doing under a v0.2
21:29:15 <bcwaldon> rather than straight to v1
21:29:27 <ttx> bcwaldon: sounds a bit more careful indeed
21:29:33 <bcwaldon> yes
21:29:39 <ttx> people tend to find bugs
21:29:41 <bcwaldon> and I'm kind of breaking my own rule by going from v0 to v1
21:29:59 <bcwaldon> the project is in a weird spot, and I want to make the best next step
21:30:20 <ttx> Questions on Glance ?
21:30:54 <ttx> #topic Quantum status
21:31:00 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-3
21:31:05 <ttx> danwent: yo
21:31:12 <danwent> hey
21:31:15 <ttx> Good progress on High/Essential stuff... let's see the Essential ones in more detail
21:31:23 <ttx> * https://blueprints.launchpad.net/quantum/+spec/provider-networks
21:31:27 <danwent> the worst one is assigned to me :)
21:31:33 <ttx> Will this be completed once https://review.openstack.org/#/c/9069/ hits ? Or is there more to it ?
21:31:52 <danwent> that patch is part 2 of 3
21:31:56 <danwent> part 1 merged recently.
21:32:06 <danwent> part 3 is fairly small, so i'm not too worried.
21:32:11 <ttx> danwent: ok
21:32:15 <ttx> * https://blueprints.launchpad.net/quantum/+spec/quantum-v2-public-networks
21:32:20 <ttx> Will this be completed once https://review.openstack.org/#/c/9845/ hits ?
21:32:24 <danwent> yes
21:32:33 <ttx> and the last one :)
21:32:34 <ttx> * https://blueprints.launchpad.net/quantum/+spec/quantum-l3-fwd-nat
21:32:39 <danwent> this is mostly just hung up on terminology discussions, which I think we cleared up meeting yesterday
21:32:46 <danwent> (comment was about previous link)
21:32:56 <danwent> yeah, that's the biggest item outstanding, and its on me.
21:32:58 <ttx> Any progress on that ? ETA ?
21:33:09 <danwent> progress has been slower than I like in the past week.
21:33:18 <ttx> wonder why
21:33:29 <danwent> but I have some volunteers to help as well, so I'll probably split it into two by next week.
21:33:41 <danwent> a lot of the underlying stuff is there thanks to the dhcp work, so i'm not too concerned
21:33:50 <ttx> danwent: two parts: both essential ?
21:33:50 <danwent> if its not good progress by next week though, definitely would be worried.
21:34:00 <danwent> yes
21:34:03 <ttx> ok
21:34:04 <danwent> but worked on by two people
21:34:16 <ttx> You mentioned last week that there were a lot of blueprints, but you wanted to track them all because someone said they would do it...
21:34:30 <ttx> But there are a number of unassigned blueprints in there. So I'd think they should have an assignee or be removed from the F3 goals ?
21:34:50 <danwent> yeah, i saw your script called those out.
21:35:13 <danwent> currently, i have things assigned to F-3, as when people finish up their essential/high BPs, they often look for other ways to help
21:35:23 <danwent> I could probably create a tag for that though, if you prefer
21:35:37 <ttx> No that's ok
21:35:59 <ttx> Just thought that they would be busy enough with one of the other 28 blueprintds
21:36:14 <danwent> we actually have a very large number of people contributing these days.
21:36:51 <ttx> danwent: some other projects use the series goal = Folsom with no milestone for the "wishlist fof folsom if there is time left" thing
21:37:04 <danwent> that's a good idea.  i'll switch to that.
21:37:12 <ttx> Very visible under https://blueprints.launchpad.net/quantum/folsom
21:37:26 <ttx> danwent: Anything else ?
21:37:35 <danwent> not that I can think of.
21:37:40 <ttx> Questions on Quantum ?
21:38:01 <ttx> #topic Cinder status
21:38:07 <ttx> jgriffith: howdy!
21:38:11 <jgriffith> hey there
21:38:13 <ttx> #link https://launchpad.net/cinder/+milestone/folsom-3
21:38:19 <ttx> Looking at targeted blueprints...
21:38:32 <ttx> * https://blueprints.launchpad.net/cinder/+spec/cinder-notifications
21:38:33 <jgriffith> The first two have landed
21:38:42 <ttx> This one is marked "Deferred", does that mean it's been pushed back to Grizzly ?
21:38:45 <jgriffith> The only one that is outstanding is the migration
21:39:13 <ttx> remove-extra-dbapi-methods is completed ? I can set it to "Implemented" ?
21:39:23 <jgriffith> Yes,
21:39:41 <jgriffith> I'll need to see if cp16net is going to pick back up the notifications
21:39:55 <jgriffith> That just leaves the migration
21:40:37 <ttx> For the notifications: please update when you know (set priority and status)
21:40:46 <jgriffith> ttx: Will do
21:40:48 <ttx> * https://blueprints.launchpad.net/cinder/+spec/migrate-nova-volumes-to-cinder
21:41:01 <ttx> This one is a bit undefined... No priority, no assignee, series goal unset, unknown status... Could you explain what's expected from that one ?
21:41:26 <jgriffith> That's coming up with a plan to do a clean and tested migration
21:41:52 <jgriffith> I don't have anything to add "yet"
21:42:00 <ttx> jgriffith: Sounds like high priority to me... who is working on that ?
21:42:20 <jgriffith> Not yet, but hopefully later this week
21:42:28 <jgriffith> It's going to be the highest priortiy
21:42:42 <ttx> Who will be working on that ?
21:42:43 <jgriffith> Also need to come up with tests etc (ie live clusters)
21:42:57 <jgriffith> ttx: Me for sure...
21:43:07 <ttx> jgriffith: so OK if I mark it yours, Not started and High prio ?
21:43:08 <jgriffith> ttx: I suspect vishy will have some input :)
21:43:16 <jgriffith> ttx: Yep
21:43:23 <ttx> Are those 3 the only features missing in Folsom Cinder ?
21:43:36 <ttx> hmm those 2 actually
21:43:43 <jgriffith> No... I still have a few things I'm trying to get finished
21:43:57 <jgriffith> Well... striclty speaking yes
21:44:08 <jgriffith> I still have to get everyting working on parity
21:44:19 <jgriffith> Get devstack defaulting to cinder etc
21:44:27 <ttx> ok
21:44:31 <ttx> jgriffith: Anything else ?
21:44:41 <jgriffith> ttx: Nah
21:44:46 <ttx> #topic Nova status
21:44:50 <vishy> hi!
21:44:51 <ttx> vishy: hey
21:44:55 <ttx> #link https://launchpad.net/nova/+milestone/folsom-3
21:45:04 <ttx> Slow progress overall. I'm a bit concerned with the two Essential ones, which look stalled since F2:
21:45:15 <ttx> * https://blueprints.launchpad.net/nova/+spec/finish-uuid-conversion (mikal)
21:45:29 <vishy> yes I just tried to ping mikal today
21:45:30 <ttx> Been "almost there" for a long time... What's left to do here ? Any chance that it would land before next week ?
21:45:43 <vishy> he hasn't updated the review for a week
21:45:55 <ttx> Will chase him tomorrow morning
21:46:05 <ttx> * https://blueprints.launchpad.net/nova/+spec/general-host-aggregates (jog0)
21:46:09 <vishy> he's is still working on the general host stuff
21:46:17 <vishy> I think he's making good progress though
21:46:30 <vishy> I want to defer trusted messaging and user configurable rbac
21:46:37 <vishy> I don't think either of those will make it
21:46:40 <jog0> ttx, vishy: I am working on step 2 right now and hope to start step 3 later this week
21:46:42 <ttx> vishy: sounds like a good idea
21:47:01 <ttx> jog0: there are only 3 steps right ?
21:47:20 <ttx> Would be good to have all code merged or proposed by next week
21:47:35 <ttx> (i.e. bp in "Needs code review" status)
21:47:49 <vishy> the no-db-nova-compute is questionable
21:47:51 <jog0> ttx: there is a step 4 and 5 that involve extra testing and updated docs only.
21:48:06 <jog0> ttx:  sounds good
21:48:13 <vishy> russel is making good progress but it is a big change. We'll see how it is next week
21:48:34 <vishy> config drive is underway. Extract volumes i will mark complete as soon as jgriffith is done moving the gating tests over
21:49:16 <ttx> * https://blueprints.launchpad.net/nova/+spec/volume-usage-metering -> Low ?
21:49:19 <vishy> yun is making progress on the transactional task management. I don't know if the whole thing will make it in, but perhaps some more incremental improvements
21:49:25 <ttx> or should that just move to Cinder ?
21:49:52 <vishy> it looks like nova-volumes might still exist so I don't mind it being in there a slow
21:51:03 <ttx> #action vishy to defer trusted messaging and user configurable rbac to Grizzly
21:51:36 <ttx> Finally, would be great if we could have some triaging done on Nova bugs, so that we have a clearer, prioritized view on what needs to be fixed before Folsom release
21:51:46 <ttx> In particular we have 85+ New/Undecided bugs that need some feedback
21:51:58 <ttx> See https://launchpad.net/~nova-bugs to join the effort
21:52:27 <ttx> vishy: Anything else ?
21:52:46 <ttx> hyper-v-revival -> should probably be "started" given what I heard
21:52:54 <vishy> ttx: only a mention to nova-core that sdague still needs some more votes!
21:53:06 <vishy> the other 3 will be added tomorrow
21:53:10 <vishy> ttx: yes
21:53:20 <ttx> Questions on Nova ?
21:53:48 <ttx> #topic Horizon status
21:53:52 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-3
21:54:00 <ttx> Slow progress overall... Still feeling on track ?
21:54:06 <ttx> gabrielhurley: ^
21:54:09 <gabrielhurley> ttx: hello!
21:54:31 <gabrielhurley> ttx: things are picking up steam, I think we're doin' alright.
21:54:37 <ttx> https://blueprints.launchpad.net/horizon/+spec/ext-roles is marked Blocked... Could you elaborate on what it's blocking on ? Isn't clear from the blueprint whiteboard.
21:54:44 <gabrielhurley> ttx: quantum being the biggest, I've seen code there and it's pretty close
21:55:03 <gabrielhurley> the ext-roles sounds like it has to be bumped based on joe and vish's comments in this meeting
21:55:27 <ttx> which comments ?
21:55:28 <gabrielhurley> It was blocked based on keystone, et. al. supporting RBAC (particularly rolling up RBAC to keystone)
21:55:58 <gabrielhurley> so Keystone not having that and/or the v3 API falling short, plus Vish saying user-configurable policy being bumped... I'm not hopeful for seeing this come together
21:56:36 <ttx> ok, could you clarify if this is dropped to Grizzly before next week ?
21:56:43 <gabrielhurley> ttx: definitely can
21:57:03 <ttx> #action gabrielhurley/devcamcar to clarify droppage of ext-roles due to lack of RBAC support
21:57:18 <ttx> gabrielhurley: anything else you wanted to mention
21:57:20 <ttx> ?
21:57:50 <gabrielhurley> ttx: not especially. beyond the roles/RBAC blueprint everything else is on track.
21:57:55 <ttx> Questions for Horizon ?
21:58:19 <ttx> #topic Other Team reports
21:58:27 <ttx> annegentle, jaypipes, mtaylor, *: ?
21:58:33 <markmc> ttx, you wanted to catch up on stable branch status
21:58:35 * markmc haz status
21:58:45 <ttx> markmc: shoot
21:58:51 <markmc> ok
21:58:57 <markmc> it's been 4 weeks since 2012.1.1
21:59:02 <ttx> markmc matches *
21:59:03 <markmc> most activity in nova
21:59:07 <markmc> 20+ fixes
21:59:13 <markmc> 1 of the a serious security fix
21:59:26 <markmc> also ~5 fixes in keystone
21:59:32 <markmc> nothing really in glance and horizon
21:59:46 <markmc> figure it'd be good to do a nova and keystone 2012.1.2 release soon
22:00:17 <ttx> markmc: will look at the security pipe and let you know if we are in good shape
22:00:24 <markmc> ttx, ok
22:00:34 <markmc> ttx, what do you think of doing a release next week?
22:00:39 <ttx> #action ttx to confirm green light to nova and keystone 2012.1.2
22:00:46 <markmc> oh, and any stable-maint members - please take a look at:
22:00:56 <ttx> markmc: pending that last item, sure
22:00:58 <markmc> https://review.openstack.org/9534   Handle local & remote exceptions consistently.
22:00:58 <markmc> https://review.openstack.org/10155  Adding networking rules to vm's on compute service startup
22:01:03 <markmc> ttx, cool
22:01:13 <ttx> Any other team lead with a status report ?
22:01:44 <ttx> #topic Open discussion
22:01:54 <ttx> Any last-minute comment ?
22:02:38 <ttx> well then...
22:02:42 <ttx> #endmeeting