16:01:14 <dhellmann> #startmeeting
16:01:15 <openstack> Meeting started Thu Jul 26 16:01:14 2012 UTC.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:19 <dhellmann> #link https://lists.launchpad.net/openstack/msg15134.html
16:01:27 <dhellmann> If you are here to participate in the ceilometer meeting, please make yourself known.
16:01:30 <dhellmann> o/
16:01:34 <dricco> I'm here
16:01:53 <dhellmann> hi, dricco
16:01:59 <dhellmann> jd___: ping?
16:03:08 <dhellmann> We usually start by reviewing actions from the previous meeting, so...
16:03:13 <dhellmann> #topic dhellmann to get some feedback now about the sorts of meters users want from the mailing list
16:03:19 <dhellmann> #info My message to list about meters: https://lists.launchpad.net/openstack/msg15104.html
16:03:25 <dhellmann> #info I've had no feedback on the meters yet
16:03:44 <dhellmann> Does anyone here have any feedback?
16:04:30 <dhellmann> We went through a round of questions on this at the beginning of the project, but this issue was raised by the PPB when we applied for incubation so we are asking for updates.
16:05:12 <dhellmann> 3
16:05:27 <glauaguiar> #info I don't have feedback at the specific meters yet but I do believe it would be helpful to see a clear definition and colletion of the meters and their meaning
16:05:33 <dhellmann> 2
16:05:44 <jd___> pong
16:05:48 <dhellmann> ok, we do have some documentation about that in the wiki
16:06:08 <dhellmann> #link http://wiki.openstack.org/EfficientMetering#Meters
16:06:27 <dhellmann> glauaguiar: does that list help, or were you looking for more detail?
16:06:30 * jd___ rushed
16:06:34 <dhellmann> note that not all of those are implemented, yet
16:06:44 <jd___> we should probably document every plugin/meters at some point
16:06:47 * dhellmann waves to jd___
16:07:02 <jd___> something in rst in docs/ directory probably I guess
16:07:11 <dhellmann> agreed, something to add to http://ceilometer.readthedocs.org/en/latest/index.html
16:07:24 <jd___> exactly
16:07:26 <glauaguiar> dhellmann I see that information but for example, there you talk about hourly usage and the cpu meter, for example talks about minute
16:07:29 <dhellmann> with more exposition about what exactly is being collected
16:07:56 <glauaguiar> dhellmann: correct, that would be usefull
16:08:43 <dhellmann> glauaguiar: in most of the cases where the unit looks like time, we will collect in the finest resolution we can
16:08:57 <dhellmann> or at least in the finest resolution that is "reasonable"
16:09:28 <Vincent_Hou> what is the finest resolution
16:09:40 <dhellmann> #action dhellmann to open a ticket to add documentation about the meters to the rst docs based on the wiki
16:10:15 <dhellmann> Vincent_Hou: that is adjustable, but you're not likely to get up-to-the-minute results very reliably because of the load required to poll that often
16:10:18 * jd___ afk 5 minutes
16:11:06 <dhellmann> we have the default polling interval set to 1 minute right now for development, but will be changing it to something more like 5-10 before release
16:12:09 <dhellmann> Vincent_Hou: how fine do you expect to need for production? I assume you're billing customers?
16:13:05 <Vincent_Hou> I am not a customer. I am also curious about the question.:-)
16:13:43 <dhellmann> OK
16:13:52 <Vincent_Hou> I know some providers here in China is trying to make it like 1 min.
16:13:57 <dhellmann> this is another area I would like to get feedback from potential users
16:14:17 <dhellmann> well, it is possible to bill at that frequency without polling that often
16:14:40 <jd___> anyway that's something everybody will be able to decide
16:14:44 <dhellmann> right, let's move on
16:14:45 <dhellmann> #topic jd to setup opa voting system to start on 26th and end on Aug 3rd
16:15:01 <dhellmann> that's done, right? I got email inviting me to vote.
16:16:06 <dhellmann> jd___: is there anything else to be done to set up the election system?
16:16:17 <jd___> dhellmann: now it's done
16:16:22 <jd___> you should be able to vote
16:16:29 <jd___> i've amended the list of voters on the wiki and on the system
16:16:35 <jd___> see http://wiki.openstack.org/EfficientMetering/PTLElectionProcess
16:16:36 <dhellmann> great, thanks for taking care of that
16:17:10 <jd___> so there's only 6 voters :)
16:17:16 <dhellmann> and 3 of us are running :-)
16:17:34 <dhellmann> that will make it interesting
16:17:37 <jd___> yeah hehe :))
16:17:59 <dhellmann> ok, next up:
16:18:00 <dhellmann> #topic dhellmann to open a bug and work on devstack integration
16:18:08 <dhellmann> #link https://bugs.launchpad.net/ceilometer/+bug/1023972
16:18:10 <uvirtbot> Launchpad bug 1023972 in ceilometer "add devstack integration" [High,Confirmed]
16:18:14 <dhellmann> #info Have not started dev work, yet. Focusing on the API server first.
16:18:35 <dhellmann> so I opened the task, but haven't actually done any development work
16:18:58 <jd___> ok
16:19:11 <dhellmann> it will be easier to do the work all at once when we have a better idea of the dependencies for the API server
16:19:23 <dhellmann> so I'll carry that action over
16:19:31 <dhellmann> #action dhellmann to open a bug and work on devstack integration
16:19:36 <jd___> not sure you need to carry it since you opened a bug
16:19:38 <jd___> but your call
16:19:48 <jd___> (if we start carrying #action for every bug… well… :D)
16:19:48 <dhellmann> oh, good point :-)
16:20:15 <dhellmann> if anyone wants to volunteer to work on that bug, go ahead and assign it to yourself
16:20:24 <dhellmann> #topic dhellmann create a diagram of ceilometer architecture
16:20:29 <dhellmann> #info No progress
16:20:44 <dhellmann> this one I do need to carry over
16:20:45 <dhellmann> #action dhellmann create a diagram of ceilometer architecture
16:21:03 <dhellmann> this was also related to the incubation proposal
16:21:32 <dhellmann> I expect to give a presentation on this to our local openstack meetup group in the next couple of months anyway, so I have 2 motivating factors for doing it now
16:21:34 <jd___> #info jd did one
16:21:41 <dhellmann> oh?
16:21:45 <dhellmann> link?
16:21:46 <jd___> :-)
16:21:53 <dhellmann> or better yet, add it to the docs
16:21:59 <jd___> ok it's time to announce that I did a presentation of Ceilometer today at a conference
16:22:07 <dhellmann> ah, a presentation
16:22:11 <dhellmann> excellent!
16:22:15 <jd___> so i've a slide deck with a  diagram
16:22:15 <dhellmann> which conference?
16:22:25 <jd___> http://xlcloud.org/bin/view/Main/
16:22:36 <jd___> it's an R&D project
16:22:46 <jd___> and I'll work on it because they want to use Ceilometer
16:23:04 <dhellmann> nice
16:23:42 <dhellmann> can you post a link to your presentation on the mailing list?
16:24:02 <jd___> I will
16:24:10 <dhellmann> either the slide deck or any recording
16:24:11 <jd___> I'll publish everything tomorrow, it's on my agenda :-)
16:24:21 <dhellmann> good, thanks!
16:24:30 <jd___> so that was my surprise ;)
16:24:59 <dhellmann> it's nice to see the project reach the level of maturity where we can talk about it in real depth
16:25:00 <jd___> and adding that the project has been very well welcomed
16:25:13 <jd___> even if I said we had little code :D
16:25:22 <dhellmann> we're getting there… :-)
16:25:52 <dhellmann> ok, let's keep moving:
16:25:54 <dhellmann> #topic dhellmann write a walk-through of setting up ceilometer and collecting data
16:25:58 <dhellmann> #info No progress
16:26:14 <dhellmann> I should probably open a ticket for this, since we want to have the info in our documentation
16:26:27 <jd___> +1
16:26:36 <dhellmann> #action dhellmann open a ticket to write a walk-through of setting up ceilometer and collecting data
16:27:11 <dhellmann> there is already some information about installing from the git repo, but I don't think it covers doing things that would actually cause data to be generated
16:27:17 <dhellmann> and I think it predates the database work, too
16:27:40 <dhellmann> I know we've had some queries from users on the mailing list about doing this recently, too
16:27:58 <dhellmann> do we have any users attending the meeting who have tried to get ceilometer running on their systems?
16:28:52 <glauaguiar> I did.. but I tried using Essex
16:29:20 <dhellmann> yeah, we've had a couple of people report issues with that. we will discuss essex support in a few minutes
16:29:28 <jd___> teasing!
16:29:46 <dhellmann> ok, moving on
16:29:48 <dhellmann> #topic lzyeval create a blueprint to add counter for nova-volume disk usage retrieval
16:30:26 <dhellmann> I see https://bugs.launchpad.net/ceilometer/+bug/1004447 so I think this is done, isn't it?
16:30:26 <dricco> I'm here to discuss
16:30:27 <uvirtbot> Launchpad bug 1004447 in ceilometer "Pollster for nova-volume" [Wishlist,Confirmed]
16:30:28 <jtran> dhellmann,  i have tried
16:30:34 <dricco> nova-volume disk usage retrieval
16:30:35 <jtran> whoops late on that response sorry
16:30:46 <dhellmann> jtran, no problem, it's good to have you here
16:31:13 <dhellmann> dricco, go ahead
16:31:15 <jd___> this place's getting crowded
16:31:34 <dricco> haven't had much time this week to work on it, well only today to be honest
16:31:42 <dricco> went to the volumes meeting last night
16:31:55 <dricco> and volumes guys have approved the blueprint
16:32:07 <dhellmann> do you have a link to the blueprint?
16:32:15 <dricco> hopefully have something out for review monday
16:32:23 <dricco> yup - https://blueprints.launchpad.net/nova/+spec/volume-usage-metering
16:32:36 <dhellmann> #link https://blueprints.launchpad.net/nova/+spec/volume-usage-metering
16:32:48 <dhellmann> good, thanks
16:33:18 <dricco> not much else to say really, until I have something out for review
16:33:24 <dhellmann> I'll take a look at that this afternoon or tomorrow morning (in the next ~12 hrs)
16:33:58 <dhellmann> ok
16:34:11 <dhellmann> oh, that's the next action item:
16:34:11 <dhellmann> #topic dricco work and report about nova-volume metering notification https://blueprints.launchpad.net/nova/+spec/volume-usage-metering
16:34:15 <dricco> perfect thx
16:34:25 <dhellmann> so you've done that :-)
16:34:36 <dhellmann> and that's all of the actions from the last meeting
16:34:42 <dhellmann> we had a couple of other items on the agenda for today
16:34:43 <dhellmann> #topic Discuss priority of maintaining Essex support and find contributor to work on it if we are going to do it
16:35:07 <dhellmann> We've had a couple of people trying to run ceilometer against Essex, and as a result uncovered some issues doing so.
16:35:33 <dhellmann> A big part of the problem is that ceilometer tries to import code from nova, and the essex and folsom versions of nova have diverged.
16:35:49 <dhellmann> We will need to work to move the parts of nova that we depend on into openstack-common before ceilometer will work with essex.
16:36:38 <dhellmann> Neither jd___ nor I are planning to run ceilometer on Essex, so it would help if we could get some support (in the form of code contributions) from users who *do* want to use Essex.
16:37:06 <dhellmann> I know the folks at eNovance were interested, and jtran too (you're AT&T, right?)
16:37:43 <dhellmann> do we have anyone else who can lend a hand? I can explain what needs to be done in more detail on the mailing list if someone can step up to work on it.
16:37:52 <jd___> as as I'm concerned I'm ok to keep backward compat for Essex, but I'm afraid that in 3 months we will have to support Essex, Folsom, and target Grizzly, and this will become a nightmare
16:37:54 <jtran> dhellmann, yes at&t we are intersted in that
16:38:03 <jd___> so maybe we should discuss a backward compat policy at some point
16:38:07 <jtran> i can and will contribute to that aspect
16:38:18 <dhellmann> jtran: excellent, thank you
16:38:22 <dhellmann> jd___: yes, I agree, we need to work that out
16:38:47 <dhellmann> I believe that once we stop importing nova code directly we could be largely compatible with essex without a lot of trouble.
16:38:59 <dhellmann> There may be some degredation in features, though.
16:39:26 <dhellmann> For example, the Essex notification messages do not include all of the instance metadata, so that info won't be collected.
16:39:27 <jd___> the real question for now, to me, is do we keep the thing that the previous version (today, essex) of OS is supported by Ceilometer and therefore we have a Jenkins test for that, or not?
16:39:41 <jtran> even if we move nova code over to openstack.common, we'd have to backport that nova change into esses-stable ..  that would be challenging.
16:40:13 <dhellmann> jtran: If we put the code in common, we can copy it into Ceilometer and avoid importing from nova. The essex version of nova doesn't have to change.
16:40:32 <dhellmann> jd___: that's a good point. What is the general OpenStack policy on backwards compatibility support?
16:40:46 <dhellmann> or I guess I should say, supporting "legacy" versions?
16:40:59 <jd___> there's no legacy support AFAIK
16:41:08 * dhellmann rolls eyes
16:41:15 <jd___> you're not supposed to run Glance Essex with Nova Diablo
16:41:18 <jd___> for example
16:41:22 <jd___> or whatever
16:41:28 <dhellmann> well, that at least makes sense
16:41:56 <jd___> or currently we are making Ceilometer Folsom works with OpenStack Essex, nobody else is doing that
16:41:58 <dhellmann> what if we run the tests, but don't use them to gate? that would help us know if we break something, but not prevent us from moving forward
16:42:07 <jd___> dhellmann: that sounds like a good plan
16:43:04 <dhellmann> I have no problem supporting use of ceilometer with older versions of the other services, as long as we get some help and it is understood that "support" may mean fewer features if we depend on hooks or other behaviors in the new versions of the services.
16:43:34 <dhellmann> we have several core members out today, so how about we put this on the agenda for next week to have a vote?
16:43:51 <jd___> fine with me
16:44:17 <dhellmann> in the mean time, we can start investigating how much work it will actually be to support essex in some useful way
16:44:34 <dhellmann> jtran, can I give you that action?
16:44:39 <jtran> sure!
16:45:20 <dhellmann> #action jtran investigate and report on the amount of work needed to support metering essex
16:45:33 <dhellmann> ok, moving on
16:45:33 <dhellmann> #topic PTL election
16:45:49 <dhellmann> I believe we discussed this enough earlier. Does anyone have anything to add?
16:46:09 <jd___> VOTE FOR ME FOR FREE HUGS
16:46:10 <jd___> no.
16:46:19 * jd___ hides
16:46:33 * dhellmann LOL
16:46:55 <jd___> the election is in place and every voters should have received a mail with a link to vote
16:47:01 <dhellmann> I will just say that I would be fine working with either of the other candidates if they win.
16:47:33 * jd___ too
16:47:38 <dhellmann> that's it for the formal agenda
16:47:44 <dhellmann> #topic Open discussion
16:48:57 <dhellmann> does anyone have anything?
16:49:23 <jd___> I don't think so
16:50:10 <dhellmann> ok, I think we can end a little early then
16:50:17 <dhellmann> thank you, everyone!
16:50:19 <dricco> thx
16:50:26 <jd___> thanks!
16:50:35 <glauaguiar> thanks
16:50:44 <dhellmann> #endmeeting