16:00:01 <nijaba> #startmeeting
16:00:01 <nijaba> #meetingtopic Ceilometer
16:00:01 <nijaba> #chair nijaba
16:00:01 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
16:00:02 <openstack> Meeting started Thu Aug  2 16:00:01 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> Current chairs: nijaba
16:00:19 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
16:00:19 <nijaba> o/
16:00:24 <dhellmann> o/
16:00:44 <jd___> o/
16:01:04 <nijaba> First I'd like to apologize for not sending a meeting reminder yesterday.  Good habits are easily lost while on vacation, it seems...
16:01:21 <nijaba> #topic actions from previous meeting
16:01:31 <nijaba> #topic dhellmann to open a ticket to add documentation about the meters to the rst docs based on the wiki
16:01:49 <dhellmann> I'm looking to see if I did that. I think I did, but don't have the link handy
16:02:15 <dhellmann> https://bugs.launchpad.net/ceilometer/+bug/1030120
16:02:18 <uvirtbot> Launchpad bug 1030120 in ceilometer "document the available meters" [Wishlist,Confirmed]
16:02:21 <nijaba> thanks!
16:02:35 <nijaba> let's continue the dhellmann quizz then!
16:02:37 <nijaba> #topic dhellmann to open a bug and work on devstack integration
16:02:45 <jd___> (haha)
16:02:53 <dhellmann> jtran is working on that
16:03:04 <dhellmann> https://bugs.launchpad.net/ceilometer/+bug/1023972
16:03:06 <jtran> yes
16:03:06 <uvirtbot> Launchpad bug 1023972 in ceilometer "add devstack integration" [High,Confirmed]
16:03:18 <dhellmann> jtran, did dean approve it yet?
16:03:30 <jtran> no not yet
16:03:31 <nijaba> nice!  jtran, anything worth mentioning?
16:03:40 <jtran> nijaba, nothing worth mentioning
16:03:54 <nijaba> ok, next dhellmann quizz then!
16:03:59 <dhellmann> we could use some +1 votes on the changeset to get more attention for it
16:04:04 <nijaba> #topic dhellmann create a diagram of ceilometer architecture
16:04:07 <jtran> altho i think by now the code has changed so none of it is working so i have to resubmit
16:04:20 <dhellmann> I didn't make any progress on this, but jd___ has a nice one in his presentation I was hoping to steal
16:04:26 <jd___> :-)
16:04:55 <nijaba> should we reconduct the action, or transfer it to someone else?
16:04:59 <dhellmann> although as jtran points out, we have a slightly different architecture now so maybe we need a new one
16:05:13 <dhellmann> we need to do it, but I'm sure I'm not going to get to it in the next week
16:05:33 <dhellmann> we have a sprint starting next week and I'm going to be working on integrating ceilometer with our billing system
16:05:34 <nijaba> dhellmann: I could give it a try
16:05:44 <dhellmann> nijaba: thanks, that would help
16:05:57 * nijaba is in a sprint too next week, but hope to get a few spare cycles
16:05:58 <dhellmann> I can help with debugging sphinx issues if you run into trouble
16:06:13 <nijaba> #action  create a diagram of ceilometer architecture
16:06:20 <nijaba> #action nijaba create a diagram of ceilometer architecture
16:06:42 <nijaba> jtran: feel free to poke us when you need +1
16:06:49 <nijaba> #topic dhellmann open a ticket to write a walk-through of setting up ceilometer and collecting data
16:06:49 <jtran> nijaba, will do!
16:06:54 <dhellmann> https://bugs.launchpad.net/ceilometer/+bug/1030119
16:06:55 <uvirtbot> Launchpad bug 1030119 in ceilometer "document example of collecting data about running servers" [Wishlist,Confirmed]
16:07:30 <nijaba> cool!
16:07:47 <nijaba> #topic jtran investigate and report on the amount of work needed to support metering essex
16:07:52 <dhellmann> I got lots of tickets opened this week :-)
16:08:20 <jtran> i did some investigation into this and openstack.common is causing big problems for essex to be compatible w/ ceilometer
16:08:38 <jtran> if i update essex-stable to use latest openstack.common, everything breaks and not easily resolved
16:08:55 <dhellmann> you shouldn't need to update essex-stable, though
16:08:59 * nijaba grumbles about library benefits
16:09:01 <jd___> since openstack.common is embedded, that should not be a problem
16:09:09 <dhellmann> we have our own copy of common
16:09:11 <jd___> ...until it's not embedded
16:09:36 <jtran> the reasoning is that i need to update flags.py in essex-stable to use from trunk...
16:09:38 <dhellmann> I thought the problem was actually that we still import things directly from nova that haven't made their way into common yet
16:09:42 <dhellmann> right
16:09:43 <jtran> and that relies on openstack.common latest
16:10:00 <dhellmann> I think a better solution is to make it so we don't need to import flags any more
16:10:16 <dhellmann> there are a couple of changes pending for common to import the service and manager modules
16:10:22 <dhellmann> that will be one step for us
16:10:38 <dhellmann> we also use the database layer in nova's Service class, so we need to replace that
16:10:44 <jtran> yes i think you're right so should i start less work on ceilometer essex compatibility and more focus on just ceilometer no more flags?
16:10:50 <dhellmann> and I *think* after that we will be free of nova imports
16:11:00 <jtran> yes, fully agreed.
16:11:27 <dhellmann> replacing the db access with rpc calls would be a good thing to start on
16:11:29 <jtran> as long as ceilometer depends on flags (and probably other nova code such as services), it'll be tough sledding getting essex to be compliant and work w/ it
16:11:41 <dhellmann> that way when the service code lands in common we can start to use it and not worry about the nova db
16:11:41 <nijaba> jtran: should you take that as an action for next meeting?
16:11:54 <jtran> nijaba, in full honesty i think that might be way over my head
16:12:00 <jtran> i can try though!
16:12:05 <dhellmann> I think we have tickets for all of those things
16:12:10 <nijaba> k
16:12:11 <jd___> dhellmann: will Essex work with RPC calls rather than DB access ?
16:12:36 <dhellmann> ah, no, we don't have one for the db work
16:12:49 <dhellmann> so jtran, would you open a ticket for that? we can work out the details of what to do on the mailing list
16:12:58 <jtran> dhellmann, will do
16:13:09 <dhellmann> jd___: doesn't essex nova have an rpc call to ask about the list of instances?
16:13:17 <dhellmann> I assumed it did, but maybe I'm wrong
16:13:36 <nijaba> #action jtran to open a ticket for the DB access work
16:13:37 <dhellmann> thanks, jtran
16:13:43 <jtran> no problem
16:13:51 <nijaba> I guess that's it for last week's actions...
16:14:03 <jd___> dhellmann: not sure but I don't know, this is why I asked :)
16:14:07 <dhellmann> jtran: have you signed a contributor agreement?
16:14:16 <jtran> dhellmann, for nova in general yes
16:14:16 <dhellmann> jd___: I guess we'll find out :-)
16:14:21 <jd___> :-)
16:14:24 <jtran> do i need a separate one for ceilometer?
16:14:28 <nijaba> next topic is very well alligned with last action:
16:14:29 <dhellmann> jtran: no, that applies to us, too
16:14:31 <nijaba> #topic Discuss priority of maintaining Essex support and find contributor to work on it if we are going to do it
16:14:48 <jtran> excellent, i do have ccla as well as cla
16:15:01 <dhellmann> I know essex support is important to loic and enovance
16:15:11 <dhellmann> we have had some other users express interest, too
16:15:16 <jtran> dhellmann, important to AT&T too
16:15:17 <dhellmann> dreamhost is going to be using folsom
16:15:19 <jtran> for now anyway
16:15:21 <nijaba> and it is somewhat important to canonical too
16:15:51 <dhellmann> as jd___ pointed out, it's a little unusual to worry about supporting old versions with new services
16:16:04 <nijaba> so I would suggest we keep this topic for when gmb will hvae returned from vacation
16:16:12 <dhellmann> but I don't have an issue doing it if we can get developers and it doesn't prevent us from finishing support for folsom
16:16:27 * nijaba agrees with dhellmann
16:16:28 <dhellmann> ok, that makes sense
16:16:30 <jd___> +1
16:16:58 <nijaba> #action nijaba to maintain topic about essex compat for next meeting
16:17:11 <nijaba> #topic PTL election
16:17:18 <nijaba> So, tomorrow is the end of the voting process, right? Do we know how many people have voted so far?
16:17:32 <dhellmann> do we have any way to tell that, jd___ ?
16:17:41 <jd___> 5 out of 6
16:18:02 <dhellmann> I guess that's a quorum :-)
16:18:04 <nijaba> ok, so we'll have to wait until tomorrow to know the results!!!
16:18:18 <nijaba> suspense!
16:18:25 <jd___> btw the end of the vote is manual and I don't think I'll do it at 00:00 GMT tonight
16:18:26 <dhellmann> :-)
16:18:34 <jd___> just sayin' :)
16:18:43 <dhellmann> I don't think that's a problem
16:18:45 <nijaba> jd___: no worries, you can do it when you wake up
16:18:48 <jd___> so it may be a little longer
16:18:50 <jd___> :)
16:19:11 <jd___> I'll send a mail with the results ASAP after 00:00 GMT :)
16:19:16 <nijaba> jd___: so I guess that will leave you with the responsibility of publishing the results?
16:19:23 <nijaba> general ml?
16:19:28 <jd___> sounds like a plan
16:19:34 <dhellmann> +1
16:19:54 <nijaba> #action jd___ to publish results of PTL election on general ml sometimes tomorrow
16:20:08 <jaypipes> hi all.
16:20:14 <nijaba> hey jaypipes
16:20:17 <jd___> hi jaypipes
16:20:25 <jaypipes> how's it goin?
16:20:43 * jaypipes chatted with jtran about support for Essex in Ceilometer a little while ago.
16:20:45 <nijaba> I think pretty well!
16:21:13 <nijaba> I guess we can move to the next topic then
16:21:14 <jaypipes> nijaba: do you guys have a stable/essex branch set up for Ceilometer yet?
16:21:20 <jaypipes> in gerrit
16:21:26 <nijaba> #topic Open Discusssion
16:21:38 <dhellmann> jaypipes: ceilometer isn't compatible with essex, yet
16:21:39 <jd___> jaypipes: no, we never released so..
16:21:44 <nijaba> jaypipes: no, we were just discussing the merrits of supporting Essex or not
16:21:55 <jtran> jaypipes, this is pertinent:  <dhellmann> as jd___ pointed out, it's a little unusual to worry about supporting old versions with new services
16:22:04 <nijaba> jaypipes: and we decided to rediscuss next week
16:22:09 <jaypipes> dhellmann: for my info, could you elaborate on what precisely isn't compatible and how difficult you think it would be to work on compat issues?
16:22:26 <jtran> i had invited jaypipes  to come in and provide thoughts on it.
16:22:35 <dhellmann> ceilometer imports code from nova that has moved between essex and folsom
16:22:47 <dhellmann> that was always a short-cut to get us running, and we want to change that anyway
16:22:54 <jaypipes> dhellmann: specifically which code? oepnstack-common stuff?
16:23:01 <dhellmann> some of the code we use is moving into common, so that's easy (service and manager)
16:23:06 <jaypipes> kk
16:23:21 <dhellmann> the db code we shouldn't be using anyway, so we are going to look into switching to rpc to get the list of instances
16:23:33 <dhellmann> there may be some other db queries that we would need to convert to rpc, I'm not sure
16:23:33 <jaypipes> what I was really worried about was the event notification and RPC message formats.
16:23:56 <dhellmann> we did add some details to the nova instance notifications, but the format didn't change afaik
16:24:02 <jaypipes> if the message formats are off, then ceilometer will need to have multiple aggregators, no?
16:24:09 <jaypipes> ok, good to hear.
16:24:27 <dhellmann> so a ceilometer server listening to an essex nova might not have all of the metadata that we want
16:24:40 <jaypipes> dhellmann: k
16:24:42 <dhellmann> we might need to backport one or two of those metadata changes, if that's allowed
16:24:58 <dhellmann> otherwise we can try to code-around the limits
16:25:00 <jaypipes> dhellmann: I think I'd need to see a code example to comment further on that one.
16:25:50 <nijaba> in any cases, we'll decide next week if someone is willing to do this
16:25:52 <jaypipes> dhellmann: I guess the meta-question is "Is ceilometer designed to aggregate and function against multiple releases or versions of OpenStack deployments?"
16:25:53 <dhellmann> ok. we can talk about that on the list
16:26:13 <jaypipes> or further: "Is ceilometer going to speak multiple public API versions of Compute/Image/Identity, etc?"
16:26:30 <dhellmann> jaypipes: I've been designing it to go with folsom and ahead, but essex support would be fine if we get some development help
16:26:41 <jaypipes> dhellmann: gotcha.
16:26:50 <dhellmann> right now we're not using public apis at all, just rpc and other internal apis
16:26:59 <jaypipes> dhellmann: ok, well that handles that question :)
16:27:04 <dhellmann> that may change when we integrate with other services :-)
16:27:26 <jaypipes> dhellmann: course, pegging on internal or RPC formarts/versions is going to be more of a hassle, but you already knew that. :)
16:27:34 <dhellmann> yep
16:27:57 <nijaba> we should be able to handle version management in the plugin code in any case, shoudn'twe?
16:27:58 <dhellmann> so, speaking of more developer help, I have been trying to do a little recruiting
16:28:09 <dhellmann> nijaba: yes, we should be able to
16:28:33 <jaypipes> nijaba: sorry, haven't taken a look at ceilometer code in a month or so... not sure about that one until I look again.
16:28:37 <dhellmann> I would like to have another couple of developers. I know flacoste was going to be hiring a team.
16:28:47 <dhellmann> and now we have jtran as well
16:28:58 <jaypipes> dhellmann: from our side, jtran is certainly on board.
16:29:03 <jtran> ;)
16:29:09 <nijaba> dhellmann: flacoste team is one it's way.  gmb was the first hire
16:29:15 <jaypipes> dhellmann: I can try to carve out some time myself, but difficult given my tempest and glance constraints
16:29:39 <dhellmann> what's the general policy for adding core reviewers? do we want to ask for a minimum commitment or contribution of some sort?
16:29:52 <jaypipes> dhellmann: I think having someone focusing on deployment of ceilometer in multi-node environments is a critical piece of the puzzle.
16:30:08 <dhellmann> yes, that will be important
16:30:10 <jaypipes> dhellmann: are there puppet modules/chef cookbooks/juju charms created for ceilometer yet?
16:30:16 <jaypipes> if not, we can work on that as well.
16:30:17 <jd___> dhellmann: when many other core members agree, we can add someone, I guess
16:30:19 <dhellmann> I think we've got that covered as far as the collector goes
16:30:23 <dhellmann> and the compute agent, of course
16:30:27 <nijaba> jaypipes: not yet, but we'll have juju charms for sure
16:30:28 <jaypipes> dhellmann: the cookbooks?
16:30:44 <dhellmann> jaypipes: we have not done anything with cookbooks, I just meant the architecture
16:30:49 <jaypipes> ah, k
16:31:07 <jaypipes> dhellmann: well perhaps I can be the point for the chef stuff then, with jtran working on coding.
16:31:17 <dhellmann> jaypipes: welcome aboard!
16:31:20 <dhellmann> :-)
16:31:28 <jaypipes> dhellmann: me and a couple others from AT&T are working with mattray on chef stuff, so it's a good fit.
16:31:45 <dhellmann> excellent, my ops team will be happy to hear it
16:31:46 <nijaba> nice
16:31:56 <jaypipes> dhellmann: OK, feel free to add an #action item for me to create the upstream (opscode) cookbook for ceilometer.
16:32:14 <dhellmann> I think anyone can add an action, right nijaba ?
16:32:23 <nijaba> definitely
16:32:30 <jaypipes> #action jaypipes to create ceilometer cookbook
16:32:55 <dhellmann> so how about my question about the policy for adding new contributors?
16:32:57 <jaypipes> OK, final thing before I run off...
16:33:24 <dhellmann> I'd like to have at least one patch, maybe some reviews, but I don't think we need to be super strict at this point
16:33:25 <jaypipes> dhellmann: for that, should just decide as a group...
16:33:25 <dhellmann> thoughts?
16:33:30 <nijaba> dhellmann: I think we should use the same policy as other OS projects
16:33:41 <dhellmann> nijaba: is there a formal policy written down somewhere?
16:33:42 <jaypipes> nijaba: each one is different ;)
16:33:51 * dhellmann rolls eyes
16:33:54 <jaypipes> dhellmann: :)
16:33:56 <nijaba> duhhh
16:34:16 <nijaba> ok, what do you do for glance jaypipes
16:34:18 <nijaba> ?
16:34:23 <dhellmann> it's like this is some sort of federated open source project
16:34:25 <jaypipes> so, I would advise just going organically. core contributors will appear over time. as people do more code reviews, they should be asked to join core.
16:34:28 <jd___> dhellmann: when many other core members agree, we can add someone, I guess
16:34:43 <jd___> jaypipes: +1
16:34:59 <dhellmann> ok, that makes sense
16:35:03 <jaypipes> nijaba: we do the "if you do some code reviews consistently and make a n effort consistently, the PTL will ask other core committers about you"
16:35:10 <dhellmann> the code reviews are what I was looking for anyway :-)
16:35:32 <jaypipes> nijaba: until you have the (happy) problem of having hundreds of committers, I don't think there's a need to do the formal nova-core tghing.
16:35:42 <jd___> :-)
16:35:48 <nijaba> true...
16:36:17 <jaypipes> dhellmann: easiest way to increase number of reviewers is to send emails to the openstack-dev list with subjects like "Hey, got five minutes? We've got a few code reviews you might be interested in..."
16:36:31 <jaypipes> dhellmann: it'll get people out to gerrit and going through the code.
16:36:34 <dhellmann> jaypipes: that's a good thought, I'll try that
16:36:52 <jaypipes> dhellmann: same with the "low hanging fruit" bugs ...
16:37:04 <jaypipes> dhellmann: a simple two line email to the list can do wonders ;)
16:37:27 <nijaba> jaypipes: dhellmann has been tagging  them by complexity, so that's really easy to find!
16:37:29 <dhellmann> jaypipes: I've been getting a lot more requests for essex support than offers of code ;-)
16:37:45 <jaypipes> dhellmann: patience :)
16:37:57 <dhellmann> jaypipes: indeed
16:38:14 <jaypipes> dhellmann: I find that if you carve up tasks into small, digestable chunks, and advertise those chunks for people to pick up, it goes faster and better :)
16:38:30 <dhellmann> we're getting close to the point where we have a functional end-to-end system, so that should make it easier for other people to understand how to contribute
16:38:44 <jaypipes> dhellmann: lots of times, people just need a small task to get comfortable with the code and the community contribution process, and they can go from there.
16:38:50 <jaypipes> dhellmann: ++
16:38:50 <dhellmann> and for us to carve the work up into smaller pieces
16:38:59 <jaypipes> which brings me to my final point before I head off ;)
16:39:26 <jaypipes> I was wondering if you all have a demo environment anywhere that people can go to to see what ceilometer is all about?
16:39:35 <jd___> nop
16:39:37 <nijaba> jaypipes: not yet
16:39:56 <jaypipes> jtran: think that's something we can help with?
16:39:56 <nijaba> we need to finish the first pass first
16:40:05 <jtran> jaypipes, i dunno, there's not much to see
16:40:22 <jaypipes> jtran: ok, when there is, perhaps AT&T can assist there.
16:40:32 <jtran> i have agents and collectors writing data , but there's no front end to show off anything  :)
16:40:34 <nijaba> sounds great!
16:40:35 <dhellmann> jaypipes: I'll keep that in mind
16:40:40 <jaypipes> kk
16:40:41 <jtran> i can have a page w/ mysql rows if you want jpi
16:40:43 <jtran> jaypipes,  ^
16:40:55 <jaypipes> jtran: well, it's a start :)
16:40:56 <dhellmann> there isn't really a plan for a UI for ceilometer right now
16:41:00 <nijaba> jtran: I was thinking of an horizon plugin
16:41:05 <jaypipes> nijaba: +10
16:41:12 <dhellmann> what would it show?
16:41:24 <nijaba> the current user summary
16:41:24 <jaypipes> http://docs.openstack.org/developer/horizon/topics/customizing.html
16:41:31 <jaypipes> https://github.com/gabrielhurley/horizon_demo
16:41:37 <jaypipes> http://gabrielhurley.github.com/slides/openstack/building_on_horizon/index.html
16:41:45 <jaypipes> anyway, food for thought
16:41:58 <jtran> i'll talk to you about that one offline jaypipes
16:42:00 <dhellmann> nijaba: we could do that, but the rules for turning the stats into something meaningful are vendor-specific
16:42:02 <jaypipes> coolio.
16:42:13 <dhellmann> but I see the benefit of having *something*
16:42:17 <jaypipes> dhellmann: sure, of course. but examples speak volumes.
16:42:20 <nijaba> dhellmann: true, but at least it works for a private cloud or a demo
16:42:56 <dhellmann> +1
16:43:15 <jaypipes> ok ceilometerites, I'm off to tackle some nasty bugs in tempest :) Catch you all later!
16:43:23 <nijaba> thanks jaypipes
16:43:29 <dhellmann> thanks for the input/advice jaypipes
16:43:39 <jaypipes> dhellmann: hey, thx for the answers!
16:43:43 <jd___> bye jaypipes
16:44:00 <nijaba> ok...  any other topics for today?
16:44:23 <jtran> should we consider our own mailing list?
16:44:24 <dhellmann> we covered everything I wanted to talk about with increasing the dev team size
16:44:46 <dhellmann> jtran: the trend has been toward a single -dev list with topics based on subject prefixes
16:45:07 <jtran> understood.  sometimes i have such simple boring questions i hate to pollute the main dev mailing list
16:45:11 <dhellmann> besides, we're already too far under the radar. we need more visibility, not less! :-)
16:45:37 <nijaba> jtran: you should not worry, as long as you prefix your message with [metering] only us seem to read it!
16:45:42 <jtran> :)
16:46:17 <dhellmann> seriously, I have a separate mail filter for [metering] or [ceilometer] messages, so if you use the prefix I'll see the email sooner
16:46:37 <jtran> got it!
16:46:49 <nijaba> same here
16:47:02 <nijaba> anything else?
16:47:09 <jd___> not from me
16:47:16 <dhellmann> I'm done
16:47:33 <nijaba> sounds like breakfast time for dhellmann
16:47:39 <dhellmann> lunch, actually :-)
16:47:44 <jtran> brunch
16:47:47 <nijaba> ok.  let's close that meeting then
16:47:48 <jtran> too early for lunch
16:47:55 <nijaba> #endmeeting