21:03:16 <ttx> #startmeeting
21:03:17 <openstack> Meeting started Tue Aug  7 21:03:16 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:26 <markwash> bcwaldon is on his way
21:03:28 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:31 <vishy> o/
21:03:39 <ttx> #info One week left to propose, review and merge the last Folsom features!
21:03:58 <ttx> do we have markmc for a 2012.1.2 update ?
21:04:15 <ttx> otherwise we'll push that at the end
21:04:19 <heckj> he's not online at the moment...
21:04:28 <ttx> #topic Keystone status
21:04:35 <ttx> heckj: then you're in
21:04:47 * heckj waves
21:04:49 <ttx> markmc: keystone in, you're next
21:04:51 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-3
21:05:03 <ttx> How is https://blueprints.launchpad.net/keystone/+spec/pki going ?
21:05:13 <heckj> quite well
21:05:13 <markmc> ttx, sorry, had network issues
21:05:30 <heckj> good feedback from the community on revocation needs around the initial implement, getting nailed down in blueprint right now
21:05:47 <ttx> ok good
21:05:47 <heckj> we're not holding PKI back for it, but accelerating getting revocation ready to roll
21:05:53 <ttx> About document-deployment-suggestions-policy, it's doc-only, right ? So we can postpone it to RC1 if not completed in the week ?
21:06:00 <heckj> uncertain if we'll make the feature freeze deadline, but giving it a shot
21:06:09 <heckj> ttx: it's doc only
21:06:18 <ttx> Quick look at untargeted blueprints on the series plan at:
21:06:23 <ttx> #link https://blueprints.launchpad.net/keystone/folsom
21:06:35 <ttx> heckj: agree that prompt-for-password is actually a python-keystoneclient blueprint ?
21:06:43 <heckj> ttx: yes
21:06:47 <ttx> wil redirect
21:06:59 <ttx> heckj: about https://blueprints.launchpad.net/keystone/+spec/iana-register-port ... I suspect it's still blocked at IANA ?
21:07:24 <heckj> yes, they haven't responded. Not likely to happen at this point, so we'll be staying where we are :-/
21:07:32 <ttx> Should we defer to grizzly ? target to F3 and pray ?
21:07:49 <heckj> grizzly is what I'm thinking
21:08:06 <ttx> Final question: what's the status of APIv3 one week away from featurefreeze ?
21:08:25 <heckj> some initial stabs at implementation up for review (thank you dolph!), not as much as we'd hoped.
21:08:51 <ttx> heckj: is it worth pushing anything in, then ?
21:09:22 <ttx> heckj: the grizzly branch should be open in a few weeks, once we nail RC1...
21:09:24 <heckj> I don't believe so - everyone's strapped for time, but not a lot of progress on much other than PKI right now
21:09:54 <ttx> heckj: agreed, looks like a Grizzly thing now
21:10:05 <ttx> heckj: anything else ?
21:10:13 <heckj> not from me
21:10:19 <ttx> Questions about Keystone ?
21:10:44 <ttx> #topic 2012.1.2 stable release
21:10:53 <ttx> markmc: the plan is still to have Keystone/Nova 2012.1.2 on Thursday ?
21:10:58 <markmc> so, the nova security fix we were waiting for has landed
21:11:10 <markmc> and we've had ~10 more nova fixes and a couple of keystone fixes
21:11:22 <ttx> so we have candidates up for testing, or are we waiting for anything more ?
21:11:25 <markmc> there's one nova fix that I'm worried might be a regression, looking at that
21:11:41 <markmc> the big change is that we've had ~10 fixes backported by bcwaldon for glance
21:11:47 <bcwaldon> aw yeah
21:11:49 <markmc> most haven't landed yet
21:11:54 <bcwaldon> aw
21:12:03 <markmc> it'd be nice to do 2012.1.2 with at least some of them
21:12:19 <markmc> but thinking we should get the important ones landed today
21:12:21 <bcwaldon> markmc: we can make those land this afternoon
21:12:30 <markmc> and send out a call for testing for nova, glance and keystone
21:12:34 <markmc> and then release friday
21:12:44 <markmc> giving another day for testing glance
21:12:57 <markmc> pushing out another week would conflict with folsom-3
21:12:58 <ttx> markmc: ok, so we should see clearer tomorrow, and call for testing candidates then
21:13:17 <markmc> ttx, yep, hoping to send out the call for testing tonight
21:13:29 <Ravikumar_hp> what level of testing ? is it unit tests by develoepr?
21:13:30 <ttx> #info 2012.1.2 may be pushed back to Friday to include Glance
21:13:57 <ttx> Ravikumar_hp: it's mostly a question of looking at proposed deliveries for things that would not get caught by our rigorous testing
21:14:06 <ttx> like fucked up tarballs.
21:14:27 <ttx> markmc: anything else ?
21:14:32 <mtaylor> ttx: I promise, no fucked up tarballs this time
21:14:41 <patelna> yayaya ...
21:15:01 <dolphm> ayoung: i'm honestly not sure how the client should call :5000/v2.0/tenants without initializing it as Client(token='asdf', endpoint='http://keystone:5000/v2.0')
21:15:40 <markmc> ttx, nope
21:15:42 <ttx> #topic Swift status
21:15:46 <ttx> notmyname: hey
21:15:47 <notmyname> hi
21:15:53 <ttx> You just released 1.6.0, so I don't have so many questions for you :)
21:15:58 <notmyname> :-)
21:16:00 <ttx> notmyname: should I create a tentative 1.6.1 milestone to target new things against ?
21:16:05 <ttx> (like for 1.5.1 we can always rename it if you change your mind wrt numbering)
21:16:17 <notmyname> yes. 1.6.1 for now
21:16:28 <ttx> #action ttx to create 1.6.1 milestone for Swift if nobody beats him to it
21:16:41 <ttx> notmyname: anything you wanted to mention ?
21:16:48 <notmyname> ya, I have one question for you
21:17:10 <notmyname> I think we have time for about one more release for folsom
21:17:21 <notmyname> when is that scheduled?
21:17:40 <ttx> notmyname: definitely. Final is scheduled for Sep 22
21:17:55 <ttx> I expect to have RC1 for the other projects around Sep 6
21:18:06 <notmyname> ok, thanks. that's what I was wonderign
21:18:40 <ttx> So I'd say you can plan one between Sep 1-13
21:18:56 <ttx> Err, release is Sep 27
21:19:03 <notmyname> ok
21:19:11 <ttx> Sep 22 was Diablo. Good ol days
21:19:31 <ttx> Questions on Swift ?
21:20:28 <ttx> #topic Glance status
21:20:32 <ttx> bcwaldon: o/
21:20:36 <ttx> #link https://launchpad.net/glance/+milestone/folsom-3
21:20:41 <bcwaldon> ttx: hey hey
21:20:50 <ttx> Looking good, let's see in more details:
21:20:57 <ttx> * https://blueprints.launchpad.net/glance/+spec/api-v2-store-access
21:21:07 <ttx> What's the status here ? ETA for code being proposed ?
21:21:19 <bcwaldon> ttx: today/tomorrow
21:21:27 <ttx> Ok... Is this the last step before we can mark the api-2 super-blueprint completed ?
21:21:43 <bcwaldon> yes
21:21:46 <ttx> * https://blueprints.launchpad.net/glance/+spec/glance-deprecate-client
21:21:58 <ttx> Is this one just a question of finding the 5min to do it, or is it blocked on something else ? (like glance-client-parity ?
21:22:00 <bcwaldon> that will be done today/tomorrow by me if nobody jumps at it
21:22:00 <ttx> )
21:22:04 <bcwaldon> its a 5-min thing
21:22:17 <ttx> ok, then I think we look good here
21:22:26 <ttx> On python-glanceclient side, is there anything blocking the core stuff ?
21:22:31 <bcwaldon> negative
21:22:34 <bcwaldon> its in great shape
21:22:40 <bcwaldon> it does have some outstanding ssl-related reviews
21:22:44 <bcwaldon> that could use some love
21:23:22 <ttx> yes
21:23:25 <ttx> bcwaldon: Anything else ?
21:23:44 <bcwaldon> yes
21:23:58 <bcwaldon> I wanted to mention that I'm thinking through images api versioning
21:24:01 <bcwaldon> (surprise surprise)
21:24:11 <bcwaldon> and I will be sending out an email with my thoughts
21:24:22 <ttx> suspense is now killing me
21:24:27 <vishy> ttx: mind if i jump ahead in the queue, may be losing internet soon.
21:24:35 <bcwaldon> #bcwaldonisdone
21:24:37 <ttx> vishy: ok, you're next
21:24:39 <ttx> Questions on Glance ?
21:25:07 <ttx> #topic Nova status
21:25:18 <ttx> #link https://launchpad.net/nova/+milestone/folsom-3
21:25:26 <ttx> vishy: Let's see progress on essential stuff:
21:25:29 <vishy> ohai!
21:25:31 <ttx> * https://blueprints.launchpad.net/nova/+spec/general-host-aggregates (jog0)
21:25:39 <ttx> This one looks in danger because of lack of review activity ?
21:26:01 <vishy> ttx: yes, although I think it is ready, just needs a +2
21:26:06 <jog0> ttx: I got a few reviews today, but still need more reviews
21:26:14 <vishy> the last patch in the series might not make it
21:26:27 <ttx> #help nova-core needed to review general-host-aggregates proposed changes
21:26:35 <vishy> jog0, ttx: but I think we can mark it complete without it
21:27:09 <jog0> vishy: I agree
21:27:12 <ttx> vishy, jog0: sure, maybe create a separate blueprint or bug to track the remaining work
21:27:20 <vishy> ttx: cool
21:27:23 <ttx> * https://blueprints.launchpad.net/nova/+spec/integrate-python-glanceclient
21:27:27 <ttx> Is this one complete ? Or more code is needed ?
21:27:31 <jog0> ttx: +1
21:27:40 <bcwaldon> I'm blocked on testing that guy
21:27:42 <bcwaldon> so frustrating
21:28:05 <ttx> blocked on testing ? How can we unblock you ?
21:28:18 <bcwaldon> not use glance client three different ways in nova
21:28:28 <bcwaldon> its all on me
21:28:43 * vishy slaps bcwaldon
21:28:50 <bcwaldon> :(
21:28:58 <ttx> bcwaldon: should still be in in time for F3 ?
21:29:16 <bcwaldon> yes
21:29:27 <bcwaldon> I dont want openstack folsom to use legacy glance client
21:29:35 <bcwaldon> wouldnt be the end of the world, but t'would be better
21:29:58 <ttx> hmm right. We would probably have to grant an exception for that
21:30:07 <ttx> but would definitely prefer if it got in in time
21:30:15 <ttx> Others may just already be complete:
21:30:21 <ttx> * https://blueprints.launchpad.net/nova/+spec/extract-nova-volumes (remaining work is covered in Cinder blueprint ?)
21:30:31 <vishy> jgriffith: progress on migration?
21:30:40 <ttx> (or is there anything left to do on Nova's code side ?)
21:30:44 <jgriffith> vishy: ttx: pretty much there
21:30:57 <jgriffith> db and persistent targets added to cinder-manage
21:30:58 <vishy> jgriffith: do you have changes to nova-manage? or is it separate?
21:31:09 <jgriffith> vishy: I made them all in cinder-manage
21:31:21 <vishy> great we can mark that implemented then
21:31:25 <annegentle> jgriffith: how's progress on docs?
21:31:29 <jgriffith> Writing a script now to do the service switch over etc and doing some tests
21:31:31 <ttx> vishy: will do
21:31:36 <vishy> done
21:31:38 <vishy> :)
21:31:39 <jgriffith> annegentle: believe it or not, I am working on it :)
21:31:40 <ttx> * https://blueprints.launchpad.net/nova/+spec/xenstore-metadata looks complete too
21:31:47 <annegentle> jgriffith: I do :)
21:32:09 <ttx> as do https://blueprints.launchpad.net/nova/+spec/per-user-quotas and https://blueprints.launchpad.net/nova/+spec/update-flavor-key-value
21:32:21 <vishy> yes and the plugin one
21:32:28 <ttx> All 4 ?
21:33:06 <ttx> novaplugins ?
21:33:59 <ttx> vishy: still with us ?
21:34:04 <vishy> yes
21:34:08 <vishy> just marking them
21:34:10 <ttx> heh, just checking.
21:34:16 <vishy> andrewbogott_afk: ping?
21:34:26 <vishy> looks like he is afk, I'm not sure if he had more to do on that one
21:34:30 <ttx> vishy: you can update them off-meeting
21:34:33 <vishy> marked the other three implemented
21:34:34 <vishy> :)
21:34:35 <ttx> A couple more questions...
21:34:40 <ttx> * https://blueprints.launchpad.net/nova/+spec/disable-server-extensions : priority ?
21:35:03 <vishy> i consider it essential for release
21:35:16 <vishy> but the later ones can be done as bugs
21:35:41 <ttx> vishy: mark it High and we'll do bugs
21:35:48 <ttx> * https://blueprints.launchpad.net/nova/+spec/volume-usage-metering : was that started ? ISTR seeing it discussed somewhere
21:35:52 <vishy> ttx: marked it, any that miss we will do as bugs
21:36:20 <vishy> ttx: yes it was discussed, but i think the plan was to do it in cinder instead
21:36:26 <vishy> haven't seen any props
21:36:27 <jgriffith> Yes, that's correct
21:36:37 <ttx> in Cinder in Folsom ?
21:36:42 <ttx> or some Grizzly thing ?
21:36:45 <jgriffith> ttx: yes Folsom
21:36:53 <ttx> ok will redirect
21:36:54 <jgriffith> ttx: But I haven't heard anyhting about it for a while now
21:37:01 <ttx> #info In general, if anyone already knows a given feature won't make it, please mark its blueprint "Deferred"
21:37:14 <ttx> there are more than one in that case
21:37:19 <ttx> It will help others focus on stuff that is more likely to land.
21:37:25 <ttx> vishy: Anything else ?
21:37:53 <vishy> nope, we will have another meeting on thursday
21:37:57 <vishy> mostly just need help with reviews
21:38:00 <vishy> actually yes
21:38:27 <vishy> need lots of help with reviews:
21:38:28 <vishy> https://review.openstack.org/10726
21:38:45 <vishy> is a big one that would be nice to get in
21:38:49 <vishy> + the cells code
21:38:53 <ttx> #help need help with reviews, including https://review.openstack.org/10726
21:38:53 <jgriffith> yikes
21:39:03 <markmc> yeah, was going to mention cells
21:39:17 <ttx> vishy: you really want Cells in in Folsom rather than early Grizzly ?
21:39:21 <markmc> would be good to have a bp to track it every week
21:39:25 <annegentle> #help need documentation on cells
21:39:57 <ttx> #action comstud to create a Cells blueprint so that we can track it
21:40:20 <vishy> ttx: early grizzly is probably fine for cells, although experimental support in would be nice for the third parties that are waiting on it
21:40:24 <vishy> like mercado-libre
21:40:32 <ttx> vishy: it's sufficiently separate ?
21:40:37 <ttx> from the core code ?
21:40:42 <vishy> they may be able to work off of trunk though so isn't super crazy
21:40:45 <markmc> vishy, if only we had a way of marking things as experimental :)
21:40:53 <vishy> ttx: yes, both cells and bare metal don't really touch core
21:41:00 <russellb> and even if it's marked experiemental, people are going to want backports
21:41:06 <vishy> markmc: yes we do! release notes!
21:41:13 <markmc> heh, who reads docs
21:41:19 <ttx> i do.
21:41:20 * markmc hides from annegentle :)
21:41:23 <russellb> so not sure what experimental does other than set expectations ... doesn't reduce maintenance load
21:41:27 * ttx lies well
21:41:27 * annegentle finds markmc
21:41:31 * jgriffith ducks so annegentle can reach markmc
21:41:32 <vishy> russellb, markmc: point taken, do you feel the same about the bare metal stuff?
21:42:01 <russellb> i don't think something should go in as experiemental, if it's not ready, it's just not ready
21:42:01 <markmc> vishy, haven't looked yet, but it does seem late
21:42:20 <markmc> vishy, new drivers are slightly different, though - e.g. doesn't add API
21:42:22 <ttx> russellb: +1 -- bracnhes can be used to track experimental stuff
21:42:27 <russellb> baremetal stuff does have some docs on the wiki, so that was cool, i don't know about the code state yet
21:42:38 <vishy> markmc: we have the unfortunate result of having a tremendous amount of work being done by multiple companies
21:42:50 <vishy> markmc: who are trying to do their best to get into folsom
21:43:01 <vishy> lets discuss it at the nova meeting/mailing list
21:43:04 <ttx> Looks like a good topic for the Nova meeting
21:43:06 <markmc> sure, sounds good
21:43:18 <ttx> As long as there is no blueprint for it, it doesn't exist from my perspective
21:43:18 <russellb> i don't think we should decide based on that it seems late, judge it by the quality of the code
21:43:26 <ttx> and late blueprint I do despise.
21:43:34 <russellb> but i don't think we should cut slack if there isn't enough time for legitimate feedback to be addressed
21:43:50 <vishy> ttx: ok I'm done, you can move on!
21:43:52 <ttx> Other questions on Nova ?
21:44:10 <ttx> #topic Quantum status
21:44:16 <ttx> danwent: yo
21:44:18 <danwent> hi
21:44:20 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-3
21:44:29 <danwent> btw, refresh if you haven't in the past half hour
21:44:29 <ttx> Progress looks generally good, but I think it's time to land and complete stuff
21:44:48 <danwent> yeah, today was our deadline for all 'features' being pushed to review.openstack.org
21:44:57 <danwent> some of the stuff is not truly complete though, they are WIP branches
21:44:58 <ttx> Ah, that explains it
21:45:02 <ttx> OK, essential stuff review...
21:45:07 <ttx> * https://blueprints.launchpad.net/quantum/+spec/provider-networks
21:45:13 <ttx> Proposal is in, missing review: https://review.openstack.org/#/c/10938/
21:45:17 <ttx> It's the last part, right ?
21:45:37 <danwent> yes
21:45:44 <ttx> * https://blueprints.launchpad.net/quantum/+spec/quantum-v2-public-networks
21:45:49 <ttx> Still blocked in review at https://review.openstack.org/#/c/9845/
21:45:53 <ttx> This is also the last part ?
21:46:12 <danwent> checking the reviews, it looks like we're getting some input from people who weren't around when the original discussion happened on the ML :(
21:46:30 <danwent> so I think we're going to simplify the code a bit to avoid the objection, and then merge it.
21:46:31 <ttx> yay, ignore them :)
21:46:39 <ttx> ok...
21:46:43 <ttx> * https://blueprints.launchpad.net/quantum/+spec/quantum-l3-fwd-nat
21:46:53 <ttx> "Needs code review"... Where is the review ?
21:47:02 <danwent> I just pushed that today.  definitely still needs polish, testing, and style cleanup
21:47:08 <ttx> Is it the only part needed ?
21:47:15 <danwent> I think jenkins missed it
21:47:22 <danwent> yes, all code is there, just not in great shape
21:47:28 <ttx> Link it here and I'll add it
21:47:36 <danwent> https://review.openstack.org/#/c/10993/
21:47:49 <ttx> OK. In other news was wondering if https://blueprints.launchpad.net/quantum/+spec/quantum-notifications was actually completed ?
21:47:51 <danwent> i'll add it, as I want to add the cli link too
21:48:13 <danwent> yes, it was merged a few days ago, but not updated on LP
21:48:24 <ttx> ok, will do
21:48:26 <ttx> There are a number of folsom-3 targets that are not in the plan:
21:48:30 <ttx> cisco-nxos-enables-multiple-ports, metadata-overlapping-networks, metaplugin
21:48:33 <ttx> Should I just add them with Low prio ?
21:48:59 <danwent> i actually updated their priority abou 20 mins ago
21:49:08 <danwent> all med + low
21:49:21 <ttx> danwent: did you set their series goal as well ?
21:49:27 <ttx> =Folsom ?
21:49:28 <danwent> yes
21:49:33 <ttx> awesome
21:49:42 <ttx> Finally, looking at untargeted blueprints in https://blueprints.launchpad.net/quantum/folsom :
21:49:43 <danwent> (at least on two of them… i'll re-run ttx.py later to be sure)
21:49:53 <ttx> https://blueprints.launchpad.net/quantum/+spec/add-basic-quantum-system-tests looks like it should be a Tempest blueprint rather than a Quantum one ?
21:50:28 <danwent> yes, probably, though I think that BP is basically dead (no one has worked in it in months)
21:50:35 <ttx> will redirect
21:50:37 <ttx> What about https://blueprints.launchpad.net/quantum/+spec/quantum-security-groups and https://blueprints.launchpad.net/quantum/+spec/quantum-client-security-groups ?
21:51:04 <ttx> can I remove them from the Folsom series goal ?
21:51:19 <danwent> We're going to work on them very soon after F-3, but we just can't get them in for Folsom.  We have a lot of testing + bug fixing to do as it is.
21:51:23 <danwent> yeah
21:51:31 <ttx> danwent: ok... Anything else ?
21:51:46 <danwent> not that I can think of...
21:51:58 <danwent> just going to need to organize the core devs to focus on the top priority reviews
21:52:08 <ttx> yes, lots of review backlog now
21:52:08 <danwent> and then test test test
21:52:12 <ttx> Questions on Quantum ?
21:52:17 <annegentle> o/
21:52:28 * ttx pauses
21:52:40 <annegentle> I just wanted to check on the doc plan of record - you're updating wiki pages and Diane's bringing it into "official" docs?
21:52:57 <danwent> annegentle: that's what we're doing for the API spec.  salv-orlando is leading that.
21:53:08 <danwent> for admin docs, I was planning on doing doc-book directly
21:53:16 <annegentle> ok, and what's the plan for admin?
21:53:19 <danwent> while pulling in chunks of text from others
21:53:20 <annegentle> heh I can't type  fast enough!
21:53:23 <danwent> :)
21:53:29 <ttx> Other questions ?
21:53:34 <danwent> i'll be the point-of-contact for admin docs
21:53:37 <annegentle> ok sounds good. Any WADL for the API so we could put it on api.openstack.org?
21:53:54 <annegentle> I can contact salv-orlando offline with the WADL Q.
21:53:58 <danwent> i don't think we have it at this point.
21:54:00 <danwent> yeah, that would be great.
21:54:00 <salv-orlando> I don't believe we'll have a wadl for next week
21:54:01 <salv-orlando> sorry
21:54:04 <ttx> ok then
21:54:08 <ttx> #topic Cinder status
21:54:12 <ttx> jgriffith: howdy!
21:54:15 <ttx> #link https://launchpad.net/cinder/+milestone/folsom-3
21:54:17 <jgriffith> Howdy
21:54:26 <ttx> We already touched it during the Nova part
21:54:30 <ttx> * https://blueprints.launchpad.net/cinder/+spec/migrate-nova-volumes-to-cinder
21:54:42 <ttx> How is this doing ? You told me yesterday it was almost done ?
21:54:49 <jgriffith> I think we're ready to close that
21:55:03 <annegentle> salv-orlando: I just got a WADL for object storage last week so it's not time-sensitive other than missing out on being on api.openstack.org :)
21:55:19 <ttx> jgriffith: as in.. propose code ?
21:55:26 <ttx> or have it merged ?
21:55:33 <jgriffith> Yeah, I should push the review today
21:55:49 <ttx> ok, set to "Needs code review" status when done
21:55:50 <jgriffith> The patch will only be db and targets
21:56:01 <jgriffith> Everything else is so dependent I'm doing an example script
21:56:07 <ttx> jgriffith: Anything else on your mind ?
21:56:08 <jgriffith> ie switching the service
21:56:16 <jgriffith> Lots of things up in the air
21:56:41 <jgriffith> multi back-ends and boot from volumes
21:56:43 <ttx> That's how the last week before FeatureFreeze should look
21:56:49 <jgriffith> :)
21:56:53 <ttx> Questions on Cinder ?
21:57:16 <ttx> #topic Horizon status
21:57:23 <ttx> gabrielhurley: o/
21:57:23 <gabrielhurley> ttx: hello sir
21:57:26 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-3
21:57:36 <ttx> Still feeling confident about those 4 incomplete "High" blueprints ? What's the ETA for code proposal on them ?
21:57:55 <gabrielhurley> as soon as I get through this quantum stuff they're next on deck
21:58:15 <gabrielhurley> well, two of them *are* the quantum stuff
21:58:23 <ttx> right
21:58:37 <ttx> so code should be pushed for review in the next two days for those ?
21:58:49 <gabrielhurley> I'd say end of the week is reasonable
21:58:56 <ttx> ok
21:59:01 <ttx> Looking at https://blueprints.launchpad.net/horizon/folsom ...
21:59:06 <ttx> Can we assume that anything not targeted to folsom-3 (i.e. identity-backend-type, syspanel-tests and tenant-deletion) should be deferred to Grizzly ?
21:59:14 <gabrielhurley> definitely
21:59:23 <ttx> ok, will clean up
21:59:29 <gabrielhurley> thanks
21:59:31 <ttx> gabrielhurley: Anything else you wanted to mention ?
21:59:48 <gabrielhurley> more eyes on the quantum code review would be awesome
21:59:54 <ttx> #action ttx to create grizzly series for Horizon and defer non-targeted Folsom bps
21:59:58 <gabrielhurley> also, help getting the devstack/quantum docs up-to-date
22:00:11 <gabrielhurley> it's making reviewing/testing that code difficult
22:00:35 <gabrielhurley> that's about it
22:00:41 <ttx> Questions for Horizon ?
22:01:05 <ttx> #topic Other Team reports
22:01:11 <ttx> Any other team lead with a status report ?
22:01:21 <annegentle> o/
22:01:24 <annegentle> I'll be quick
22:01:26 <annegentle> promise
22:01:30 <ttx> annegentle: go for it
22:01:54 <annegentle> Reminder to please use DocImpact in your commit messages. And don't be surprised if I just amend  your message with DocImpact added.
22:02:01 <annegentle> that's all
22:02:10 <ttx> quick indeed
22:02:22 <ttx> #info remember to please use DocImpact in your commit messages. And don't be surprised if I just amend  your message with DocImpact added.
22:02:27 <ttx> #topic Open discussion
22:02:31 <ttx> Anything else, anyone ?
22:03:01 <ttx> well the,
22:03:02 <ttx> n
22:03:03 <ttx> #endmeeting