16:00:02 <nijaba> #startmeeting
16:00:02 <nijaba> #meetingtopic Ceilometer
16:00:02 <nijaba> #chair nijaba
16:00:02 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
16:00:03 <openstack> Meeting started Thu Aug  9 16:00:02 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:06 <openstack> Current chairs: nijaba
16:00:13 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
16:00:13 <nijaba> o/
16:00:19 <mrevell> o/
16:01:13 <nijaba> dhellmann: around?
16:01:28 <gmb> 0/
16:01:39 <nijaba> ok, let's start
16:01:42 <nijaba> #topic actions from previous meeting
16:01:56 <nijaba> #topic jaypipes to create ceilometer cookbook
16:02:07 <nijaba> jaypipes: any progress on this?
16:02:48 <jaypipes> nijaba: no, sorry man
16:03:00 <nijaba> should I forward the action?
16:03:02 <jaypipes> nijaba: might be able to get to it over weekend or monday
16:03:05 <jaypipes> nijaba: sure
16:03:23 <nijaba> #action jaypipes to create ceilometer cookbook
16:03:41 <nijaba> #topic jtran to open a ticket for the DB access work
16:03:50 <nijaba> jtran informed us that he won't be able to join us this week, but did open the bug:
16:03:50 <nijaba> #link https://bugs.launchpad.net/ceilometer/+bug/1034666
16:03:52 <uvirtbot> Launchpad bug 1034666 in ceilometer "Remove nova db access for all ceilometer code" [Undecided,New]
16:04:03 <nijaba> #topic nijaba to create a diagram of ceilometer architecture
16:04:13 <nijaba> I have prepared a first version of this diagram that you can see here:
16:04:13 <nijaba> #link https://docs.google.com/drawings/pub?id=1_cIFir6HS6jSkPw7chrmyu8DGE2ZgXk79Kbj8nw-Hqo&w=960&h=720
16:04:13 <nijaba> Comments are welcome.
16:04:53 <nijaba> I can share the google doc with anyone who wants to modify it
16:05:32 <DanD> is there a description of component responsiblitiy?
16:05:53 <nijaba> DanD: not at the moment, but could be a nice addition
16:06:27 <nijaba> if anyone wants to comment later, ping me...
16:06:58 <nijaba> #action nijaba to write description of componet responsibility
16:07:03 <nijaba> let's move on
16:07:21 <nijaba> #topic Discuss dhellmann's API change proposal
16:07:21 <nijaba> #link http://lists.openstack.org/pipermail/openstack-dev/2012-August/000389.html
16:07:41 <nijaba> not sure if dhellmann has joined us...
16:08:10 <dhellmann> sorry, running late
16:08:13 <nijaba> np
16:08:37 <nijaba> so the proposal seemed very reasonable
16:08:51 <nijaba> and jaypipes' comment made it even better
16:08:56 <dhellmann> jd___ approved the changeset, but we can make adjustments as needed
16:08:58 <dhellmann> yes, thanks jaypipes
16:09:27 <nijaba> any other comment before we formally approve it?
16:09:57 <nijaba> if not, then I propose that we skip voting and just mark this as agreed
16:10:18 <nijaba> going once
16:10:22 <nijaba> twice
16:10:24 <dhellmann> it would help if someone had a few minutes to go through the URL list in comments in the v1.py file now and make sure all of the endpoints from the original list are included
16:10:39 <dhellmann> I double checked, but a second set of eyes is always good
16:11:02 <nijaba> dhellmann: i did this summarilly this morning.  I can take the action to do a better match
16:11:16 <dhellmann> ok, thanks!
16:11:42 <nijaba> #agreed new api proposal from dhellmann provide a second check that all case are covered
16:12:01 <nijaba> #action nijaba to do a second thouroughness check on API and report next week
16:12:18 <nijaba> #topic Discuss priority of maintaining Essex support and find contributor to work on it if we are going to do it
16:12:25 <jd___> lo
16:12:25 <jd___> sorry i'm late :)
16:12:42 <nijaba> hey jd___!
16:13:08 <jd___> (i'm on holidays so my schedule is a bit chaotic :)
16:13:29 <nijaba> so, it seemed last week that jtran wanted this to happen, but was not sure to be able to do it alone, correct?
16:13:44 <jd___> seems so
16:13:50 <dhellmann> that's how I remember it
16:13:52 <nijaba> is anyone here that care about this and wants to second him?
16:14:16 <nijaba> it seems that most of us really care about folsom support
16:14:30 <dhellmann> I thought loic wanted it, too?
16:14:50 <nijaba> dhellmann: yep, but he does not seem to be around
16:14:57 <dhellmann> ok
16:15:12 <jd___> i though too but it's away for a while now so maybe he doesn't care about it now
16:15:28 <jd___> s/it/he
16:15:33 <nijaba> so I propose that we postpone this until someone proposes himself?
16:15:39 <dhellmann> +1
16:15:52 <jd___> I agree
16:16:05 <jd___> i'm all for do-ocracy on this :)
16:16:08 <dhellmann> there has been some progress on moving the service and manager bits out of nova into common, which will help us
16:16:18 <dhellmann> we want that anyway, even for folsom
16:16:22 <jd___> yup
16:16:57 <nijaba> #agreed essex support postponed until someone that cares about it signals himself and want to work on it
16:17:17 <nijaba> moving on...
16:17:19 <nijaba> #topic Discuss integration with Heat
16:17:31 <nijaba> so their are 2 subtopics here
16:17:49 <nijaba> 1/ instrumenting heat so that ceilometer can meter it
16:17:59 * dhellmann doesn't know what heat is
16:18:04 <nijaba> 2/ the "cloudwatch" proposal
16:18:27 <nijaba> dhellmann: heat is a project to mimick AWS cloudformation in openstack
16:18:44 <nijaba> it has just been submited for incubation
16:18:53 <nijaba> like use, the response was postoned
16:18:55 <ppetit> Don't want to speak for Heat representative but heat is more than that. Its an attempt to support CloudFormation for OpenStack
16:19:23 <dhellmann> ok, thanks for the background
16:19:24 <nijaba> ppetit: any better definition is welcome
16:19:46 <jd___> hi ppetit
16:19:47 <ppetit> As per the support of CloudFormation's service semantic, support of CloudWatch is desirable.
16:20:01 <ppetit> Hi!
16:20:40 <nijaba> so, regarding 1/, I think we would welcome to see heat instrumented too, right?
16:20:40 <ppetit> But also auto-scaling, ... and other integrated cloud services that are part of AWS
16:21:02 <nijaba> question being, how and who...
16:21:09 <ppetit> Not sure this is heat we'd like to instrument.
16:21:26 <dhellmann> yeah, I was just reaching that conclusion: what would we meter in heat?
16:21:28 <jd___> cloudwatch is part of heat too actually, no?
16:21:44 <ppetit> I think the propoal was more about having one point of support for CloudWatch-like functionality
16:21:55 <dhellmann> and CloudWatch is monitoring?
16:22:04 <ppetit> And that would be under Ceilometer project instead of Heat
16:22:10 <nijaba> so that's point #2
16:22:39 <nijaba> for which, as I said on the ml, I think we need to discuss this at ODS in october
16:22:51 <dhellmann> agreed
16:23:24 <ppetit> Yes, I think it makes sense because the subject is complexe
16:23:37 <ppetit> We are speaking of an ecosystem of components
16:23:44 <nijaba> exactly
16:24:42 <dhellmann> it may be appropriate for the monitoring tool to listen for metering events, but as nijaba pointed out they are likely not to come frequently enough
16:24:59 <nijaba> so I propose the following agreement: "propose a joint session with heat at ODS regarding cloudwatch"
16:25:16 <dhellmann> +1
16:25:17 <ppetit> One neat thing about CloudWatch-like functionality is the support of a monitoring service above ceilometer with stuffs like policies, recovery action, threshold monitoring and so forth....
16:25:22 <jd___> dhellmann: sure but they can write their own metering tools too
16:25:32 <dhellmann> jd___: sure
16:25:41 <nijaba> ppetit: I fully agree on the usefulness
16:26:02 <nijaba> any one against the above proposal?
16:26:32 <nijaba> ...
16:26:53 <nijaba> #agreed propose a joint session with heat at ODS regarding cloudwatch
16:27:08 <nijaba> ok, so let's dig a bit into #1
16:27:41 <dhellmann> what would we meter in heat?
16:27:50 <nijaba> ppetit: there is nothing in heat/cloudformation that could be billed to customers?
16:28:12 <nijaba> I am not familiar enough with this to have an opinion
16:28:13 <ppetit> Hmm... on the top of my head no, not really.
16:28:25 <nijaba> ok, so moot point, then
16:28:38 <nijaba> let's move on
16:28:52 <ppetit> Perhaps stuffs like how fast or how slow a cloudformation stack can be deployed
16:28:52 <nijaba> #topic Open Discusssion
16:29:02 <jd___> yeah i though #2 was actually the main point for heat
16:29:21 <ppetit> that's my understanding 2
16:29:51 <dhellmann> ok
16:29:54 <ppetit> Is there any heat developer around?
16:30:18 <jd___> doesn't seems so unfortunately
16:30:24 <ppetit> :-(
16:30:32 <nijaba> well, I don't think there is any hurry and we can bring back the subject in a later meeting
16:31:33 <nijaba> any other topics?
16:31:36 <ppetit> jd__: that's a relatively important subject regarding project XLcloud. I'd like we keep a close look at it
16:31:55 <jd___> sure
16:32:08 <nijaba> ppetit: XLcloud?
16:32:16 <ppetit> check xlcloud.org
16:32:23 * nijaba checks
16:32:44 <ppetit> Collaborative project around HPC cloud based on OpenStack
16:32:55 <nijaba> hahh!  neat!
16:33:07 <jd___> nijaba: xlcloud is planning to use ceilometer, i did a talk about ceilometer, i talked about it when you were on holidays :)
16:33:30 * nijaba admits to have only read summaries
16:33:36 <jd___> :D
16:33:44 <ppetit> And Heat to help with virtual cluster post-install config
16:34:00 <nijaba> ok
16:34:06 <nijaba> that sounds exciting
16:34:31 <ppetit> yes indeed!
16:35:24 <nijaba> should we move on?
16:35:37 <nijaba> any other topics for today?
16:35:58 <dhellmann> nothing here
16:36:05 <jd___> here neither
16:36:09 <nijaba> I personally wanted to thank everyone for the vote of confidence!
16:36:19 <dhellmann> oh, I will mention that we're working on integration ceilometer with our billing system this sprint
16:36:24 <ppetit> just let us know about follow of Heat and Ceilometer please
16:36:37 <nijaba> ppetit: noted!
16:36:38 <jd___> dhellmann: that's neat
16:36:47 <nijaba> dhellmann: yeah!
16:36:52 <dhellmann> congratulations, nijaba!
16:37:01 <nijaba> dhellmann: thanks
16:37:47 <nijaba> dhellmann: are you going to use the API?
16:37:54 * nijaba thinks so...
16:37:57 <dhellmann> nijaba: yes
16:38:03 <nijaba> very cool
16:38:06 <jd___> he'd better does!
16:38:07 <jd___> :)
16:38:14 <nijaba> can't wait for the feedback
16:38:25 <dhellmann> our sprint is 2 more weeks, so I should have more feedback at next week's meeting
16:38:46 <jd___> ok
16:38:54 <nijaba> so, if anyone is going to cloudopen, note that I'll be there in 3 weeks
16:39:17 <jd___> i'll try to be present at next meetings, but excuse me in advance if I don't make it :)
16:39:28 <nijaba> it runs in parallel with linuxcon
16:39:43 <nijaba> jd___: hey, enjoy your vacation time!
16:40:14 <jd___> thanks!
16:40:15 <nijaba> I guess that's a wrap for today!
16:40:24 <nijaba> thanks everyone
16:40:28 <mrevell> Thanks nijaba
16:40:32 <ppetit> Okay thanks ! Bye
16:40:44 <nijaba> #endmeeting