21:02:43 <ttx> #startmeeting
21:02:44 <openstack> Meeting started Tue Aug 21 21:02:43 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:53 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:07 <ttx> #info We are under FeatureFreeze for everything but Swift, so please take extra care in reviews
21:03:25 <ttx> #info Core reviewers should flag changes that add a new feature, modify the behavior without fixing a bug, modify translatable strings or add/modify a configuration option
21:03:50 <ttx> #topic Keystone status
21:03:56 <ttx> ayoung: o/
21:04:02 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-rc1
21:04:18 <ttx> So one blueprint was granted an exception, yours :)
21:04:22 <ttx> * https://blueprints.launchpad.net/keystone/+spec/pki
21:04:33 <ttx> ayoung: How far are you ? I couldn't really find reviews linked to this...
21:05:01 <ayoung> PKI was done for a while, with the exception of Revocation.  Revocation was merged last week
21:05:19 <ttx> IIUC that means it's now all in ?
21:05:22 <ayoung> there is a bug that is up for review
21:05:34 <ayoung> ttx, yes, in master
21:05:51 <ttx> ayoung: ok, will mark that blueprint implemented. The bug was targeted to folsom-rc1 ?
21:06:24 <ayoung> Heh, it will be shortly.
21:06:30 <ttx> hmm, apparently not
21:06:33 <ttx> ok :)
21:06:47 <ttx> More generally, your RC bug list is very empty
21:06:59 <ttx> Somehow I doubt those two listed issues are the only one standing between you and a release-quality RC1 :)
21:07:15 <vishy> o/
21:07:16 <ttx> Would be good to go through bugs and start targeting all bugs you think should be fixed before we can release Folsom
21:07:18 <vishy> (btwo)
21:07:34 <ayoung> https://bugs.launchpad.net/keystone/+bug/1038309
21:07:35 <uvirtbot> Launchpad bug 1038309 in keystone "auth_token fails to fetch revocation list" [Undecided,In progress]
21:07:49 <ayoung> ttx, heckj was doing just that
21:07:51 <ttx> ayoung: targeted
21:08:21 <ttx> #action heckj to go through keystone buglist and target release blockers to RC1 where appropriate
21:08:33 <ayoung> from today's keystone meeting:
21:08:43 <ayoung> http://eavesdrop.openstack.org/meetings/openstack-meeting/2012/openstack-meeting.2012-08-21-18.02.html
21:08:46 <ttx> Looking at triage now... looks like you triaged them all ?
21:09:21 <ayoung> Joe was very busy
21:09:28 <ttx> ayoung: I think once the RC buglist is built you should be in good shape
21:09:35 <ayoung> Agreed
21:09:48 <ayoung> we've been trying to keep an eye to stability
21:10:01 <ttx> ayoung: then it's all downhill with bugfixing and bug assignment to RC1
21:10:15 <ttx> ayoung: anything else you wanted to mention ?
21:10:57 <ayoung> No, I think those are the important things
21:10:58 <ttx> Questions about Keystone ?
21:11:25 <ttx> #topic Swift status
21:11:30 <notmyname> hi
21:11:31 <ttx> notmyname: o/
21:11:40 <ttx> notmyname: Did you send that email with your 2.0 thoughts ?
21:12:19 <notmyname> I did not. I'm still collecting them
21:12:34 <ttx> #action notmyname to send an email to openstack-dev with 2.0 thoughts
21:12:37 <notmyname> turns out it's an issue with lots of factors :-)
21:13:02 <ttx> notmyname: for the release date, would be good if it was before Sep 13
21:13:10 <ttx> i.e. at least two weeks away from release
21:13:15 <notmyname> how about sept 13 then?
21:13:16 <ttx> (common release)
21:13:23 <ttx> notmyname: works for me
21:13:49 <notmyname> ttx: is that for the QA'd release or the RC?
21:13:57 <ttx> QA'd release
21:14:01 <notmyname> ah
21:14:33 <notmyname> ok. we'll see what we can do
21:14:50 <ttx> ok, keep me posted
21:14:54 <ttx> notmyname: anything else ?
21:14:55 <notmyname> we have a lot of changed I'd like to see get in
21:14:59 <notmyname> nope
21:15:40 <ttx> if there are so many changes it might make sense to include 1.6.1 in Folsom
21:15:56 <ttx> and keep 2.0 as an early Grizzly thing
21:16:42 <notmyname> or 1.7 in folsom and 2.0 "later"
21:16:46 <notmyname> ;-)
21:16:51 <ttx> heh
21:17:09 * ttx holds on before creating a 2.0 in Folsom series :)
21:17:11 <ttx> Questions on Swift ?
21:17:40 <ttx> #topic Glance status
21:17:46 <ttx> bcwaldon: around ?
21:18:28 <ttx> let's skip to Quantum, Brian told me he might have to leave IRC for a few
21:18:35 <ttx> #topic Quantum status
21:18:40 <ttx> danwent: yo
21:18:45 <danwent> hello
21:18:49 <ttx> danwent: congrats by the way
21:18:54 <danwent> thanks :)
21:19:03 <danwent> she's right by me… hope you can't hear her scream via IRC :)
21:19:11 <ttx> I can just imagine
21:19:18 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-rc1
21:19:23 <ttx> Got only two standing Quantum-code-related exceptions on that list:
21:19:35 <ttx> * https://blueprints.launchpad.net/quantum/+spec/quantum-multihost-dhcp (nati)
21:19:37 <danwent> yes, still need to send you mail, sorry
21:19:44 <ttx> * https://blueprints.launchpad.net/quantum/+spec/test-agent (nati)
21:19:53 <ttx> The rest is either completed, doc, devstack or quantumclient related, IIUC
21:20:05 <danwent> that is true in terms of blueprints.
21:20:20 <danwent> there are two other items that are tracked as bugs, but are signfiicant enough that i'm treating them like FFE items.
21:20:23 <danwent> xml support
21:20:31 <danwent> and the last phase of bob's provider networks branch
21:20:44 <ttx> danwent: hmm, we'll come back to those later
21:20:53 <danwent> anything that smells like an FFE, I've told people needs to be proposed for non-WIP review by next monday
21:20:58 <ttx> danwent: how are those two above doing ?
21:21:07 <danwent> the bps or the bugs?
21:21:11 <ttx> (nati's ones)
21:21:29 <danwent> both are under review already (they have been since F-3)
21:21:36 <danwent> the test-agent is for testing only
21:21:38 <danwent> and is pretty close
21:21:49 <danwent> the multi-host DHCP, i need to re-review since providing feedback.
21:22:21 <danwent> multi-host patch got much smaller in review, which is good.
21:22:22 <ttx> both should land before the end of week ?
21:22:42 <danwent> I would say by start of next week, giving them the weekend, as nati is on vacation at least part of this week.
21:22:57 <danwent> though he's responding to reviews (or at least has been so far).
21:23:04 <mtaylor> danwent, ttx: status on quantum in devstack-gate?
21:23:38 <danwent> mtaylor: glad that you mentioned it.  we were going to wait for one of the above items, but after discussing it at the meeting yesterday, we're just going to go ahead with a simple gate to start.
21:23:46 <mtaylor> danwent: great!
21:23:57 <danwent> mtaylor: will send you email after the meeting, but have told team this is top priority
21:24:05 <danwent> (assuming we can get some devstack review help)
21:24:08 <mtaylor> danwent: you always make me super-happy
21:24:13 <mtaylor> danwent: we'll prioritize that
21:24:19 <danwent> great, thanks.
21:24:20 <jeblair> +1
21:24:20 <ttx> danwent: link to devstack review ?
21:24:41 <danwent> https://review.openstack.org/#/c/10828/
21:24:53 <ttx> #help devstack review help needed https://review.openstack.org/#/c/10828/
21:25:09 <ttx> ok, so about those two bugs-that-look-like-features
21:25:18 <danwent> yes
21:25:25 <ttx> XMl support sounds like something I'd prefer to have a blueprint about
21:25:40 <ttx> if only to track the major features that landed in Folsom
21:26:13 <ttx> No so sure about the other one, which looks like a gap bug
21:26:25 <danwent> agreed.  I will up to to a BP.  we had a branch proposed for review for XML support during F-3, but I wasn't happy with it.  I told the two people who really wanted XML support in Folsom that they could have a week to clean it up and get it approved.
21:26:50 <danwent> ttx: yes, other one is last bit of something that landed in F-3.  we could have deferred the BP, but instead we created a 'follow-on' bug.
21:26:52 <ttx> danwent: not really happy to see that landing now, tbh. It affects the work of QA people quite a bit
21:27:03 <danwent> ttx: the xml?
21:27:11 <ttx> and as famous examped showed, untested XML is like no XML
21:27:18 <ttx> examples*
21:27:20 <ttx> danwent: yes
21:27:30 <danwent> i'm ok with you denying it…
21:27:35 <danwent> if it makes you unhappy
21:27:43 <danwent> it doesn't make me very happy either
21:27:56 <danwent> but the folks seem close, so I told them to take a shot.
21:27:58 <ttx> hmm, we'll discuss that offline
21:28:08 <ttx> #action danwent/ttx to discuss XML support FFE status
21:28:15 <danwent> and if it didn't make the core devs happy by monday, we'd drop it from folsom
21:28:22 <ttx> Looking at bugs now... good list
21:28:23 <annegentle> danwent: the API spec under review has XML samples
21:28:31 <annegentle> but yes discuss offline
21:28:34 <ttx> Did you go through the complete open bugs list to build it ?
21:28:38 <danwent> annegentle: yes, we will have to remove those if it doesn't make it.
21:28:44 <annegentle> danwent: noted
21:28:57 <danwent> ttx:  not yet.  can do it today… i'll pull the baby card :)
21:29:05 <ttx> Would be great to get people assigned to each of those too
21:29:26 <ttx> danwent: also someone should carete that XML support blueprint
21:29:29 <ttx> create*
21:29:32 <danwent> yes.  I filed a few more last night, as there are some squishy points on integration of nova + quantum that we need to firm up ASAP.
21:29:38 <danwent> ttx: I will
21:29:40 <ttx> (Generally when noone is assigned to them they don't progress fast enough for RC1.)
21:29:45 <ttx> (the bugs)
21:29:51 <ttx> Looking at bug triaging, you also have 22 untriaged
21:30:03 <danwent> ttx: my bad.  will do full bug pass today
21:30:11 <ttx> danwent: delagate, dude :)
21:30:23 <danwent> ttx: good point :)
21:30:36 <annegentle> or danwent: man up, daddy-o :)
21:30:40 <ttx> #action danwent and team to triage all bugs and build the RC bug list
21:30:45 <ttx> danwent: Anything else ?
21:30:48 <annegentle> sleep, schmeep
21:30:59 <annegentle> :)
21:31:09 <danwent> nope, clearly have a bit of catch-up to do.  will ping you offline about xml. and will ping CI people about gate.
21:31:16 <ttx> Questions on Quantum ?
21:31:21 <ttx> bcwaldon: back?
21:31:28 <bcwaldon> ttx: yes
21:31:51 <ttx> #topic Glance status
21:31:55 <ttx> #link https://launchpad.net/glance/+milestone/folsom-rc1
21:31:59 <ttx> No exception, yay
21:32:11 <ttx> Looking at bugs, I see you got a decent list of RC bugs
21:32:13 <bcwaldon> yepper, just a buncha bugs
21:32:25 <bcwaldon> I pushed off bugfixin until now
21:32:26 <ttx> Is that list reasonably complete ? i.e. did you go through the whole open bugs list ?
21:32:33 <bcwaldon> yes
21:32:36 <ttx> Awesome.
21:32:51 <bcwaldon> I might expect to see a few more added
21:32:57 <bcwaldon> but maybe not
21:32:58 <ttx> Well, you did your homework, I see.. anything specific you wanted to mention ?
21:32:59 <bcwaldon> we'll see :)
21:33:19 <bcwaldon> I did want to highlight my message to the ML covering Glance's Folsom release http://markmail.org/message/rpewwtqcb2qxa5t5
21:33:42 <bcwaldon> that has some good info in it for people not following glance development too closely
21:33:45 <ttx> bcwaldon: yes, I just read it. Will definitely help in release notes and messaging around folsom release
21:33:55 <mtaylor> ++
21:33:56 <bcwaldon> yes, I'll condense it down for official release notes
21:34:21 <bcwaldon> thats it from me
21:34:24 <ttx> Questions on Glance ?
21:34:52 <ttx> #topic Cinder status
21:34:57 <jgriffith> Yo
21:34:57 <ttx> jgriffith: o/
21:35:02 <ttx> #link https://launchpad.net/cinder/+milestone/folsom-rc1
21:35:08 <ttx> No exception either, yay
21:35:12 <jgriffith> :)
21:35:22 <jgriffith> Quotas should be closing as soon as I get reviews
21:35:25 <ttx> On the bug side though, you should start to aggressively triage your bug list and mark more of those RC (by targeting them to folsom-rc1)...
21:35:32 <ttx> ... as I suspect Cinder is more than 3 bugs away from perfection ?
21:35:35 <jgriffith> The Netapp ones I have to find Ben.. he's been MIA since last week
21:35:38 <jgriffith> LOL
21:35:44 <jgriffith> Sure.. that sounds good
21:35:50 <ttx> You also have 11 untriaged bugs that you should probably go through
21:35:59 <jgriffith> I have plans for most of them
21:36:06 <jgriffith> I want to get input from the core team in tomorrows meeting though
21:36:21 <ttx> #action jgriffith and Cinder team to triage new bugs and come up with a list of release blockers
21:36:24 <jgriffith> There will be at least 4 added to RC1 after tomorrow
21:36:53 * ttx prefers known targeted bugs to unknown quality
21:37:01 <jgriffith> fair enough
21:37:23 <ttx> jgriffith: that's all I had for you... anything you wanted to mention ?
21:37:38 <jgriffith> Nope... just pushing these, then trying to get everybody to pitch in on docs
21:38:10 <ttx> Less exceptions give more time for bugfixing and documentation, yay
21:38:10 <annegentle> jgriffith: just to clarify, both nova-volume and cinder will exist as options in folsom, correct?
21:38:11 <jgriffith> Anybody wants to help with reviews that would be great
21:38:18 <jgriffith> annegentle: yes
21:38:30 <jgriffith> annegentle: There will be a synch between the two after RC1
21:38:35 <annegentle> #info the docs need to cover both nova-volume and cinder
21:38:37 <jgriffith> Or for RC1
21:38:46 <ttx> jgriffith: are you lacking reviewers ?
21:38:56 <jgriffith> This week I seem to be
21:39:04 <ttx> #help Cinder reviewers wanted
21:39:10 <ttx> Questions on Cinder ?
21:39:34 <ttx> #topic Nova status
21:39:39 <ttx> vishy: hey
21:39:49 <ttx> #link https://launchpad.net/nova/+milestone/folsom-rc1
21:40:21 <ttx> vishy: ?
21:40:22 <vishy> hi
21:40:28 <ttx> Hi! Looking at standing exceptions:
21:40:35 <ttx> * https://blueprints.launchpad.net/nova/+spec/scheduler-resource-race
21:40:57 <ttx> vishy: Under review ? How close is it ?
21:41:03 <vishy> i think very
21:41:15 <ttx> cool.
21:41:19 <ttx> * https://blueprints.launchpad.net/nova/+spec/os-api-network-create
21:41:22 <ttx> what about this one ?
21:41:33 <vishy> actually the first is implemented
21:41:54 <vishy> the second we were giving a chance to the author to fix it, or else markmc will update it
21:42:03 <markmc> I sorted out the blocking API issues today
21:42:05 <ttx> vishy: ok will mark it done
21:42:10 <vishy> I think we will have him do it since the author is not doing much
21:42:10 <ttx> * https://blueprints.launchpad.net/nova/+spec/project-specific-flavors
21:42:26 <markmc> ttx, network-create isn't done yet
21:42:32 <ttx> markmc: right
21:42:32 <markmc> ttx, network-associate is
21:42:54 <vishy> k so it looks good
21:42:59 <ttx> markmc: I think vishy's point was that scheduler-resource-race was done... right ?
21:43:01 <vishy> just needs an approval it is good by me
21:43:05 <vishy> ttx: correct
21:43:09 <markmc> ah
21:43:20 <vishy> so the project-specific flavor just needs some reviews
21:43:23 <vishy> i think it is good
21:43:27 <ttx> vishy: ok, so everything should be in by mid-week, cool
21:43:47 <ttx> except the network-create stuff which shoiuld get done by the end of the week ?
21:44:04 <vishy> no i didn't realize it is done
21:44:05 <vishy> e
21:44:11 <vishy> everything should be in by thursday i think
21:44:11 <med_> ?
21:44:26 <ttx> OK. We also have late FFEs requested by mtaylor:
21:44:31 <ttx> #link http://lists.openstack.org/pipermail/openstack-dev/2012-August/000750.html
21:44:35 <vishy> so the remaining question is whether to let the entry point stuff in
21:44:37 <ttx> #link http://lists.openstack.org/pipermail/openstack-dev/2012-August/000751.html
21:44:49 <vishy> i like that it simplifies external drivers.
21:45:08 <ttx> vishy: I think it's relatively harmless
21:45:26 <vishy> if so it will probably make external drivers much happier
21:45:29 <mtaylor> it _should_ failover to current behavior in case someone is making use of the current import-basd behavior
21:45:31 <vishy> markmc: thoughts?
21:45:35 <ttx> vishy: it either loads or doesn't, so easy to see problems ?
21:45:48 <markmc> vishy, haven't look properly yet and don't really understand what it's all about
21:45:48 <mtaylor> it breaks the unittest suite REALLY quickly when it's broken :)
21:45:54 * markmc plans to look in the morning
21:46:08 <mtaylor> markmc: tl;dr - ability to use entry points to load virt and scheduler drivers
21:46:09 <ttx> vishy: maybe decide by next Nova's meeting ?
21:46:11 <vishy> markmc: it allows drivers to be loaded from entrypoints in addition to class names
21:46:32 <ttx> and in the mean time, keep it in review ?
21:46:41 <vishy> ttx: sounds good
21:46:47 <vishy> we will discuss it in the meeting
21:47:11 <markmc> if it's harmless, we can assume FFE probably?
21:47:19 <mtaylor> vishy: fwiw, I'm AFK starting tomorrow - but if something minor needs to get tweaked, I'm more than happy for someone to edit and re-push those
21:47:30 <ttx> #action nova-core and ttx to review FFE for entry point stuff by Thursday
21:47:52 <ttx> markmc: I have to have a deeper look, but on the tin it says it's harmless
21:48:31 <ttx> vishy: Switching to RC bugs now, you got 11 targeted
21:49:00 <ttx> But I think you can't really target until some serious triaging is done. A huge effort is needed in that area. We have 101 untriaged bugs
21:49:11 <ttx> I feel like we won't have a good RC list until we get those confirmed and prioritized.
21:49:19 <ttx> vishy: Do you have a plan to handle that ?
21:49:22 <vishy> ttx: yes, I've just been targetting the ones that i find myself
21:49:24 <markmc> wow, 101
21:49:42 <vishy> ttx: yeah it is hard to keep up but nova-core is focusing on bugs so i hope we can.
21:49:54 <ttx> it's a shitty job but needs to be done.. and the sooner the better
21:50:15 <ttx> I can help, within my limited abilities.
21:50:28 <markmc> I'm up for a bug triage day if we got a handful of nova-core folks together
21:50:51 <ttx> markmc: I'm in vacation next week, so can't really coordinate that
21:51:08 <ttx> but I can give you the keys to the party hall
21:51:29 <ttx> vishy: do you think a bugday would help ?
21:51:41 <ttx> or just asking everyone in nova-core to do 15 ?
21:52:34 <vishy> we need a bug 2 weeks
21:52:38 <vishy> every day should be a bug day
21:53:00 <ttx> vishy: yes at this point we ned to get the list back to 0.. then handle incoming reports
21:53:03 <ttx> nee*
21:53:05 <ttx> d
21:53:55 <ttx> vishy: so asking everyone to take at least 101/nova-core bugs ?
21:55:01 <ttx> running out of time
21:55:24 <ttx> #action vishy to find a way to get untriaged bugcount to 0
21:55:29 <ttx> Questions on Nova ?
21:55:31 <annegentle> o/
21:55:38 <ttx> annegentle: go ahead
21:55:41 <annegentle> It looks like https://blueprints.launchpad.net/nova/+spec/disable-server-extensions is marked as "Implemented" but I didn't see doc additions to document the changes, what's a good plan for that?
21:55:49 <annegentle> weird underlines, sorry
21:56:16 <annegentle> (asking vishy )
21:56:41 <ttx> looks like we lost him, we'll let him answer asynchronously
21:56:46 <ttx> #topic Horizon status
21:56:50 <ttx> gabrielhurley: hey
21:56:53 <gabrielhurley> ttx: hi
21:56:58 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-rc1
21:57:05 <ttx> No feature freeze exception, let's look at the RC bug list...
21:57:18 <ttx> gabrielhurley: only 8 open bugs on the RC bug list ?
21:57:26 <gabrielhurley> there's a recent request for an FFE for quantum public network support. I haven't seen code yet, so I'm holding off on seeing how invasive it is before deciding to ask for an FFE
21:57:42 <ttx> gabrielhurley: good to know, thanks
21:57:45 <gabrielhurley> and yeah, the bug list is accurate
21:57:55 <gabrielhurley> probably handle all of it this week
21:58:23 <ttx> gabrielhurley: fwiw given that horizon is at the downstream of everything else it's fair that you ask a bit late
21:58:28 <ttx> (foir FFE)
21:58:33 <gabrielhurley> heh. thanks.
21:58:48 <ttx> Did you go through the whole bug list to target blockers ?
21:58:56 <ttx> I see one critical bug not targeted yet: bug 967882
21:58:58 <uvirtbot> Launchpad bug 967882 in horizon "Volumes, volume snapshots, instance snaphots and keypairs all show cross-tenant info when logged in as admin" [Critical,Confirmed] https://launchpad.net/bugs/967882
21:59:15 <ttx> looks like it needs to be de-prioritized or RC1-targeted :)
21:59:30 <gabrielhurley> that one is a known issue in nova, though I hear they may have recently patched it
21:59:36 <gabrielhurley> it's not actually a horizon fix, just a reminder
21:59:51 <gabrielhurley> and yeah, I go through the whole backlog periodically
22:00:12 <ttx> hmm, any way we could not keep that bug open if it's just a reminder ?
22:00:19 <gabrielhurley> sure. I'll do something with it
22:00:25 <ttx> On the triaging side, you look on top of it...
22:00:31 <ttx> gabrielhurley: Anything else you wanted to mention ?
22:00:32 <gabrielhurley> yessir
22:00:41 <gabrielhurley> don't believe so. just test away!
22:00:43 <ttx> Questions for Horizon ?
22:01:01 <ttx> annegentle: looks like you'll have to ask vishy offline. Or at the Nova meeting Thursday
22:01:15 <ttx> #topic Other Team reports
22:01:19 <annegentle> shall I do a creiht sigh just for the effect?
22:01:27 <ttx> annegentle: that would do it
22:01:29 <ttx> Any other team lead with a status report ?
22:01:29 <annegentle> o/
22:01:31 * annegentle sighs
22:01:36 <annegentle> As you saw from my mailing list note, now's the time to kick docs up a notch.
22:01:43 <vishy> annegentle: it is going to be part of the api testing i'm putting together
22:01:47 <annegentle> We're going to be moving reviews through
22:01:57 <annegentle> I've got a new CLI guide in review at https://review.openstack.org/#/c/11744/
22:02:12 <annegentle> #help Please review new CLI guide at https://review.openstack.org/#/c/11744/
22:02:32 <annegentle> vishy: ok, I'll also log doc bugs such as "document os-multiple-create"
22:02:36 <markmc> ttx, just a note that openstack-common has branched for folsom
22:02:48 <markmc> ttx, projects should be syncing from stable/folsom until grizzly opens
22:02:59 <ttx> #info openstack-common has branched for folsom, projects should be syncing from stable/folsom until grizzly opens
22:03:21 <ttx> #topic Open discussion
22:03:25 <ttx> Anything else, anyone ?
22:04:01 * ttx moves the discussion about nova bug triaging to #openstack-dev
22:04:04 <ttx> #endmeeting