16:01:59 <odyssey4me> #startmeeting OpenStack-Ansible
16:01:59 <openstack> Meeting started Thu Mar 17 16:01:59 2016 UTC and is due to finish in 60 minutes.  The chair is odyssey4me. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:02 <openstack> The meeting name has been set to 'openstack_ansible'
16:02:06 <odyssey4me> #topic Roll-call and Agenda
16:02:09 <automagically> o/
16:02:21 <spotz> o/
16:02:24 <stevelle> o/
16:03:08 <jmccrory> o/
16:04:55 <palendae> o/
16:05:51 <odyssey4me> we have no action items from last week, so let's get to the agenda
16:05:59 <odyssey4me> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:06:17 <odyssey4me> #topic Newton Summit Planning
16:06:30 <odyssey4me> #link https://etherpad.openstack.org/p/openstack-ansible-newton-summit
16:06:49 <odyssey4me> #link https://etherpad.openstack.org/p/openstack-ansible-newton-roadmap-refresh
16:06:58 <odyssey4me> #link https://etherpad.openstack.org/p/openstack-ansible-newton-roadmap-brainstorm
16:07:27 <odyssey4me> in the last link I've added a bunch of thoughts around work item planning for Newton - I'd love to see everyone else add notes, questions, thoughts, etc
16:07:34 <automagically> Any response on the # of rooms we’ll have for sessions
16:08:00 <odyssey4me> automagically not yet, I'll ping the organisers and see if there's an update
16:08:09 <odyssey4me> #action odyssey4me to follow up on room allocations
16:08:35 <automagically> odyssey4me: Maybe mention dynamic inventory test coverage in the roadmap items
16:08:43 <jmccrory> odyssey4me an email on that came through yesterday
16:09:40 <jmccrory> automagically odyssey4me OpenStackAnsible: 1fb, 8wr, cm:half
16:10:01 <odyssey4me> jmccrory oh? where do you see that?
16:10:02 <automagically> translation please jmccrory
16:10:14 <odyssey4me> that sounds like we got what we asked for
16:10:30 <jmccrory> 1 fishbowl, 8 workrooms, and halfday at contributor's meetup
16:10:45 <odyssey4me> awesome, that's exactly what we asked for
16:10:52 <automagically> Ah, thx
16:11:17 <odyssey4me> automagically can you add that item to the brainstorm?
16:11:28 <odyssey4me> or are you referring to the roadmap-refresh?
16:11:47 <automagically> roadmap-refresh
16:11:54 <odyssey4me> ah ok - let me work that in
16:12:04 <automagically> We went from 0 test coverage, to a decent amount during this cycle
16:12:26 <automagically> Well, not 0, the AIO was obviously providing some coverage there
16:12:44 <odyssey4me> done - that's a very high level thing for the product WG and press coverage
16:16:23 <automagically> odyssey4me: I’m noticing no mention of multi-platform in the newton roadmap. Intentional?
16:16:46 <odyssey4me> ok, we have 15 proposed sessions for the summit - so we need to choose 8 which will become work sessions... the rest can be optionally taken on in the contributor day
16:16:49 <automagically> I’m ok with it, as my only needs at present at Ubuntu, and I’m glad to see the 16.04 work there
16:16:51 <spotz> automagically it's in the summit ether
16:17:06 <odyssey4me> can we finalise votes - or propose any consolidations / changes
16:17:16 <automagically> spotz: Thanks
16:17:38 <odyssey4me> automagically yeah, it seems to me that the lion's share of attention will be on Ubuntu 16.04 work and the multi-OS will simply be a side effect
16:17:42 <cloudnull> late but ohai
16:17:50 <automagically> agreed odyssey4me
16:18:22 <odyssey4me> I don't see it as a focal point until someone comes along to actually do the work, and so far we have no really consistent contributors showing interest
16:18:34 <odyssey4me> I think it'll become easier once we've done the 16.04 work though
16:19:22 <odyssey4me> So I propose that we take Multi-OS work off the table for work sessions and that we keep the Ubuntu 16.04 work session planned. Any objections?
16:19:42 <automagically> For workgroups, we’ve got 2 about gating. Any objections to combining those?
16:19:43 <spotz> Not from me if the one will most likely spawn the other
16:20:32 <odyssey4me> so the one session was to explain how gating works, and the other is a follow on to look at how we can do scenario gating
16:20:50 <odyssey4me> each session is 40 mins, and I think 40 mins is just enough time to cover the explanation
16:20:55 <automagically> Ah, okay
16:21:32 <automagically> Looks like we have about 9 highly voted topics
16:21:35 <automagically> for WG
16:22:29 <spotz> hehe
16:22:35 <automagically> Can we git lessons learned from Mitaka into the Work planning for Newton?
16:22:40 <automagically> fit not git
16:23:49 <odyssey4me> the housekeeping session?
16:23:59 <automagically> Yep
16:24:12 <spotz> I can see it fitting in either, maybe whichever goes first?
16:24:17 <odyssey4me> moved to the top - we must have it, and I recommend that we do that first
16:24:27 <automagically> +1, its definitely a must have
16:24:49 <odyssey4me> ubuntu 16.04 is heavily voted for - we do that in its own session
16:25:03 <odyssey4me> dynamic inventory is also heavily voted for
16:25:38 <odyssey4me> The CI windmill thing - we can shift to community day, I think?
16:25:51 <automagically> makes sense
16:26:22 <odyssey4me> it looks like the OVS work session will have to wait for then too?
16:26:51 <michaelgugino> hello
16:27:00 <odyssey4me> o/ michaelgugino
16:28:37 <odyssey4me> maybe role dep cleanup, tags cleanup and var cleanup can be a consolidated work session?
16:29:01 <automagically> +1 on a single cleanup session
16:29:13 <spotz> +1
16:29:15 <odyssey4me> automagically will you facilitate that?
16:29:20 <automagically> Sure
16:29:27 <spotz> leaving the doc cleanup seperate?
16:29:32 <odyssey4me> can you consolidate each topic into yours then?
16:29:38 <odyssey4me> yeah doc cleanup should be seperate
16:29:42 <automagically> Will do
16:29:48 <spotz> +1
16:29:59 <odyssey4me> ansible 2 must also be done
16:30:11 <spotz> and I don't see that one combining
16:32:43 <odyssey4me> ok, how should we use the fishbowl?
16:33:03 <odyssey4me> it'll be published on the schedule, and a large room - so we often get a lot of non-contributors coming
16:33:30 <spotz> odyseey4me what about a history, we're at and where we're going?
16:33:32 <odyssey4me> My initial thoughts was simply to do a Project Update - This is what we did in Mitaka and plan to do in Newton
16:33:37 <spotz> where we're at...
16:33:45 <odyssey4me> heh, spotz - exactly my thoughts
16:33:59 <odyssey4me> ery much a status update and a chance for interested parties to meet with us and chat
16:35:04 <spotz> also maybe end with how to contribute?
16:35:53 <automagically> Can anyone speak to how OSA compares to similar puppet efforts? I’d imagine many operators who are interested in automation may have already been down the puppet path
16:36:06 <automagically> I also expect deployers/operators to have questions about how OSA compares to Kolla
16:37:07 <odyssey4me> automagically I imagine that's of interest - but I'd rather not get into a position of competitve discussions. We're all working together to make the deployment of OpenStack simpler.
16:37:40 <spotz> Leave 5 minutes for Q&A at the end and be prepared for those type of questions
16:37:47 <automagically> Fair enough. I suppose it could be difficult to do an objective comparison
16:38:32 <spotz> Summit topic for a spain session! Have someone from each group:)
16:38:51 <stevelle> Pretty sure we did that in Tokyo, and I sat through it.
16:39:07 <stevelle> Wasn't intentional, though
16:39:20 <odyssey4me> spotz interestingly enough, we've seen others do it - often consulting groups doing presentations comparing approaches, etc
16:40:12 <odyssey4me> ok, if we had to vote for one work session to not happen this summit - which would it be?
16:40:47 <automagically> New services
16:40:48 <odyssey4me> that's not that it won't happen, but more along the lines of it happens another time - probably remotely
16:40:48 <hughsaunders> whichever one is scheduled latest in the day
16:40:59 <odyssey4me> hughsaunders is a helper :p
16:41:00 <automagically> Only because I think the other sessions will set expectations for new services
16:41:41 <automagically> Very closely to the intended outcome of the new services session proposed
16:42:00 <odyssey4me> yeah, let's move that to the contributors day
16:42:07 <odyssey4me> any objections to that?
16:42:09 <hughsaunders> maybe housekeeping - its quite general
16:42:29 <spotz> housekeeping I think is first hughsaunders
16:42:37 <odyssey4me> hughsaunders yeah, but we need to get the housekeeping session done right at the start
16:43:18 <odyssey4me> before we plan any work too heavily, I need some time with the team to discuss Mitaka and consider how we do Newton in a way that goes more smoothly
16:44:08 <stevelle> need to smooth the glidepath.  done.
16:45:06 <odyssey4me> based on the experience from the last summit, we get randoms popping in on the contributor day
16:45:24 <odyssey4me> so actually discussing stuff like new project integration and all that would be good
16:45:46 <odyssey4me> alright - we have 8 work sessions!
16:46:10 <odyssey4me> cool, we have 10 mins left to quickly discuss releases
16:46:14 <odyssey4me> happy to move on?
16:46:29 <automagically> +1 to moving on
16:46:42 <odyssey4me> #topic Release Planning and Decisions
16:47:01 <odyssey4me> Liberty 12.0.8 and Kilo 11.2.11 are due today
16:47:13 <odyssey4me> is anyone aware of any issue on those branches which should block the release?
16:47:37 <odyssey4me> I'm aware that there are some CVE's in the next SHA bump, so it is fairly crucial that we release now and move on.
16:48:23 <odyssey4me> alright, I'll release them
16:48:38 <odyssey4me> #action odyssey4me to release Liberty 12.0.8 and Kilo 11.2.11
16:48:54 <odyssey4me> how're we looking on the functional test front?
16:49:31 <odyssey4me> The OpenStack Projects have started releasing RC's, so we need to get going with updating SHA's in the roles and seeing whether they continue to work.
16:49:41 <odyssey4me> Then also looking for any deprecations.
16:50:05 <odyssey4me> When do we want to release? And what is our criteria for releasing Mitaka?
16:50:31 <automagically> Functional testing looks like its almost there. Still waiting for swift to get through reviews
16:51:11 <automagically> I believe neutron is still waiting for workflow
16:51:53 <odyssey4me> ok, I think we're in a reasonably good state to get on with bumping SHA's
16:52:05 <odyssey4me> Great work from jmccrory sorting out Keystone already! :)
16:52:40 <jmccrory_> think thatll need to be merged ahead of osa bumping shas
16:52:41 <stevelle> we have time for open discussion?
16:53:28 <odyssey4me> jmccrory yep
16:53:37 <odyssey4me> #topic Open Discussion
16:53:44 <admin0> regions regions :D
16:53:46 <admin0> \o/
16:54:14 <odyssey4me> admin0 we'll have to get to that after Mitaka's released - we need to focus on finalising
16:54:18 <admin0> ok
16:54:24 <odyssey4me> stevelle did you have something you wanted to raise?
16:54:41 <stevelle> I haven't had a lot of time to revise https://review.openstack.org/#/c/290834/
16:54:47 <stevelle> it's open for grabs
16:55:32 <automagically> Cool, I may have time for that stevelle
16:55:36 <stevelle> # link https://review.openstack.org/#/c/290834/
16:55:42 <stevelle> err no space, huh
16:55:51 <spotz> Hey if I put together some things to do in the Hill Country for the Women of OpenStack you guys interested in it too?
16:56:37 <automagically> surely spotz
16:56:41 <stevelle> +1
16:57:23 <odyssey4me> stevelle cloudnull commented on the discussion in https://review.openstack.org/290834
16:57:39 <odyssey4me> spotz that'd be pretty cool, thanks :)
16:58:02 <odyssey4me> I'll be getting to Austin on Sat and Leaving on Sat, so I may have a little time to look around.
16:58:27 <odyssey4me> ok, we're done for time - thanks all!
16:58:31 <odyssey4me> #endmeeting