16:03:41 <mhayden> #startmeeting OpenStack-Ansible
16:03:42 <openstack> Meeting started Thu Jun  9 16:03:41 2016 UTC and is due to finish in 60 minutes.  The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:46 <openstack> The meeting name has been set to 'openstack_ansible'
16:03:46 <mhayden> #topic Rollcall & agenda
16:03:53 <palendae> o/
16:03:56 * mhayden stumbles into the room
16:04:01 <eil397> o/
16:04:02 <thorst> o/
16:04:04 <andymccr> o/
16:04:12 <adreznec> o/
16:04:30 <d34dh0r53> o/
16:04:31 <ametts> o/
16:04:45 <d34dh0r53> in another meeting so lurking
16:05:00 <spotz> \o\
16:05:52 * mhayden gives it a minute or two more since i started late
16:06:00 <mrhillsman> o/
16:06:14 <mhayden> jmccrory: are you around?
16:06:15 <v1k0d3n> o/
16:07:35 <mhayden> okay, let's roll
16:07:39 <mhayden> #topic Review action items
16:07:56 <mhayden> #link Last week's meeting log -> http://eavesdrop.openstack.org/meetings/openstack_ansible/2016/openstack_ansible.2016-06-02-15.59.html
16:08:12 <mhayden> first two actions are about the mid-cycle -- we can get to those in a second
16:08:31 <mhayden> next was asettle and andymccr to send something to the ML about the testing repository
16:08:39 * mhayden remembers seeing that in his inbox
16:09:04 <mhayden> #link andymccr's repository -> https://github.com/andymcc/openstack-ansible-testing-core
16:09:11 <mhayden> asettle / andymccr: any updates there?
16:09:17 <andymccr> mhayden: mail was sent!
16:09:22 <asettle> woah don't look at me aye. I edited. It got sent. Ta daaaa
16:09:22 <asettle> :p
16:09:41 <mhayden> okay, so that one is still open -- has anyone had a chance to look over it yet?
16:09:44 <mhayden> it's still in my queue
16:10:31 <mhayden> #action Everyone review andymccr's email to see how we can help move that along
16:10:41 <andymccr> feel free to ping me if you have questions/feedback
16:10:56 <andymccr> im keen to gather, so far evrardjp has given some - which ive noted (in the email)
16:11:07 <mhayden> Next is reviewing phil_h's Astara etherpad
16:11:25 <mhayden> #link phil_h's Astara etherpad -> https://etherpad.openstack.org/p/astara-openstack-ansible
16:11:40 <mhayden> phil_h: looks like you got a good response in there!
16:11:46 <phil_h> I hope everyone has taken a look
16:11:56 <mhayden> speak now or forever hold your peace
16:12:02 <phil_h> We have tried to answer everyones questions
16:12:04 <mhayden> or at least hold your piece until the spec comes up
16:12:09 <phil_h> lol
16:12:10 <mhayden> *peace
16:12:12 <mhayden> :)
16:12:21 <mhayden> anything else you need from us, phil_h?
16:12:30 <phil_h> I don't think so
16:12:40 <mhayden> do you have enough to begin work on the spec?
16:12:44 <phil_h> I am looking at code and we will get a spec written
16:12:56 <mhayden> swee
16:12:58 <mhayden> t
16:13:03 <phil_h> spec is next
16:13:10 <mhayden> #action phil_h to start drafting the Astara spec soon
16:13:16 <mhayden> next action item is andymccr
16:13:18 <mhayden> errr
16:13:22 <phil_h> I will miss the next two meetings
16:13:29 <mhayden> next action item is antonym's Xen spec -- which actually merged today!
16:13:37 <mhayden> phil_h: we will miss you sir
16:13:45 <mhayden> antonym: nice going on the spec
16:14:02 <antonym> mhayden: thanks :)
16:14:12 <mhayden> anything you need from us on the rest, antonym?
16:14:33 <antonym> mainly just going to track how the multi os stuff is looking and try and replicate how that all looks for xen
16:14:47 <antonym> i think the nova stuff was still in flight
16:15:02 <mhayden> quite a few of us have hacked on the multi-os stuff, so we will be glad to help point you in the right direction for things
16:15:07 <antonym> just want to align it with how it looks for the other OS types
16:15:18 <antonym> cool, i'm sure i'll be bugging some of you all
16:15:34 <mhayden> sounds good
16:15:50 <mhayden> #action antonym to get started on adding Xen support using the multi-os framework
16:16:11 <mhayden> next up, odyssey4me was working on Newton-1 tags and next tags for Liberty/Mitaka
16:16:46 <mhayden> jenkins appears to be unhappy about some things in the newton-1 tag -> https://review.openstack.org/#/c/325252/
16:17:08 <mhayden> but the 12.0.14 and 13.1.2 releases did go out
16:17:21 <mhayden> odyssey4me: if you need a hand, let us know!
16:17:41 <mhayden> last item was evrardjp's review https://review.openstack.org/#/c/322249/
16:17:53 <mhayden> which merged
16:17:54 <mhayden> hooray!
16:17:58 <andymccr> woo!
16:18:05 <mhayden> man this agenda is easy
16:18:17 <andymccr> its a commentary on how skilled you are mhayden
16:18:17 <mhayden> #topic Topics for Discussion
16:18:29 <mhayden> first up, the mid-cycle!
16:18:32 <mhayden> cue the fanfare
16:18:51 <mhayden> so automagically had a date for hosting at comcast, but he's out of the office at that time :(
16:19:04 <mhayden> i was able to get three dates for hosting at Rackspace's HQ in San Antonio, TX
16:19:10 * mhayden digs in email
16:19:20 <asettle> Nice, nice
16:19:22 <mhayden> here are the options:
16:19:26 <mhayden> 1) Aug 10-12
16:19:32 <mhayden> 2) Aug 22-26
16:19:40 <mhayden> 3) Aug 29 - Sep 2
16:19:51 <mhayden> (apologies to the UK folks who are confused by this date format) :)
16:19:58 <spotz> mhayden: So we can have it in Philly but automagically wouldn't be there?:)
16:20:08 <mhayden> automagically said that Aug 29-Sep2 won't work for him
16:20:22 <mhayden> spotz: we could order some philly cheesesteak sandwiches to make it feel more like PA
16:20:44 <mhayden> does anyone have any strong feelings on these dates?
16:20:57 <mhayden> i'm good with #1 + #2, but #3 is not preferred
16:21:02 <asettle> Uhhhh no strong feelings?
16:21:04 <spotz> I'd say throw out #3
16:21:22 <mhayden> does anyone else wanna strike #3?
16:21:24 <spotz> And I guess comcast is out as an option too
16:21:42 <stevelle> +1, #3 is not great for me
16:21:52 <mhayden> okay, so we could probably toss #3
16:22:06 <mhayden> Aug 10-12 is Wed-Fri
16:22:07 <spotz> yeah if 2 cores can't make it it's no bueno
16:22:12 <mhayden> Aug 22-26 is Mon-Fri
16:22:36 <mhayden> Aug 22-26 conflicts with LinuxCon (Toronto)
16:22:47 <spotz> I might be out 8/12 but you don't need me there
16:23:51 <asettle> You don't need me either but I'll gate crash for fun
16:23:55 <mhayden> any opinions from the other core folks? d34dh0r53 jmccrory andymccr (forgetting a few here)
16:24:14 <spotz> cloudnull - but he's still on vaca
16:24:17 <mhayden> August in san antonio is a little toasty, so be prepared
16:24:28 <d34dh0r53> 1 or 2
16:24:36 <mhayden> we can take this to the ML to decide, but i need to get back with my room booking person fairly soon :)
16:25:10 <mhayden> #action mhayden to send an email to the ML about choosing between Aug 10-12 or something during Aug 22-26
16:25:24 * mhayden is still working on an executive sponsor on this end for budget (food and such)
16:25:48 <mhayden> and we need funds for d34dh0r53's security detail
16:25:50 <mhayden> :)
16:25:54 <mrhillsman> 8/23 and 8/24 openstack days east
16:26:03 <mhayden> ah, good catch mrhillsman
16:26:16 <spotz> So looks like option 1 by default?
16:26:19 <mhayden> so it sounds like Aug 10-12 may be the preferred date -- i'll get something out to the ML to verify
16:26:43 <mhayden> we can work on agendas and stuff soon, i'm sure, but i'll put that ball in odyssey4me's court ;)
16:26:50 <spotz> Party at mhayden's house!
16:26:51 <mhayden> are we good on mid-cycles for the moment?
16:26:57 <mhayden> spotz: that's possible
16:27:25 <mhayden> okay, next topics for discussion
16:27:38 <mhayden> we already got updates from andymccr, phil_h, and andymccr
16:27:56 <mhayden> we need an update on pip_lockdown from automagically, but he's not here
16:28:05 <mhayden> it looked to be moving well in reviews
16:28:25 <asettle> I can randomly talk about pips and lockdowns if that suits? :p
16:28:25 <mhayden> it looked like there were maybe 3-4 reviews left that jmccrory was cleaning up
16:28:35 <mhayden> i guess we can table that for now
16:28:44 <mhayden> oh silly me, i haven't been changing the topic
16:29:01 <mhayden> #topic ppc64le mirror issue for mariadb (thorst and adreznec)
16:29:08 <mhayden> thorst / adreznec: you have the mic! :)
16:29:40 <thorst> So we're testing out on ppc64le and the current repos point to x86
16:29:45 <adreznec> Yeah, so the issue here is that some of the package repos used don't support ppc64le for things like mariadb and percona
16:30:17 <mhayden> are we talking about the upstream mariadb/percona repos or something else?
16:30:23 <adreznec> Those packages do exist in the upstream repo for Xenial from Canonical/Ubuntu directly, but that's not where we're point today
16:30:35 <adreznec> Yeah, like https://mirror.rackspace.com/mariadb/repo/10.0/ubuntu/
16:30:46 <adreznec> Containers amd64/i386 only
16:30:49 <adreznec> *Contains
16:30:56 <mhayden> oh, i see what you're saying
16:31:03 <mhayden> so they're missing from the rackspace repository?
16:31:07 <mhayden> but they're in other repositories?
16:31:21 <adreznec> Yep basically
16:31:34 <mhayden> so it sounds like we need to chat with the rackspace mirror maintainers to get that added
16:31:37 <adreznec> So we either need to figure out how to build them there or be able to point elsewhere, I guess?
16:31:41 <mhayden> i imagine they filter it out to save bandwidth/disk space
16:31:59 <adreznec> Yeah I thought that might be the case
16:32:04 <mhayden> adreznec: i'd imagine we can temporarily check for ppc and use a different mirror (short term)
16:32:06 <stevelle> the point elsewhere should be possible today
16:32:08 <mhayden> and get the rackspace mirrors fixed
16:32:28 <mhayden> can i get a racker to volunteer to reach out to the mirror team? :)
16:32:49 <thorst> mhayden: Yeah, that's what we're doing for now in our tests.  I know wangqwu is pointing to another mirror
16:33:02 <adreznec> Yeah that seems like a reasonable approach. No idea what the turnaround is on that from the repo update side
16:33:20 <mhayden> the turnaround on the rackspace side shouldn't be big, unless we're short on disk space
16:34:06 <adreznec> So for things that are pulled from the rackspace repo that should be no problem then
16:34:16 <mhayden> antonym: would you be able to sync up with the mirror folks about ppc on mirror.rackspace.com?
16:34:21 <mhayden> i know you have some ppc work going as well ;)
16:35:02 <antonym> mhayden: yeah, we can ping them on that
16:35:07 <mhayden> antonym: thanks sir
16:35:10 <adreznec> There are some other things that are pulled from non-Rackspace repos like Percona that points to https://www.percona.com/downloads for the deb
16:35:29 <mhayden> #action antonym to talk to rackspace's mirror team about getting PPC packages added
16:35:43 <mhayden> okay, was there anything else on that topic, adreznec / thorst?
16:35:44 <adreznec> We'll have to work through those and point at alternate repos where needed
16:36:12 <adreznec> Nope, I think that's it
16:36:29 <thorst> adreznec: lets sync with kylek3h on the Percona one
16:36:31 <mhayden> awesome -- thanks for your work on ppc support in OSA! :)
16:36:42 <kylek3h> adreznec: ok
16:36:44 <mhayden> #topic Release planning and decisions
16:36:49 <adreznec> thorst: Sounds good
16:36:54 <mhayden> so we talked about 13.1.2 and 12.0.14 going out already
16:37:04 <mhayden> the last kilo tag (11.2.17) is still in progress
16:37:12 <mhayden> does anyone have any input on that ag?
16:37:15 <mhayden> s/ag/tag/
16:37:50 <mhayden> i'm not sure if the appropriate kilo-eol tags have gone out on other projects
16:37:56 <mhayden> we'll leave that for odyssey4me
16:38:12 <mhayden> #topic Open discussion
16:38:21 <mhayden> asettle: anything on the docs side you want to update us on ?
16:38:30 <asettle> hello!
16:38:31 <mhayden> (and pardon me for ending with a preposition)
16:38:53 <asettle> Thanks to everyone contributing to the spec with their thoughts and comments - it has been merged
16:39:11 <asettle> As of today also, darrenc opened up a PR to begin work on the draft folder for the install guide
16:39:16 <asettle> Give me two seconds and I'll grab a link
16:39:20 <michaelgugino> I'm having some issues getting nova to pass tempest testing on 16.04.  It's complaining about a non existent AZ, but no AZ is specified when the tempest test calls the api
16:39:25 <asettle> This has also been merged
16:39:47 <michaelgugino> local tempest testing has shown I don't know how to run tempest testing locally, lol.
16:39:54 <asettle> https://review.openstack.org/#/c/327467/
16:39:55 <asettle> See here
16:40:07 <asettle> If you have any questions regarding this, please message myself or Darren
16:40:10 <michaelgugino> but, if anyone can look at the log output and see if there is anything jumping out at you, I'd appreciate it.
16:40:32 <asettle> This is visible for a build, but it is not currently available publicly. It is an exact reflect of the current install guide and will just be the platform for all incoming changes
16:40:58 <asettle> darrenc will be working on updating this folder to reflect the new ToC for the install guide
16:41:02 <asettle> Which is super exciting.
16:41:28 <asettle> I'll be away form the 13th to the 23rd. Once I return, Darren and I will begin working on some of the smaller intricacies along with mhayden and Travis
16:41:35 <asettle> Questions, concerns, comments?
16:41:37 <mhayden> woot
16:41:42 <asettle> :)
16:42:14 <asettle> Hopefully I will also be at the OSA midcycle meetup, so I'll be working on the docs there too!
16:42:20 <asettle> The deadline for this is Newton :)
16:43:04 <mhayden> michaelgugino: do you have a review up? and/or tempest output from jenkins?
16:43:11 <mhayden> asettle: thanks for leading the charge there
16:43:21 <asettle> mhayden: not a problem. Thanks for being a key reviewer!
16:43:31 <michaelgugino> https://review.openstack.org/#/c/324045/
16:43:33 * mhayden woots
16:43:34 <asettle> And thanks to everyone that took the time to review and keep up to date with our changes
16:44:49 <mhayden> michaelgugino: looking now -- we can take this over to #openstack-ansible
16:44:52 <mhayden> anything else?
16:45:00 * mhayden starts the timer...
16:45:05 <adreznec> Just wanted to drop out here that a thorst, ashana, and I have started picking through the issues with multi-architecture/multi-repo
16:45:09 <asettle> mhayden: nothing from me, thanks guys
16:45:20 <adreznec> I've started documenting the work items/issues out at https://etherpad.openstack.org/p/osa-multi-arch-repo
16:45:28 <michaelgugino> we need to work out the lxc container create process a little more on xenial
16:45:46 <michaelgugino> lxcbr0 is not coming up after reboot due to conflicts with lxc-net service
16:45:47 <asettle> adreznec: if you want any help with documentation, feel free to ping me :)
16:46:01 <adreznec> asettle: Thanks, will do!
16:47:07 <mhayden> #link adreznec put together an etherpad for multiple cpu architectures in OSA -> https://etherpad.openstack.org/p/osa-multi-arch-repo
16:47:11 <mhayden> anything else?
16:47:27 <michaelgugino> yes
16:47:44 <mhayden> adreznec: can you propose this spec in gerrit so we can iterate on it?
16:47:52 <michaelgugino> I was thinking we should but a role requirements file in each of the repos, because the meta lists dependencies
16:48:03 <adreznec> mhayden: Sure, I'll throw it up there for review
16:48:04 <michaelgugino> this would help people that want to use some of the plays outside of OSA
16:49:50 <mhayden> michaelgugino: want to summarize the idea there and get it out to the mL ?
16:50:15 <michaelgugino> mailing list?
16:50:42 <mhayden> yeah
16:51:10 <michaelgugino> sure, I can do that
16:52:05 <mhayden> okay folks, i'll close it up
16:52:09 <mhayden> thanks for coming!
16:52:12 <mhayden> #endmeeting