16:00:01 <mhayden> #startmeeting OpenStack-Ansible
16:00:02 <openstack> Meeting started Thu Jun 23 16:00:01 2016 UTC and is due to finish in 60 minutes.  The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> The meeting name has been set to 'openstack_ansible'
16:00:12 <mhayden> #topic Roll call!
16:00:12 <evrardjp> nice multithreading skills mhayden
16:00:14 <inc0> o/
16:00:17 <d34dh0r53> o/
16:00:23 <mhayden> evrardjp: trying my best :)
16:00:27 <mrhillsman> o/
16:00:35 <adreznec> o/
16:00:51 <spotz> \o/
16:00:55 <automagically> o/
16:01:26 <evrardjp> o/
16:01:28 <raddaoui> o/
16:01:33 <prometheanfire> yo
16:01:39 <alextricity25> o/
16:01:43 <mhayden> 𝙒𝙊𝙊𝙏
16:02:17 <mhayden> looks like we have pretty good attendance today -- let's do the thing
16:02:24 <mhayden> #topic Review action items from last week
16:02:56 <mhayden> first one was midcycle related
16:03:05 <mhayden> but we will get to that in a minute in detail
16:03:25 <mhayden> next up was odyssey4me doing quite a few things around gating -- getting xenial/centos checks from non-voting to voting
16:03:31 <mhayden> and adding experimentals to openstack-ansible
16:03:43 <mhayden> i already saw some of this getting done
16:03:48 <cloudnull> o/
16:03:56 <jmccrory> o/
16:04:05 <mhayden> the security role has voting checks on trusty/xenial/centos, whee
16:04:27 <mhayden> okay, onto the other topics
16:04:34 <mhayden> #topic Newton Mid-cycle Meeting
16:04:43 <mhayden> #link https://etherpad.openstack.org/p/osa-midcycle-newton
16:04:47 <mhayden> the etherpad is coming along nicely
16:04:52 <mhayden> 19 attendees so far
16:05:04 <mhayden> looks like 7 needs hotels
16:05:31 <mhayden> i'll see if we can get a hotel deal set up at the Aloft for that, but it might not be enough people -- then again, the deal was $9 off per night :/
16:05:44 <mhayden> but they do offer a free shuttle to rackspace from what i understand
16:05:46 <automagically> That’s some deal!
16:05:52 <spotz> mhayden what about the regular Rackspace discount?
16:06:12 <mhayden> ah, do we have a discount code?  let's not share it here, but if we do, that could be nice
16:06:41 <spotz> mhayden: I know they booked me there for my interview so I'm sure they have something with them
16:06:59 <mhayden> the room is confirmed here at the Castle -- we should have large-screen TV hookups + audio
16:07:12 <mhayden> it's *possible* the room has VC -- but i need to walk up there and check
16:07:31 <mhayden> and the dates are set as Aug 10-12
16:07:53 <mhayden> if you haven't added yourself to the etherpad, please do that soon
16:08:06 <mhayden> and it would be cool to plan some type of social outing one of the nights
16:08:14 <automagically> mhayden: Thx for all your footwork on getting this pulled together
16:08:17 <mhayden> so if anyone has excellent party planning skills, let me know
16:08:20 <automagically> +++++ on the social outing
16:08:22 <mhayden> automagically: no problemooooooo
16:08:32 <mhayden> it will be toasty, so we could do something indoors
16:08:33 <spotz> mhayden: I'll help with that
16:08:46 <evrardjp> mhayden: 10 need hotels
16:08:56 <mhayden> #info Anyone interested in the social event at the mid-cycle -- please speak to spotz
16:08:58 <mhayden> thanks spotz
16:08:59 <evrardjp> don't know if that changes something
16:09:28 <evrardjp> thanks spotz, I'll be happy to attend
16:09:32 <mhayden> three of those are tentative
16:09:35 <mrhillsman> not sure i will attend social, but you can almost guarantee outside is going to be unpleasantly hot
16:09:46 <mhayden> i'll ask -- if we come up short on what we book at the hotel, rackspace has to foot the bill
16:09:54 <mhayden> :|
16:09:58 <mrhillsman> lol
16:10:11 <mhayden> #action mhayden to check on how many rooms would be in the minimum block
16:10:28 <mhayden> anything else to talk about on the mid-cycle?
16:10:35 <mhayden> i'm sure we will assemble the agenda a little later
16:10:44 <automagically> FWIW, due to my corp travel policies I _may_ not be able to stay at the aloft anyway. I’ll let you know mhayden later today
16:10:49 <mhayden> i'll inquire about getting building tools for the folks flying in
16:10:55 <mhayden> automagically: oh okay
16:11:03 <mhayden> thanks
16:11:08 <mhayden> anything else on the midcycle?
16:11:16 <mrhillsman> so pushy
16:11:31 <evrardjp> nothing, except do we have the priorities agenda yet?
16:11:47 <mhayden> evrardjp: not that i know of. that could be a good question for _ody
16:11:49 <evrardjp> or we'll figure that out later?
16:11:50 <evrardjp> ok
16:11:55 <mhayden> errr odyssey4me
16:12:01 <evrardjp> Will wait next week for that
16:12:06 <mhayden> sounds good
16:12:07 <evrardjp> fine
16:12:16 <mhayden> #topic Release Planning & Decisions
16:12:33 <mhayden> so 13.1.3, 12.0.15 and newton milestone 1 are out
16:12:39 <mhayden> that kilo one is still dangling
16:12:59 <evrardjp> was it due to swift?
16:13:16 <mhayden> i'm not sure what's hanging that one up -- i assume someone hasn't done kilo-eol tags yet
16:13:20 <evrardjp> I don't remember who hasn't given feedback yet
16:13:35 <evrardjp> mhayden: yes, that's what I think too
16:13:45 <evrardjp> I don't recall which one, and I didn't follow that
16:13:50 <mhayden> FWIW, i am still hacking on a script to help with better diffs on those releases -> https://review.openstack.org/#/c/332858/
16:14:16 <mhayden> that won't work terribly well on newton yet since our role requirements are still set to 'master'
16:14:54 <mhayden> we can sync up with odyssey4me on that kilo release when he's back from holiday
16:15:08 <mhayden> so that was the end of the agenda for today...
16:15:09 <evrardjp> master is still WIP, so I think it shouldn't be a worrying target
16:15:12 <mhayden> #topic Open floor
16:15:37 <mhayden> anyone need help or want to share something?
16:16:05 <adreznec> Hey, wanted to ask this here so in front of the larger group. Is there a reason why OSA is using MariaDB 10.0 instead of 10.1?
16:16:50 <adreznec> I ask because currently 10.0 isn't available for ppc64el Xenial, only 10.1 is.
16:17:03 <evrardjp> not that I am aware of, we did a bump a while back from another thing
16:17:11 <evrardjp> maybe 10.1 is possible
16:17:14 <adreznec> At least in the official mirrors (including the RAX one)
16:17:21 <automagically> For those of you using OVS or have used OVS or want to use OVS with OSA, I’d appreciate you keeping an eye out on https://review.openstack.org/#/q/topic:bp/support-openvswitch+status:open
16:17:26 <automagically> I’d love help and love reviews
16:17:32 <mhayden> that is a good question -- maybe cloudnull would have some input on the mariadb version?
16:17:36 <evrardjp> adreznec: do you think it will be a big work?
16:17:52 <mhayden> automagically: sounds good
16:17:59 <evrardjp> automagically: starred, will do whenever possible
16:18:02 <cloudnull> adreznec: no reason in particular that I'm aware of
16:18:07 <adreznec> evrardjp: which way? To get 10.0 working on ppc64el Xenial, or to move forward to 10.1?
16:18:15 <cloudnull> I think there were forks that played with 10.1 a while back
16:18:16 <evrardjp> to move forward
16:18:24 <cloudnull> but I've not seen any movement on that in a bit
16:18:43 <cloudnull> I know that the galera bits are included with 10.1 so it may be a good time to change
16:18:48 <adreznec> That's not 100% clear to me. Both are stable, but I'm not sure what the forward movement/upgrade impact would be
16:18:50 <evrardjp> cloudnull: was there a reason to not merge at that time?
16:18:55 <cloudnull> however IDK what the state is at this time /
16:19:00 <cloudnull> evrardjp: no.
16:19:20 <cloudnull> I dont remember ever seeing a PR
16:19:20 <evrardjp> ok
16:19:20 <cloudnull> I think it was only discussed
16:19:44 <cloudnull> adreznec: I've not given it a go myself, so IDK what the upgrade impact would be at this time.
16:20:02 <evrardjp> adreznec: do you think it would be possible for you to try it and give us feedback?
16:20:04 <cloudnull> if you have some cycles to give it a try in a lab it'd be appreciated for sure.
16:20:19 <adreznec> Ok. Not sure if anyone else has more experience there, but I could throw together a test environment quick on the side running 10.1 to see what the impact is
16:20:28 <cloudnull> ++
16:20:32 <mhayden> https://mariadb.com/kb/en/mariadb/upgrading-from-mariadb-100-to-101/
16:20:36 <evrardjp> cool
16:20:48 <adreznec> Thanks mhayden
16:20:50 <cloudnull> #link https://mariadb.com/kb/en/mariadb/upgrading-from-mariadb-100-to-101/
16:20:53 <mhayden> it looks like some options changed defaults, but nothing too nuts
16:21:04 <cloudnull> ^ just adding so it'd be in the logs
16:21:11 <mhayden> the upgrade process looks standard, too -- upgrade and run mysql_upgrade
16:21:18 <mhayden> thanks, cloudnull :)
16:21:19 <adreznec> Yeah, looks pretty straightforward
16:21:31 <cloudnull> our current role should support the upgrade process
16:22:24 <adreznec> Sounds good, I'll take an initial stab at running with 10.1 here and see how things go then
16:22:47 <mhayden> #action adreznec to look at upgrading to MariaDB 10.1 and report back
16:22:52 <mhayden> thank you, adreznec
16:23:45 <mhayden> also, i'll try to assemble that big WHOA report monthly for OSA, so if you know something that should go in the report, please don't hesitate to send me something
16:23:49 <evrardjp> thank you indeed
16:24:01 <mhayden> it's hard to keep up with all of these moving pieces :)
16:24:34 <evrardjp> indeed that's a whoale lot of changes in a month
16:24:49 <palendae> mhayden, https://review.openstack.org/#/c/332595/8 will be important
16:25:13 <mhayden> the june report is here -> https://major.io/2016/06/15/whats-happening-openstack-ansible-whoa-june-2016/
16:25:14 <evrardjp> I agree with palendae it's kind of a big deal IMO
16:25:30 <mhayden> palendae: interesting
16:25:35 <palendae> Still needs docs work before final submittal
16:26:10 * mhayden starred it
16:26:49 <mhayden> also, if darrenc was awake now, he'd probably ask for a hand on reviewing his doc patches
16:26:58 <mhayden> he's got some good stuff going for the install guide
16:27:59 <mhayden> okay, anything else to talk about?
16:28:30 <evrardjp> that was the fastest community meeting ever?
16:28:38 <mhayden> our agenda was a little light
16:28:43 <mhayden> :)
16:28:44 <eil397> : - )
16:28:46 <palendae> I need to get a blueprint in for a reworked inventory system
16:28:47 <jmccrory> https://review.openstack.org/#/c/331786/ thinking of handling conversion of tables in neutron, aodh, horizon databases in upgrade playbook
16:28:54 <automagically> I’ve been reviewing Darren’s doc patches. Definitely need more eyes there
16:29:08 <jmccrory> it looks like the others are all done within project db migration scripts
16:29:08 <palendae> I think I'm mostly done with the current stuff, and I want thoughts on my thoughts before I proceed
16:30:12 <evrardjp> palendae: that's a good idea, I'd be happy to give my opinion on this :p
16:30:23 <evrardjp> jmccrory: good job for the investigation
16:30:39 <mhayden> jmccrory: i like the idea of consistency -- do we have a plan to convert existing tables over to the right collation?
16:30:44 <palendae> evrardjp, Yeah, I saw your mailing list thread. I want to consolidate my thoughts and note where I think there's going to be some issues
16:31:11 <jmccrory> mhayden: that's what i was hoping to clear up. i was thinking maybe a playbook upgrade for newton
16:31:28 <jmccrory> upgrade playbook*
16:32:03 <evrardjp> palendae: when this mail was written, ara didn't even exist, so there are maybe experiences to share/take/give to build a larger community too
16:32:08 <mhayden> jmccrory: alrighty
16:32:15 <palendae> evrardjp, Yeah
16:32:29 <palendae> I know OSCI is working on Craton, which may feed in too
16:32:32 <palendae> OSIC*
16:32:50 <palendae> I big thing I wanted to do was lay out what the current inventory does and why, then address the problems with it
16:32:56 <evrardjp> jmccrory: the upgrade playbook seems the most readable approach, we just need to make sure everything is idempotent if possible
16:33:05 <palendae> ^ yes
16:33:19 <palendae> I'm a big supporter of upgrade playbooks and them being idempotent
16:33:38 <jmccrory> evrardjp: yep, just worried about turning off foreign key constraint for that moment
16:33:55 <evrardjp> Oh yes... :/
16:34:01 <mhayden> jmccrory: so the issue is that some tables are *explicitly* created as latin1 by the projects for some reason?
16:35:17 <jmccrory> oh, the problem was we default to different collation than charset
16:35:55 <mhayden> jmccrory: i wonder if this would make a good ML discussion
16:36:23 <mhayden> i'm not sure if i totally understand the problem
16:36:36 <mhayden> it has been a while since i dealt with collation shenanigans
16:37:52 <jmccrory> so our my.cfg hardsets the default collation to utf8-unicode, but mariadb's default for utf8 charset is utf8-general
16:39:11 <mhayden> okay, i see
16:39:39 <mhayden> so your patch addresses 1) new deployments and 2) new tables added to existing deployments after the patch is applied
16:39:52 <mhayden> but the question is: what to do about those other collations that are hanging around?
16:39:57 <jmccrory> so it was breaking a few days ago after cinder changed their initial db migrate script and there were different collations between tables
16:40:16 <jmccrory> yep
16:41:05 <jmccrory> nothing's broken at this point, just a consistenty thing and avoid this issue in the future
16:41:25 <mhayden> jmccrory: i gave you a +2 -- this stops the bleeding and makes new deployments less broken :)
16:41:32 <mhayden> but we need to figure out the follow up for sure
16:41:59 <mhayden> but automagically still has the W-1 hammer on that one
16:43:27 <automagically> I can be reasoned with
16:43:27 <mhayden> okay, do we want to take this discussion to the main channel and close up the meeting?
16:43:29 <automagically> ++ mhayden
16:43:45 <mhayden> alrighty, well thanks everyone! :)
16:43:48 <mhayden> #endmeeting