16:00:41 <mhayden> #startmeeting OpenStack-Ansible
16:00:42 <openstack> Meeting started Thu Aug 18 16:00:41 2016 UTC and is due to finish in 60 minutes.  The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:45 <mhayden> #topic Roll Call
16:00:46 <openstack> The meeting name has been set to 'openstack_ansible'
16:00:48 * mhayden o/
16:00:59 <asettle> o/
16:01:07 <adreznec> o/
16:01:13 <automagically> o/
16:01:25 <stevelle> o/
16:01:29 <nishpatwa> O/
16:01:34 <rromans> \o
16:01:34 <BjoernT> o/
16:01:36 <shasha_tavil> o/
16:01:37 <spotz> \o/
16:01:45 <evrardjp> o/
16:01:50 <cjloader> o/
16:01:54 <logan-> o/
16:02:05 <qwang> o/
16:02:07 * mhayden /o/ \o\ /o/ \o/
16:02:47 <andymccr> o/
16:03:02 <evrardjp> mhayden: fusion?
16:03:15 <mhayden> (╯°□°)╯︵ ┻━┻
16:03:24 <mhayden> i guess we've got enough folks here ;)
16:03:25 <evrardjp> riolympics?
16:03:37 <mhayden> #topic Docs call to action
16:03:40 * mhayden hands the mic to asettle
16:03:46 <asettle> Heyyyy!
16:04:00 <asettle> So, firstly, just want to thank everyone at the midcycle who lent a hand to the docs effort :)
16:04:07 <michaelgugino> hi
16:04:09 <asettle> It was awesome how much we managed to do, and it's really starting to shape up.
16:04:20 <cjloader> nice asettle!
16:04:24 <asettle> On that note however, Newton 3 is coming up, and subsequently the development freeze.
16:04:32 <asettle> In that time, I know you'll all be DESPERATE to help out again ;)
16:04:35 <nishpatwa> It was nice working with you asettle
16:04:40 <asettle> THanks everyone!
16:04:50 <asettle> We're looking for volunteers to help out with a full TECHNICAL review of the guide.
16:04:57 <asettle> I have that in caps, mostly because that's the emphasis we'll be looking at.
16:05:04 <nishpatwa> Yes sure we will help you
16:05:14 <asettle> I need people to RUN through the installation guide and help me find where the bugs are and nits etc at actually following the guide.
16:05:16 <asettle> Make sense?
16:05:20 <asettle> Thanks nishpatwa !
16:05:20 <mhayden> asettle: you requested that folks roll through a deploy using exactly what's in the docs -- right?
16:05:23 <evrardjp> it makes sense
16:05:29 <asettle> mhayden: thank you, exactly :)
16:05:40 <asettle> We need to ensure it's all up and ready to roll so we can present it at the summit with much hurrah
16:05:58 <shasha_tavil> Makes sense....will surely help.... :)
16:06:01 <cloudnull> o/
16:06:04 <asettle> I have an etherpad for names... one second
16:06:13 <nishpatwa> Install guide you mean by [draft] right ?
16:06:32 <asettle> Yes, sure do. It will be moved over to be the 'install' guide, shortly :) but I will post all details here: https://etherpad.openstack.org/p/install-guide-reviewteam
16:06:34 <mhayden> #action everyone to roll through the new Newton documentation for a technical review
16:06:41 <asettle> If you are interested in helping out - please put your names down here: https://etherpad.openstack.org/p/install-guide-reviewteam
16:06:48 <mhayden> #link https://etherpad.openstack.org/p/install-guide-reviewteam
16:06:48 <asettle> And I will be in contact with information on what to do, how to do, and where to do :)
16:07:19 <asettle> Thanks again everyone for your help at the midcycle! Was really impressed with everyone's efforts and seriously chuffed at how much help we received :)
16:07:20 <mhayden> woot
16:07:23 <nishpatwa> Sure
16:07:26 <asettle> Also thanks to the person who is actually typing in my currently blank etherpad ;)
16:07:30 <asettle> Hahaha
16:07:36 <mhayden> asettle: i am glad we could provide so much chuffing
16:07:47 <asettle> Such chuff
16:08:00 <mhayden> the role docs look quite nice
16:08:22 <cloudnull> +1
16:08:32 <mhayden> also, as odyssey4me mentioned at the mid-cycle, getting good comments into the defaults/main.yml in each role is really important now
16:08:43 <mhayden> since it's prominently displayed on the docs homepage for the role ;)
16:08:55 <asettle> *thumbs up* that too
16:09:02 <rromans> PROMINENTLY
16:09:05 <asettle> We will also be looking at volunteers to help with the role docs ;)
16:09:05 <asettle> BUT
16:09:12 <asettle> I'll call for htat on another week :P
16:09:17 <asettle> I won't stress you all out with too much volunteering
16:09:54 <odyssey4me> :)
16:09:57 <qwang> don't worry. we'd like to do it
16:10:14 <asettle> Thanks qwang :D loving the enthusiasm
16:10:18 <mhayden> okay, are we good on this topic, asettle ?
16:10:21 <asettle> Awesome, any questions - email me :)
16:10:22 <asettle> All good mhayden !
16:10:28 <mhayden> sweet, thanks for that
16:10:34 <nishpatwa> Sure asettle
16:10:37 <mhayden> #topic Applying for the stable:follows-policy governance tag
16:10:45 <mhayden> this one is still on the agenda but i'm not sure if we covered it last week
16:10:58 <automagically> We didn’t meet last week
16:11:09 <palendae> Sure we did :)
16:11:11 <automagically> We were too busy mid-cycling
16:11:14 <mhayden> well i mean at the mid-cycle :P
16:11:17 <mhayden> i don't remember hearing it come up, but i missed a lot of thurs
16:11:25 <palendae> I didn't hear it either
16:11:52 <odyssey4me> yeah, we kinda forgot about it
16:12:17 <odyssey4me> I think we can remove it from the agenda and revisit it another time.
16:12:24 <mhayden> got it, i'll remove it now
16:12:25 <odyssey4me> maybe the summit, maybe before
16:12:33 <mhayden> #topic Release Planning & Decisions
16:12:37 * mhayden hands the mic to odyssey4me
16:13:02 <odyssey4me> hmm, ok this is a week between releases
16:13:15 <odyssey4me> is there anything critical for the next tags that needs attention?
16:13:46 <cloudnull> not that im aware of
16:14:04 <palendae> There are a couple things that RPC would like to see get into the next Mitaka tag, but they seem to be progressing
16:14:17 <palendae> https://bugs.launchpad.net/openstack-ansible/+bug/1614211 and https://bugs.launchpad.net/openstack-ansible/+bug/1614213
16:14:17 <openstack> Launchpad bug 1614211 in openstack-ansible "Playbook Runs Fail in Multi-Domain Environments" [Undecided,New]
16:14:18 <openstack> Launchpad bug 1614213 in openstack-ansible "Add OPENSTACK_KEYSTONE_ADMIN_ROLES to horizon_local_settings.py.j2 Template" [Undecided,In progress] - Assigned to Nolan Brubaker (nolan-brubaker)
16:14:31 <odyssey4me> the N3 milestone is in two weeks... please try and get everything you want for Newton done before then: http://releases.openstack.org/newton/schedule.html
16:14:32 <palendae> I think one more patch is necessary to make the 1st one work
16:15:22 <odyssey4me> thanks palendae - we'll keep an eye on them, although there are enough reviewers in RPC who could do the same
16:15:30 <palendae> Yeah
16:16:03 <mhayden> #link http://releases.openstack.org/newton/schedule.html
16:16:16 <mhayden> Aug 29 is the newton-3 milestone and freeze
16:16:36 <andymccr> If people have a chance to review: https://review.openstack.org/#/c/351227/ I'd like to be changing the default swift ports to match the upstream change, and I don't want to do it before that patch merges.
16:16:43 <mhayden> Release is Oct 3! :) coming up soon
16:17:29 <mhayden> andymccr: slapped a star on it
16:17:31 <automagically> Dayyummm - we better get moving
16:17:54 <mhayden> anything else on releases for now?
16:18:01 <odyssey4me> nope, that's it for now - thanks
16:18:08 <logan-> the only big thing I have before the feature freeze is https://review.openstack.org/#/c/340175/ and https://review.openstack.org/#/c/340174/ .. those are ready for reviews
16:18:31 <evrardjp> starring everything - I hope I'll have time to check at those stars!
16:18:39 <mhayden> same here
16:18:41 <mhayden> thanks logan-
16:18:52 <logan-> thanks!
16:19:02 <mhayden> #topic Blueprint work
16:19:04 <mhayden> so there are a bunch of BP's on the meeting agenda -- can we roll through them really quick and clean them up if needed?
16:19:20 <mhayden> first up -- Ubuntu 16.04 support... obviously this one is ongoing for the next little while
16:19:22 <automagically> mhayden: ++
16:19:24 <michaelgugino> I'm going to try to get the watcher role done before the freeze
16:19:28 <odyssey4me> yeah, they're there to keep track of them and for optional discussion
16:19:33 <automagically> michaelgugino: ++
16:19:44 <mhayden> we already covered asettle and the Docs overhaul, so that should stay
16:19:49 <mhayden> how about "Ansible 2.1 support"?
16:19:59 <mhayden> didn't we get those 2.1 patches in for roles last week?
16:20:02 <asettle> mhayden: thanks :)
16:20:08 <evrardjp> mhayden: just started
16:20:10 <automagically> yeap, but gating issues
16:20:15 <evrardjp> I have an etherpad for that
16:20:21 <cjloader> why not make it use any version mhayden?
16:20:25 <evrardjp> I should point that out because it wasn't updated
16:20:30 <odyssey4me> yeah, regarding the xenial support, the project-config patch is in to switch every role except zaqar to voting... and to switch the integrated repo to non-voting
16:20:40 <mhayden> yeah, i'm wrestling with security role shenanigans :)
16:20:40 <mhayden> evrardjp: have a link for the pad?
16:20:42 <evrardjp> https://etherpad.openstack.org/p/ansible-2.1-gate-fixing
16:20:44 <evrardjp> just found it
16:20:46 <odyssey4me> it passed for the first time earlier, so I think we're good to go and ready for more battle testing
16:21:08 <evrardjp> that's just for 2.1 gate work -- we'll probably have to dig deeper for full 2.1 work
16:21:08 <automagically> #link https://etherpad.openstack.org/p/ansible-2.1-gate-fixing
16:21:15 <evrardjp> thanks automagically
16:21:16 <evrardjp> :D
16:21:22 <mhayden> okay, updated the agenda with the pad link
16:21:24 <michaelgugino> the nova tempest testing should be fixed upstream in nova, so hopefully less rechecks on roles that depend on tempest test server basic ops tests.
16:21:28 <mhayden> next is "Liberty to Mitaka upgrades"
16:21:38 <mhayden> are we still in active dev there?
16:21:48 <odyssey4me> mhayden yep, that's outstanding :/
16:21:58 <mhayden> okay got it
16:22:06 <mhayden> Mitaka to Newton upgrades? that one is in dev as well
16:22:10 <odyssey4me> and by that I don't mean that it's great
16:22:15 <mhayden> any etherpads or topics for that one that i can add?
16:22:22 <odyssey4me> yeah M->N needs to start after N3
16:23:20 <mhayden> okay, marked that one
16:23:29 <mhayden> next is the Xen virt driver -- antonym ?
16:23:53 <mhayden> last i saw it was still underway, but i didn't know if antonym needs help with dev/testing
16:24:23 <mhayden> i'll mark that one as stalled pending antonym's feedback
16:24:31 <odyssey4me> michaelgugino have you run any os_nova tests for lxc since it was marked experimental?
16:24:51 <odyssey4me> I'd like to progress that test, but need feedback about whether it's working
16:25:01 <odyssey4me> ie I'd like to move it to non-voting asap
16:25:06 <mhayden> next is the PowerVM Virt Driver
16:25:13 <mhayden> adreznec / thorst_: how are we on this one?
16:25:17 <michaelgugino> no, I haven't.  I just issued a check experimental on someone's patch
16:25:38 <adreznec> mhayden: Things are progressing smoothly for PowerVM as a compute node
16:25:49 <adreznec> I have it running in the lab today, though https://review.openstack.org/#/c/346863/ needs to merge before it will work upstream
16:26:02 <mhayden> awesome -- i'll keep it on the list as-is
16:26:10 <adreznec> Were starting to look at Power support for testing now
16:26:13 <mhayden> automagically / michaelgugino: OVS/DVR support BP ?
16:26:27 <mhayden> it has "active development" listed
16:26:27 <automagically> mhayden: Believe we can consider that DONE
16:26:30 <mhayden> but it seems like y'all are g2g
16:26:52 <automagically> Well, to be fair, we need docs in os_neutron around how to configure it
16:26:59 <automagically> I’ll get on that
16:27:12 <mhayden> good stuff
16:27:26 <mhayden> next is "Neutron Midonet Support"
16:27:31 <mhayden> but vdo isn't here
16:27:41 <mhayden> anyone have insight on that one?
16:28:02 <michaelgugino> haven't seen or heard anything on that one since the start of the cycle
16:28:05 <mhayden> got it
16:28:12 <mhayden> last one is Proj Calico support
16:28:18 <mhayden> logan-: any input there? shows as dormant for now
16:28:29 <evrardjp> there are patches that logan- just asked here above
16:28:29 <evrardjp> :p
16:28:30 <logan-> reviews are up and its passing tempest for me locally
16:29:29 <logan-> i believe most if not all of the prereq patches have merged so thanks for the reviews on those everyone
16:29:41 <mhayden> perfect
16:29:52 <mhayden> thanks for helping me work through that list everyone!
16:29:55 <mhayden> #topic Open floor
16:30:32 <odyssey4me> I think we can ditch Midonet off the agenda
16:30:35 <automagically> As of https://review.openstack.org/#/c/357294/ the os_rally role has functional testing in its gate
16:30:48 <mhayden> if anyone has a spare moment, i could use a hand on https://review.openstack.org/354768 (just needs +2+W)
16:31:01 <odyssey4me> automagically w00t - just in time for xenial to go voting, eh :)
16:31:10 <mhayden> odyssey4me: i'll remove midonet for now
16:31:16 <automagically> In investigating functional gating of os_ceilometer using Tempest, I found that Rally has far better testing support. Thoughts/opinions on doing os_ceilometer gating with Rally?
16:31:19 <logan-> oh one note, this would be helpful to have in the next mitaka tag: https://review.openstack.org/#/c/355154/
16:31:24 <cloudnull> also https://review.openstack.org/#/c/356864/ could use a review
16:31:33 <cloudnull> ^ needs to likely be backported to mitaka
16:31:42 * mhayden hugs andymccr
16:32:35 <stevelle> cloudnull: I haven't looked at the rally coverage for ceilo
16:32:41 <stevelle> err sorry automagically^
16:32:45 <asettle> mhayden: que?
16:32:46 <asettle> Hahhaha
16:33:05 <logan-> hope everyone had a good midcycle. I couldn't make it because we did L->M on the prod cloud last week. I'm happy to say it went fairly smoothly so thanks to everyone who has worked on the upgrade plays and docs.
16:33:21 <adreznec> So while work on PowerVM is progressing as a compute node, we've hit a bit of a snag with Power AIO. There's a galera change that's missing from the version with mariadb 10.0 related to page sizes that's preventing the version bundled with 10.0 from working on Power today
16:33:29 <automagically> stevelle https://github.com/openstack/rally/tree/master/rally/plugins/openstack/scenarios/ceilometer
16:33:38 <evrardjp> cloudnull: not a direct backport then -- we don't have the multi os stuff in mitaka, except for a few roles where that slept in
16:33:47 <adreznec> We thought this would be resolved with the release of 10.0 support for ppc64el Xenial in the mariadb mirrors, but it's still broken there
16:34:10 <cloudnull> evrardjp:  no it'll be hand backport
16:34:12 <evrardjp> adreznec: that's bad news
16:34:21 <adreznec> We're pushing a bug forward to get this fixed in the package, but we're not sure how long it will take to get resolved
16:34:46 <adreznec> We've build a version of the package with the fix in the lab that works, but we're looking for guidance on how to proceed
16:35:05 <michaelgugino> I wanted to move forward with mariadb 10.1 support, but xtradb is the hangup, I believe
16:35:11 <prometheanfire> not sure if any of this stuff would help, but it's out there http://ftp.osuosl.org/pub/osl/repos/yum/openpower/centos-7/ppc64le/openstack-mitaka/
16:35:13 <adreznec> We could either try and move to 10.1 (late in the cycle) or find a way to publish a "fixed" galera package for 10.0 ppc64el
16:35:23 <adreznec> and point to that for the interim
16:35:25 <prometheanfire> doesn't have maria/xtradb
16:35:32 <odyssey4me> adreznec :(
16:35:32 <stevelle> automagically: I'm not so happy with those ceilo scenarios either because they appear to be api only. am I missing something?
16:35:34 <michaelgugino> I think it will be worth looking at that next cycle, since support for trusty is being dropped by most projects for Ocata
16:36:02 <evrardjp> adreznec: you're thinking of building a ppa ad-interim?
16:36:07 <adreznec> odyssey4me: Yeah, this particularly impacts us for CI, since we'll be using AIO there
16:36:11 <thorst_> so the other thing the power AIO / mariadb 10.0 thing hits is our CI, but I think our plan is to just use that internal build for the time being.
16:36:13 <adreznec> evrardjp: That's one option
16:36:17 <automagically> stevelle: Fair enough. I’ll catch up with post-meeting to chat about it further
16:36:26 <adreznec> Kind of looking for feedback on that end
16:36:42 <odyssey4me> michaelgugino support for trusty is being dropped by all projects for newton
16:36:53 <michaelgugino> what?
16:36:59 <odyssey4me> there may be a few exceptions, but all gate jobs are now running xenial for master
16:37:06 <odyssey4me> there may be a few exceptions, but all gate jobs are now running xenial *only* for master
16:37:24 <odyssey4me> trusty is being used *only* for stable branches
16:37:56 <odyssey4me> so when newton releases, it'll only have been tested on xenial - and ubuntu is only doing newton on xenial
16:38:16 <michaelgugino> that puts us in a peculiar position
16:38:23 <stevelle> ^
16:38:31 <adreznec> Indeed...
16:38:33 <rromans> for varying definitions of peculiar
16:38:45 <michaelgugino> adreznec: AIO's don't use clustering for mariadb, so perhaps you can just install normal mariadb packages for that purpose on power
16:38:55 <odyssey4me> michaelgugino yes, that's why we discussed not going through to Ocata with trusty... our dependent packages won't be on trusty, so we'll be stuck
16:39:11 <odyssey4me> so we'll do trusty & xenial for newton, and drop trusty for ocata
16:39:41 <michaelgugino> right, Ocata on Xenial makes sense, newton is a little quick IMO.  I'm glad we'll have support for both.  Hopefully projects don't backport breaking changes of some sort.
16:39:48 <adreznec> michaelgugino: Yeah, though differing from upstream there definitely isn't ideal
16:39:48 <odyssey4me> adreznec thorst_ it would seem you have no choice for CI other than to use the custom packages until the bug is fixed upstream
16:40:14 <cloudnull> michaelgugino: i thnk we should be ok supporting both trusty and xenial for newton.
16:40:49 <cloudnull> even if a project backports a breaking system change we'll make it go. :)
16:41:03 <odyssey4me> michaelgugino the configurations at risk for newton on trusty for OSA will be those that use OVS because we'll be grabbing that from UCA... and UCA for trusty will not be updated with the same versions as the stuff for Newton
16:41:27 <thorst_> odyssey4me: One thing I think we need to do is clear up the wording in the nova docs around this...I can take that todo.  I *think* it says it supports an all in power...which I think I jumped too far ahead on last week
16:41:31 <adreznec> odyssey4me: If we build the package and create a PPA/repo for it, could we add an architecture-specific flag in the galera server role to use that package for ppc64el until we move to 10.1 next cycle?
16:41:31 <odyssey4me> yeah, so I don't think it's a *huge* risk... but it is a factor to bear in mind
16:41:32 <thorst_> so I'll correct that
16:42:01 <odyssey4me> adreznec thorst_ that's a good idea (both of them)
16:42:48 <odyssey4me> adreznec thorst_ are there *any* ppc64el mariadb repositories anywhere?
16:43:10 <adreznec> odyssey4me: The default repositories have ppc64el support in them
16:43:26 <adreznec> e.g. http://nyc2.mirrors.digitalocean.com/mariadb/repo/10.0/ubuntu/pool/main/m/mariadb-10.0/
16:43:27 <evrardjp> the important would be to add
16:43:56 <evrardjp> #TODO (adreznec): remove the ppa when <link> is fixed upstream
16:43:57 <evrardjp> :D
16:43:58 <adreznec> We've just hit that issue with one package from the mariadb mirrors
16:44:05 <odyssey4me> adreznec ok, why not just set the default for power to usousl (the primary source I think), then for your CI just mirror that?
16:46:01 <odyssey4me> adreznec yep, osuosl has them: http://ftp.osuosl.org/pub/mariadb/repo/10.0/ubuntu
16:46:14 <adreznec> Yeah, all the mirrors do
16:46:22 <odyssey4me> we can't use that mirror for CI because it has rate limiting
16:46:48 <adreznec> https://mirror.rackspace.com/mariadb/repo/10.0/ubuntu has them as well
16:46:53 <odyssey4me> but we could happily switch to using a decent mirror as the default that has everything you need
16:47:20 <adreznec> The issue is really that we need galera-3 25.3.16, and 10.0 is currently using 25.3.15
16:47:58 <odyssey4me> ah
16:47:59 <adreznec> Whereas 10.1 using 25.3.16
16:48:06 <automagically> mhayden: One for the next WHOA - https://medium.com/@michaelgugino/deploying-nova-lxd-hypervisors-with-openstack-ansible-39525157879d#.2db4rxhvj
16:48:11 <automagically> Nice work michaelgugino
16:48:13 <odyssey4me> ok, then it's a waiting game
16:48:14 <adreznec> Which contains https://github.com/MariaDB/galera/commit/0e815d9f12af74e3e94bcb39a913d26bdfd946b8
16:48:18 <adreznec> Yeah
16:48:47 <odyssey4me> so go for the ppa strategy for now - submit a known issue release note for it
16:48:53 <adreznec> Ok, will do
16:48:54 <evrardjp> I think we can temporarily accept a ppa
16:48:57 <mhayden> automagically: nice!
16:49:07 <evrardjp> odyssey4me: was faster
16:49:08 <mhayden> automagically: i'll prob get the next whoa out tomorrow
16:49:09 <odyssey4me> once the fix is released we can add tasks to remove the ppa and switch to the normal mirror
16:49:10 <adreznec> Should be for ppc64el only
16:49:12 <evrardjp> once again!
16:49:15 <adreznec> So that would reduce the scope of impact for now
16:49:17 <michaelgugino> thanks automagically.  We're supposed to be launching some kind of tech blog here at work, which that article may or may not eventually be included in.  But in the mean time, there's something on the web for those interested.
16:49:38 <cloudnull> michaelgugino automagically: nice!
16:50:00 <odyssey4me> awesome michaelgugino :)
16:50:30 <evrardjp> nice indeed
16:50:35 <cloudnull> its on twitter
16:50:36 <odyssey4me> adreznec of course with power support, I'm kinda itching to try out an ARM build and use them as computes for the LXD hypervisor :)
16:50:39 <evrardjp> a new bedtime reading
16:50:56 <prometheanfire> odyssey4me: I have access to arm64 servers :D
16:50:59 <adreznec> odyssey4me: All kinds of new opportunities :)
16:51:09 <prometheanfire> armv8
16:51:22 <palendae> RasPi3 computes ;)
16:51:24 <evrardjp> too bad there isn't small easy to afford power servers, right?
16:51:27 <prometheanfire> nah
16:51:42 <prometheanfire> evrardjp: I asked about that, 2.5k is entry
16:51:50 <adreznec> evrardjp: We're working on it... but not yet
16:51:54 <evrardjp> :D
16:52:00 <adreznec> Definitely a gap
16:52:15 <mhayden> on that note, if people have things that should go in the WHOA, feel free to send those my way
16:52:25 <odyssey4me> adreznec a few questions in https://review.openstack.org/346863 before I +2
16:52:27 <michaelgugino> what is the whoa?
16:52:29 <evrardjp> anyway it's cool to see all this love for nova
16:52:37 <palendae> michaelgugino, What's Happening in OpenStack-Ansible
16:52:38 <adreznec> odyssey4me: Thanks, I'll take a look
16:52:42 <odyssey4me> shut the front door... michaelgugino hasn't seen WHOA?
16:52:48 <prometheanfire> anyway, the odroid-c2 is good for testing armv8 on
16:52:51 <palendae> Little newsletter thingy mhayden does
16:53:00 <evrardjp> WHOA michaelgugino didn't read WHOA.
16:53:00 <odyssey4me> https://www.youtube.com/watch?v=PkFyGNjaQ8k
16:53:01 * michaelgugino doesn't faithfully read the mailing lists
16:53:19 <mhayden> michaelgugino: https://major.io/tag/whoa/
16:53:23 <palendae> Keanu Reeves is the WHOA mascot right?
16:53:46 <michaelgugino> sweet.
16:53:55 <mhayden> palendae: only on the internal reports :P
16:53:57 <asettle> Oh my word mhayden
16:54:11 <mhayden> michaelgugino: long story short, i generally do a weekly WHOA internal to the company, then a monthly one to the world
16:54:24 <automagically> The worldly WHOA
16:54:39 <michaelgugino> very cool.  I was thinking that would be a good type of publication, and you're already doing it.
16:55:01 <odyssey4me> mhayden will take contributions - ping him any time you have something newsworthy
16:55:03 <andymccr> that mhayden, he's always one step ahead of the crowd
16:55:22 * odyssey4me sees mhayden starting a news agency
16:55:25 <automagically> mhayden: The WHOA needs moar GIFz
16:55:41 <odyssey4me> oh dear
16:55:56 <evrardjp> automagically: don't start him on that
16:56:12 <odyssey4me> actually, I haven't had a gif fix from mhayden all week
16:56:14 <cloudnull> automagically: +1 GIF for all the posts!
16:56:23 <evrardjp> we'll have loldogs and cheezeburgers everywhere
16:56:43 <mhayden> yes yes -- please send over anything noteworthy that the world should know about OSA
16:56:44 <evrardjp> sorry
16:56:46 <mhayden> i'll be sure to include it
16:56:52 <evrardjp> everyWHOAere
16:56:58 <mhayden> okay, down to 3 minutes left
16:56:58 <mhayden> ready to close this up?
16:57:04 <andymccr> seems so :P
16:57:04 <odyssey4me> oh dear, yes I think so
16:57:11 <asettle> God evrardjp
16:57:12 <odyssey4me> thanks mhayden
16:57:17 <mhayden> WHEEEEEEEEEEEEE
16:57:17 <andymccr> thanks all!
16:57:18 <asettle> Too much time here with us
16:57:18 <mhayden> thanks everyone
16:57:21 <mhayden> #endmeeting