16:01:24 <mhayden> #startmeeting OpenStack-Ansible
16:01:25 <openstack> Meeting started Thu Sep 29 16:01:24 2016 UTC and is due to finish in 60 minutes.  The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:26 <evrardjp> o/
16:01:28 <openstack> The meeting name has been set to 'openstack_ansible'
16:01:30 * mhayden had the window buried ;)
16:01:41 <mhayden> #topic Roll call
16:01:43 <andymccr> o/
16:01:45 <evrardjp> o?
16:02:04 <automagically> o/
16:02:05 <cloudnull> o/
16:02:08 <asettle> o/
16:02:13 <asettle> evrardjp: y u gotta be dat guy
16:02:15 <evrardjp> I'm super enthuisastic today!
16:02:24 <evrardjp> no I just type wrong
16:02:28 <mhayden> I'LL HAVE WHAT HE'S HAVING
16:02:30 <mhayden> :)
16:02:44 <evrardjp> :D
16:03:09 <michaelgugino> hi
16:03:39 <odyssey4me> o/
16:04:06 <jmccrory> o/
16:04:49 <qwang> o/
16:05:02 <mhayden> okay, let's put the lime in the coconut
16:05:14 <mhayden> #topic Action items from last week
16:05:40 <mhayden> looks like palendae's request for help on the inventory patches was fulfilled!
16:05:46 <mhayden> so i can't find any other action items
16:05:51 <palendae> \o/
16:06:04 <odyssey4me> I was supposed to do Liberty/Mitaka releases, and forgot :p
16:06:05 <mhayden> #topic OpenStack-Ansible Install Guide Testing (asettle)
16:06:13 * mhayden passes the mic to asettle
16:06:20 <palendae> I was going to add to the agenda some things to do for inventory in Ocata but forgot to update it
16:06:52 <mhayden> palendae: we can cover that when asettle is done if you want
16:07:15 <asettle> SORRY
16:07:15 <asettle> WHAT
16:07:16 <asettle> I WAS LIKE
16:07:18 <asettle> RUNNING AWAY
16:07:27 <asettle> mhayden: thanks
16:07:48 <asettle> At the moment install guide testing is still underway
16:07:56 <asettle> I have received only one bug, which indicates one of two thing
16:08:01 <asettle> A: Nobody is testing
16:08:03 <asettle> B: The guide is perfect
16:08:09 <asettle> I'm going with option B in my head.
16:08:18 <asettle> I will begin my own testing as of next week, I have been caught up with a few things.
16:08:23 <automagically> Option A more likely
16:08:27 <asettle> I'd be interested to hear from anyone who has been using the guide, or has tested teh guide
16:08:33 <automagically> Sadly I have not yet been able to contribute to the testing effort
16:08:35 <asettle> automagically: letting the team down. Never forget.
16:09:06 <evrardjp> I'm sorry I didn't read it carefully yet
16:09:13 <asettle> If anyone has the time to test the guide, please contact me.
16:09:25 <asettle> You will be requested to perform a full deploy using the Newton guide.
16:09:31 <asettle> And nobody speak to automagically
16:09:39 <automagically> ^ clearly
16:09:47 <asettle> :p
16:10:01 <mhayden> haha
16:10:13 <mhayden> asettle: all good on this topic?
16:10:16 <asettle> Anyway, that's my time done.
16:10:18 <asettle> Thanks mhayden :)
16:10:23 <mhayden> woot
16:10:45 <mhayden> #topic Ocata inventory to-do's (palendae)
16:10:49 * mhayden passes the mic to palendae
16:11:12 <palendae> I just made https://etherpad.openstack.org/p/osa-inventory-ocata with a short list of things
16:11:15 <odyssey4me> I see what you did there mhayden
16:11:42 <mhayden> odyssey4me: palendae asked so nicely, though
16:11:55 <palendae> sorry!
16:12:10 <palendae> I'm content to work from that etherpad, nothing urgent
16:13:46 <mhayden> palendae: anything else on that?
16:13:53 <palendae> Nope
16:13:59 <automagically> #link https://etherpad.openstack.org/p/osa-inventory-ocata
16:14:36 <mhayden> alrighty!
16:14:50 <mhayden> #topic Standardizing the openstack-ansible-tests repository (andymccr / odyssey4me)
16:15:08 * mhayden cuts the mic in half and gives pieces to andymccr and odyssey4me
16:15:25 <odyssey4me> is andymccr in the house?
16:15:27 <andymccr> so it was a really quick one, thoughts on the in role overrides
16:15:45 <andymccr> there are a few going about. which is tests/test-vars.yml, or tests/rolename-overrides.yml
16:16:03 <andymccr> i personally am in favour of rolename-overrides.yml so it doesnt overlap with the default test-vars in openstack-ansible-tests
16:16:14 <andymccr> but if nobody has any strong opinions we can just set a standard and move on
16:16:37 <michaelgugino> I think that's a fine format
16:16:41 <automagically> andymccr: Overlap how?
16:16:55 <andymccr> automagically: more just that the var name is the same
16:17:03 <automagically> diff paths tho
16:17:10 <andymccr> oh yeah i mean the functionality of it is fine
16:17:12 <automagically> common/test-vars.yml vs test-vars.yml
16:17:13 <andymccr> its more a cosmetic issue
16:17:18 <odyssey4me> for context, see https://github.com/openstack/openstack-ansible-os_keystone/blob/master/tox.ini#L156 versus https://github.com/openstack/openstack-ansible-os_designate/blob/master/tests/test-vars.yml versus https://github.com/openstack/openstack-ansible-os_designate/blob/master/tests/test-designate-functional.yml#L25-L27
16:17:19 <automagically> Eh, whatevs
16:17:28 <michaelgugino> it's clearer to users of the test what the intention of the file is.
16:17:48 <automagically> FWIW - with scenario testing and additional vars files, we’ll get some naming introduced as well
16:17:49 <odyssey4me> we have different ways of applying the extra vars in the repo which override the vars from the common repo... ideally we should standardise on one way
16:17:53 <automagically> But consistency is preferable
16:18:13 <automagically> odyssey4me: ++ -e @overrides should be the consistent pattern
16:18:31 <andymccr> oh yeah true
16:18:38 <odyssey4me> agreed on that front
16:18:42 <andymccr> ok cool
16:18:44 <andymccr> done
16:18:58 <automagically> You both plan to open bugs on those or should we just expect patches incoming soon
16:19:03 <odyssey4me> the file naming is cosmetic - happy for it to be based on the rolename instead of 'test-vars' to keep it from being ambiguous
16:19:09 <automagically> Or just bringing it up for discussion
16:19:11 <michaelgugino> ++ -e
16:19:14 <evrardjp> I don't care, it seems a not importnat decision, I'll trust the decision
16:19:36 <evrardjp> I mean not a damaging for the future
16:19:40 <evrardjp> or I misunderstood
16:20:11 <automagically> FWIW, I know we’ve historically tended not to track work items like this in launchpad, but I’m noticing that our newer contributors seem to benefit from it as they can easily find new work items
16:20:16 <automagically> Take that for what you will
16:20:25 <odyssey4me> I'm a little tied up with another patch series. I can put a bug together though.
16:20:31 <odyssey4me> automagically yeah, agreed
16:20:34 <andymccr> yeah it may be worthwhile
16:20:36 <andymccr> its a low hanging item
16:20:55 <odyssey4me> it's becoming useful to note things in bugs in such a way that hopefully anyone can pick them up
16:21:15 <odyssey4me> ok, I can put a bug together tomorrow, unless you have time to do it before then andymccr ?
16:21:30 <evrardjp> please triage it already :p
16:21:32 <andymccr> odyssey4me: will add a note :D
16:21:45 <stevelle> +1 putting some wishlist low hanging items into launchpad. doesn't do much good to put in launchpad as low hanging if we have cores jump on them though
16:22:21 <evrardjp> stevelle: well that's the importance of proper triaging
16:22:29 <evrardjp> but at the moment we are quite good
16:22:33 <odyssey4me> stevelle yeah, but having cores jump on them isn't bad either - bugs are more visible to everyone than my notebook :p
16:22:40 <evrardjp> we don't have critical or high bugs open IIRC
16:23:19 <evrardjp> so cores can jump on whatever
16:23:35 <evrardjp> but yes, it's maybe better to leave the low-hanging-fruit bugs to new ppl
16:23:49 <evrardjp> maybe it's worth tagging them as low-hanging-fruit in the future
16:23:53 <mhayden> so odyssey4me and andymccr will add these into launchpad?
16:23:58 <evrardjp> like the other openstack projects
16:24:06 <andymccr> will do
16:24:15 <evrardjp> thanks andymccr
16:24:37 <mhayden> #action andymccr will add work items to launchpad for testing overrides
16:24:54 <mhayden> ugh, that was poorly worded
16:24:59 <mhayden> but i think we get the idea (hopefully)
16:26:00 <mhayden> all good on this topic andymccr / odyssey4me  ?
16:26:07 <odyssey4me> yup
16:26:09 <mhayden> woot
16:26:16 <mhayden> #topic Release Planning & Decisions
16:26:30 <mhayden> odyssey4me: you're on again! :)
16:27:11 <odyssey4me> ok, I've done belated tags for Mitaka/Liberty - apologies for not doing it last week
16:27:43 <odyssey4me> For Newton, how do we feel about our current position? Should we tag RC2 and branch now - or hang tight a little longer?
16:28:11 <odyssey4me> My concern is now that upstream has branched, new patches are going in which are Ocata orientated, so our role tests aren't testing newton any more
16:28:35 <odyssey4me> there aren't a lot at this point, so we're kinda OK, but it will progressively diverge
16:28:46 <andymccr> odyssey4me: imo we should branch now. i have nothing going in that isnt testing related. thats just my perspective though
16:28:53 <odyssey4me> branching now does mean we'll be doing backports in the next few weeks though
16:29:02 * mhayden tends to agree with andymccr on branching now
16:29:12 <stevelle> andymccr: I assume we want that testing work backported when reasonable
16:29:22 <andymccr> stevelle: yeah definitely
16:29:23 <palendae> Release is next week...
16:29:38 <palendae> So I'd also be for branching now
16:29:43 <evrardjp> is it possible to stick the requirements to the stable branch, and branch when we say the docs is ready?
16:30:00 <odyssey4me> yes, I support backporting the testing work - Mitaka has almost no testing in the roles... and I'd definitely prefer having two releases well tested with the same framework
16:30:07 <stevelle> Based on issues I know about in the upstream release candidates I think we should be looking at branching soon.
16:30:32 <odyssey4me> evrardjp we can backport docs fixes just as well as any other fixes
16:30:33 <stevelle> rather, I'm not aware of a reason not to branch osa
16:30:59 <evrardjp> odyssey4me: I know, just wanted to have a an opinion in the middle
16:31:06 <odyssey4me> as per last cycle, I fully expect that up until milestone 1 as we get feedback of more real world deployments we'll be doing a lot of fixing and backporting
16:31:08 <evrardjp> I don't see a problem of branching now
16:31:15 <jmccrory> stevelle: +1, and get roles/integrated gates testing against stable/newton
16:31:32 <odyssey4me> alright, it sounds to me like we're a go on that - I'll request the branch
16:31:57 <evrardjp> ok good
16:32:03 <evrardjp> thanks odyssey4me
16:32:09 <odyssey4me> please all pay attention to patches that merged after the current SHA's and help with the backporting
16:32:58 <automagically> mhayden: Can osa-differ help with identifying backport potentials?
16:34:01 <mhayden> automagically: potentially -- but it isn't meant to compare across branches
16:34:49 <stevelle> patches welcome?
16:35:22 <palendae> No, no patches welcome
16:35:27 <automagically> It seems like we may have a lot to backport, so looking for some shared understanding of how to determine the list and act upon it. Seemed like a script would be the easiest way to get there
16:35:28 <stevelle> better that way
16:35:55 <stevelle> software is by definition correct. It does exactly what we told it to.
16:36:57 <asettle> ... welll uhhh likeeee
16:37:05 <asettle> mmmm
16:38:23 <stevelle> ok, we had an action item up there for the branch
16:39:52 <automagically> #action odyssey4me To request/create stable/newton branches
16:40:16 <mhayden> sorry folks -- got some walkups at my desk and getting distracted
16:40:35 <evrardjp> I think an email on the mailing list to confirm that the branching is done couldn't be bad
16:41:18 <odyssey4me> meh, the announcements list gets the announcements for all releases
16:41:27 <evrardjp> that's true
16:42:46 <mhayden> automagically: sounds like we might need a commit diff between two branches on each proj?
16:42:53 <mhayden> that's doable with some bash and git
16:43:03 <odyssey4me> Next tag and branch request is in: https://review.openstack.org/379590
16:43:06 <automagically> mhayden: Yep
16:43:41 <mhayden> yay newton
16:43:47 <odyssey4me> a commit diff between branches will be useful initially, but will quickly become useless as we start working on new things.
16:43:52 <evrardjp> thanks odyssey4me
16:44:46 <automagically> odyssey4me: Agreed, but may help us get over the backport hump of the testing consistency patchs
16:45:17 <mhayden> okay, ready for open floor?
16:45:19 <odyssey4me> automagically yep
16:46:08 <odyssey4me> mhayden sure
16:46:13 <mhayden> #topic Open floor
16:46:20 <palendae> Anything happening with summit planning?
16:46:53 <automagically> palendae: Great question. Would be good to get an etherpad together with list of attendees at a minimum
16:46:55 <odyssey4me> #link http://lists.openstack.org/pipermail/openstack-dev/2016-September/103851.html
16:47:07 <odyssey4me> we have the number of work sessions and fishbowls we requested
16:47:24 <automagically> Ah, good news
16:47:29 <odyssey4me> I will graciously leave the rest of the planning to andymccr and simply offer my support if he wishes. :)
16:47:31 <palendae> My understanding is turn out from our team's going to be low
16:47:45 <palendae> Just asking since it's not tooooo far out
16:47:45 <andymccr> i'll set up an ehterpad
16:47:46 <automagically> andymccr: Enjoy!
16:47:57 <andymccr> etherpad - and we can figure out attendees and start throwing ideas in there for the sessions
16:47:59 <automagically> jmccrory and michaelgugino - You guys attending?
16:48:07 <michaelgugino> I'm here
16:48:14 <stevelle> attending Barcelona?
16:48:19 <automagically> Attending BCN, yes
16:48:21 <michaelgugino> Yes, we're both going
16:48:37 <automagically> Cool, see ya there
16:48:39 <odyssey4me> yes, I do think it's time that we start planning for Ocata work - I would hope that we have some specs to discuss at the summit.
16:48:39 * mhayden will be there
16:48:46 * odyssey4me will be there
16:48:57 <palendae> That was mostly why I threw up the Ocata inventory stuff
16:49:00 <palendae> But won't be there to discuss
16:49:54 <andymccr> https://etherpad.openstack.org/p/osa-barcelona-schedule - thrown up quickly now - but i'll spend some time tomorrow fleshing out the schedule and a good place for ideas. for now just "attendees" section :)
16:49:58 <jmccrory> yep
16:50:10 <automagically> #link https://etherpad.openstack.org/p/osa-barcelona-schedule
16:51:04 <michaelgugino> If anyone has an OSA related (or other presentation), it would be useful to list items there.
16:51:12 <andymccr> good point
16:51:41 <mhayden> i'll be mentioning OSA in mine
16:53:03 <mhayden> okay, anything else for today?
16:53:18 <andymccr> one quick one
16:53:24 <automagically> Anyone currently running ceph-backed cinder using OSA mitaka?
16:53:54 <evrardjp> automagically: yup?
16:54:06 <evrardjp> what's the question/issue?
16:54:29 <automagically> I’ll bother you in #openstack-ansible post-meeting
16:54:34 <automagically> Thx evrardjp
16:54:44 <evrardjp> ok
16:55:11 <michaelgugino> automagically: we're running it in liberty
16:55:28 <michaelgugino> + we have lots of ceph expertise on hand.
16:55:36 <andymccr> i'll raise mine in openstack-ansible also its more a request for reviews :)
16:56:00 <mhayden> hah okay
16:56:03 <mhayden> i'll close it up
16:56:05 <evrardjp> hehe andymccr
16:56:05 <mhayden> thanks everyone!
16:56:08 <evrardjp> thanks
16:56:10 <mhayden> #endmeeting