16:00:23 <asettle> #startmeeting OpenStack Ansible
16:00:24 <openstack> Meeting started Thu Oct 13 16:00:23 2016 UTC and is due to finish in 60 minutes.  The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:27 <evrardjp> woot
16:00:28 <openstack> The meeting name has been set to 'openstack_ansible'
16:00:32 <asettle> Yay go meeting!
16:00:36 <asettle> #topic Roll Call
16:00:41 <evrardjp> o/
16:00:41 <andymccr> o/
16:00:42 <asettle> Get to it people
16:00:57 <odyssey4me> o/
16:01:12 <mattt> \o
16:01:30 <evrardjp> all those left handed ppl
16:01:39 <asettle> I'll give it to :05 before we begin
16:01:55 <adreznec> o/
16:02:25 <odyssey4me> /o\ \o/
16:02:31 <asettle> odyssey4me: nice moves bro
16:02:39 <odyssey4me> just doing a little exercise :p
16:02:44 <asettle> Well, good time to stretch, you know?
16:03:06 <palendae> o/
16:03:53 * odyssey4me eyes the Playstation VR on the table in front of him...
16:04:00 <asettle> Alright, shall we boogie people? 5 minutes is a really long time.
16:04:20 <asettle> #topic Review action items from last week
16:04:32 <asettle> "summit-attendees Talk about upstream Ansible modules for OpenStack"
16:04:38 <asettle> andymccr , is this you?
16:04:58 * odyssey4me sees palendae's name next to the agenda item
16:05:20 <asettle> I see no names. Oh well, I trust you odyssey4me
16:05:21 <asettle> palendae: ?
16:05:30 <andymccr> i think its more a point that we need to talk about it at the summit! and decide what to do, i think its a valid issue, although it would be helpful if we could add some examples of what currently doesnt work.
16:05:47 <evrardjp> all the modules?
16:05:48 <evrardjp> :p
16:05:59 <andymccr> i definitely like the idea of using the upstream modules
16:06:10 <evrardjp> keystone is obviously the more critical because it's used in many roles
16:06:25 <odyssey4me> It seems pretty straightforward - let's move everything we can to use upstream modules. Then identify things that don't yet work and PR them upstream.
16:06:36 <evrardjp> andymccr: we have to verify the overlap (if shade now does everything we need)
16:06:46 <evrardjp> i am pretty sure it's better than before
16:06:57 <palendae> asettle, That's from last week
16:06:58 <palendae> Sorry
16:07:00 <andymccr> im sure we can
16:07:04 <michaelgugino> o/
16:07:06 <odyssey4me> The unfortunate side-effect is that we may need to hedge our bets and update our modules for those parts that don't work because Ansible is terrible at turnaround for modules.
16:07:13 <odyssey4me> *core* modules
16:07:15 <asettle> palendae: ah okay :) thanks for letting me know!
16:07:22 <palendae> But yeah, those points stand
16:07:30 <palendae> I added a link to the existing modules that I found on the summit etherpad
16:07:31 <evrardjp> odyssey4me: we can ship it within the plugins repo as we currently do
16:07:37 <evrardjp> it's perfectly fine for me
16:07:45 <evrardjp> that was the initial idea with config_template anyway
16:07:45 <palendae> From what I could see, only Keystone stuff is in there so far
16:07:46 <odyssey4me> I don't know if you can do some level of assessment palendae and get cracking at it?
16:07:56 <odyssey4me> I think there is glance too.
16:08:32 <evrardjp> odyssey4me: who? if it's me I'd be happy to
16:08:32 <odyssey4me> http://docs.ansible.com/ansible/os_image_module.html
16:08:33 <evrardjp> real work
16:08:39 <evrardjp> :p
16:08:47 <palendae> Ok, I'll try to map out what services are currently supported
16:08:58 <andymccr> palendae: that'd be great
16:08:59 <andymccr> thanks!
16:09:17 <odyssey4me> I think we can cover the os_tempest role needs by the looks of things
16:09:26 <odyssey4me> and possibly the service registrations too
16:09:47 <evrardjp> palendae: we'd have to check deep for keystone (domain support etc...) ... you probably know that :p
16:10:06 <andymccr> yeah - i think we can figure that out but the end result atm is that we are agreed in moving to upstream modules for OS services
16:10:07 <palendae> evrardjp, Yeah, I figure I'll start high level then work my way down
16:10:15 <evrardjp> feel free to share
16:10:17 <odyssey4me> I'm pretty sure that Bluebox will be working on much the same stuff, so if we have a hit list prepared for the summit then we can divide the work up and collaborate.
16:10:24 <palendae> And infra
16:10:34 <palendae> Dunno if anyone from Ansible will be at Summit
16:11:07 <palendae> Their attention seems to help move things along ;)
16:11:09 <spotz> o\ - late:)
16:11:31 <asettle> No sweat spotz
16:11:39 <andymccr> #action palendae to review upstream modules
16:11:44 <andymccr> ok i think we're good to move on?
16:11:45 <asettle> Moving along.
16:11:51 <palendae> Onward
16:11:52 <asettle> Now, if something goes wrong - or I bring up an outdated issue, I apologise.
16:11:55 <asettle> I'm having tech wiki issues.
16:11:57 <odyssey4me> palendae yeah, we have buttons to push to move things along - but core modules fall under the core team and they're bottlenecked
16:11:58 <asettle> For some reason
16:11:59 <asettle> ANYWAY
16:12:10 <asettle> #topic Barcelona Summit schedule
16:12:21 <asettle> andymccr
16:12:24 <odyssey4me> although mordred will likely be a module maintainer for the os_ modules and he never sleeps :p
16:12:29 <asettle> You're up if you have anything
16:12:39 <asettle> #link https://etherpad.openstack.org/p/osa-barcelona-schedule
16:12:50 <evrardjp> odyssey4me: @emonty, @shrews, @juliakreger, @j2sol, @rcarrillocruz on github for the os modules
16:12:51 <andymccr> that link is still up, so https://etherpad.openstack.org/p/osa-barcelona-schedule - i'm going to put a few topics up against some of those tomorrow
16:13:01 <andymccr> to make it smoother at the summit, but i don't want it to be too rigid
16:13:36 <asettle> Anyone have any questions/comments/ concerns for the summit schedule?
16:13:37 <andymccr> that's pretty much it on that, so if you have some summit ideas you definitely want discussed add them to the etherpad or ping me!
16:13:54 <asettle> On that note, andymccr don't run away
16:13:57 <asettle> #topic PTG Atlanta Feb 20-24th
16:14:19 <andymccr> so just a note again - thats the date of the PTG, planning is still early doors, I've confirmed that OpenStack-Ansible will be attending, details will follow
16:14:33 * odyssey4me notes it in his diary
16:14:33 <evrardjp> thanks andymccr
16:14:49 <asettle> Thanks andymccr :)
16:14:52 <asettle> Moving on,
16:14:57 <asettle> #topic Documentation
16:15:14 <asettle> Install guide is all done, give or take a few updates
16:15:16 <asettle> Thanks everyone
16:15:25 <asettle> palendae: you had a note in the agenda for today
16:15:30 <asettle> "Do we want automated code extraction from the docs, to verify accuracy/functionality?"
16:15:33 <asettle> Do you have any more on this?
16:15:39 <asettle> Related
16:15:40 <asettle> #link https://review.openstack.org/#/c/382649/
16:15:42 <palendae> asettle, That was also from last week, guess I should have cleaned up :p
16:15:56 <asettle> palendae: bummer bro. All good. We'll move on :)
16:16:06 <asettle> I actually do want to talk about docs
16:16:14 <asettle> I'm interested in overhauling the Upgrade Guide for Ocata
16:16:21 <asettle> It's a small release cycle, enough time
16:16:28 <asettle> andymccr odyssey4me - do you have thoughts/objections?
16:16:53 <palendae> Overhaul how?
16:16:55 <andymccr> asettle: what are you thinking for the overhaul, and how much help are you thinking you'll need?
16:16:56 <odyssey4me> asettle we may just end up overhauling the whole process, not sure
16:17:11 <andymccr> yeah thats true - we are looking to change the process, or at least come up with ideas around that
16:17:26 <odyssey4me> This may be worth a chat at the summit - I think we have a lot more people interested in making upgrades be awesome now.
16:17:34 <asettle> Well, basically - looking at adjusting it similarly to the way we did the install guide. We'll look at restructuring for best practice. And the other thing, whihc odyssey4me has already noted, is the practice was planned to be overhauled anyway
16:17:42 <odyssey4me> So if it's not on the agenda already, I suggest we make it so.
16:17:43 <asettle> Working alongside with the upgrade team, we'll work on the guide.
16:17:46 <evrardjp> odyssey4me: +1
16:17:54 <andymccr> agree - I'll set one session to talk about hte upgrade process and docs around that - would that work for you?
16:17:54 <palendae> No objections then
16:18:01 <asettle> andymccr: would definitely :) thank you
16:18:03 <asettle> Thanks palendae
16:18:09 <odyssey4me> wfm :)
16:18:18 <asettle> Okay, thanks guys
16:18:20 <asettle> Moving on
16:18:26 <andymccr> #action: andymccr to assign summit session to upgrades
16:18:35 <asettle> Thanks for being my actioneer
16:18:38 <asettle> Apparently I can't remmeber that command :P
16:18:44 <asettle> #topic Release Planning and Decisions
16:18:49 <asettle> odyssey4me:
16:19:02 <evrardjp> asettle: it's told at the beginning of the meeting when you startmeeting
16:19:04 <odyssey4me> Alrighty - Newton  RC3 must be requested today
16:19:14 <odyssey4me> we have a short list of patches that should get in
16:19:14 <asettle> evrardjp: I know dude :p I just don't remember it
16:19:18 <asettle> Remember to do it*
16:19:20 <odyssey4me> https://review.openstack.org/#/q/starredby:jesse-pretorius+project:%255Eopenstack/openstack-ansible.*+status:open
16:19:22 <evrardjp> grep
16:19:26 <asettle> odyssey4me: could you put that i the etherpad?
16:19:37 <odyssey4me> one is still a master patch, so it'll need backporting once it merges
16:19:39 <asettle> odyssey4me: they look like they're all in
16:19:58 <odyssey4me> so I'll need some review assistance in a bit
16:20:18 <asettle> odyssey4me: okay, cool. Ping us when you need in openstack-ansible
16:20:20 <odyssey4me> the overlayfs one can probably wait - any thoughts on that?
16:20:37 <odyssey4me> I'm basically thinking nice to have, but not essential.
16:21:17 <odyssey4me> no thoughts?
16:21:18 <andymccr> hmm yeah probably agree
16:21:28 <andymccr> if it goes in happy to backport it straight away
16:21:31 <jmccrory> might be bad first impression if someone has a new aio deploy at newton and it fails
16:21:44 <asettle> *raises hand* yes I'd agree with that
16:21:45 <odyssey4me> yeah, that was kinda my only motivation for having it included
16:22:01 <andymccr> hmm
16:22:02 <andymccr> yeah tahts fair
16:22:05 <odyssey4me> ok, it's back in then
16:22:05 <andymccr> ok lets backport it?
16:22:12 <asettle> Yep
16:22:14 <evrardjp> jmccrory: +1
16:22:18 <andymccr> odyssey4me: just ping us and we'll get it in.
16:22:31 <odyssey4me> *ahem* sure
16:22:34 <palendae> Yeah, AIOs should probably work :p
16:22:34 <asettle> #action andymccr and odyssey4me to ensure backports are completed
16:23:03 <asettle> Shall we continue? :)
16:23:08 <andymccr> si si
16:23:08 <odyssey4me> oh yes
16:23:13 <asettle> #topic Blueprint work
16:23:17 <asettle> I actually mhayden but he's not here
16:23:17 <odyssey4me> any thoughts on mitaka/liberty releases?
16:23:27 <odyssey4me> I think we may be behind on a tag or something
16:23:32 <odyssey4me> I honestly have lost track.
16:23:34 <asettle> OH yes, sorry odyssey4me ma bad
16:23:47 <asettle> odyssey4me: perhaops someone could do a inventory?
16:23:53 <asettle> Anyone available to do that?
16:24:13 <evrardjp> well depending on what to do
16:24:31 <odyssey4me> yes, it seems I'm a week behind
16:24:48 <odyssey4me> ok - any objections to requesting a release for mitaka/liberty?
16:25:13 <andymccr> no objection
16:25:14 <odyssey4me> I have some admin to catch up on - I'll get it done tomorrow
16:25:22 <odyssey4me> and show andymccr how it all works
16:25:24 <evrardjp> none, do we want to wait for recent upgrades to M bugs to be merged?
16:25:29 <andymccr> haha +2
16:25:31 <asettle> #action odyssey4me to catch up on admin and show andymccr how to FLYYYYYYY
16:25:41 <evrardjp> wooot
16:25:45 <odyssey4me> evrardjp there's always another tag :p
16:25:58 <asettle> Anyway, back to the topic of Blueprint work.
16:26:01 <asettle> Any comments on mhayden 's things?
16:26:05 <asettle> Or shall we ignore until next week?
16:26:19 <andymccr> i think mhayden has started his patches
16:26:23 <odyssey4me> his review are up for the first bit of work - they need attention for anyone who has a bit of time
16:26:23 <asettle> He has indeedy
16:26:32 <asettle> Okay, good to know. Thank you odyssey4me
16:26:38 <asettle> #action team to review everything by mhayden
16:26:38 <andymccr> #link https://review.openstack.org/#/q/topic:bp/security-rhel7-stig
16:26:39 <odyssey4me> the blueprint section is a bit like a parking space as a reminder :)
16:26:53 <asettle> Noted ;)
16:26:54 <odyssey4me> not necessarily something on the agenda
16:27:09 <asettle> I'm a meeting-holder noob. First time guys :p
16:27:10 <asettle> On that note
16:27:19 <asettle> #topic OpenStackussion
16:27:20 <asettle> HAHAHA
16:27:21 <asettle> Okay sorry
16:27:26 <asettle> #topic Open Discussion
16:27:33 <asettle> I'm so funny.
16:27:50 <evrardjp> Indeed
16:27:57 <asettle> evrardjp: calm your enthusiasm :p
16:27:59 <asettle> Anyone? :)
16:28:09 <andymccr> nothing from my side!
16:28:15 <jmccrory> more for M-N upgrades, but if anyone has a chance to help test https://review.openstack.org/#/c/384269/ it would be appreciated
16:28:49 <odyssey4me> just a little heads-up - the os_neutron role now has calico tests (non voting) on it... if anyone has the inclination to help logan- make it work I'm sure he'd be happy to work with you
16:29:14 <asettle> Good stuff :)
16:29:26 <asettle> Okay, well, on that note. I think we can call it a day super early.
16:29:26 <odyssey4me> jmccrory yep, with newton released I'd love to see us work on patterns to improve the upgrades in-role where possible
16:29:33 * asettle is jumping ahead of herself
16:29:46 <odyssey4me> asettle you're beside yourself :p
16:29:53 <asettle> odyssey4me: mostly laughing so much at my hilarious joke
16:29:54 <asettle> But yep
16:30:01 <logan-> thanks odyssey4me. seems some testing has changed in that role since i wrote the calico tests. im going to try to dig thru soon if someone doesn't beat me to it and see what changes are needed.
16:30:11 <palendae> Well as long as you can keep yourself amused, asettle
16:30:13 <evrardjp> jmccrory: sorry for the wrong idea about flushing handlers :p I wanted to make sure :) I'll have a look at the rest
16:30:18 <asettle> palendae: always bro
16:30:23 <andymccr> logan-: i'd be happy to help - i did a part of that rewrite
16:30:26 <evrardjp> logan-: cool
16:30:50 <logan-> thanks andymccr
16:31:06 <odyssey4me> logan- also happy to pitch in, seeing that I also caused some of the new chaos
16:31:32 <jmccrory> evrardjp : no problem, thought it was a good idea. ansible just didn't want to behave
16:31:40 <evrardjp> logan-: I see you've got enough ppl on it :D
16:31:52 <asettle> Good community vibe here people
16:31:58 <evrardjp> jmccrory: I'm thinking the best way ansible would want us to work with this kind of work is playbooks
16:32:06 <odyssey4me> I can't help at all with networking though - just test config. :)
16:32:23 <logan-> haha
16:32:23 <evrardjp> but calico seems simple!
16:32:33 <odyssey4me> evrardjp sure, but then we won't be able to do it as a part of the normal operations for an install
16:33:09 <evrardjp> odyssey4me: I don't complain about the solution, I just tell something that is expected. Just stating a fact.
16:33:17 <evrardjp> Shipping in role is easier for collab too
16:33:26 <odyssey4me> doing it in-line in the role is great because it makes the upgrade as simple as a deploy - and also means that a minor version upgrade or a major version upgrade are no different - which is an important place to be
16:33:38 <evrardjp> agreed
16:33:55 <odyssey4me> probably easier to develop a test scenario around too :)
16:33:58 <logan-> looking at the agent logs it looks like an inventory issue since linuxbridge-agent and stuff are being deployed.
16:34:02 <evrardjp> we are on the same boat you know :p
16:34:21 <odyssey4me> logan- oh really? that may be my fault
16:34:22 <logan-> also.. awesome we have container logs now :D
16:34:45 <asettle> \o/
16:35:18 <odyssey4me> hmm, I wonder if the setenv in tox.ini from the base env are perhaps *not* being overridden for the test env
16:35:24 <odyssey4me> let's take that to the channel
16:35:31 <asettle> Let's!
16:35:35 <odyssey4me> asettle has ants
16:35:41 <asettle> Hahhahaah
16:35:45 <asettle> I just... you know...
16:35:59 <asettle> This has been a wild ride guys! Again sometime ;)
16:36:02 <odyssey4me> http://i1.kym-cdn.com/entries/icons/original/000/015/319/do_you_want_ants.jpg
16:36:09 <asettle> The truth.
16:36:19 <asettle> Alright poeple, let's call it quits and move discussions to the channel
16:36:32 <asettle> For anything important, ping andymccr and odyssey4me your friendly PTL
16:36:47 <asettle> For more hilarious jokes, ping me.
16:36:48 <odyssey4me> I accept gifts of whiskey.
16:36:59 <andymccr> ok we're done here i assume :) thanks all!
16:37:02 <asettle> Bro when don't you
16:37:09 <asettle> #endmeeting