#openstack-meeting-4: OpenStack Ansible Meeting

Meeting started by b3rnard0 at 16:00:52 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting (b3rnard0, 16:01:08)

  1. RollCall (b3rnard0, 16:01:19)
  2. Review action items from last week (b3rnard0, 16:03:56)
    1. ACTION: hughsaunders to start reading inventory-manage.py (b3rnard0, 16:08:42)
    2. hughsaunders: We were talking about extracting some bits to make it a more general library, with potentially more back ends (b3rnard0, 16:09:53)
    3. bp https://blueprints.launchpad.net/openstack-ansible/+spec/dynamic-inventory-lib (b3rnard0, 16:10:09)
    4. ACTION: b3rnard0 use link shortener at next meeting (b3rnard0, 16:11:48)

  3. Vote on the genericized patch and merge process for review "https://review.openstack.org/#/c/152753/" <- this is in response to the community request that the repository be de-rackspace-ified and fulfills the blueprints (b3rnard0, 16:12:58)
    1. https://review.openstack.org/#/c/152753/ (b3rnard0, 16:13:06)
    2. https://blueprints.launchpad.net/openstack-ansible/+spec/galaxy-roles (b3rnard0, 16:13:15)
    3. https://blueprints.launchpad.net/openstack-ansible/+spec/rackspace-namesake (b3rnard0, 16:13:23)
    4. from cloudnull: removing maas, and some of the rackspace scripts is no problem (b3rnard0, 16:23:33)
    5. http://docs.ansible.com/playbooks_best_practices.html#directory-layout for reference (Apsu, 16:25:07)
    6. http://docs.ansible.com/playbooks_best_practices.html#directory-layout (b3rnard0, 16:25:40)
    7. http://docs.ansible.com/playbooks_best_practices.html (b3rnard0, 16:27:06)
    8. from odyssey4me we'll have to develop patches for juno independantly from master (b3rnard0, 16:31:43)
    9. cloudnull: so what i want is for people to review it, comment on it, and before it is excepted i'd like to have +6, cores and other. (b3rnard0, 16:38:23)
    10. ACTION: d34dh0r53 : to help with review of https://review.openstack.org/#/c/152753/ (b3rnard0, 16:38:55)

  4. Upstream gating and how do we make it better - (cloudnull) - patch in review for some improvements: (b3rnard0, 16:39:11)
    1. https://review.openstack.org/152965 (b3rnard0, 16:39:19)
    2. from hughsaunders: performance testing on pub cloud isn't great; but I would like to see that as a job run from the same jenkins master (b3rnard0, 16:49:27)

  5. Open discussion (b3rnard0, 16:52:19)


Meeting ended at 16:56:21 UTC (full logs).

Action items

  1. hughsaunders to start reading inventory-manage.py
  2. b3rnard0 use link shortener at next meeting
  3. d34dh0r53 : to help with review of https://review.openstack.org/#/c/152753/


Action items, by person

  1. b3rnard0
    1. b3rnard0 use link shortener at next meeting
  2. d34dh0r53
    1. d34dh0r53 : to help with review of https://review.openstack.org/#/c/152753/
  3. hughsaunders
    1. hughsaunders to start reading inventory-manage.py
  4. openstack
    1. d34dh0r53 : to help with review of https://review.openstack.org/#/c/152753/


People present (lines said)

  1. cloudnull (78)
  2. odyssey4me (47)
  3. b3rnard0 (28)
  4. palendae (23)
  5. hughsaunders (20)
  6. Apsu (13)
  7. git-harry (5)
  8. alextricity (5)
  9. d34dh0r53 (5)
  10. openstack (3)
  11. toxick (2)
  12. stevelle (1)
  13. sigmavirus24 (1)
  14. rackertom (1)
  15. mancdaz (1)
  16. serverascode (1)


Generated by MeetBot 0.1.4.