16:00:53 <b3rnard0> #startmeeting OpenStack Ansible Meeting
16:00:56 <openstack> Meeting started Thu May  7 16:00:53 2015 UTC and is due to finish in 60 minutes.  The chair is b3rnard0. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:00 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:16 <d34dh0r53> \*/
16:01:22 <b3rnard0> #topic Agenda & rollcall
16:01:22 <b3rnard0> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:01:31 <palendae> Hi
16:01:51 <stevelle> hello
16:02:21 <b3rnard0> howdy
16:03:50 <Sam-I-Am> howdy
16:04:41 <cloudnull> presente
16:04:43 <cloudnull> :)
16:04:44 <cloudnull> and late.
16:04:58 <sigmavirus24> o/
16:05:47 <b3rnard0> #chair cloudnull
16:05:48 <openstack> Current chairs: b3rnard0 cloudnull
16:07:11 <cloudnull> so lets get started.
16:07:16 <cloudnull> is everyone here ?
16:07:32 <cloudnull> if your not present please stand up. . .
16:07:38 * Sam-I-Am stands up
16:07:50 * b3rnard0 sits down
16:07:59 <cloudnull> #topic Review action items from last week
16:08:09 <cloudnull> we only had one action item which was
16:08:15 <cloudnull> cloudnull to learn to use better bash magic - http://mywiki.wooledge.org/BashFAQ/035#getopts for das reference
16:08:59 <cloudnull> and i did it and have decided that I will ignore getops and continue using my while loop. so thats good. - yw Apsu
16:09:20 <cloudnull> #topic Blueprints
16:09:32 <sigmavirus24> cloudnull: A+
16:09:54 <cloudnull> We have one BP to talk about so far:
16:09:56 <cloudnull> Developer docs https://blueprints.launchpad.net/openstack-ansible/+spec/developer-docs / https://review.openstack.org/#/c/173155/. Specifically, a section was added to discuss extending os-ansible-deployment. This spec is now in its final draft
16:10:04 <cloudnull> hands mic to palendae
16:10:06 <Apsu> cloudnull: lol. As long as you're aware of getopts and how you're failing, my work here is done ;P
16:10:18 <b3rnard0> #info Developer docs https://blueprints.launchpad.net/openstack-ansible/+spec/developer-docs / https://review.openstack.org/#/c/173155/. Specifically, a section was added to discuss extending os-ansible-deployment. This spec is now in its final draft
16:10:36 <palendae> yep, I feel confident about this spec now and would appreciate more reviews
16:10:49 <cloudnull> Apsu its all about failing forward.
16:11:17 <Sam-I-Am> moar docs
16:11:34 <cloudnull> oh look a volunteer. Sam-I-Am
16:11:34 <Apsu> cloudnull: Good man
16:11:40 <palendae> Don't have a whole lot else to say - comments on the spec are welcome
16:12:01 <Sam-I-Am> cloudnull: lol
16:12:08 <Sam-I-Am> i'm drooling to contribute stuff :)
16:13:44 <Sam-I-Am> palendae: these dev docs will likely include some sort of install guide
16:14:04 <Sam-I-Am> plus the config file documentation
16:14:14 <palendae> Sure, and more
16:14:19 <Sam-I-Am> moarrrr
16:14:24 <cloudnull> one of our approved specs for ceilometer needs more reviews on the implementation commit.
16:14:25 <cloudnull> https://review.openstack.org/#/c/173067/
16:15:02 <cloudnull> i know that alex is OOO for this week and i think next but it would be great to get some folks to review that patch so we can move it a long.
16:15:44 <b3rnard0> #info cloudnull one of our approved specs for ceilometer needs more reviews on the implementation commit. https://review.openstack.org/#/c/173067/
16:15:59 <cloudnull> another patch that is implementing ceph client side work for Juno needs reviews: https://review.openstack.org/#/c/181022/ < contributed by svg a community member.
16:18:45 <cloudnull> we also have an approved bp for https://blueprints.launchpad.net/openstack-ansible/+spec/build-facts-archive
16:18:56 <cloudnull> https://github.com/stackforge/os-ansible-deployment-specs/blob/master/specs/kilo/build-facts-archive.rst
16:19:05 <cloudnull> i want to say jwagner is working on that ?
16:19:32 <jwagner> i did not assign myself but i can
16:20:05 <cloudnull> not required. just curious if anyone has looked at implementation ?
16:20:43 <palendae> I have not yet
16:20:47 <palendae> Glanced over the spec
16:21:58 <cloudnull> ok. so moving on.
16:22:18 <cloudnull> #topic Reviews
16:22:41 <cloudnull> #info Adding Sphinx machinery for developer docs https://review.openstack.org/#/c/178503/
16:22:57 <cloudnull> this is the dev docs review palendae was talking about.
16:23:12 <palendae> Yeah, that's the start of implementation for the spec/bp
16:23:14 <cloudnull> cores please do the needfuls.
16:23:44 <cloudnull> we need more reviews on that.
16:24:21 <cloudnull> Especially from the Core members of the team.
16:24:36 <d34dh0r53> will do
16:24:56 <d34dh0r53> can we add https://review.openstack.org/#/c/180746/ and https://review.openstack.org/#/c/180747/ to the list
16:25:28 <cloudnull> this touches on an issue that we've seen as of late, I'd like to call out and make sure that we, the core members, are doing reviews daily.
16:25:51 <stevelle> good reminder, thanks
16:26:00 <d34dh0r53> yep
16:26:10 <b3rnard0> #info d34dh0r53: can we add https://review.openstack.org/#/c/180746/ and https://review.openstack.org/#/c/180747/ to the list
16:27:24 <cloudnull> #action core-members review needs to be done on https://review.openstack.org/#/c/178503/
16:27:24 <cloudnull> #action core-members review needs to be done on https://review.openstack.org/#/c/180746/
16:27:24 <cloudnull> #action core-members review needs to be done on https://review.openstack.org/#/c/180747/
16:27:24 <cloudnull> #action core-members review needs to be done on https://review.openstack.org/#/c/181022/
16:27:25 <cloudnull> #action core-members review needs to be done on https://review.openstack.org/#/c/173067/
16:27:43 <Sam-I-Am> my config docs patch will be ready for review soon too
16:27:52 <Sam-I-Am> not official yet, but feel free to comment on whats there
16:27:53 <cloudnull> yay! moar words!
16:28:27 <Sam-I-Am> uhh, many many more words
16:28:32 <palendae> Damn, andymccr beat to me to rechecking the master mysql log patch
16:28:35 <b3rnard0> oh dear, so many action items!
16:28:39 <Sam-I-Am> maybe splitting out cinder stuff is a good idea :)
16:28:44 <Sam-I-Am> like we did swift
16:28:48 <cloudnull> #topic Bugs
16:29:30 <palendae> Sam-I-Am: Into the conf.d? Yeah, I don't think that's a bad idea
16:29:39 <Sam-I-Am> yeah conf.d
16:29:52 <Sam-I-Am> after doing all this stuff i think we might want to split a few things in there
16:30:03 <Sam-I-Am> this file is hueg
16:31:08 <palendae> Yep. I think the intention was to start migrating towards that kind of layout, but it's been low priority since the current state works
16:31:52 <Sam-I-Am> well, maybe i'll write a bp/spec
16:31:54 <Sam-I-Am> if it needs one
16:31:57 <Sam-I-Am> or its just something we do
16:32:03 <Sam-I-Am> cloudnull: sir?
16:32:16 <Sam-I-Am> also need to test/unbreak this cinder nfs stuffs
16:32:24 <cloudnull> i say breaking out the config into smaller parts will only make things more understandable.
16:32:36 <d34dh0r53> +1
16:32:43 <Sam-I-Am> cloudnull: now why would we want to do that?
16:32:59 <cloudnull> good point, scratch that .
16:33:03 <Sam-I-Am> haha
16:33:16 <Sam-I-Am> want me to take this idea?
16:33:24 <Sam-I-Am> i need to write more words
16:34:01 <cloudnull> sure.
16:34:02 <palendae> If you're volunteering
16:34:14 <Sam-I-Am> if it needs a spec...
16:34:16 <cloudnull> #action Sam-I-Am think about breaking out the configs
16:34:26 <cloudnull> voluntold.
16:34:29 <b3rnard0> volunsuggesting?
16:34:33 <palendae> s/ing out//
16:34:48 <palendae> Anyway
16:34:48 <palendae> BUGS
16:34:53 <Sam-I-Am> there are no bugs
16:34:58 <palendae> Cool, done here.
16:35:13 <cloudnull> so do we have issues that we are working on that we need to call out as a group ?
16:35:43 <Sam-I-Am> i think i'm going to figure out how to make nfs work
16:35:58 <Sam-I-Am> it doesnt smell right as-is
16:36:03 <palendae> None here, I'm mostly working on downstream stuff
16:36:27 <Bjoern__> if you need help in regards to NFS, let me know. I did setup the netapp nfs builds
16:37:14 <cloudnull> ok.
16:37:17 <Sam-I-Am> BjoernT: there's netapp nfs, and then generic nfs
16:37:22 <Sam-I-Am> the netapp nfs works
16:37:39 <BjoernT> ok
16:39:31 <d34dh0r53> this mysql binary logging talk has me thinking that we may want to look at storing the binary logs on a different set of spindles for performance reasons.
16:41:35 <cloudnull> d34dh0r53 we're storing them within the container in a bind mount.
16:41:50 <cloudnull> which would be an LV ideally.
16:42:26 <d34dh0r53> right but that bind mount is on the same set of drives as the actual db creating essentially double writes
16:42:27 <cloudnull> are you thinking that we look to add a separate pv/vg on a different set of logical disks to do that ?
16:44:15 <stevelle> thats what I am hearing
16:45:05 <andymccr> that sounds quite hard to implement reliably? although i do like the idea of having it not-bind mounted
16:45:09 <d34dh0r53> yeah, just a thought for now, nothing immediate that needs attention, more curious as to where bottlenecks will arise
16:45:35 <cloudnull> it'd be interesting to spec / poc that out .
16:45:55 <cloudnull> i think there would be usecases where that'd be useful on a couple of services.
16:46:06 <andymccr> perhaps it could just be configurable, e.g. which pv you use and by default it'll just use the same one but createa  separate lv?
16:47:27 <d34dh0r53> yeah, that could work, having the ability to point services at specific pv's could be really nice
16:47:53 <andymccr> i think what cloudnull said is true - could be useful more generically which is a win
16:48:13 <cloudnull> ^ ++
16:48:17 <cloudnull> #topic Open discussion
16:49:22 <cloudnull> is there anything generally that we need to discus ?
16:50:04 <d34dh0r53> aka Airing of grievances
16:50:23 <cloudnull> so we done here ?
16:50:35 <Sam-I-Am> i think so
16:50:41 <Sam-I-Am> things are good and we are all happy
16:50:57 <cloudnull> thats what im reading :)
16:51:05 <cloudnull> ok thanks everyone !
16:51:06 <cloudnull> #endmeeting