16:03:26 <cloudnull> #startmeeting OpenStack Ansible Meeting
16:03:28 <openstack> Meeting started Thu Jun 11 16:03:26 2015 UTC and is due to finish in 60 minutes. The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:30 <b3rnard0> oh my, ms outlook what?
16:03:31 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:03:32 <cloudnull> boom suck it b3rnard0
16:03:37 <odyssey4me> o/
16:03:44 <d34dh0r53> lol
16:03:44 <rromans> ...
16:04:00 <cloudnull> #topic Agenda & rollcall
16:04:15 <b3rnard0> i be here
16:04:25 <stevelle> howdy
16:04:40 <cloudnull> #kick b3rnard0
16:04:42 <odyssey4me> \o
16:04:49 <sigmavirus24> o/
16:04:52 <sigmavirus24> \o/
16:04:54 <d34dh0r53> o\
16:05:10 <Sam-I-Am> moo.
16:05:21 <palendae> o/
16:06:12 <jwagner> o/
16:07:49 <cloudnull> so lets get started
16:07:59 <cloudnull> #topic To BigTent or not to BigTent that is the question?
16:08:19 <cloudnull> so we have an etherpad going talking about this
16:08:25 <cloudnull> #link https://etherpad.openstack.org/p/osad-openstack-naming
16:08:41 <cloudnull> I'd like for people to chime in here regarding the move
16:09:05 <cloudnull> and if there are any glaring things that we need to take care of before we apply, if we agree that we should apply.
16:09:46 <odyssey4me> cloudnull do we have any idea from ansible regarding whether we're allowed to use their name?
16:10:01 <cloudnull> no.
16:10:17 <cloudnull> but when we send the request out to the ML we'll cc them to get them on the record
16:10:51 <cloudnull> but pulling from prior art it we'll likely need to change it
16:11:13 <odyssey4me> ok cool - then I think we should try for 'openstack-ansible' first
16:11:19 <Sam-I-Am> doesnt puppet use puppet?
16:11:33 <sigmavirus24> Sam-I-Am: puppet-openstack
16:11:34 <sigmavirus24> I think
16:11:44 <sigmavirus24> or they used to
16:11:49 <palendae> http://lists.openstack.org/pipermail/openstack-dev/2015-April/061712.html
16:11:49 <Sam-I-Am> seems like having the name of the deployment system makes sense
16:11:55 <odyssey4me> ansible doesn't seem to be sticky about the trademark - almost every role I find on github uses 'ansible-' in the name
16:11:58 <palendae> Sam-I-Am: It does, so long as we don't have TM issues
16:12:09 <palendae> odyssey4me: Yeah, I think ansible *wants* the name there
16:12:11 <cloudnull> yes, but the official project name is marionette or something similar
16:12:53 <Sam-I-Am> guess it boils down to ansible's legal, and hoping they aren't dense.
16:13:17 <palendae> Yeah, that email makes it sound like Puppet, Inc was the issue, not Openstack
16:13:29 <palendae> But it's worth taking into consideration, and working with Ansible, Inc on
16:13:56 <palendae> We don't have a rep from there here, do we? Would be nice if Greg could make some of these meetings
16:14:42 <Sam-I-Am> alternatives would be something like what puppet did... a name that is related to puppet. ansible has a few, but most of them arent easy to spell.
16:15:31 <odyssey4me> Sam-I-Am +1, but it's hard to find something like that - I like the idea of the sci-fi theme, but we've yet to find a good name
16:16:06 <Sam-I-Am> it'd take some good digging. i'd call up the sci-fi oracle, karin :)
16:16:15 <cloudnull> so moving into that space.
16:16:18 <cloudnull> #topic BigTent project code name
16:16:20 <palendae> odyssey4me: Just cause we haven't yet doesn't mean we won't :p
16:16:52 <cloudnull> if we rename, i'd like a list in the etherpad which we can +1 / -1 and then move forward by EOW .
16:17:37 <palendae> Sounds reasonable to me
16:20:30 <cloudnull> so do we have any issues with the move to big tent ?
16:20:47 <Sam-I-Am> as long as its air-conditioned
16:20:55 <Sam-I-Am> and there's some docs now
16:21:07 <cloudnull> just need some more ascii diagrams
16:21:43 <Sam-I-Am> ha nooooo
16:21:47 <Sam-I-Am> just like we need more OVS
16:21:52 <Sam-I-Am> fair trade
16:22:31 <palendae> I am +1 on big tent
16:23:20 <odyssey4me> me too +1
16:23:50 <odyssey4me> do we deal with the RAX tech debt before-hand? we'll have to move those branches I guess?
16:24:06 * gregdek hullos
16:24:15 <gregdek> I hear you've got some naming considerations, hm?
16:24:29 <cloudnull> #link https://etherpad.openstack.org/p/osad-openstack-naming
16:24:32 * gregdek is the Ansible guy
16:24:41 <cloudnull> gregdek: for prez
16:24:43 <cloudnull> :)
16:25:11 <gregdek> Oh, no.
16:25:24 <gregdek> No, I don't do elected governance. ;)
16:25:29 <cloudnull> odyssey4me: ideally we'd keep osad in stackforge and move master / kilo forward .
16:25:37 <sigmavirus24> +1 here on big tent
16:25:41 <gregdek> Gimme a sec to read over the etherpad and I'll comment if I have any.
16:25:56 <sigmavirus24> welcome gregdek
16:27:10 <gregdek> cowstack would be pretty awesome, I gotta say. :)
16:27:20 <Sam-I-Am> yeah, i like cows.
16:27:22 <Sam-I-Am> they're trendy too
16:28:06 <Sam-I-Am> although that theory didn't work for gateway computer
16:28:26 <d34dh0r53> moo.stack
16:28:32 <palendae> Sam-I-Am: Hey, they're still around!
16:28:35 <palendae> OpenMoo
16:29:00 <Sam-I-Am> i hear the nebula name might be available
16:29:03 <Sam-I-Am> thats sciency, right?
16:29:12 <gregdek> I think broadly it's "be descriptive" (ansible-openstack) or "be fun" (cow-based).
16:29:13 <odyssey4me> lol, sies Sam-I-Am
16:29:17 <palendae> I bet the investors woiuld gladly sell it
16:29:19 <Sam-I-Am> to soon?
16:29:27 <gregdek> (wow. that's harsh.)
16:29:40 <palendae> gregdek: So, as far as you know, no legal issues with having ansible in the name?
16:29:48 <palendae> I think there's concern about whether Ansible, Inc would condone it
16:29:48 <Sam-I-Am> an5ible ... there, no trademark problems
16:29:57 <palendae> ansistack
16:30:01 <gregdek> palendae: if there are, that ship has kinda sailed, since Ansible is already in OSAD.
16:30:03 <odyssey4me> s/legal/trademark/
16:30:14 <gregdek> And we basically endorsed that with all kinds of press. :)
16:30:17 <palendae> odyssey4me: Trademarks are legal :p
16:30:21 <d34dh0r53> intergalacticstack
16:30:47 <palendae> openstack-erector-set
16:30:51 <odyssey4me> sounds fair enough :)
16:30:52 <gregdek> So long as what $newcowproject is using is stock Ansible, legal should be ok.
16:30:58 <palendae> Ok
16:31:08 <palendae> Basically if we're not forking and calling it Ansible
16:31:10 <sigmavirus24> Queue E Em Ewe
16:31:20 <palendae> PostgreStack
16:31:33 * odyssey4me kicks palendae :p
16:31:35 <gregdek> There's a potential political issue down the road: what happens if some other Ansible-based install project gets a head of steam?
16:31:45 <sigmavirus24> palendae: but trademark has to be enforced
16:31:57 <sigmavirus24> And Ansible Inc could have enforced that before endorsing os-ansible-deployment
16:32:00 <gregdek> But from my perspective, because OSAD planted the flag, OSAD has the name.
16:32:18 <gregdek> When does the decision need to be made?
16:32:30 <palendae> cloudnull was talking about EOW
16:32:36 <palendae> So, tomorrow
16:32:44 <gregdek> Because the paranoid side of me says I should probably sit down with counsel to make superdupersure.
16:32:53 <palendae> Totally fair and reasonable to me
16:32:57 <stevelle> that seems like a good idea
16:32:58 <gregdek> OK, I'll go do that.
16:33:16 <gregdek> Are we using a bot in here for action items?
16:33:18 <cloudnull> gregdek: im going to put through the governance commit likely today , but that doesn't need to be finalized by tomorrow
16:33:25 <cloudnull> yes
16:33:34 <gregdek> Someone feel free to action me then :)
16:34:00 <cloudnull> #action gregdek talk to legal people about using the ansible name in the OSAD project for OpenStack governance.
16:34:15 <gregdek> Of course, this assumes the final vote is ansible-openstack and not $funcowname...
16:34:26 <gregdek> ...which obviously doesn't require our help. :)
16:34:29 <cloudnull> this is true.
16:34:43 <gregdek> Part of me wants to stonewall you to make you choose $funcowname!
16:34:51 <gregdek> (But I won't actually do that.)
16:35:06 <cloudnull> i respect that :)
16:35:47 <gregdek> Is it openstack-ansible or ansible-openstack? If legal has a preference, do you care?
16:36:02 <palendae> Our IRC channell is #openstack-ansible now
16:36:09 <cloudnull> gregdek: ^
16:36:09 <sigmavirus24> moosible openstack
16:36:13 <palendae> So we do have some precedence, but I suppose that could be changed
16:36:18 <cloudnull> so ill submit the governance change today. and we'll circle back on the name if needed.
16:36:30 <gregdek> OK. Simple enough. I'll have an answer soon.
16:37:03 <cloudnull> #action commit governance change to https://github.com/openstack/governance
16:37:16 <cloudnull> gregdek: is it ok if i cc you on the ML post for the change ?
16:39:27 <cloudnull> so moving on.
16:39:29 <cloudnull> #Blueprints
16:39:33 <cloudnull> #topic Blueprints
16:43:38 <cloudnull> hahaha
16:43:40 <cloudnull> wrong channel
16:43:46 <palendae> gj
16:44:32 <cloudnull> just to recap because im an idiot
16:44:34 <cloudnull> [11:37] <palendae> That's happening. Only stones-- is tomorrow
16:44:35 <cloudnull> [11:38] <cloudnull> https://review.openstack.org/#/c/189938/ needs further approval when someone gets a chance
16:44:37 <cloudnull> [11:39] <palendae> cloudnull: was in process, should be ready soon
16:44:38 <b3rnard0> i guess i know what i'm doing next week
16:44:38 <cloudnull> [11:40] <cloudnull> palendae: this spec was merged so i think we're good there. https://review.openstack.org/#/c/173155/
16:44:40 <cloudnull> [11:41] <palendae> cloudnull: Yeah, just making sure I go over the scripty parts
16:44:41 <cloudnull> [11:41] <cloudnull> ok.
16:44:43 <cloudnull> [11:42] <cloudnull> palendae: is there any blockers into further implementation ?
16:44:44 <cloudnull> [11:42] <cloudnull> anything that you need to make it go?
16:44:46 <cloudnull> [11:42] <palendae> cloudnull: Of docs? Getting healthy again :p
16:44:48 <cloudnull> [11:43] <cloudnull> #action palendae needs to get healthy again
16:44:49 <cloudnull> [11:43] <palendae> I need to re-review what's in the list in the BP and get to writing the rest of the sections
16:44:50 <cloudnull> [11:43] <cloudnull> ok
16:44:56 <palendae> wow the pings
16:45:35 <palendae> But basically yes, the developer docs BP has stalled while I deal with health issus.
16:45:54 <cloudnull> ok
16:46:18 <cloudnull> Sam-I-Am: https://review.openstack.org/#/c/181544/ this spec has been stalled a bit too
16:46:34 <cloudnull> can we get some reviewers on it so that we can make it go.
16:46:58 <cloudnull> seems like that leads us to the path of config validation
16:47:03 <sigmavirus24> yes
16:47:07 <andymccr> ugh yeh i need to adjust my link to look for open specs too
16:47:08 <sigmavirus24> which I need to find time to work on
16:47:41 <palendae> Yeah, schema validation should be broken out
16:47:50 <cloudnull> agreed.
16:48:06 <palendae> Not sure if that should be a hard prereq or not, but it does certainly make implementation of this easier
16:48:16 <cloudnull> if someone has some cycles it would be great to get that spec written up . i think it will be of realy value for deployers.
16:48:37 <cloudnull> *real
16:49:27 <sigmavirus24> the cli works just fine, we just need schema(s?) written for the various config files
16:49:37 <sigmavirus24> And I'm thinking of making the schema be able to be YAML
16:49:43 <sigmavirus24> so that it's YAML schema for YAML files
16:49:48 <sigmavirus24> Instead of having to write JSON
16:50:00 <palendae> One thing that could put a wrench in that is extended config files. e.g. rpc-openstack has it's own
16:50:07 <palendae> Not sure if those would just go un-checked or what
16:50:20 <sigmavirus24> palendae: the spec should have an opinion on when validation happens
16:50:43 <sigmavirus24> Either as a pre-req to running the playbooks, as an optional part of running them, or as part of the playbooks somehow
16:51:02 <sigmavirus24> I leave that decision as an exercise for the spec author
16:51:08 <stevelle> I forget was linting going to be broken out or lumped into that
16:51:22 <stevelle> I know there was discussion
16:51:56 * svg just got home
16:53:47 <palendae> stevelle: I don't remember. I could see it being included
16:53:49 <cloudnull> linting should remain stand alone imo
16:54:53 <cloudnull> but alas it also could be lumped in. im with sigmavirus24 the writer of the spec should sort that.
16:55:08 <sigmavirus24> And it'll get yak shaved anyway
16:55:09 <sigmavirus24> So
16:55:11 <sigmavirus24> YOLO
16:55:18 <palendae> Sure
16:55:38 <cloudnull> So in the last few min id like a quick pull of people , this meeting time seems to be less that ideal for a fair amout of folks,
16:55:42 <cloudnull> do we want to change it ?
16:55:55 <sigmavirus24> I was going to bring that up in #openstack-ansible
16:55:55 <b3rnard0> +1
16:55:56 <palendae> +1 from me. It's over the noon hour during DST
16:55:56 <sigmavirus24> lol
16:55:58 <sigmavirus24> +1
16:55:58 <cloudnull> and do we want to hold rotating meeting times for various time zones ?
16:56:08 <sigmavirus24> rotating meetings work well for some projects
16:56:18 <sigmavirus24> usually lends to confusion and frustration the largeer the project gets though
16:56:18 <b3rnard0> +1
16:56:27 <cloudnull> ok.
16:56:29 <andymccr> from uk perspective, 5pm is often a time ppl need to leave for one reason or another. usually its ok for me personally but yeh i'd +1
16:56:32 <sigmavirus24> so it should work now, but we should be open to reconsidering in a few months
16:56:34 <odyssey4me> +1 to rotation
16:56:41 <cloudnull> so when would be best?
16:57:12 <d34dh0r53> should we -1 hour from the start time during DST?
16:57:46 <stevelle> I would say move 1 hour earlier and call it done
16:57:52 <andymccr> -1 hour would be good for uk i think, but not sure how that impacts on west coasters!
16:57:53 <stevelle> if you can find a room
16:58:09 <Sam-I-Am> cloudnull: er, yeah i need to work on that spec
16:58:16 <Sam-I-Am> cloudnull: sort of had some higher priorities
16:59:01 <stevelle> as a west-coaster, any more than 1h earlier is gonna hurt
16:59:07 <cloudnull> so when do we want to do this in UTC?
16:59:29 <Sam-I-Am> cloudnull: maybe 2 meetings?
16:59:40 <stevelle> I feel if we are going for governance, do meeting in UTC
16:59:48 <Sam-I-Am> meetings need to be in utc
17:00:12 <Sam-I-Am> otherwise people's calendars get b3rnard0'd when DST happens in different locales
17:00:25 <openstack> cathy_: Error: Can't start another meeting, one is in progress. Use #endmeeting first.
17:00:39 <b3rnard0> Sam-I-Am: just give me a diagram
17:00:41 <Sam-I-Am> looks like we need to take this back to o-a
17:00:43 <cloudnull> #endmeeting