16:07:35 <b3rnard0> #startmeeting OpenStack Ansible Meeting
16:07:36 <openstack> Meeting started Thu Jun 18 16:07:35 2015 UTC and is due to finish in 60 minutes.  The chair is b3rnard0. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:07:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:07:39 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:07:52 <b3rnard0> #topic Agenda & rollcall
16:07:55 <odyssey4me> o/
16:08:05 <b3rnard0> #chair odyssey4me
16:08:06 <openstack> Current chairs: b3rnard0 odyssey4me
16:08:14 <b3rnard0> presente!
16:08:22 <odyssey4me> howdy all, sorry about the late start
16:09:04 <b3rnard0> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:09:09 <odyssey4me> (to be included in the roll call you need to say something after the meeting start) :)
16:09:19 <stevelle> something
16:09:35 <b3rnard0> anything?
16:09:57 <hughsaunders> <-- present
16:10:00 <evrardjp> something
16:10:07 <palendae> Present
16:10:08 <KLevenstein> o/
16:10:45 <svg> \m/
16:11:34 <b3rnard0> was the agenda updated? because that's what I'll use for this meeting
16:11:59 <odyssey4me> b3rnard0 we'll go with it - if anything wasn't added then it'll come into open discussion
16:12:03 <odyssey4me> shall we begin?
16:12:03 <rromans> .
16:12:25 <b3rnard0> #topic To BigTent or not to BigTent that is the question?
16:12:41 <odyssey4me> I think we pretty much agree on this last week.
16:12:45 <odyssey4me> Is gregdek around?
16:12:49 <b3rnard0> #link https://etherpad.openstack.org/p/osad-openstack-naming
16:12:52 * sigmavirus24 is present
16:13:37 <odyssey4me> I guess not. Well, last I checked we had five positive votes, and just need 3 more I think.
16:14:44 <sigmavirus24> yep
16:14:52 * sigmavirus24 forgets how many searchlight needed
16:14:59 <odyssey4me> a reminder to everyone to check the suggested names and add your thoughts, and vote
16:15:01 <sigmavirus24> a good idea would be to ask ttx to add this to the TC meeting
16:15:34 <evrardjp> First, crucible is a product from atlassian IIRC, it's maybe not a good idea, right?
16:15:54 <odyssey4me> evrardjp if you can add that to the etherpad that'd be great
16:16:06 <odyssey4me> we don't want to end up infringing trademarks
16:16:16 <odyssey4me> no-one needs another quantum debacle :p
16:18:01 <odyssey4me> the governance change was submitted anyway - does someone have the review link handy?
16:18:21 <sigmavirus24> https://review.openstack.org/191105
16:18:24 <sigmavirus24> #link https://review.openstack.org/191105
16:18:50 <evrardjp> odyssey4me: done
16:19:55 <b3rnard0> okay anything else on this topic?
16:20:12 <odyssey4me> ok, so we have a few more days to go before the results, and yes sigmavirus I think it would be a good idea for cloudnull to ask ttx to add the vote to the TC agenda
16:22:08 <odyssey4me> right, I think that's all on this topic
16:22:41 * svg on train, almost at destination..
16:22:46 <b3rnard0> #topic Review action items from last week
16:23:07 <b3rnard0> #info gregdek talk to legal people about using the ansible name in the OSAD project for OpenStack governance.
16:23:19 <odyssey4me> I don't have any feedback from cloudnull who couldn't make it today - we'll have to carry that over to next week
16:23:26 <b3rnard0> k
16:23:44 <b3rnard0> #action gregdek talk to legal people about using the ansible name in the OSAD project for OpenStack governance.
16:24:06 <b3rnard0> #info commit governance change to https://github.com/openstack/governance
16:24:14 <odyssey4me> #action: cloudnull to ask ttx to add the openstack-ansible vote review https://review.openstack.org/191105 to the TC meeting agenda
16:24:23 <cloudnull> sorry, im not really here but https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee we're already on the agenda for next week.
16:24:37 <odyssey4me> lol, ok - action done then :p
16:24:52 * cloudnull goes away again
16:25:10 <b3rnard0> those were all of the action items i had on the list from last week
16:25:33 <odyssey4me> yep, ok - next
16:25:35 <palendae> I noticed my stuff about the docs BP is still on the wiki page. I'll clean those out
16:25:44 <b3rnard0> #topic Blueprints
16:25:59 <b3rnard0> okay, so we'll ignore that one from palendae
16:26:10 <b3rnard0> any blueprints worth discussing?
16:27:07 <stevelle> I suspect we don't have anyone to speak for https://review.openstack.org/#/c/192421/ today
16:27:51 <odyssey4me> yeah, ok we can briefly cover that
16:27:52 <b3rnard0> no
16:28:02 <palendae> That's the only one I can see that I know
16:28:59 <odyssey4me> the spec for multi-region (https://review.openstack.org/192421) will probably not be worked on immediately, it will probably continue some time in the future
16:29:35 <odyssey4me> if no-one has any questions, comments or anything relating to blueprints, let's move on
16:29:44 <stevelle> I would suggest that not having any blueprints to discuss means we need to make work for ourselves
16:30:12 <b3rnard0> i think we'll be getting some specs in the near future
16:30:16 <palendae> stevelle: So what BP are you proposing? :)
16:30:17 <stevelle> soon
16:30:31 <b3rnard0> #topic Reviews
16:30:36 <stevelle> I wont hold up reviews
16:30:45 <odyssey4me> there are some showing up here which don't have specs yet: https://blueprints.launchpad.net/openstack-ansible
16:31:09 <odyssey4me> are there any reviews that anyone wants focus on?
16:31:36 <odyssey4me> or does anyone have unanswered questions or wants to discuss current reviews
16:32:04 <odyssey4me> https://review.openstack.org/#/q/project:stackforge/os-ansible-deployment,n,z
16:32:34 <odyssey4me> or rather: https://review.openstack.org/#/q/project:stackforge/os-ansible-deployment+is:open,n,z
16:34:43 <odyssey4me> alright - I think there's one thing that I'd like to ask is that we stop doing premature cherry-picks
16:35:01 <odyssey4me> ie only backport a patch once the one to master has merged
16:35:27 <stevelle> merged, not just gets workflow approval
16:35:32 <stevelle> ?
16:35:38 <b3rnard0> #info odyssey4me: alright - I think there's one thing that I'd like to ask is that we stop doing premature cherry-picks; ie only backport a patch once the one to master has merged
16:35:41 <odyssey4me> this is to prevent something merging into another branch before it hits master
16:36:08 <odyssey4me> I see a review that's just got +2+w for kilo, but the master review is still -1
16:36:40 <odyssey4me> thanks, shall we move on then?
16:37:11 <b3rnard0> #topic Bugs
16:37:27 <odyssey4me> Does anyone have any questions/comments about any current bugs?
16:37:42 <odyssey4me> #link: https://bugs.launchpad.net/openstack-ansible
16:38:51 <evrardjp> yes
16:39:30 <evrardjp> I'm new, so I don't get how #1424797 Implement SSL for spice consoles is tagged as medium
16:40:47 <b3rnard0> #link https://bugs.launchpad.net/openstack-ansible/+bug/1424797
16:40:48 <openstack> Launchpad bug 1424797 in openstack-ansible trunk "Implement SSL for spice consoles" [Medium,Triaged]
16:41:13 <evrardjp> while I don't ask to have a higher priority for it, I'd like to know how it works, but (I guess) I'm far from the topic. Sorry for getting out of the path
16:41:25 <odyssey4me> evrardjp that was probably a rating from discussion between the bug reporter and the triage team from the tuesday meetings
16:41:32 <evrardjp> ok
16:41:36 <evrardjp> thanks for the clarification
16:41:59 <odyssey4me> it should actually be marked confirmed as I don't see any triage information in there
16:42:08 <odyssey4me> (ie there's no solution noted)
16:42:59 <odyssey4me> if anyone has a solution, please add it as a comment or submit a review for it :)
16:43:05 <odyssey4me> anyone/anything else?
16:43:43 <sigmavirus24> s/add it as a comment or/
16:43:45 <sigmavirus24> /
16:43:59 <odyssey4me> :p
16:44:06 <odyssey4me> ok, shall we move on then?
16:44:54 <b3rnard0> #topic Milestones
16:46:11 <odyssey4me> alright, our targeted release dates for 10.1.9/9.0.10 is tomorrow, and we seem to still have plenty of reviews in flight that are scheduled for them
16:46:25 <odyssey4me> oh, and 11.0.3
16:46:57 <odyssey4me> link: https://launchpad.net/openstack-ansible/+milestone/11.0.3
16:47:02 <odyssey4me> #link: https://launchpad.net/openstack-ansible/+milestone/10.1.9
16:47:15 <odyssey4me> #link: https://launchpad.net/openstack-ansible/+milestone/9.0.10
16:47:23 <odyssey4me> #link: https://launchpad.net/openstack-ansible/+milestone/11.0.3
16:47:36 <odyssey4me> 9.0.10 looks fine
16:48:50 <odyssey4me> is this one only juno? https://bugs.launchpad.net/openstack-ansible/juno/+bug/1462572
16:48:51 <openstack> Launchpad bug 1462572 in openstack-ansible juno "[WARNING]: It is unnecessary to use '{{' in loops, leave variables in loop expressions bare" [Low,In progress] - Assigned to Darren Birkett (darren-birkett)
16:49:00 <odyssey4me> ah, yes it is - ok, it's committed
16:49:06 <sigmavirus24> woot
16:49:43 <odyssey4me> we need a volunteer to pick up https://bugs.launchpad.net/openstack-ansible/+bug/1424705
16:49:44 <openstack> Launchpad bug 1424705 in openstack-ansible trunk "tear apart the schedule for cron.daily/weeky/monthly " [Low,Triaged]
16:50:24 <odyssey4me> otherwise it'll slide to the next release
16:50:59 <sigmavirus24> it's not a high priority
16:51:03 <sigmavirus24> I think we can let it slide
16:51:16 <sigmavirus24> especially if the targeted release date is tomorrow
16:51:30 <odyssey4me> sigmavirus24 yeah, I'll leave that decision to cloudnull
16:52:41 <odyssey4me> can we get some eyes on https://review.openstack.org/192102 please
16:52:55 <odyssey4me> it's a backport from master to kilo
16:53:35 <sigmavirus24> #link https://review.openstack.org/192102
16:54:45 <b3rnard0> we are down to 5 mins; should we switch to open discussion?
16:55:47 <evrardjp> sigmavirus24: as an end user, I find this clearer
16:55:54 <odyssey4me> b3 yep - please check other bugs and reviews associated with them
16:55:59 <odyssey4me> b3rnard0 ^
16:56:15 <sigmavirus24> evrardjp: not sure what you mean
16:57:32 <evrardjp> splitting environment files by component makes it easier to read
16:57:35 <b3rnard0> odyssey4me: with them? please clarify
16:57:50 <odyssey4me> b3rnard0 I mean regarding the milestones
16:58:23 <b3rnard0> okay
16:58:24 <odyssey4me> sorry - that was a general call to action to look through the next milestones and try and get fix committed for any bugs listed in them
16:58:26 <evrardjp> sigmavirus24: so I think, if it's more readable/modular, it's a better effort in the long term
16:58:40 <odyssey4me> and I think we're pretty much out of time - thanks all
16:58:48 <b3rnard0> thanks everyone
16:59:09 <b3rnard0> #endmeeting