16:01:26 <cloudnull> #startmeeting OpenStack Ansible Meeting
16:01:27 <openstack> Meeting started Thu Jul  9 16:01:26 2015 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:30 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:47 <cloudnull> #topic Agenda & rollcall
16:02:07 <b3rnard0> hello
16:02:09 <andymccr> o/
16:02:10 <odyssey4me> o/
16:02:24 <palendae> o/
16:02:30 <qwebirc82056> good day folks
16:02:31 <cloudnull> hi everybody
16:03:40 <serverascode> o/
16:03:47 <hughsaunders> hey
16:04:37 <qwebirc82056> first time tacker joinee here - good to see you all
16:04:46 <d34dh0r53> o/
16:04:49 <cloudnull> welcome qwebirc82056
16:05:08 <odyssey4me> welcome qwebirc82056 and serverascode :)
16:05:26 <cloudnull> #topic Review action items from last week
16:05:37 <cloudnull> odyssey4me to update the specs for federation.
16:05:54 <cloudnull> looks like that was all done
16:06:10 <cloudnull> #link https://blueprints.launchpad.net/openstack-ansible/+spec/keystone-federation
16:06:27 <cloudnull> cloudnull we will no longer backport things from master until its been +w / merged into master.
16:06:39 <odyssey4me> yep, those are done and should be considered final - can we get some final reviews on https://review.openstack.org/194147 ?
16:06:40 <cloudnull> also it seems that everyone is following that change
16:07:06 <cloudnull> yes ^ that should be priority item https://review.openstack.org/#/c/194147/
16:07:09 <cloudnull> #link https://review.openstack.org/#/c/194147/
16:07:26 <odyssey4me> and https://review.openstack.org/194255
16:07:27 <cloudnull> #topic Blueprints
16:07:51 <cloudnull> so jumping into the specs / bps
16:08:21 <cloudnull> odyssey4me:  whats your feeling on https://review.openstack.org/#/c/194255/ ?
16:08:35 <cloudnull> do we think that we'll have working bits by 11.1.x ?
16:09:02 <odyssey4me> cloudnull yeah, we have some patches up for review which cover SSL-related stuff which we depend on
16:09:12 <odyssey4me> let me pick them out for review attention:
16:09:17 <cloudnull> ++
16:10:04 <odyssey4me> #link: https://review.openstack.org/194474 (keystone SSL support)
16:10:34 <odyssey4me> #link: https://review.openstack.org/196943 (keystone v3 api usage in the Ansible library)
16:11:06 <odyssey4me> #link: https://review.openstack.org/199307 (allow 'insecure' use of keystone by everything)
16:11:49 <odyssey4me> #link: https://review.openstack.org/198957 (ssl offloading to haproxy)
16:12:10 <odyssey4me> if we can get some attention on those reviews and try to get them merged this week that'd really help
16:12:18 <cloudnull> +1
16:12:56 <cloudnull> palendae hughsaunders sigmavirus24 mattt andymccr
16:13:08 <sigmavirus24> sorry, I'm here
16:13:23 <hughsaunders> ok :)
16:14:22 <odyssey4me> I think that the haproxy review still needs some attention.
16:14:33 <cloudnull> about that one .
16:14:49 <cloudnull> when i looked at it last it was forwarding ssl to the endpoing using tcp
16:14:54 <odyssey4me> git-harry has raised a good point in https://review.openstack.org/199307 - perhaps the decision of whether to set 'insecure' should be manual? thoughts on that?
16:15:02 <cloudnull> have we looked at haproxy 15 with ssl terminiation ?
16:15:55 <odyssey4me> cloudnull https://review.openstack.org/198957 is to use haproxy for ssl offloading, but https://review.openstack.org/194474 still implements ssl at the keystone endpoint as there are use-cases where people want to do both
16:17:09 * cloudnull was looking at that review
16:17:13 <odyssey4me> the haproxy patch will conflict with the keystone one at the moment, but we'll fix that - so I think that patch needs more work but the keystone one is good to go
16:17:21 <cloudnull> my one nit there would be the use of "http://ppa.launchpad.net/vbernat/haproxy-1.5/ubuntu"
16:17:36 <cloudnull> in the past we've had deployment issues when using ppa's
16:17:44 <cloudnull> but i can cover that in the PR
16:18:14 <odyssey4me> cloudnull yeah, perhaps the decision of using the ppa should be made based on whether there are any ssl endpoints... not use it if it's not needed
16:19:01 <cloudnull> +1, I'd also not be against simply adding the ability for us to compile / build the package for haproxy.
16:19:21 <cloudnull> if we deem 1.5 is the way to go
16:19:51 <stevelle> after reading the osad manifesto through once or twice that strikes me as not crazy
16:20:17 <cloudnull> #link https://etherpad.openstack.org/p/openstack-ansible-manifesto
16:20:36 <cloudnull> wiki:
16:20:39 <cloudnull> #link https://wiki.openstack.org/wiki/OpenStackAnsible
16:21:26 <odyssey4me> I have to admit, I haven't been able to read through it properly. :/
16:22:03 <cloudnull> i figured id wait a couple weeks before i pr to master.
16:22:12 <cloudnull> for that reason, theres been a lot going on
16:22:34 <cloudnull> but if anyone has a minute to review it please tear it apart.
16:22:35 <odyssey4me> cloudnull perhaps it should just be pr'd to master and we can edit/discuss in review?
16:23:15 <cloudnull> maybe, ill wait a few more days for people to collaborate on the etherpad.
16:23:44 <hughsaunders> will have a read
16:23:45 <stevelle> I'm still doing tiny edits to fix typos and what not
16:23:54 <cloudnull> thanks stevelle hughsaunders
16:24:03 <cloudnull> next on the BP reviews
16:24:05 <cloudnull> #link https://review.openstack.org/#/c/173067
16:24:18 <cloudnull> this is for ceilometer cores please do the needfuls
16:24:33 <odyssey4me> yep, I've just built it and it's build complete
16:24:53 <sigmavirus24> odyssey4me: mind if I piggy back my testing off your build?
16:25:19 <odyssey4me> sigmavirus24 sure, I'll add your keys
16:25:25 <sigmavirus24> gracias
16:26:44 <odyssey4me> msg sigmavirus 104.239.228.118
16:26:48 <odyssey4me> hahaha
16:26:50 <odyssey4me> whoops
16:26:59 <d34dh0r53> lulz
16:27:22 <hughsaunders> odyssey4me: its ok we didn't see hunter2
16:27:48 <odyssey4me> it's built - I'm not all that familiar with ceilometer so perhaps someone can do some things to make pretty graphs and stuff?
16:27:55 <cloudnull> #topic Open discussion
16:28:08 <cloudnull> should we move the docs out into their own repo and elect a new core team for docs? - cloudnull
16:28:17 <cloudnull> what do we think ?
16:28:46 <odyssey4me> cloudnull if we can get a docs repo created in openstack/ then yeah, I think that's a good plan
16:28:47 <palendae> IMO no; at least not all docs
16:28:51 <andymccr> dont think they need their own repo. The docs should pertain only to the os-ad stuff the rest of "how to openstack" is/should already be doc'd.
16:29:00 <d34dh0r53> I nominate sigmavirus24 for core of docs
16:29:09 <palendae> I don't want to see it become more of a "docs is THEIR job" thing
16:29:17 <palendae> Docs should be on developers implementing a feature
16:29:21 <palendae> At least part of them
16:29:32 <sigmavirus24> d34dh0r53: of course
16:29:36 <stevelle> == palendae
16:30:23 <palendae> we're already bad about keeping the docs we have up to date. I think this would just make it worse
16:30:56 <odyssey4me> yeah, I am inclined to agree - we need to pay more attention to keeping docs up to date with code - and this makes it easier
16:32:55 <cloudnull> ok. so for now, do we say no moving the docs ?
16:33:09 <andymccr> that would be my vote!
16:33:29 <palendae> For now, no
16:33:35 <palendae> Maybe if it morphs and gets bigger
16:33:44 <andymccr> (if it really gets that big we are probably doing it wrong)
16:33:49 <palendae> I think we'll still need some stuff documenting the structure and so on for other devs
16:33:53 <cloudnull> lets try this
16:33:54 <palendae> but like andymccr says, that should be small
16:34:05 <cloudnull> #startvote to move the docs into its own repo
16:34:06 <openstack> Unable to parse vote topic and options.
16:34:10 <odyssey4me> I agree with andymccr
16:34:33 <palendae> Oo, using bot features
16:34:34 <sigmavirus24> cloudnull: #startvote Should we move the docs into its own repo? Yes, no
16:34:47 <cloudnull> #startvote to move the docs into its own repo? yes, no
16:34:48 <openstack> Begin voting on: to move the docs into its own repo? Valid vote options are yes, no.
16:34:49 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:34:54 <andymccr> #vote no
16:34:55 <sigmavirus24> #vote no
16:35:00 <odyssey4me> #vote no
16:35:05 <stevelle> #vote no
16:35:16 <palendae> #vote no
16:35:40 <d34dh0r53> #vote abstain
16:35:41 <openstack> d34dh0r53: abstain is not a valid option. Valid options are yes, no.
16:35:49 <Apsu> #vote pedro
16:35:50 <openstack> Apsu: pedro is not a valid option. Valid options are yes, no.
16:35:57 <odyssey4me> lol
16:35:58 <d34dh0r53> damn, no Switzerland for me
16:36:03 <cloudnull> good enough for me
16:36:05 <sigmavirus24> HAW HAW
16:36:06 <cloudnull> #endvote
16:36:06 <d34dh0r53> #vote no
16:36:07 <openstack> Voted on "to move the docs into its own repo?" Results are
16:36:09 <openstack> no (5): sigmavirus24, palendae, stevelle, odyssey4me, andymccr
16:36:24 <Apsu> d34dh0r53: You abstained anyway in the end.
16:36:26 <d34dh0r53> FRAUD, I clearly got my vote in before the bell
16:36:42 <Apsu> Time to recount the hanging chads
16:36:54 <cloudnull> next How should we handle the change in OpenStack package version numbers? odyssey4me
16:37:08 <cloudnull> idk if this is a problem for us
16:37:13 <odyssey4me> so the two links outline the changes and what they mean
16:37:24 <cloudnull> pbr should kick out the right version numbers,
16:37:44 <odyssey4me> this will affect upgrades
16:37:59 <cloudnull> and we've been seeing this change in the recent master builds. IE http://rpc-repo.rackspace.com/os-releases/master/neutron-7.0.0.0b2.dev158-py2.py3-none-any.whl
16:38:05 <odyssey4me> if that's the case, then great
16:38:20 <odyssey4me> but perhaps an upgrade test can be done to confirm?
16:38:26 <cloudnull> +1
16:38:40 <cloudnull> #action test upgrading from kilo to liberty (master)
16:39:01 <sigmavirus24> +1
16:39:14 <sigmavirus24> Would it be a good idea to add greande jobs like upstream uses?
16:39:23 <sigmavirus24> (or to have jobs that test those upgrade paths)
16:39:38 <odyssey4me> sigmavirus24 that'd be great
16:39:45 <cloudnull> i looked at that. those jobs seem to be reserved for os namespaced projects.
16:39:50 * sigmavirus24 wasn't volunteering
16:39:54 <stevelle> soon cloudnull
16:39:56 <sigmavirus24> cloudnull: so soon that won't be a problem?
16:40:02 <cloudnull> as well as the periotic jobs.
16:40:03 <sigmavirus24> == stevelle
16:40:09 <sigmavirus24> what about patriotic jobs?
16:40:10 <cloudnull> ++ sigmavirus24 stevelle
16:40:11 <sigmavirus24> =P
16:40:34 <cloudnull> patriotic jobs are once a year and the 4th has passed.
16:40:40 <stevelle> sigmavirus24: that's on your own time, son.
16:41:13 <cloudnull> so is there anything pressing on the bug side.
16:41:22 <cloudnull> any wish list items we want to raise ?
16:41:43 <cloudnull> we've been smashing the open bugs so great works guys !
16:42:38 <cloudnull> littering and ?
16:43:41 <andymccr> swift multi region reviews are starting to go in as a headsup!
16:43:43 <stevelle> any mid-cycle events we expect to have folks showing up at?
16:43:53 <stevelle> might be worth a mention
16:44:26 <stevelle> suppose that was early, not in open discussion yet
16:44:45 <cloudnull> we are stevelle
16:45:10 <cloudnull> the ops midcycle is in planning (kinda)
16:45:39 <cloudnull> #link http://lists.openstack.org/pipermail/openstack-operators/2015-July/007592.html
16:45:55 <cloudnull> it'd be great to get some more OSAD people in on that thread
16:46:12 <cloudnull> for anyone interested.
16:46:44 <cloudnull> +1 andymccr
16:49:01 <cloudnull> also the kolla guys are looking into some of our modules to use within their, IE SamYaple, we might want to see if we can help out. it'd be a good collaborative effort . http://lists.openstack.org/pipermail/openstack-dev/2015-July/069014.html
16:49:11 <cloudnull> *their project
16:49:44 <cloudnull> and or participating in the thread, if anyone is interested.
16:50:35 <cloudnull> thats all we have on the agenda today . im inclinded to end early if theres nothing else.
16:51:02 <palendae> I don't have anything
16:51:04 * sigmavirus24 objects to ending early for no particular reason
16:51:24 <d34dh0r53> #vote yes
16:51:36 * d34dh0r53 is disenfranchised
16:51:59 <cloudnull> #noted sigmavirus24 objects
16:52:06 <cloudnull> #endmeeting