16:00:57 <odyssey4me> #startmeeting OpenStack Ansible Meeting
16:00:57 <openstack> Meeting started Thu Aug  6 16:00:57 2015 UTC and is due to finish in 60 minutes.  The chair is odyssey4me. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:00 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:20 <odyssey4me> #topic Agenda & rollcall
16:02:04 <serverascode> o/
16:02:33 <odyssey4me> morning/afternoon/evening everyone
16:02:49 <Apsu> Morning
16:02:50 <b3rnard0> hello
16:02:59 <palendae> Morning
16:03:04 <prometheanfire> moin
16:03:09 <stevelle> hellos
16:03:19 <evrardjp> hello
16:05:14 <odyssey4me> #topic Review action items from last week
16:05:55 <odyssey4me> sigmavirus24 I saw the mail thread, but didn't see anyone weight in on it except me :/
16:06:16 <odyssey4me> thanks for doing that though
16:06:29 <odyssey4me> can others please weigh in?
16:06:45 * odyssey4me sigmavirus24 and cloudnull to put together a POC for pip and epoch's
16:07:15 <odyssey4me> sigmavirus24 how's that going?
16:09:28 <odyssey4me> ok, it seems that'll have to carry
16:09:35 <odyssey4me> #action sigmavirus24 and cloudnull to put together a POC for pip and epoch's
16:09:50 <sigmavirus24> sorry
16:09:51 * odyssey4me odyssey4me to move all unassigned juno bugs to the 10.1.12 milestone
16:09:53 <sigmavirus24> Haven't had time to act on it
16:09:55 <odyssey4me> that was done
16:10:10 <odyssey4me> sigmavirus24 no worries, it's not urgent at this stage
16:10:20 * odyssey4me odyssey4me to move all unassigned and not yet 'in-progress' kilo bugs to the 11.1.1 milestone
16:10:23 <odyssey4me> that was also done
16:10:45 <odyssey4me> #topic Blueprints
16:10:57 <odyssey4me> #link https://blueprints.launchpad.net/openstack-ansible/+spec/ceph-block-devices
16:11:32 <odyssey4me> so a patch for this has merged to master, and we have yet to release 11.1.0, so some discussion has been had around backporting this
16:11:35 <odyssey4me> any thoughts?
16:11:52 <odyssey4me> svg evrardjp git-harry ?
16:12:00 <odyssey4me> mattt ^
16:12:24 <evrardjp> mm
16:12:44 <evrardjp> I'll let the others talk: I'm only starting to test it
16:12:51 <odyssey4me> the question is whether it's gone through enough testing - I know that mattt and git-harry had reservations and think it should stay on the 11.2.0 milestone
16:13:18 <odyssey4me> unfortunately they're not here to discuss it
16:13:21 <evrardjp> when has the decision to be taken?
16:14:09 <odyssey4me> well, it seems that we'll have to carry that decision and it all depends on when 11.1.0 gets released, which is an agenda point later
16:14:34 <odyssey4me> but based on what I'm seeing in the channel discussions I think it may be best to leave on the 11.2.0 milestone
16:14:59 <odyssey4me> any thoughts from anyone?
16:15:23 <evrardjp> at least waiting for svg and git-harry input would be wise
16:15:49 <evrardjp> so if you can't have it now, let's postpone the merge to kilo?
16:16:01 <odyssey4me> yeah, neither are in the channel - so we'll carry the decision
16:16:07 <odyssey4me> #topic reviews
16:16:18 <odyssey4me> #link https://review.openstack.org/#/q/starredby:%22Jesse+Pretorius%22+project:stackforge/os-ansible-deployment,n,z
16:16:46 <odyssey4me> I have found a cause for the master branch being stuck.
16:16:51 <odyssey4me> https://review.openstack.org/209998 should fix it
16:17:13 <odyssey4me> https://launchpad.net/bugs/1482260 explains the bug in detail
16:17:13 <openstack> Launchpad bug 1482260 in openstack-ansible trunk "python-zaqarclient has incompatible requirements with oslo.middleware" [High,In progress] - Assigned to Jesse Pretorius (jesse-pretorius)
16:18:01 <odyssey4me> sigmavirus24 palendae please review https://review.openstack.org/209998 asap - just vote, no workflow for now until the gate check passes
16:19:11 <odyssey4me> as for the rest of the starred reviews, we're not meeting the 11.1.0 deadline, so either we shift the deadline again or we shift the blueprints not yet merged to the 11.2.0 milestone
16:19:14 <odyssey4me> thoughts?
16:19:42 <evrardjp> it doesn't serve to always postpone right?
16:20:17 <odyssey4me> evrardjp yeah, we need to release so that we can continue to push forward with patch releases
16:20:27 <stevelle> I'm leaning towards shifing to 11.2.
16:20:32 <odyssey4me> we have a build-up of bugs and fixes for them which need to get in
16:20:36 <stevelle> agreed
16:21:14 <odyssey4me> unfortunately it seems that we don't have a quorum of cores here, so the decision will have to wait :/
16:22:07 <odyssey4me> palendae sigmavirus24 any thoughts before we move on?
16:22:20 <sigmavirus24> sorry I'm very distracted
16:22:47 <palendae> I'd be fine with moving some blueprints to 11.2
16:22:48 <sigmavirus24> I want at least the SP patch into 11.10
16:22:51 <sigmavirus24> *11.1.0
16:22:57 <sigmavirus24> Other things make sense for 11.2
16:23:04 <sigmavirus24> Is master unblocked yet for the SP patch?
16:23:38 <odyssey4me> sigmavirus24 it may be after the above-mentioned patch
16:24:14 <odyssey4me> palendae sigmavirus24 note that https://review.openstack.org/201136 has been thoroughly tested by miguelgrinberg and stevelle so we're needing a final vote there to get https://blueprints.launchpad.net/openstack-ansible/+spec/multi-region-swift through
16:24:42 <sigmavirus24> Yeah I'd like to test that but I think that might need to be targetted to 11.2
16:25:41 <odyssey4me> most importantly the end-user experience is not changed for any currently supported swift deployment
16:25:59 <evrardjp> so ceilometer is the only inclusion in 11.1?
16:26:06 <odyssey4me> so my vote is to merge it to get it done and open the gate for more thorough testing and minor patches
16:26:44 <evrardjp> seems a big inclusion already
16:27:03 <palendae> odyssey4me: Sure, not changing defaults is good, but I'd like to at least read over it. Supposed lack of enablement isn't necessarily grounds for merge
16:27:05 <odyssey4me> evrardjp if we stay in this state, yes - that and all the wishlist items, some of which are actually quite significant
16:28:31 <odyssey4me> palendae sure, my concern though is that we've not released anything in kilo for over a month now and we usually release a hotfix every two weeks, so we need to get back to our release cadence
16:29:09 <odyssey4me> shall we defer until tomorrow to give time to release master and review those patches?
16:30:07 <stevelle> The value of deferring would be to reduce the demands on eyeballs?
16:30:22 <stevelle> As they are split between priorities with master being blocked?
16:30:35 <palendae> odyssey4me: Sure, I get that; not sure I want to release just to release...also unfortunately my time is fairly booked this week =\
16:31:18 <odyssey4me> ok, how about we switch the discussion a bit to help
16:31:28 <odyssey4me> when should we aim to release 11.2.0 ?
16:31:42 <stevelle> I vote for after 11.1.0
16:31:47 <odyssey4me> lol
16:33:16 <evrardjp> if we continue to postpone 11.1.0 that's not gonna be easy ><
16:33:52 <sigmavirus24> == stevelle
16:34:00 <evrardjp> (to release after 11.1.0 for those who didn't get the joke)
16:34:24 <sigmavirus24> why not tag 11.1.0 and 11.2.0 simultaneously?
16:34:28 <odyssey4me> so the project's cadence has always been to release fast and release often
16:34:29 <sigmavirus24> just 11.2.0 30 seconds later?
16:34:43 <odyssey4me> at least for hotfix releases
16:34:51 <stevelle> joking aside, this project has maintained a cadence of putting fixes out to the community quickly, and maintained the principle that version numbers are cheap. we already pushed a deadline and it didn't give us any reward so I would like to revert to prior behavior.
16:35:23 <palendae> So we're +2ing just to get a release
16:35:24 <evrardjp> 11.1 includes ceilometer, that deserves a release alone (just my opinion)
16:35:34 <odyssey4me> liberty will hit feature freeze in Sep
16:36:10 <odyssey4me> so I vote for releasing 11.1.0 this week (tomorrow) and anything that's not in yet can release with 11.2.0 which we should plan to release at the end of Aug IMO
16:36:17 <palendae> I'm fine with that
16:36:28 <evrardjp> +1
16:36:51 <odyssey4me> end Aug - mid Sep - somewhere around there, giving us perhaps 3 hotfix releases before then
16:36:53 <evrardjp> ppl would still have the time to give their opinion
16:37:50 <odyssey4me> ok, we'll aim to release 11.1.0 tomorrow and jump back into the hotfix cadence
16:38:14 <odyssey4me> whatever is already in, will be in and whatever doesn't make it can go forward into a hotfix or 11.2.0
16:38:43 <odyssey4me> #topic Open Discussion
16:38:50 <sigmavirus24> so long as SP doesn't land in a hot fix
16:38:54 <odyssey4me> is there anything anyone wants to raise?
16:38:59 <odyssey4me> sigmavirus24 agreed
16:39:32 <odyssey4me> #action odyssey4me to release 11.1.0 on 7 Aug 2015, any blueprints not yet merged to be postponed to 11.2.0
16:40:02 <palendae> Really the issue we're having right now is the majority of cores are on vacation/holiday, and the rest are being pulled into internal work
16:40:04 <odyssey4me> #action odyssey4me to set 11.2.0 release date to the (tentative) date of 4 Sep
16:40:40 <evrardjp> palendae: when is the return from holidays?
16:40:53 <palendae> evrardjp: They're all different
16:41:05 <odyssey4me> evrardjp we have three returning next week I think
16:42:10 <Sam-I-Am> nothing is happening with the wedged gate :/
16:42:37 <odyssey4me> Sam-I-Am we're waiting for gate results, but https://review.openstack.org/209998 should unwedge it
16:42:51 <Sam-I-Am> odyssey4me: cool
16:43:34 <odyssey4me> I'm still having issues with bumping SHA's in master though - something seems to have changed upstream that's breaking our AIO network config
16:43:43 <odyssey4me> instances are not getting DHCP
16:43:56 <Sam-I-Am> wouldnt surprise me if neutron is beoken
16:44:07 <Sam-I-Am> should see if the neutron gates are passing
16:44:21 <Sam-I-Am> neutron broke kilo for a while too
16:44:21 <odyssey4me> Sam-I-Am Apsu I could do with some help with that, but that may have to wait until next week as I know you guys are tied up with other work right now
16:44:32 <Sam-I-Am> the old l2pop problem that blocked our release
16:44:59 <odyssey4me> Sam-I-Am we can chat after the meeting, perhaps you can help me figure it out
16:45:12 <Sam-I-Am> i have another meeting after this meeting, then more meetings
16:45:17 <Sam-I-Am> but you dont sleep, so we're good
16:45:19 <Apsu> Sam-I-Am sounds like your guy
16:45:33 <Sam-I-Am> i just need to kick a box
16:45:38 <odyssey4me> alright, if that's all then we can move to the channel for other discussions :)
16:46:01 <odyssey4me> thank you all for attending, even with your busy schedules
16:46:05 <odyssey4me> #endmeeting