16:03:18 <cloudnull> #startmeeting OpenStack Ansible Meeting
16:03:18 <openstack> Meeting started Thu Sep  3 16:03:18 2015 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:22 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:03:24 <cloudnull> #chair odyssey4me
16:03:24 <openstack> Current chairs: cloudnull odyssey4me
16:03:37 <cloudnull> #topic Agenda & rollcall
16:03:43 <odyssey4me> o/
16:03:44 <cloudnull> o/ whos all here today ?
16:04:23 <serverascode> o/
16:04:27 * mhayden 
16:04:33 <andymccr> o/
16:06:08 <cloudnull> ok so lets get started.
16:06:11 <cloudnull> #topic Review action items from last week
16:06:35 <cloudnull> Sam-I-Am to drop note on the ML for OSAD to ensure we're making the proper changes for liberty
16:06:36 <evrardjp> hello
16:07:06 <Sam-I-Am> cloudnull: what?
16:07:27 <cloudnull> ^ Sam-I-Am i've seen no note. liberty is just around the corner, can you get to that sometime soonish ?
16:07:37 <Sam-I-Am> cloudnull: i was assigned something?
16:07:43 <cloudnull> you were
16:07:52 <Sam-I-Am> glad i'm late to the party
16:08:08 <stevelle> better late than never?
16:08:40 <Sam-I-Am> i need a refresh on whatever this is
16:08:47 <cloudnull> Sam-I-Am:  http://eavesdrop.openstack.org/meetings/openstack_ansible_meeting/2015/openstack_ansible_meeting.2015-08-27-16.01.log.html
16:09:03 <cloudnull> 16:08:44 - 16:12:42
16:09:32 <cloudnull> next on the action item list: follow up with mattt regarding neutron changes - related to https://review.openstack.org/#/c/215584/
16:09:36 <Sam-I-Am> yeah, i had to bail when that came up
16:10:18 <andymccr> mattt isn't available atm i think
16:10:24 <odyssey4me> cloudnull I think that was for me, but it was done
16:10:31 <odyssey4me> we're waiting for that patch to merge now
16:10:40 <cloudnull> Sam-I-Am:  you bbl'd 9 seconds before the action item ....
16:10:59 <Sam-I-Am> cloudnull: these changes arent really architectural. just config changes... like other services get between releases.
16:11:23 <Sam-I-Am> the main one is that agent config that is currently in ml2_conf.ini gets broken out into agent config files
16:11:24 <cloudnull> odyssey4me: ok yea that patch is now accepted.
16:11:28 <Sam-I-Am> that deal was finally settled
16:11:47 <Sam-I-Am> also implementation of ml2 extensions, if necessary
16:12:08 <cloudnull> so the only follow up we should do on that is to see if theres a better way to do incremental migrations.
16:13:12 <cloudnull> however right now they work. as they've done in the past so its not pressing.
16:14:00 <odyssey4me> yep
16:14:49 <cloudnull> anything else from last week that we should be following up on ?
16:15:00 <odyssey4me> not to my knowledge
16:15:00 <cloudnull> based on the summary i think that was all we had.
16:15:08 <cloudnull> #topic Liberty Release Blueprints (note dependencies)
16:15:46 <cloudnull> looks like theres been some progress on https://blueprints.launchpad.net/openstack-ansible/+spec/liberty-upgrade-path
16:15:48 <odyssey4me> I added https://blueprints.launchpad.net/openstack-ansible/+spec/named-veths as a dependency, as it seems this should be sorted out asap
16:16:09 <cloudnull> +1
16:16:13 <Sam-I-Am> yarp
16:16:23 <cloudnull> palendae:  just needs some time to get at the rest of that spec
16:16:31 <Sam-I-Am> time
16:17:03 <cloudnull> mariadb 10 spec is ready for review https://blueprints.launchpad.net/openstack-ansible/+spec/upgrade-mariadb-v10 - https://review.openstack.org/#/c/203708/
16:17:10 <Sam-I-Am> cloudnull: do we need a general liberty-things spec that we can hit for changes like neutron bits?
16:17:27 <odyssey4me> cloudnull yeah that review is consistently failing, so there must be an issue there
16:17:36 <palendae> cloudnull: I had some of that updated, but a drive-by patchset, so I'm trying to figure that out
16:17:56 <odyssey4me> Sam-I-Am personally I don't think we need a spec for the liberty bits - we just add the blueprint link
16:18:11 <Sam-I-Am> odyssey4me: ok
16:18:47 <Sam-I-Am> palendae: if you give me the things, i can update the spec
16:18:52 <odyssey4me> it makes better sense to me to have spec for bigger changes in functionality, or new features - but the bp is fine for the basic goal
16:19:31 <cloudnull> odyssey4me:  ill have to redigg into the mariadb10 changes i had to rebase it this morning.
16:19:35 <Sam-I-Am> there's openstack changes, and osad architectural/ansible changes... neutron not impacting the latter
16:19:40 <odyssey4me> Sam-I-Am it's better if you simply add comments to the review and let the author handle the changes
16:19:47 <palendae> Sam-I-Am: Or I could just write the same things in the spec
16:19:48 <cloudnull> same with rabbitmq
16:19:51 <cloudnull> https://blueprints.launchpad.net/openstack-ansible/+spec/compartmentalize-rabbitmq
16:21:28 <cloudnull> at this point the one spec that I've not worked on is https://blueprints.launchpad.net/openstack-ansible/+spec/limit-mysql-config-distribution
16:21:36 <cloudnull> https://review.openstack.org/#/c/203754/
16:22:04 <cloudnull> if someone has "time" it would be great to get some help with that
16:24:03 <prometheanfire> hi
16:24:10 <odyssey4me> yeah, the rest of the work for liberty is really to figure out the deprecated bits and to adjust the configs, policies, etc
16:24:20 <cloudnull> ++
16:25:00 <cloudnull> I think that we should spend the next couple of weeks on stability and just that.
16:25:14 <odyssey4me> it might be best to itemise each service into a blueprint, then assign those individually
16:25:24 <odyssey4me> no specs - just a blueprint for easier tracking
16:25:38 <cloudnull> Im game with that
16:25:53 <odyssey4me> the alternative is that we just use the one blueprint
16:26:16 <cloudnull> #action make a BP to track each OS service and remove deprecated variables
16:26:21 <prometheanfire> do we know how much work is needed for kilo -> liberty upgrades?
16:26:30 <cloudnull> you will when you do the work
16:26:39 <prometheanfire> thanks
16:26:40 <cloudnull> :)
16:26:44 * cloudnull a helper
16:26:57 <prometheanfire> right after we finish juno -> kilo
16:27:01 <cloudnull> #topic Mitaka Summit Discussion Agenda (input required)
16:27:10 <cloudnull> #link https://etherpad.openstack.org/p/openstack-ansible-mitaka-summit
16:27:11 <odyssey4me> we could do with https://review.openstack.org/168976 being reviewed
16:27:23 <prometheanfire> ops will likely have a session on using containers infra side
16:27:46 <cloudnull> i updated the bottom of the etherpad
16:27:47 <cloudnull> Our requested rooms
16:28:08 <cloudnull> we requrested 2 workgroups , 1 fishbowl, and a contributors meetup on friday
16:28:24 <cloudnull> from the foundation the space is small and rooms are going to be at a premium
16:28:28 <prometheanfire> they'll also have a upgrade session we could probably talk at
16:28:46 <cloudnull> that said, ttx said that there will also be a lot of overflow tables
16:28:51 <cloudnull> which we can consume as needed.
16:29:03 <evrardjp> good to know
16:29:06 <prometheanfire> info here https://etherpad.openstack.org/p/TYO-ops-meetup
16:29:23 <odyssey4me> it may be worthwhile for us to do some sort of work session - perhaps to update docs for liberty?
16:29:33 <odyssey4me> docs are quickly falling behind
16:29:43 <odyssey4me> both kilo and liberty docs are horribly out of date
16:29:56 <cloudnull> Sam-I-Am: ^^
16:30:53 <cloudnull> prometheanfire:  on the ops etherpad , if you've not already, could you drop some bits there so that we can try and be part of their general discussion.
16:31:03 <prometheanfire> ya, will do
16:31:15 <cloudnull> getting into the moderators for the tokyo ops meetup might be a good thing too
16:31:29 <cloudnull> ++ lightning talks
16:31:46 <prometheanfire> ya, we can do the lightening talks for sure
16:32:19 <cloudnull> #action prometheanfire to get involved with the ops meetup ligtning and moderator talks
16:32:46 <cloudnull> # topic Reviews
16:32:49 <cloudnull> #topic Reviews
16:32:57 <cloudnull> what do we need to highlight for reviews
16:33:43 <cloudnull> tunable plugin - https://review.openstack.org/#/c/220212/
16:34:01 <odyssey4me> as always: http://bit.ly/openstack-ansible-review-starred
16:34:02 <cloudnull> ive seperated out the plugin from the replace, NOTE: i still need to update the replace review
16:34:54 <cloudnull> sigmavirus24:  if youre able I've updated the plugin in a new review implementing the comments you had on the initial patch
16:35:35 <cloudnull> #topic Open discussion
16:36:06 <cloudnull> the airing of grievances - does anyone have anything ?
16:36:24 <odyssey4me> nope, not me
16:36:31 <stevelle> thank you everyone for the work on build stability
16:36:36 <evrardjp> wasn't the tunable plugin supposed to be called update_template or template_update?
16:36:54 <sigmavirus24> cloudnull: will review
16:36:55 <odyssey4me> stevelle ++
16:37:14 <evrardjp> I agree with stevelle
16:37:19 <cloudnull> evrardjp: there was some talk and config_template is what was landed on
16:37:27 <evrardjp> ok
16:37:27 <cloudnull> however I'm open to change
16:37:38 <evrardjp> nope, whatever was decided in the last meeting is fine
16:38:22 <evrardjp> other question, should we define a session to work on the lxc template creation and distribution?
16:38:37 <cloudnull> sure that'd be awesome !
16:38:43 <odyssey4me> ++
16:38:49 <odyssey4me> a little mini sprint
16:39:31 <cloudnull> I think we can get a lot of those mini sprints done at the overflow tables.
16:39:47 <cloudnull> if we cant get a specific session for it
16:39:59 <cloudnull> but yes I think thats an awesome topic to cover.
16:40:06 <odyssey4me> just consider that we do have a lot we're trying to do, so it'd be best if we figure out what we must do and focus on it
16:40:37 <cloudnull> agreed
16:41:33 <evrardjp> so I guess you have a list in mind odyssey4me? ;)
16:41:46 <odyssey4me> oh, in other news: https://review.openstack.org/186684
16:42:25 <odyssey4me> evrardjp yeah, the blueprints already registered :) https://blueprints.launchpad.net/openstack-ansible
16:44:38 <cloudnull> ok so i guess we're done here.
16:44:42 <cloudnull> thank you everyone
16:44:55 <odyssey4me> o/
16:45:10 <cloudnull> #endmeeting