16:01:13 <cloudnull> #startmeeting OpenStack Ansible Meeting
16:01:15 <openstack> Meeting started Thu Sep 17 16:01:13 2015 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:18 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:52 <evrardjp> o/
16:02:00 <prometheanfire> \o
16:02:02 <cloudnull> #topic Agenda & rollcall
16:02:07 <Sam-I-Am> yo
16:02:39 <cloudnull> #chair odyssey4me
16:02:39 <openstack> Current chairs: cloudnull odyssey4me
16:02:39 <odyssey4me> o/
16:03:06 <serverascode> o/
16:03:35 <cloudnull> so lets jump right in
16:03:39 <cloudnull> #topic Review action items from last week
16:03:46 <cloudnull> Sam-I-Am to create an etherpad for the config changes he finds for future OSAD implementation
16:03:55 <Sam-I-Am> i did this
16:03:58 <Sam-I-Am> well, doing
16:04:26 <cloudnull> link ?
16:04:49 <odyssey4me> we had a link already
16:04:54 <Sam-I-Am> yeah, we did
16:05:00 <evrardjp> we did ;)
16:05:00 <Sam-I-Am> i have it here somewhere buried in tabs
16:05:06 <cloudnull> i found it
16:05:08 <cloudnull> #link https://etherpad.openstack.org/p/liberty-config-changes
16:05:09 <Sam-I-Am> https://etherpad.openstack.org/p/liberty-config-changes
16:05:32 <cloudnull> so its still a work in progress, but gives us something to start reviewing.
16:05:52 <Sam-I-Am> its getting updated as i hit services
16:06:06 <Sam-I-Am> right now i'm in the middle of rearchitecting the upstream install guide, so there's a pause on the neutron stuff
16:06:24 <Sam-I-Am> looks like middleware changed again, so i get to dig through the gates for those updates
16:06:47 <cloudnull> sweet. great work on those bits. we'll keep watchfull on the etherpad.
16:06:51 <cloudnull> next
16:06:53 <cloudnull> odyssey4me to switch the blueprint for juno->liberty upgrades to 12.1.0
16:07:15 <odyssey4me> yup, done
16:07:33 <prometheanfire> uh, we are doing juno -> liberty without going through kilo?
16:07:48 <evrardjp> wasn't it kilo -> liberty in the previous meeting?
16:07:59 <stevelle> deja vu
16:08:14 <odyssey4me> yeah, I put the wrong thing in :p
16:08:19 <evrardjp> the action points weren't updated ;)
16:08:59 <cloudnull> palendae: Sam-I-Am: we also have https://review.openstack.org/#/c/207713/ which is liberty upgrade related,
16:09:20 <cloudnull> git-harry: had a lot of good feedback there. itd be good to get that updated / replied to when possible.
16:10:07 <odyssey4me> palendae ^
16:10:26 <odyssey4me> oh, silly me didn't see that he was already notified :p
16:10:36 <palendae> Yep, I'm gona look over it
16:10:50 <palendae> Oh wait
16:10:53 <palendae> That's mine
16:11:12 <cloudnull> it is.
16:11:19 <cloudnull> so moving on
16:11:25 <cloudnull> #topic Liberty Release Blueprints (note dependencies)
16:11:33 <cloudnull> #link https://blueprints.launchpad.net/openstack-ansible/+spec/liberty-release
16:12:14 <cloudnull> in that segment the bigest one pending is https://blueprints.launchpad.net/openstack-ansible/+spec/tunable-openstack-configuration
16:12:33 <cloudnull> which has the following items that need to be reviewed https://review.openstack.org/#/q/status:open+project:openstack/openstack-ansible+branch:master+topic:bp/tunable-openstack-configuration,n,z
16:12:49 <evrardjp> such a cool spec. If it was one facebook I'd almost like it.
16:13:04 <cloudnull> ha
16:13:07 <evrardjp> (the first one)
16:13:08 <odyssey4me> lol
16:13:12 <odyssey4me> you can +1 :p
16:13:26 <stevelle> I'm going through review of those but taking my time
16:13:37 <cloudnull> twitter is the new facebook
16:13:44 <evrardjp> I don't have them
16:13:46 <evrardjp> :p
16:14:19 <evrardjp> sorry for the off-topic.
16:14:30 <cloudnull> not at all.
16:14:32 <cloudnull> :)
16:14:42 <cloudnull> next in that which needs some review https://blueprints.launchpad.net/openstack-ansible/+spec/named-veths
16:15:06 <cloudnull> oh nevermind i guess the docs merged.
16:15:17 <odyssey4me> cloudnull there's an issue with https://review.openstack.org/178259 which needs fixing too
16:15:38 <cloudnull> #link https://blueprints.launchpad.net/openstack-ansible/+spec/upgrade-mariadb-v10
16:15:56 <cloudnull> yea that was next. i need to get back to reviewing / updating that
16:16:07 <cloudnull> unless someone else wants to step in
16:16:44 <cloudnull> #action cloudnull - continue working on https://review.openstack.org/178259  for MariaDB 10
16:17:09 <cloudnull> and this needs to go to
16:17:11 <cloudnull> #link https://blueprints.launchpad.net/openstack-ansible/+spec/limit-mysql-config-distribution
16:18:05 <odyssey4me> yeah, if that slips then I think it's ok
16:18:28 <cloudnull> next on my pile is mariadb but i hope to tackle that soon.
16:19:03 <cloudnull> the rest of the major specs look ok
16:19:23 <cloudnull> unless i missed one ?
16:19:27 <cloudnull> or something else ?
16:19:50 <odyssey4me> nope - just need more reviews
16:19:55 <prometheanfire> not sure if we are there yet, but ipv6 spec?
16:19:56 <cloudnull> ++ please :)
16:20:09 <prometheanfire> not a req for liberty though
16:20:17 <prometheanfire> actaully mitaka
16:20:17 <evrardjp> prometheanfire: wasn't that supposed to be also worked in the summit?
16:20:21 <odyssey4me> ipv6 spec is less urgent as it's for the mitaka cycle
16:20:27 <cloudnull> ^ that
16:20:31 <cloudnull> what evrardjp said
16:20:32 <prometheanfire> ya, forgot about that
16:20:43 <cloudnull> #topic Mitaka Summit Discussion Agenda (input required)
16:21:03 <cloudnull> odyssey4me:  has been working on this a bit , tyvm btw
16:21:38 <cloudnull> if you have things youd like to add into the sessions, please do so
16:22:07 <odyssey4me> or proposed sessions
16:22:16 <cloudnull> anything and everything is welcome .
16:22:24 <odyssey4me> we'll have to select sessions based on our final allocation of space
16:22:42 <odyssey4me> but please note the moderator, etc - don't just add a topic
16:22:59 <odyssey4me> also note that each session will require some preparation
16:23:05 <cloudnull> these sessions are about us as a community building all of this better so everything is welcome
16:24:04 <cloudnull> next
16:24:08 <cloudnull> #topic Docs
16:24:16 <cloudnull> -- Items in progress or otherwise in need of work --
16:24:25 <cloudnull> https://bugs.launchpad.net/openstack-ansible/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=choose&field.assignee=rpcdocs&field.bug_reporter=&field.bug_
16:24:26 <cloudnull> commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on
16:24:30 <evrardjp> thanks for the work done by the doc team first
16:24:30 <cloudnull> ah...
16:24:57 <Sam-I-Am> mmm, docs
16:25:05 <cloudnull> ++ evrardjp said, docs team is awesome !
16:25:35 <evrardjp> sorry if we sometimes put DocImpact without doing the doc that comes with it when we are in a hurry
16:25:38 <cloudnull> so the links are too damn big to paste in
16:25:45 <evrardjp> url shortner?
16:25:52 <cloudnull> yup its happening
16:26:07 <cloudnull> http://bit.ly/1iS6krb
16:26:29 <odyssey4me> #link https://bugs.launchpad.net/openstack-ansible/+bugs?field.assignee=rpcdocs
16:27:17 <cloudnull> these are the items we have with docimpact that may beed work
16:27:18 <cloudnull> #link http://bit.ly/1izGIiZ
16:27:30 <cloudnull> if anyone has cycles to help out thata would be great.
16:27:58 <evrardjp> I'm not sure to fully understand the DocImpact, I thought it was required to tag DocImpact when there is a change that can impact docs, even if the change is about docs itself
16:28:01 <evrardjp> is this still right?
16:28:24 <cloudnull> id say yes
16:28:28 <evrardjp> ok
16:28:35 <Sam-I-Am> noooo
16:28:39 <cloudnull> but the OS infra system will create an issue in launchpad
16:28:44 <cloudnull> anytime you use the tag
16:28:53 <Sam-I-Am> you use docimpact if you have a code change that requires docs, but does not include docs
16:29:12 <evrardjp> ok Sam-I-Am
16:29:12 <Sam-I-Am> if you include docimpact with a docs patch, it makes a new bug that tells docs folks it needs documentation
16:29:14 <cloudnull> ^ from the docs people.
16:29:27 <Sam-I-Am> realistically, you should include docs with your patch
16:29:40 <cloudnull> so lets stop doing that from now on :)
16:29:41 <Sam-I-Am> then if you want help making them better, tag a docs person in the review
16:29:41 <evrardjp> Sam-I-Am: I thought this was need to follow branches
16:30:03 <evrardjp> in order to follow the documentation changes accross merges, starting from master to the end branch
16:30:39 <evrardjp> -1 if no doc is provided then
16:30:42 <evrardjp> ok
16:31:02 <Sam-I-Am> what do you mean?
16:31:21 <evrardjp> the best way to achieve good docs is to not merge if there is no doc ;)
16:31:26 <Sam-I-Am> well, yeah
16:31:35 <Sam-I-Am> docimpact is just a way to toss it over the fence
16:31:40 <Sam-I-Am> usually to someone that doesnt understand what you did
16:31:53 <Sam-I-Am> its best used when something is obvious
16:31:55 <odyssey4me> I am a fan of rather including docs as we go.
16:32:08 <evrardjp> yeah, I think it should be done that way too
16:32:22 <evrardjp> I've put docimpact in the past to track the docchanges
16:32:40 <Sam-I-Am> yeah, and it made a mess of docs bug tracking
16:32:47 <cloudnull> ^ me too
16:32:51 <Sam-I-Am> 'hey wait, this is docs'
16:32:53 <odyssey4me> I do think that there's some base work that needs to be done to update the docs to make this entirely feasible, but that's not going to happen unless we start to enforce it.
16:33:04 <cloudnull> ++
16:33:09 <evrardjp> +1
16:33:35 <evrardjp> I'll help fix what I broke in the docs personnally Sam-I-Am. Mea culpa!
16:33:40 <cloudnull> #action Everyone - start -1 changes that dont had docs
16:33:42 <Sam-I-Am> people either tag me in reviews, or i see docs things when i look through all reviews
16:33:54 <cloudnull> so regarding all of these things - http://bit.ly/1izGIiZ http://bit.ly/1iS6krb - we need to pick through doc the changes where needed and close items that are irrelevant.
16:35:59 <cloudnull> moving on
16:36:03 <cloudnull> #topic Reviews
16:36:14 <cloudnull> #link https://review.openstack.org/#/q/starredby:cloudnull+status:open,n,z
16:36:22 <cloudnull> #link http://bit.ly/openstack-ansible-review-starred
16:36:30 <cloudnull> these are some inflight things that need to be looked at
16:40:32 <cloudnull> sorry ... irc bouncer connection was dropped
16:41:26 <cloudnull> we always need more reviews. and if you can help out on some of the inflight changes it would be most appreciated.
16:41:37 <evrardjp> noted
16:41:55 <cloudnull> #topic Upcoming Milestones
16:42:05 <cloudnull> #link https://launchpad.net/openstack-ansible/+milestone/liberty-3
16:42:24 <odyssey4me> oops, forgot to update that - that one's been released
16:42:40 <odyssey4me> 12.0.0 is the next for master
16:42:49 <cloudnull> #link https://launchpad.net/openstack-ansible/+milestone/12.0.0
16:42:55 <cloudnull> ha.
16:43:04 <cloudnull> was looking at that thinking damn we're awesome !
16:43:40 <cloudnull> and for kilo
16:43:46 <cloudnull> #link https://launchpad.net/openstack-ansible/+milestone/11.2.2
16:43:59 <cloudnull> sorry
16:44:03 <cloudnull> #link https://launchpad.net/openstack-ansible/+milestone/11.2.3
16:44:19 <odyssey4me> actually
16:44:22 <odyssey4me> #link https://launchpad.net/openstack-ansible/+milestone/11.2.3
16:44:27 <odyssey4me> ha
16:44:40 <cloudnull> i have a couple things to add to that but otherwise kilo is looking nice
16:44:47 <evrardjp> what's the deadline for it?
16:45:00 <cloudnull> 2015-09-25
16:45:01 <odyssey4me> this needs to go in for that https://review.openstack.org/224562
16:45:03 <evrardjp> 11 september according to launchpad ;)
16:45:18 <cloudnull> for 11.2.3
16:45:41 * odyssey4me forgot to update the agenda
16:46:15 <cloudnull> me too
16:46:30 <cloudnull> so lastly
16:46:33 <odyssey4me> if any other patches get backports then we'll add them to that milestone
16:46:33 <cloudnull> #topic Open discussion
16:46:50 <evrardjp> elections?
16:47:01 <cloudnull> sure
16:47:05 <evrardjp> cloudnull: you don't continue to be PTL?
16:47:17 <odyssey4me> elections are September 18 - September 24
16:47:20 <evrardjp> don't want to*
16:47:24 <cloudnull> https://github.com/openstack/election/tree/master/candidates/mitaka/OpenStackAnsible
16:47:31 <cloudnull> evrardjp: nope im stepping aside
16:47:42 <cloudnull> time for someone new :)
16:47:55 <stevelle> thanks for helping bring us this far cloudnull
16:47:57 <evrardjp> it's cool to let the others do, too. ;)
16:48:05 <evrardjp> yeah ty
16:48:06 <cloudnull> it is
16:48:22 <evrardjp> and good luck to our only candidate for now ;)
16:48:33 <cloudnull> so far our only candidate is odyssey4me , that said if someone wants to run please submit your proposal
16:48:36 <Sam-I-Am> the only one crazy enough
16:48:43 <Sam-I-Am> the rest of us like our health
16:48:50 <evrardjp> :)
16:48:52 <odyssey4me> lol
16:48:57 <Sam-I-Am> well, marginally better health
16:49:08 <cloudnull> moar beer youll be fine
16:49:13 <odyssey4me> so on the topic, I'd like to suggest that we rotate the chair for the bug triage and community meetings
16:49:15 <evrardjp> I've looked at his punchcard recently, yeah it's impressive... Most of you are ;)
16:49:34 <cloudnull> odyssey4me:  ++
16:50:03 <odyssey4me> ideally I'm thinking along the lines of someone volunteering to be the next chair early in the meeting
16:50:22 <cloudnull> I think thats a great idea
16:50:23 <odyssey4me> that way not all responsibility sits on one person all the time
16:50:53 <cloudnull> #vote should we have a rotating chair in meeting, yes or no?
16:51:06 <evrardjp> it makes sense
16:51:14 <odyssey4me> yes
16:51:38 <cloudnull> opps
16:51:40 <cloudnull> #startvote should we have a rotating chair in meeting, yes or no?
16:51:40 <openstack> Begin voting on: should we have a rotating chair in meeting, yes or no? Valid vote options are Yes, No.
16:51:41 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:51:53 <odyssey4me> #vote yes
16:51:55 <cloudnull> now go vote :)
16:51:58 <Sam-I-Am> #vote yes
16:51:59 <cloudnull> #vote yes
16:52:14 <evrardjp> #vote yes
16:52:19 <BjoernT> #vote yes
16:52:49 <cloudnull> while that happening , anything else anyone wants to bring up ?
16:52:54 <Sam-I-Am> well then
16:53:13 <prometheanfire> #vote yes
16:54:22 <cloudnull> #endvote
16:54:27 <openstack> Voted on "should we have a rotating chair in meeting, yes or no?" Results are
16:54:35 <cloudnull> so i think thats all we've got today .
16:54:47 <odyssey4me> it seems so
16:54:47 <evrardjp> Results are... ?
16:55:04 <cloudnull> it seems the bot is at a loss of words
16:55:08 <Sam-I-Am> fail
16:55:08 <odyssey4me> lol
16:55:22 <Sam-I-Am> maybe its case sensitive?
16:55:25 <cloudnull> likely because we all said, yes and not Yes
16:55:28 <cloudnull> :)
16:55:51 <evrardjp> it could have said "0% Yes"
16:55:53 <cloudnull> #action everyone - start a rotating chair at the beginning of meetings
16:55:59 <cloudnull> so we're done here.
16:56:01 <prometheanfire> such a good bot
16:56:03 <cloudnull> thanks everyone
16:56:03 <evrardjp> k thx
16:56:06 <prometheanfire> cya
16:56:09 <cloudnull> have a good one
16:56:11 <cloudnull> #endmeeting