16:00:47 <odyssey4me> #startmeeting OpenStack Ansible Meeting
16:00:48 <openstack> Meeting started Thu Oct  1 16:00:47 2015 UTC and is due to finish in 60 minutes.  The chair is odyssey4me. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:52 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:05 <odyssey4me> #topic Agenda & rollcall
16:01:05 <stevelle> o/
16:01:19 <odyssey4me> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:02:39 <evrardjp> oops I forgot to add my name on the last item, sorry
16:02:41 <cloudnull> presente !
16:02:47 <d34dh0r53> o/
16:03:08 <evrardjp> hello everyone!
16:03:13 <prometheanfire> ohai
16:03:18 <scarlisle> hello!
16:03:25 <jmccrory> hi
16:03:43 <serverascode> o/
16:05:31 <odyssey4me> #topic Review action items from last week
16:05:40 <odyssey4me> #link http://eavesdrop.openstack.org/meetings/openstack_ansible_meeting/2015/openstack_ansible_meeting.2015-09-17-16.01.html
16:06:03 <odyssey4me> cloudnull - continue working on https://review.openstack.org/178259 for MariaDB 10
16:06:12 * odyssey4me hands the mic to cloudnull
16:06:34 <odyssey4me> #link https://review.openstack.org/178259
16:07:16 <cloudnull> merged.
16:07:34 <cloudnull> master / liberty is running it now
16:07:37 <odyssey4me> I see that this has come up
16:07:37 <Bjoern_> I think we need to back port if possible
16:07:42 <odyssey4me> #link https://bugs.launchpad.net/openstack-ansible/+bug/1501168
16:07:42 <openstack> Launchpad bug 1501168 in openstack-ansible "ops-galera-recovery.rst inaccurate" [Undecided,New]
16:07:56 <odyssey4me> also
16:07:59 <odyssey4me> #link https://bugs.launchpad.net/openstack-ansible/+bug/1501196
16:07:59 <openstack> Launchpad bug 1501196 in openstack-ansible "infrastructure playbooks restart all galera at same time (10.1.5 to 10.1.14)" [Undecided,New]
16:08:24 <cloudnull> odyssey4me: the old recovery information is now, once again, acurate
16:08:33 <evrardjp> backport? Isn't it a too big change?
16:08:41 <odyssey4me> I do think that getting the docs updated for master regarding how to work with galera now is important.
16:08:42 <evrardjp> (don't know the full impact)
16:08:53 <evrardjp> odyssey4me, +1
16:08:59 <cloudnull> if we we're to backport mariadb 10 to kilo the restart all galera at the same time issue would be gone too.
16:09:16 <odyssey4me> I also think that any improvements that can be backported without changing the version is important, to bring the operations guides for Kilo back in line.
16:09:28 <cloudnull> so we can structurally backport some of the changes but i also agree that its a rather larg-ish change to backport to kilo at this point.
16:09:48 <odyssey4me> Personally I don't think it'll be wise to backport the full patch (including the version change) to Kilo.
16:10:32 <evrardjp> impact seems positive on greenfield deploys, so I don't have a problem with that, but I'd like more docs (especially on kilo to kilo updates)
16:10:39 <evrardjp> (my 2 cents)
16:11:03 <odyssey4me> evrardjp agreed, the only alternative would be to simply update the kilo docs
16:11:06 <evrardjp> db/messaging queues being the core of the danger
16:11:29 <evrardjp> ok
16:11:52 <odyssey4me> evrardjp +1 some docs on rabbitmq clustering would be useful as that seems to happen in ops reasonably often
16:12:20 <odyssey4me> something similar to the galera docs:
16:12:24 <odyssey4me> #link: http://docs.openstack.org/developer/openstack-ansible/install-guide/index.html#operations
16:12:39 <cloudnull> +1
16:13:18 <scarlisle> +1
16:13:20 <evrardjp> +1
16:13:35 <odyssey4me> any volunteers to pull that rabbitmq docs together?
16:14:13 <evrardjp> I definitely don't have the skills for that, sorry
16:14:33 <cloudnull> i'd love too but i have too many irons in the fire already to commit to it for now.
16:15:28 <odyssey4me> ok, for now I'll register a bug for it to be done - hopefully someone can pick it up some time soon or in the near future
16:15:35 <cloudnull> ++
16:15:46 <evrardjp> that's the best compromise :D
16:15:53 <odyssey4me> #action odyssey4me to register a bug to add docs for rabbitmq cluster recovery
16:16:14 <odyssey4me> any volunteers to update the docs for galera cluster recovery?
16:16:30 <cloudnull> note they only need to be updated for kilo
16:16:32 <evrardjp> and for mariadb changes (if upgrade happens to kilo)?
16:16:37 <cloudnull> master/liberty are now correct
16:16:44 <odyssey4me> and any volunteers to backport the functional changes (not the db version change) from master to kilo?
16:17:08 <cloudnull> i can pick apart my existing change, if nobody else wants to do the work
16:17:30 <cloudnull> but it may be a minute before i get to it
16:18:12 <stevelle> maybe file something for the future on that one
16:18:38 * mhayden stumbles in
16:18:46 <cloudnull> o/ mhayden
16:18:48 <odyssey4me> yeah, ok I'll file a bug for an update of the kilo docs or a backport of the functional changes
16:19:23 <odyssey4me> #action odyssey4me to file a bug for an update of the galera kilo docs or a backport of the functional changes implemented for MariaDB 10 in master
16:19:36 <odyssey4me> Everyone - start -1 changes that dont had docs
16:19:46 <evrardjp> thanks odyssey4me and cloudnull
16:19:54 <odyssey4me> we seem to be getting a little better at this
16:20:14 <odyssey4me> we've had quite a few docs updates recently, with thanks to evrardjp and mhayden among others
16:20:27 <odyssey4me> I hope to see more.
16:20:37 <odyssey4me> everyone - start a rotating chair at the beginning of meetings
16:20:57 <odyssey4me> This was an idea I presented last week. Any volunteers to chair the next meeting?
16:21:44 <odyssey4me> It's not too much work - just a few minutes to check the agenda and to keep the flow of the meeting.
16:22:08 <prometheanfire> I'd do it but don't know the proceedure too well
16:22:23 <prometheanfire> now with more e
16:22:26 <evrardjp> we can check on previous week log for that ;)
16:22:31 <odyssey4me> prometheanfire it's easy enough, and we'll be here to support you :)
16:22:35 <evrardjp> next week for me won't work, I'll tell you if I can do the week afterwards
16:22:38 <prometheanfire> sure then
16:22:43 <odyssey4me> great!
16:22:53 <odyssey4me> #action prometheanfire to chair the next community meeting
16:23:03 <evrardjp> thanks prometheanfire !
16:23:05 <odyssey4me> Any volunteers to run the Tue bug triage?
16:23:45 <prometheanfire> ha HA, dodged that bullet
16:23:55 <odyssey4me> d34dh0r53 ping :p
16:24:01 <evrardjp> indeed prometheanfire ;)
16:24:17 <cloudnull> odyssey4me: I can chair that one if needed. <-- cc d34dh0r53 :)
16:24:31 <odyssey4me> alright, great
16:24:35 <mhayden> it makes it hard to type when my chair is rotating
16:24:38 <d34dh0r53> I'll take that one next week
16:24:49 <cloudnull> boom !
16:24:57 <odyssey4me> super! it'll be great to have some variety :)
16:24:58 <evrardjp> mhayden should do it, because of what he said
16:25:01 * cloudnull passed the buck
16:25:08 <prometheanfire> like a pro
16:25:13 <evrardjp> it deserves a penalty!
16:25:14 <odyssey4me> #action d34dh0r53 to chair the Tue bug triage for next week
16:25:37 <d34dh0r53> :thumbsup:
16:25:40 <evrardjp> thanks d34dh0r53 then :)
16:25:43 <odyssey4me> #topic Liberty Release Blueprints (note dependencies)
16:25:45 <cloudnull> thanks d34dh0r53
16:25:54 <odyssey4me> #link https://blueprints.launchpad.net/openstack-ansible/+spec/liberty-release
16:26:32 <odyssey4me> #link https://launchpad.net/openstack-ansible/+milestone/12.0.0
16:26:48 <odyssey4me> so I think we're doing pretty well!
16:27:08 <odyssey4me> cloudnull how's it going with https://blueprints.launchpad.net/openstack-ansible/+spec/enable-venv-support-within-the-roles ?
16:27:53 <cloudnull> this is what i've gotten done so far https://review.openstack.org/#/q/status:open+project:openstack/openstack-ansible+branch:master+topic:bp/enable-venv-support-within-the-roles,n,z
16:27:58 <odyssey4me> #action odyssey4me to ping javeriak regarding progress for https://blueprints.launchpad.net/openstack-ansible/+spec/modularize-neutron-liberty and https://blueprints.launchpad.net/openstack-ansible/+spec/plumgrid-support-liberty
16:28:22 <cloudnull> if some folks wouldn't mind reviewing a few of those it'd be appreciated.
16:28:37 <cloudnull> it all seems to work quiet well.
16:28:48 <odyssey4me> cloudnull that is looking pretty good - what's missing there? nova - anything else?
16:29:12 <cloudnull> and in testing im able to upgrade from kilo > liberty without dealing with epochs
16:29:37 <cloudnull> odyssey4me:  neutron nova swift
16:30:09 <cloudnull> horizon was a bit of a pain in the ass but i got that worked out this morning
16:30:14 <prometheanfire> nice
16:31:09 <odyssey4me> ah, very cool - I'm guessing that neutron & nova will be a bit fiddly too
16:31:19 <cloudnull> actually i dont think so
16:31:40 <cloudnull> horizon and keystone have been the most fiddly so far
16:31:48 <evrardjp> yeah I think too
16:31:49 <evrardjp> ><
16:31:55 <cloudnull> and its because they run behind apache
16:32:21 <odyssey4me> ah, that work's important because I see that more and more projects are moving towards that model
16:32:22 <evrardjp> ofc, and their multiple paths :p
16:32:54 <cloudnull> evrardjp: yea it made it a fun time to work out.
16:33:01 <evrardjp> :)
16:33:05 <cloudnull> but it runs quite well now.
16:33:14 <evrardjp> good job, nice
16:33:40 <odyssey4me> it'll be nice to see that bake a little, and when we move onto focusing on the upgrade work for 12.1.0 that'll make everyone's lives a lot simpler
16:33:45 <cloudnull> if all goes well ill have nova and neutron out today
16:34:02 <odyssey4me> that's excellent news
16:34:09 <prometheanfire> the harder ones I'd think
16:34:48 <odyssey4me> I've done a little work on updating to Liberty RC1 for some projects: https://review.openstack.org/#/q/status:open+project:openstack/openstack-ansible+branch:master+topic:bp/liberty-release,n,z
16:35:58 <odyssey4me> the gate checks seem to be going very slowly - I think we're really pushing the limits and might need to do this: https://review.openstack.org/221957
16:36:40 <odyssey4me> that may have to be done to help get things moving until this work starts: https://review.openstack.org/221009
16:36:41 <stevelle> I have something partially baked for Horizon for RC1
16:36:46 <stevelle> just haven't submitted yet
16:36:54 <cloudnull> stevelle: ++
16:36:57 <odyssey4me> ah stevelle great!
16:37:17 <odyssey4me> if I could ask that anyone working on any of this stuff please submit a review at least once per day
16:37:32 <odyssey4me> it'll help notify others that work is being done
16:38:15 <odyssey4me> for anyone who wants to work on the stuff I started with, please ping me - I'm not trying to hog them and am happy for anyone to co-author the patches
16:39:10 <odyssey4me> any volunteers for the final bits that have no assignees in https://review.openstack.org/221189 ?
16:39:51 <odyssey4me> miguelgrinberg any chance you can spend some time on heat?
16:41:16 <odyssey4me> alright, we'll leave that standing
16:41:31 <odyssey4me> #topic Reviews - Backport of the config_template into Kilo
16:41:50 <cloudnull> IMO i think this should go
16:42:13 <cloudnull> related changes https://review.openstack.org/#/q/status:open+project:openstack/openstack-ansible+branch:kilo+topic:bp/tunable-openstack-configuration,n,z
16:42:35 <cloudnull> this makes it possible for a deployer to override / use anything they need or want
16:42:43 <cloudnull> regardless of what we've templated.
16:43:13 <odyssey4me> d34dh0r53 I know that RPC is still working through a few bits related to upgrades. How does the team feel about this going through?
16:43:29 <prometheanfire> meaning we can focus on what we need vs what each osa consumer needs
16:43:50 <stevelle> This looks like a major quality of life improvement for a deployer/operator using OSA as well.
16:43:53 <odyssey4me> prometheanfire yes, this cuts the dev cycle for the requests like: can you add this config option please
16:44:00 <prometheanfire> we talked about it earlier and I think we are fine with it going into kilo
16:44:05 <scarlisle> I'm onboard.  Means fewer bugs support opens to you guys for adding more overrides :)
16:44:13 <odyssey4me> great stuff
16:44:13 <cloudnull> ^ that
16:44:31 <cloudnull> Bjoern_:  ^^ thoughts ?
16:44:47 <stevelle> I also feel that backports will help get this in use sooner, surfacing any bugs or shortcomings sooner.
16:44:49 <odyssey4me> I think it would be prudent to wait to release it until after we release 11.2.3 though - as soon as it's tagged I'll remove the block\
16:44:53 <Bjoern_> yeah full support from support
16:45:11 <Bjoern_> as I has said we need to stop creating bugs for simple template changes
16:45:12 <d34dh0r53> I agree with odyssey4me on waiting
16:45:14 <evrardjp> I'd minus one because I don't see docs that goes with these changes, according to previous comment
16:45:17 <prometheanfire> I see what you did there
16:45:27 <d34dh0r53> lol
16:45:40 <odyssey4me> evrardjp agreed - it'd be really nice to see a follow up patch to master showing how to use it
16:45:49 <d34dh0r53> I want a change to cherry pick and test this as well
16:45:56 <d34dh0r53> s/change/chance/
16:46:07 <cloudnull> docs https://review.openstack.org/#/c/228068/2/playbooks/library/config_template,cm
16:46:08 <scarlisle> odyssey4me +1
16:46:24 <odyssey4me> alright - any volunteers to put together a doc entry?
16:46:59 <cloudnull> do we want specific docs on how to use the module ?
16:47:07 <cloudnull> that are outside of the module lib itself ?
16:47:22 <BjoernT> I think we just need to expand the examples at https://review.openstack.org/#/c/228068/2/playbooks/library/config_template,cm
16:47:31 <odyssey4me> BjoernT ++
16:47:39 <stevelle> I think it would be helpful to reference it in the install guide
16:47:43 <BjoernT> actually showing how to use config_overrides
16:47:44 <evrardjp> good question... if there is a change to the deployer (because something was already one), then it deserves docs
16:47:46 <odyssey4me> ok, I'm happy to put something together tomorrow as a starting point for the install guide
16:48:01 <odyssey4me> it'll really help people know that it can be done and understand how to use it
16:48:10 <cloudnull> related https://github.com/ansible/ansible/pull/12555 and https://github.com/ansible/ansible-modules-core/pull/2171
16:48:19 <evrardjp> but it doesn't need to be really thorough, just pointing to code could be enough
16:48:21 <cloudnull> if that goes in the "docs" will be upstream for ansible2
16:48:35 <odyssey4me> #action odyssey4me to put together some docs on how to use the config_template for the install guide
16:48:40 <d34dh0r53> cloudnull: I think so, to me this seems like a major feature that you would want to let people know about
16:49:03 <odyssey4me> a quick note related to https://launchpad.net/openstack-ansible/+milestone/11.2.3
16:49:10 <odyssey4me> we will release it tomorrow
16:49:17 <evrardjp> nice to have upstreamed that, it will remove the need for docs in openstack-ansible :)
16:49:33 <cloudnull> evrardjp:  my thoughts exactly :)
16:49:43 <odyssey4me> we just need to get https://review.openstack.org/229275 merged, which is key for keystone stability
16:49:51 <odyssey4me> it's been voted on, so no worries there
16:50:02 <evrardjp> it could still be useful to mention how we use it and how a deployer can use/abuse it
16:50:05 <odyssey4me> the final one which we could do with some testing on is https://review.openstack.org/229803
16:50:31 <odyssey4me> d34dh0r53 can you give https://review.openstack.org/229803 a test run to validate that it actually does what it's supposed to do?
16:51:00 <d34dh0r53> odyssey4me: yeah, I'll take a look at it this afternoon
16:51:01 <odyssey4me> andymccr did a test run this morning and thinks it does, but the apt mirror failed half way through :/
16:51:19 <cloudnull> odyssey4me:  it worked for me this morning
16:51:26 <cloudnull> and i rolled it up as a dep here https://review.openstack.org/#/c/224137/
16:51:36 <BjoernT> is there a way that we can get notified if the apt mirror fails ?
16:51:41 <odyssey4me> excellent cloudnull
16:51:49 <cloudnull> cc BjoernT scarlisle ^
16:51:51 <odyssey4me> BjoernT it all depends which apt mirror is used :p
16:52:33 <odyssey4me> anyway, I think it's a pretty crucial fix to simplify the upgrades and make them more reliable
16:52:37 <BjoernT> http://rpc-repo.rackspace.com in our case
16:52:52 <odyssey4me> BjoernT not that mirror - it was the rax ubuntu mirror
16:53:03 <odyssey4me> probably a london endpoint, if there is such a thing
16:53:03 <cloudnull> https://mirror.rackspace.com/ubuntu/
16:53:04 <BjoernT> yeah I had issues with both
16:53:52 <odyssey4me> we're a bit out of time - evrardjp  you had something you wanted to chat about?
16:54:01 <odyssey4me> #topic Open discussion
16:54:20 <prometheanfire> I'd like input into what you'd like to see for the ops infra containers talk
16:54:29 <prometheanfire> https://etherpad.openstack.org/p/TYO-ops-infrastructure-containers
16:54:32 <cloudnull> I'd throw it out that if the cores have time we need to get https://review.openstack.org/#/c/224137/  in sooner than later.
16:54:41 <prometheanfire> also, we might want to be at this talk as well https://etherpad.openstack.org/p/TYO-ops-upgrades
16:54:41 <evrardjp> yeah, it was about the ansible-galaxy requirements
16:54:44 <scarlisle> Is there any way we can get https://review.openstack.org/#/c/224137/ pushed through?
16:55:02 <cloudnull> evrardjp: sure.
16:55:19 <evrardjp> first I'm opening all this open discussion topics :)
16:55:21 <prometheanfire> also, was gonna give a 5 min talk about cinder container conversion to physhosts
16:55:38 <prometheanfire> but might change that, and am open to suggestions
16:55:39 <jmccrory> any plans to gate upgrades between branches?
16:55:48 <evrardjp> whatever, my conversation can wait, we can comment on the commit
16:55:58 <evrardjp> but I'd like ppl to tell what they think of it then
16:56:18 <cloudnull> evrardjp: i think what you have is good. i like the batteries included approach .
16:56:27 <evrardjp> https://review.openstack.org/#/c/218818/
16:56:35 <evrardjp> there was a dicussion
16:56:45 <evrardjp> about whether we should include the batteries or not ;)
16:56:57 <cloudnull> i like batteries :)
16:56:59 <evrardjp> so keep using the example file vs using the file
16:57:35 <evrardjp> Pros: It works directly.
16:57:41 <evrardjp> Cons: it puts every deployer into the position where that extra role is downloaded whether they want it or not
16:57:51 <evrardjp> (extract from the chan conversation we had)
16:57:53 <cloudnull> jmccrory: not yet, however we're looking at adding periodic jobs in the infra gate
16:57:57 <prometheanfire> if people could update this with what they'd like to see that'd be nice :D https://etherpad.openstack.org/p/TYO-ops-infrastructure-containers
16:58:14 <cloudnull> first up is a gate from last juno to last kilo but thatll expand im sure.
16:58:31 <odyssey4me> #action everyone to add what they'd like to see as a ops chat on https://etherpad.openstack.org/p/TYO-ops-infrastructure-containers
16:58:34 <cloudnull> evrardjp: i dont ming the extra role download
16:58:41 <prometheanfire> thanks :D
16:58:50 <cloudnull> *mind
16:58:54 <evrardjp> odyssey4me, ok too for the extra role dl ?
16:59:10 <evrardjp> if I got two yes, It's a go for me, right? :D
16:59:14 <odyssey4me> Let's take the discussion about https://review.openstack.org/224137 to the channel after the meeting
16:59:18 <evrardjp> k
16:59:32 <cloudnull> if we're moving to external roles i dont think the deployer should have to modify a file to get the things they need
16:59:32 <odyssey4me> and the same for https://review.openstack.org/218818
16:59:33 <evrardjp> same for https://review.openstack.org/#/c/218818/
16:59:51 <odyssey4me> we're pretty much out of time - let's move over to #openstack-ansible and continue
16:59:55 <evrardjp> ok
16:59:58 <evrardjp> thanks for the meeting
17:00:05 <odyssey4me> thanks you all!
17:00:05 <cloudnull> thanks everyone !
17:00:08 <prometheanfire> cya
17:00:12 <odyssey4me> #endmeeting