16:00:42 <prometheanfire> #startmeeting OpenStack Ansible Meeting
16:00:43 <openstack> Meeting ended Thu Oct 8 16:00:32 2015 UTC. Information about MeetBot at http://wiki.debian.org/MeetBot . (v 0.1.4)
16:00:44 <openstack> Minutes: http://eavesdrop.openstack.org/meetings/openstack_search/2015/openstack_search.2015-10-08-15.00.html
16:00:45 <openstack> Minutes (text): http://eavesdrop.openstack.org/meetings/openstack_search/2015/openstack_search.2015-10-08-15.00.txt
16:00:46 <TravT> thanks everybody!
16:00:47 <openstack> Log: http://eavesdrop.openstack.org/meetings/openstack_search/2015/openstack_search.2015-10-08-15.00.log.html
16:00:48 <openstack> Meeting started Thu Oct 8 16:00:42 2015 UTC and is due to finish in 60 minutes. The chair is prometheanfire. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:52 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:55 <palendae> o/
16:00:57 <prometheanfire> #topic Agenda & rollcall
16:01:04 <cloudnull> o/
16:01:07 <palendae> o/
16:01:10 <prometheanfire> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:01:20 <prometheanfire> o/
16:03:11 <prometheanfire> #topic Review action items from last week
16:03:18 <prometheanfire> #link http://eavesdrop.openstack.org/meetings/openstack_ansible_meeting/2015/openstack_ansible_meeting.2015-10-01-16.00.log.html
16:04:02 <dstanek> o/
16:04:33 <prometheanfire> not too sure about what we have to go over from last time
16:04:40 <cloudnull> #link summary http://eavesdrop.openstack.org/meetings/openstack_ansible_meeting/2015/openstack_ansible_meeting.2015-10-01-16.00.html
16:05:01 <prometheanfire> neat
16:06:45 <prometheanfire> odyssey4me to register a bug to add docs for rabbitmq cluster recovery
16:07:00 <prometheanfire> openstack: status on that?
16:07:50 <prometheanfire> and he's not here :|
16:08:05 <prometheanfire> and had all the tasks assigned to him
16:08:18 <stevelle> all but the one where you chair this meeting :)
16:08:31 <prometheanfire> ya, well, next then...
16:08:31 <stevelle> and the bug triage
16:08:51 <prometheanfire> #topic Liberty Release Blueprints
16:09:06 <prometheanfire> # link https://blueprints.launchpad.net/openstack-ansible/+spec/liberty-release
16:09:55 <prometheanfire> # link https://bugs.launchpad.net/openstack-ansible/trunk/+bug/1482756
16:09:55 <openstack> Launchpad bug 1482756 in openstack-ansible trunk "networking fails due to new ebtables-based arp spoofing protection" [High,In progress] - Assigned to Jesse Pretorius (jesse-pretorius)
16:10:28 <jasondotstar> o/ sorry I'm late - first time joining.
16:11:27 <prometheanfire> it looks like the trunk fix was actually committed in https://review.openstack.org/210593
16:12:18 <prometheanfire> #action odyssey4me verify master has fix commited and change status of https://bugs.launchpad.net/openstack-ansible/trunk/+bug/1482756
16:12:18 <openstack> Launchpad bug 1482756 in openstack-ansible trunk "networking fails due to new ebtables-based arp spoofing protection" [High,In progress] - Assigned to Jesse Pretorius (jesse-pretorius)
16:12:52 <scarlisle> w
16:13:02 <prometheanfire> scarlisle: ?
16:13:13 <prometheanfire> #link https://bugs.launchpad.net/openstack-ansible/+bug/1491440
16:13:14 <openstack> Launchpad bug 1491440 in openstack-ansible "Restarting containers leads to 'dangling' veth interfaces" [Medium,In progress] - Assigned to Major Hayden (rackerhacker)
16:13:23 <scarlisle> disregard...wrong window had focus, ehhe
16:13:30 <prometheanfire> mhayden: mind updating that one?
16:13:47 <prometheanfire> mhayden: looks like it's all commited/released
16:14:35 <prometheanfire> #action mhayden update https://bugs.launchpad.net/openstack-ansible/+bug/1491440 with current status
16:14:35 <openstack> Launchpad bug 1491440 in openstack-ansible "Restarting containers leads to 'dangling' veth interfaces" [Medium,In progress] - Assigned to Major Hayden (rackerhacker)
16:14:41 <prometheanfire> #link https://bugs.launchpad.net/openstack-ansible/+bug/1491440
16:15:31 <prometheanfire> this is the only one that doesn't look like has anyone working on it
16:15:34 <cloudnull> welcome jasondotstar ! :)
16:16:31 <prometheanfire> anyone want to help with that? looks like it's fairly well defined as to what needs doing
16:17:09 <cloudnull> prometheanfire: the dangling veth issue is something that we can close out
16:17:14 <cloudnull> its been fixed .
16:17:22 <jasondotstar> thx
16:17:25 <prometheanfire> cloudnull: I know, just noted as such
16:17:42 <cloudnull> nice
16:18:35 <jasondotstar> looking to jump in somewhere, perhaps this is a decent one.
16:18:49 <BjoernT> Didn't we submit a pull request to lxc upstram to fix this more appropriately
16:19:25 <palendae> BjoernT: mhayden did, but who knows how long it'll take to get that released. And I'm not 100% his patch is the correct fix
16:19:26 <prometheanfire> BjoernT: think that's being tracked outside of OSA
16:19:42 <prometheanfire> jasondotstar: sounds good, thanks for volunteering :P
16:20:02 <prometheanfire> #action jasondotstar work on https://bugs.launchpad.net/openstack-ansible/+bug/1491440
16:20:02 <openstack> Launchpad bug 1491440 in openstack-ansible "Restarting containers leads to 'dangling' veth interfaces" [Medium,In progress] - Assigned to Major Hayden (rackerhacker)
16:20:08 <prometheanfire> bah
16:20:10 <prometheanfire> wrong one
16:20:21 <prometheanfire> meant https://bugs.launchpad.net/openstack-ansible/+bug/1469868
16:20:21 <openstack> Launchpad bug 1469868 in openstack-ansible "OpenStack Ansible Does Not Ship Glance Metadata Definitions" [Wishlist,Confirmed]
16:20:33 <prometheanfire> #link https://bugs.launchpad.net/openstack-ansible/+bug/1469868
16:20:56 <prometheanfire> that's the one no one is working on, seems laid out, etc
16:21:00 <jasondotstar> so 1469868 is the one that needs someone to pick up?
16:21:03 <jasondotstar> ack.
16:21:06 <prometheanfire> jasondotstar: yep
16:21:12 * jasondotstar looks
16:21:23 <cloudnull> that'd be aweome to get in
16:21:57 <jasondotstar> ok I'll take a look
16:22:02 <prometheanfire> cool
16:22:09 <stevelle> just give a shout it you need help along the way
16:22:16 <prometheanfire> #action jasondotstar work on https://bugs.launchpad.net/openstack-ansible/+bug/1469868
16:22:16 <openstack> Launchpad bug 1469868 in openstack-ansible "OpenStack Ansible Does Not Ship Glance Metadata Definitions" [Wishlist,Confirmed]
16:22:33 <prometheanfire> that's it for blueprints
16:22:34 <jasondotstar> oh i will :-) I work w/ the puppet guys too. quick to ask a qn. esp when I'm a n00b here.
16:22:51 <prometheanfire> #topic Mitaka Summit Discussion Agenda
16:23:02 <prometheanfire> #link https://etherpad.openstack.org/p/openstack-ansible-mitaka-summit
16:23:19 <prometheanfire> not too sure what needs doing there, you have input cloudnull?
16:23:59 <cloudnull> if anyone has input on things we should work on while at the summit we;d love to review them
16:24:19 <prometheanfire> ya, feel free to add items, etc etc
16:24:24 <cloudnull> any and all ideas are welcome.
16:24:38 <cloudnull> and the more we get there the less we'll assume :)
16:25:26 <prometheanfire> #topic docs
16:25:43 <prometheanfire> #link https://bugs.launchpad.net/openstack-ansible/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=choose&field.assignee=rpc
16:25:49 <prometheanfire> docs&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&
16:25:55 <prometheanfire> field.has_no_blueprints.used=&field.has_no_blueprints=on
16:25:58 <prometheanfire> well, that's not gonna work
16:26:10 <prometheanfire> #link https://goo.gl/SvwR6J
16:26:31 <prometheanfire> that's another place that needs love and would be somewhat easy to get commits into
16:27:06 <cloudnull> the docs are coming together nicely.
16:27:06 <BjoernT> Oh yes please
16:27:39 <prometheanfire> #topic reviews
16:27:45 <cloudnull> recently a lot of doc updates have gone through but if we can squash some of those it'd be great
16:28:29 <prometheanfire> #link https://review.openstack.org/#/c/224137
16:29:08 <prometheanfire> It seems that that review is getting a bit bikesheded, would be nice to actually get that done sometime
16:29:54 <prometheanfire> so, if people could review it that'd be nice :P
16:29:55 <BjoernT> Sean is testing this so I think we are pretty close
16:30:00 <prometheanfire> ya
16:30:15 <prometheanfire> #link https://review.openstack.org/#/c/226621
16:30:18 <scarlisle> aaand it failed :(
16:30:32 <scarlisle> I'll get with you in a bit cloudnull
16:30:51 <cloudnull> great
16:30:53 <prometheanfire> that'd be nice to clean up bug https://bugs.launchpad.net/openstack-ansible/+bug/1399383
16:30:53 <openstack> Launchpad bug 1399383 in openstack-ansible juno "General SSL support for all public endpoints including spice" [Wishlist,In progress] - Assigned to Jimmy McCrory (jimmy-mccrory)
16:31:01 <prometheanfire> to finish the backport
16:31:22 <prometheanfire> cloudnull: you wanna talk about the venv stuff or are you waiting on feedback from the ML?
16:31:36 <cloudnull> ill talk about it
16:31:40 <prometheanfire> go
16:31:56 <cloudnull> all of the venv reviews are here https://review.openstack.org/#/q/status:open+project:openstack/openstack-ansible+branch:master+topic:bp/enable-venv-support-within-the-roles,n,z
16:32:13 <prometheanfire> #link https://review.openstack.org/#/q/status:open+project:openstack/openstack-ansible+branch:master+topic:bp/enable-venv-support-within-the-roles,n,z
16:32:20 <cloudnull> which will allow the roles to deploy openstack bits into a venv
16:32:36 <cloudnull> this in particular is good for our "on metal" bits
16:32:53 <prometheanfire> solves the requests bug iirc
16:33:06 <cloudnull> so that issues where host packages arn't conflicting with our from source everything else.
16:33:35 <cloudnull> there have been a couple of reviews regarding the changes .
16:33:38 <cloudnull> more is always better
16:34:04 * cloudnull is done talking
16:34:10 <cloudnull> questions ?
16:34:23 <prometheanfire> also, any other reviews people want to talk about?
16:34:43 <stevelle> As far as you know are all of the patch sets stable or are further changes expected, barring feedback?
16:36:32 <cloudnull> they are stable
16:36:33 <prometheanfire> gonna close this topic in a min if no responses
16:36:48 <cloudnull> jesse had put in a review to change some things
16:36:55 <cloudnull> ill try to get that done today
16:37:32 <cloudnull> but you can test / run them almost as is even with the couple of nits that im going on,
16:37:45 <BjoernT> we are still doing backports into kilo via cherry pick ?
16:38:02 <cloudnull> yes
16:38:06 <BjoernT> cool
16:38:07 <cloudnull> #link https://review.openstack.org/#/c/229513/
16:38:13 <cloudnull> ^ stevelle
16:38:18 <prometheanfire> anyone else?
16:38:19 <cloudnull> those are the comments i have so far
16:38:30 <cloudnull> all reviews follow a very similar pattern
16:38:50 <stevelle> I started reviewing them but was interrupted in priorities. I'll resume this week
16:39:48 <prometheanfire> #topic Open discussion
16:40:45 <prometheanfire> 5 min for this, then close
16:41:12 <cloudnull> are there any issues in deployment that we should address?
16:41:51 <cloudnull> or something that needs to be backported to kilo that hasn't already
16:42:35 <palendae> cloudnull: I'm still moving on the backporting mariadb bootstrapping to Kilo. Hopefully I'l have a review up today, though may be WIP
16:42:53 <cloudnull> sweet!
16:43:16 <cloudnull> BjoernT: idk if you saw this https://review.openstack.org/#/c/228197/
16:43:19 <d34dh0r53> Anyone else getting no viable alternative at character '%' on their gerrit bookmarks?
16:43:34 <BjoernT> yes i did
16:43:41 <palendae> d34dh0r53: Yep
16:44:15 <BjoernT> yes I do get this too
16:44:22 <d34dh0r53> palendae: any fixes found?
16:44:33 <palendae> d34dh0r53: I saw it once and moved on, sorry
16:44:41 <d34dh0r53> mine does it every time
16:44:56 <d34dh0r53> hmm
16:45:36 <stevelle> infra upgraded gerrit afaict so all the old dashboards I have are broken
16:45:55 <stevelle> I'm just rebuilding them
16:47:27 <prometheanfire> anyone else?
16:47:34 <cloudnull> BjoernT: also https://review.openstack.org/#/c/232657/
16:47:58 <BjoernT> thanks, I test on kilo later the day
16:48:13 <cloudnull> sweet
16:51:23 <prometheanfire> ok, take it to #openstack-ansible
16:51:26 <prometheanfire> #endmeeting