16:01:37 <odyssey4me> #startmeeting OpenStack Ansible Meeting
16:01:38 <openstack> Meeting started Thu Dec 17 16:01:37 2015 UTC and is due to finish in 60 minutes.  The chair is odyssey4me. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:41 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:53 <mattt> \o
16:01:56 <odyssey4me> #topic Agenda & rollcall
16:02:09 <oneswig> \o
16:02:15 <Sam-I-Am> yo
16:02:17 <Sam-I-Am> in two meetings at once
16:02:54 <palendae> o/
16:05:10 <cloudnull> o/
16:05:20 <cloudnull> though only 1/2 here...
16:06:42 <odyssey4me> #topic Mid-Cycle Meetup
16:07:01 <odyssey4me> I owe everyone an update.
16:07:13 <Sam-I-Am> yep
16:07:28 <odyssey4me> The majority response on the ML when asked about location gave a response that they either would prefer the UK, or don't mind if it's in the US or UK.
16:07:58 <odyssey4me> We have also been offered co-location of the mid-cycle at the Ops meetup in Manchester in mind-Feb.
16:08:43 <odyssey4me> I've suggested that we have some sessions dotted in between the Ops meetup, but that we largely would prefer to attend the Ops sessions to learn from them.
16:09:21 <odyssey4me> Basically I have general agreement from the Ops meetup that we'll have a few sessions in the Ops mid cycle, but that we'll have a full day immediately afterwards.
16:09:29 <mhayden> nice
16:09:31 <odyssey4me> The day after that is AnsibleFest in London.
16:09:34 <oneswig> sounds good to me
16:09:58 <odyssey4me> So basically it's Mon-Tue (Ops plus a sprinkle of OSA), Wed (OSA), Thu (AnsibleFest)
16:10:06 <odyssey4me> Fri - go home broken
16:10:07 <odyssey4me> :p
16:10:09 <Sam-I-Am> lol
16:10:17 <Sam-I-Am> makes it easier to plan a long trip
16:10:22 <javeriak_> late to the party, but hey folks
16:10:24 <Sam-I-Am> ops only for 2 days overseas is a bit rough for USers
16:10:27 <odyssey4me> o/ javeriak_
16:10:34 <Sam-I-Am> or even o-a for a day
16:10:38 <palendae> Sam-I-Am: Well, it's the reverse usually for non-USers
16:10:46 <palendae> So evens out
16:10:54 <palendae> But yeah, a packed week is an easier argument
16:11:08 <odyssey4me> Given the situation that AnsibleFest is in London on Thu, it may be better for us to have our full day session at the Rackspace offices in Hayes, London.
16:11:52 <odyssey4me> Initially I was thinking of doing it in Manchester, but it may make more sense to do it on London. I'd like everyone's thoughts on what they'd prefer.
16:12:13 <mhayden> what's the travel like between manchester <-> London
16:12:14 <palendae> I'll abstain since I'm not sure I'll be able to go
16:12:34 <odyssey4me> Man <-> Lon is 4 hours by car or train, or ~1 hr by plane
16:12:34 <oneswig> If it's in London, not an early start as the Manchester OpenStack meetup is also that Tuesday night and I'd like to attend that too
16:13:08 <mhayden> odyssey4me: thanks -- gotta brush up on my UK geography
16:13:24 <mhayden> odyssey4me: not sure if i can swing travel, but your plan sounds good
16:14:16 <odyssey4me> oneswig oh, is there a Tue night party?
16:14:27 <oneswig> AFAIK
16:14:56 <oneswig> BTW Manchester-London more like 2.5-3 hours train, station-to-station, obviously way more door-to-door
16:15:01 <odyssey4me> well, I think I'd rather be late for AnsibleFest than for a day of hacking with you all :)
16:15:08 <mhayden> train fares look about 20-40 GBP between manchester/london, not bad
16:16:21 <odyssey4me> oneswig quite right, I think my 4 hours is from where I live door-to-door
16:17:03 <oneswig> Is there a venue readily available in Manchester?  Otherwise it's a one-horse race anyway
16:17:35 <odyssey4me> oneswig I haven't confirmed availability. So far I've checked costs and verified that Rackspace is happy to cover those.
16:18:25 <odyssey4me> The location being the same place as the Ops meetup. I've found a room I think will be perfect - projected screen and it can be setup as a boardroom so that we can hack together, but also throw a screen up if need be.
16:18:53 <odyssey4me> cloudnull ping?
16:19:07 <odyssey4me> javeriak_ thoughts?
16:19:14 <odyssey4me> mattt thoughts?
16:19:42 <odyssey4me> hughsaunders andymccr ?
16:20:25 <mattt> thoughts on location?  :)
16:20:30 <odyssey4me> yep
16:20:36 <javeriak_> hmm.. thinking, not sure i can swing travel then too; but it sounds good generally. So would everyone leave for London tues evening after the Ops sessions wind up
16:20:40 <mattt> seems logical doing it in manchester
16:21:07 <odyssey4me> mattt are you going to the Ops meetup?
16:21:16 <odyssey4me> javeriak_ Are you making it to the Ops meetup?
16:21:23 <mattt> odyssey4me: i haven't confirmed yet
16:21:24 <javeriak_> and i've lived in London, so I'm slightly more inclined towards that option as well :)
16:22:04 <javeriak_> If I'm traveling to UK then, I'd like to try to attend Ops too
16:22:16 <mattt> odyssey4me: would we need to pay for the room in manchester?  presumably yes right?
16:23:02 <odyssey4me> mattt yep, but we have sponsorship from Rackspace for the room
16:24:19 <mattt> odyssey4me: all depends on how many people from ops summit are able to attend, if a large number then it may be cheaper to stay in manchester especially without the added cost
16:24:29 <mattt> (of travel)
16:25:11 <odyssey4me> mattt sure, but the primary focus for our focused day is for contributors and for work we decide to do... it's not really for newcomers
16:25:30 <odyssey4me> the sessions we do in between the Ops sessions can be more open
16:25:38 <mattt> odyssey4me: then i'd imagine london is more suitable, since a # of us are based there
16:26:05 <odyssey4me> that's not to say that newcomers aren't welcome, but it's just to say that we need to knuckle down and get our hands dirty :)
16:26:39 <mattt> javeriak_: would be great if you can make it!
16:27:08 <palendae> odyssey4me: dolphm was telling me there are some Intel folks that are looking at getting into OSA, I'll try to point them at the discussion
16:27:29 <odyssey4me> palendae great!
16:28:18 <odyssey4me> ok, so no major preference from anyone - but the venue in London might be more suitable overall
16:28:44 <odyssey4me> let me find out if the venue in Manchester even has the room I'd like available, then I'll feed back to the ML
16:28:53 <mattt> sounds good
16:29:09 <oneswig> My only preference is that if I get to Hayes by 12, it's not winding up...
16:29:20 <odyssey4me> if anyone has any further thoughts, concerns or preferences, please respond on the ML
16:29:43 <odyssey4me> oneswig nope, if you do end up being late then you can jump into whatever sessions are still going
16:29:46 <javeriak_> thanks mattt; just need to see what work & projects are like around then, and if i can be spared
16:30:15 <cloudnull> odyssey4me: pong
16:30:20 <cloudnull> sorry was afk
16:30:29 <odyssey4me> cloudnull check backscroll :)
16:32:25 <odyssey4me> cloudnull any thoughts before we move on?
16:32:50 <cloudnull> nope
16:32:55 <cloudnull> in the UK is good by me
16:33:21 * cloudnull goes to get travel approval ...
16:33:52 <odyssey4me> lol, so no preference between Manchester and Hayes for the dedicated OSA day between the Ops meetup and AnsibleFest?
16:35:05 <palendae> whi?
16:35:08 <palendae> Whoops
16:35:29 <odyssey4me> ok, we need to move on to the next topic
16:35:37 <odyssey4me> #topic Release Planning and Decisions
16:35:43 <hughsaunders> I would vote London
16:36:18 <odyssey4me> thanks hughsaunders
16:36:40 <odyssey4me> if you could prod andymccr for a vote, assuming he's in the office, then that'd be good :)
16:36:46 <hughsaunders> ansiblefest is in London, so people can come to both
16:36:46 <andymccr> i vote London
16:36:51 <andymccr> ^ that
16:36:53 <mattt> andymccr voted berlin :(
16:36:57 <odyssey4me> hahaha
16:37:13 <odyssey4me> alright, then we have a clear preference - I'll arrange accordingly
16:37:25 <odyssey4me> right, on to release items
16:37:32 <andymccr> berlin would be quite cool never been
16:37:56 <odyssey4me> we have two releases schedule for today/tomorrow: 12.0.3 (Liberty) and 11.2.7 (Kilo)
16:38:05 <odyssey4me> #link https://launchpad.net/openstack-ansible/+milestone/11.2.7
16:38:12 <odyssey4me> #link https://launchpad.net/openstack-ansible/+milestone/12.0.3
16:38:19 <Prithiv> have anyone tried the new flowclassifier patch
16:38:56 <odyssey4me> Is anyone aware of any release blockers for those?
16:39:02 <palendae> I am not
16:39:04 <odyssey4me> Prithiv ?
16:39:06 <mattt> not i
16:39:32 <Prithiv> yes
16:39:44 <d34dh0r53> nor i
16:40:00 <odyssey4me> Prithiv was that a question mentioned for this meeting?
16:40:06 <Prithiv> nope...
16:40:11 <odyssey4me> :)
16:40:22 <Prithiv> am just trying it out now.. was wondering is there anyone who have tried
16:40:53 <odyssey4me> Alright, so given that there are no release blockers for those I'll organise the release.
16:41:14 <odyssey4me> #action odyssey4me to release 11.2.7 and 12.0.3
16:41:25 <odyssey4me> #topic Holidays
16:41:44 <odyssey4me> I'd like to suggest that we suspend meetings until the second week of Jan.
16:41:50 <palendae> +1
16:41:58 <mhayden> +1
16:42:07 <BjoernT> +1
16:42:13 <odyssey4me> And also that our releases are suspended until two weeks after that (end of Jan), barring exceptional circumstances of course.
16:42:14 <javeriak_> +2
16:42:25 <hughsaunders> +1
16:42:25 <palendae> +1
16:42:31 <d34dh0r53> +1
16:42:41 <odyssey4me> Well, that settles it. :)
16:42:43 <d34dh0r53> to both
16:42:59 <palendae> I was gonna bring the meetings up if someone didn't :)
16:43:27 <palendae> Pretty sure a sizable percentage of my team will be gone at least 24 Dec
16:43:34 <mhayden> we're having the OSA holiday party at mattt's house, right?
16:43:38 <odyssey4me> #action everyone have a great holiday season, whether you're on holiday or not :)
16:44:08 <andymccr> so sweer
16:44:10 <andymccr> sweet
16:44:10 <andymccr> :D
16:44:21 <hughsaunders> awwww
16:44:24 <palendae> Get your telescopes from Aldi
16:44:28 <odyssey4me> #topic Open Discussion
16:44:49 <odyssey4me> Anyone want to raise anything in particular?
16:45:13 <oneswig> Is there a roadmap for moving to Ansible 2?
16:45:49 <odyssey4me> FYI to all, I'm on leave for the rest of the year. I am going to periodically check my email, so if you do need something from me then ping me via email.
16:46:04 <odyssey4me> oneswig jmccrory has been doing some testing on it, and submitting a few patches I see
16:46:32 <oneswig> I understand it may help with distro-abstraction, wonder when we could depend on it
16:46:35 <odyssey4me> but generally I think we're waiting until it releases before we dig into it
16:47:14 <d34dh0r53> any ideas as to when it's going to be released?  I've only heard soon
16:47:24 <palendae> d34dh0r53: I've not heard much since summit
16:47:37 <palendae> haven't explicitly looked either, though
16:47:49 <odyssey4me> I heard a rumour that it was Jan, then moved back to Feb. Don't quote me on it though.
16:48:12 <palendae> Yeah, it's been bumped quite a bit
16:48:27 <odyssey4me> I think that, much like the next Ubuntu LTS, this will be a focal point for the next cycle... and not so much this cycle.
16:48:32 <palendae> Yeah
16:48:42 <palendae> I assume 16.04 is in very early stages
16:49:06 <palendae> But will be launching right around Summit time
16:49:17 <d34dh0r53> so that begs the question, 16.04 is slated for N?
16:49:28 <palendae> d34dh0r53: I think that's far, far more realistic than Mitaka
16:49:35 <odyssey4me> Unless we get a lot more hands on deck, we don't really have the hands to complete our current objectives, and those
16:49:42 <palendae> Because Mitaka closes out as 16.04 launches
16:49:47 <palendae> Yeah, what odyssey4me said
16:49:58 <logan-> just dropping in to say happy holidays everyone. thanks a ton for the great work on OSA! it has made a huge difference in my work as an operator working to get OS into production and the OSA community, not just the code, has been a big part of my positive experience.
16:50:14 <d34dh0r53> doesn't 14.04 go out of support then? so ~6 months on an unsupported distro?
16:50:19 <odyssey4me> :) thanks logan-
16:50:29 <d34dh0r53> happy holidays logan-
16:50:49 <palendae> d34dh0r53: Since 16.04 isn't going to be ready until at least April 2016, I'm not sure we'll be able to settle on a 'stable' version of it til then anyway
16:51:00 <odyssey4me> d34dh0r53 nope it just switches to maintenance mode: http://www.ubuntu.com/info/release-end-of-life
16:51:16 <palendae> Yeah, canonical's LTS pretty long
16:51:20 <odyssey4me> ie no hardware related patches
16:51:22 <palendae> Something like 5 years
16:51:29 <palendae> I agree it's not great
16:51:31 <d34dh0r53> ahh, cool
16:51:45 <palendae> But even if we had tons of people, not sure we'd realistically get it in for Mitaka
16:51:56 <palendae> Just given the Ubuntu release windows vs OpenStack's
16:52:15 <d34dh0r53> I agree that Mitaka is unrealistic, just wasn't sure about the state of things in the transition from Mitaka to N
16:52:18 <oneswig> The two releases will have differences for OSA.  Is there a mechanism in place for supporting both?
16:52:35 <palendae> oneswig: Was just wondering that too
16:52:39 <oneswig> Or is that part of the multi-OS project?
16:52:59 <odyssey4me> yeah, the multi-OS work can provide the scaffolding for that
16:53:05 <palendae> Makes sense
16:53:15 <palendae> The largest difference I know of will be upstart to systemd
16:53:24 <palendae> But I'm sure there's many small ones too
16:53:24 <oneswig> for sure
16:53:31 <odyssey4me> eg: vars, templates or tasks per distro, distro-version, etc
16:53:56 <palendae> Yeah, makes sense to roll that into multi-distro support
16:54:06 <palendae> And consider a version of a distro as an almost separate distro itself
16:55:03 <oneswig> I would hope to reduce the vars per version to be the essence of any differences, avoiding duplication
16:55:11 <odyssey4me> yep, we have a bit of that in the bootstrap-host role already.... it's been structured in a way that we can easily add another distro or distro-version
16:56:07 <odyssey4me> oneswig, we the vars per distro/distro-version will largely be package lists
16:56:33 <oneswig> ah ok
16:56:44 <odyssey4me> well, that's as far as I've seen so far :)
16:56:56 <odyssey4me> I'm sure there are more surprises around the corner
16:58:26 <odyssey4me> alright, I think that about wraps it up for today
16:58:43 <odyssey4me> thank you all for your time, and have a great time over the new year!
16:59:21 <odyssey4me> #endmeeting