16:02:03 <odyssey4me> #startmeeting OpenStack Ansible Meeting
16:02:04 <openstack> Meeting started Thu Jan 14 16:02:03 2016 UTC and is due to finish in 60 minutes.  The chair is odyssey4me. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:09 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:02:09 <pabelanger> o/
16:02:14 <odyssey4me> #topic Agenda & rollcall
16:02:26 <michaelgugino> I'm here for the ansible meeting
16:02:52 <palendae> o/
16:02:54 <spotz> o/
16:03:19 <javeriak> here
16:03:33 <alextricity25> here
16:03:34 <mattt> \o
16:03:40 <jmccrory> here
16:03:46 <odyssey4me> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:03:53 <michaelgugino> here
16:03:54 <cloudnull> o/
16:05:31 <odyssey4me> hi everyone, welcome back from the holidays - I hope everyone managed to have a good time, spend some time with family, etc
16:05:42 <odyssey4me> plenty of eating, drinking and merrying
16:06:06 <alextricity25> :)
16:06:53 <odyssey4me> #topci Review action items
16:07:00 <odyssey4me> #topic Review action items
16:07:11 <odyssey4me> clearly my brain is not quite working :p
16:07:21 <odyssey4me> #link http://eavesdrop.openstack.org/meetings/openstack_ansible_meeting/2015/openstack_ansible_meeting.2015-12-17-16.01.html
16:07:23 <alextricity25> it's all that merrying
16:07:46 <odyssey4me> my bad, I didn't release immediately after the meeting - then the gate broke spectacularly over the holidays
16:08:03 <odyssey4me> so 11.2.7 is still outstanding, but the next liberty tag was done
16:09:12 <odyssey4me> 11.2.7 should be in a position to be released probably tomorrow - just waiting for one unblocking patch, and then the rest of the approved patches to merge afterwards
16:09:29 <odyssey4me> #topic Mid-Cycle Meetup
16:10:14 <odyssey4me> Did everyone see the update about the mid cycle being partially done at the Ops mid cycle in MAnchester, then a day after that at the Rackspace UK office
16:10:22 <odyssey4me> Ansiblefest in London is the day after that
16:11:00 <odyssey4me> I need to get some numbers and confirm names to ensure that we can arrange access and connectivity - any suggestions regarding how we collect that info?
16:11:03 <alextricity25> I got to take a look. I highly doubt I'll be there, though :/
16:11:05 <odyssey4me> Maybe an eventbrite ticket?
16:11:37 <cloudnull> odyssey4me:  creating an enventbrite meetup may be the best way to go
16:11:45 <spotz> eventbrite works nicely, we used it for the barbican midcycle
16:11:46 <odyssey4me> alextricity25 it's a triple whammy - ops mid cycle, OSA mid cycle and Ansiblefest... who can refuse such a travel request? ;)
16:12:02 <alextricity25> odyssey4me: I could give you my managers email
16:12:03 <alextricity25> hahaha
16:12:25 <odyssey4me> :)
16:12:31 <spotz> ooh could we vidyo the rackspace office day?
16:12:56 <alextricity25> I'll definitely ask to see if it's possible
16:13:03 <alextricity25> +1 on the eventbrite idea
16:13:29 <evrardjp> I doubt I can be there but the vidyo sounds good
16:13:36 <evrardjp> I'll try to send one of my colleagues if possible
16:13:38 <odyssey4me> spotz we could try and arrange something like that - that'll be a nice way to include some of the US/AU folk who'd like to pop in and out as we go
16:14:24 <odyssey4me> #action odyssey4me to arrange an eventbrite event for the OSA mid cycle attendance register
16:14:33 <spotz> thanks odyssey4me
16:14:48 <odyssey4me> #action odyssey4me to try and arrange Vidyo conference facility for the OSA mid cycle room
16:14:49 <mattt> video would be good -- always nice to put a face to names
16:14:58 <evrardjp> odyssey4me: please inform the lists that the eventbrite event is created too :)
16:15:27 <cloudnull> maybe we can broadcast on youtube live
16:15:46 <evrardjp> instant 1M views win.
16:16:24 <odyssey4me> #action odyssey4me to remind the ML about the mid cycle and provide eventbrite details in the reminder
16:16:37 <evrardjp> odyssey4me: thanks :)
16:16:51 <odyssey4me> any questions or comments on the mid cycle?
16:17:24 <palendae> None here
16:17:32 <palendae> Not sure I'll make it
16:17:40 <evrardjp> none for now, maybe please also mention the etherpads in communications ?
16:17:58 <evrardjp> (if any)
16:18:14 <jmccrory> it's limited to 100 people so make sure to purchase ticket
16:18:16 <odyssey4me> oh yes, that reminds me - the ops mid cycle is looking for people to volunteer to present or facilitate workshops
16:18:27 <odyssey4me> generally speaking they can relate to anything ops would be interested in
16:18:35 <odyssey4me> we're also looking for proposals
16:18:46 <odyssey4me> I'll send those details in the reminder email too
16:19:09 <odyssey4me> #action odyssey4me to include etherpad links for talk proposals in the reminder email
16:19:21 <alextricity25> is the ops mid cycle an openstack thing?
16:19:24 <alextricity25> or an OSA thing?
16:19:34 <alextricity25> i've never heard of this event
16:19:44 <palendae> alextricity25: ops mid cycle has been an openstack thing
16:19:53 <palendae> OSA's joining up this year
16:19:57 <odyssey4me> the ops mid cycle is the OpenStack Operators Mid Cycle - not OSA at all, just one of our friend groups in the OpenStack community
16:19:58 <palendae> First OSA midcycle
16:20:17 <alextricity25> Ohhh neat
16:20:22 <alextricity25> thanks for the info :)
16:20:37 <palendae> Happens to be convenient to combine
16:21:16 <odyssey4me> it's great for us to learn from the challenges Operators are facing so that we can add things that help resolve those... but it's also a good place for us to contribute back to them and to contribute to OpenStack development in general
16:21:41 <cloudnull> ++
16:21:42 <alextricity25> That makes a lot of sense. Especially for OSA.
16:21:43 <odyssey4me> we're in a great position to facilitate Ops<->Dev comms
16:22:15 <palendae> Yep, absolutely
16:22:31 <palendae> A great week for OSA, having a foot in operations and Ansible
16:22:51 <alextricity25> I feel like a workshop on debugging openstack issues with OSA would be cool
16:23:11 <alextricity25> showing log stuff, using ansible to access several nodes, etc..
16:23:20 <odyssey4me> alextricity25 why don't you propose that - then inform your boss that you're presenting :)
16:23:26 <alextricity25> :D
16:24:07 <odyssey4me> otherwise propose that as a presentation for the Austin summit :)
16:24:20 <spotz> Yeah that'd be great for summit
16:24:22 <evrardjp> or both
16:24:28 <odyssey4me> ++ evrardjp
16:24:39 <alextricity25> Oh i'lll definitely be there. Austin is just 1hr from me
16:24:40 <spotz> Or add in Ansible's conference and all 3:)
16:24:42 <mcarden> +1 on that as a summit idea
16:24:50 <odyssey4me> hahaha
16:25:11 <odyssey4me> alright, switching topics quickly
16:25:12 <mattt> i'd sit in on that, i still have no idea how logging works in openstack-ansible
16:25:13 <mattt> :)
16:25:21 <odyssey4me> #topic Release Planning and Decisions
16:26:07 <odyssey4me> the current plan is to release mitaka-2, liberty 12.0.4 and kilo 11.2.7 next week after the thu meeting
16:26:20 <odyssey4me> does anyone want a release sooner for any particular reason?
16:27:20 <mattt> odyssey4me: not i
16:28:36 <odyssey4me> are there any specific bugs that anyone wants to raise which they really, really need included in the release?
16:28:59 <cloudnull> i have nothing
16:29:22 <evrardjp> bugs that need included in the release? no thank you!
16:29:25 <odyssey4me> ok, good - then it's business as usual until next week
16:29:34 <cloudnull> evrardjp: lololol
16:29:40 <prometheanfire> cya :P
16:29:46 <michaelgugino> I have one small one
16:30:04 <odyssey4me> michaelgugino ok?
16:30:05 <michaelgugino> not really a bug in the software per se, but the release numbers don't track in the pip repos.
16:30:20 <michaelgugino> that creates breakage for people using the software.
16:30:30 <odyssey4me> michaelgugino how do you mean?
16:30:40 <michaelgugino> http://rpc-repo.rackspace.com/os-releases/
16:30:45 <michaelgugino> that has no 12.0.3
16:31:15 <michaelgugino> trying to follow the docs and setting that as the url, liberty cannot pull pip packages
16:31:15 <cloudnull> ah fair point, I think we've fallen behind in updating those
16:31:31 <cloudnull> michaelgugino:  i can push updates to that repo
16:31:38 <odyssey4me> michaelgugino RPC is not tracking Liberty yet, which is why the repo has no builds for Liberty
16:31:52 <michaelgugino> right, but the docs instruct the user to use that url
16:32:02 <odyssey4me> ah, we should remove that
16:32:22 <mattt> michaelgugino: you familiar w/ the process of building this stuff locally?
16:32:42 <michaelgugino> I have not built the pip repos, not really sure how that part works
16:33:03 <odyssey4me> I have another plan, which is to publish the repo to tarballs.openstack.org after every successful build. I'm discussing that with -infra as I don't think they have exactly what we need in place.
16:33:21 <michaelgugino> I just set user variable:  openstack_release: liberty
16:33:25 <odyssey4me> michaelgugino instead of running repo-clone, you run repo-build
16:33:59 <mattt> michaelgugino: it's a pretty long-running task (takes maybe 30 mins?) but i prefer to have all this stuff in my environment
16:34:10 <odyssey4me> michaelgugino the repo-install playbook does this automatically in Liberty+
16:34:41 <michaelgugino> I understand, I can make it work, that's not the issue.  Just saying, the documents are off or that rpc repo should be updated.
16:34:53 <mattt> michaelgugino: makes sense
16:35:05 <odyssey4me> yeah, that is true - if someone could prep a patch that'd be great!
16:35:07 <odyssey4me> :)
16:35:15 <michaelgugino> what is the preferred fix?
16:35:30 <cloudnull> i will update the rpc repo right now
16:35:31 <michaelgugino> insist the user runs repo-build?
16:35:47 <odyssey4me> the docs fix for now would be to inform the user that they should execute repo-install and it will build the repo locally
16:35:55 <michaelgugino> ok, I will do that.
16:36:24 <cloudnull> repo-clone will work once we update the repo or if the user has a self hosted repo elsewheree .
16:36:25 <odyssey4me> that fix will apply to master, and should be backported to liberty
16:36:49 <michaelgugino> sounds good.
16:37:08 <odyssey4me> cloudnull yeah, but for instructions to use those we have to ensure that we're consistenly updating the rpc-repo... this is why I'd like to automate that in OpenStack's CI
16:37:11 <cloudnull> i'd be nice to see if we, OSA, can get space within infra where we push a built set
16:37:30 <odyssey4me> :) working on it
16:37:31 <cloudnull> what odyssey4me said
16:37:47 <odyssey4me> is vdo around?
16:37:51 <odyssey4me> it appears not
16:38:23 <odyssey4me> he was going to present the intent of adding 'Midonet plugin support' to the Neutron service in OpenStack-Ansible
16:38:40 <cloudnull> that'd be interesting
16:38:56 <odyssey4me> a general reminder about the design work etherpads that are up in https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:39:16 <odyssey4me> we're still looking for a leader for the multi-OS support :)
16:39:26 <odyssey4me> #topic Open discussion
16:40:09 <michaelgugino> I'm interested in the Multi-OS support, and systemd support.
16:40:27 <odyssey4me> michaelgugino please add your name to the etherpad
16:40:33 <michaelgugino> I don't now if I can be a leader but I'd like to contribute to those efforts.
16:41:05 <cloudnull> michaelgugino: ++ that'd be awesome
16:41:27 <odyssey4me> michaelgugino we're happy to be of support to anyone leading the effort, so all it'll take is someone with the inclination and time to research, review and submit reviews
16:41:49 <michaelgugino> I'm looking to have my org adopt 16.04 asap
16:41:53 <pabelanger> I wanted to actually talk about the mission statement for openstack ansible.  And was curious if the team is open to the idea of adding more ansible roles for OpenStack Infra projects.
16:41:59 <pabelanger> EG: ansible-role-nodepool
16:42:07 <michaelgugino> and we're going to be relying heavily on ansible, so it make sense to contribute the work here.
16:42:16 <cloudnull> michaelgugino: i'd be happy to help out on that effort. i also know prometheanfire has been working on that front too
16:42:47 <odyssey4me> michaelgugino then perhaps you can take up the systemd work soon with prometheanfire
16:42:48 <michaelgugino> I looked at some of the work that has already been done regarding RHEL/Centos using different playbooks
16:43:07 <prometheanfire> ya
16:43:15 <odyssey4me> pabelanger we'll circle back to your topic shortly
16:43:15 <prometheanfire> could probably work on that
16:43:20 <michaelgugino> I just wanted to get an idea of what general direction we should go, different playbooks / roles, or converged with lots of log?
16:43:24 <michaelgugino> *logic
16:43:33 <prometheanfire> also, want to get gentoo support now that gentoo is in diskimage-builder
16:43:46 <odyssey4me> michaelgugino we have some patterns already, for example in the bootstrap-host role
16:43:56 <odyssey4me> so generally same roles, with some logic
16:44:10 <odyssey4me> if things get too onerous we can re-evaluate
16:44:24 <michaelgugino> sounds good.  Do we want to continue to deploy containers in trusty, or update containers as well?
16:44:45 <odyssey4me> michaelgugino I'd suggest breaking up the work into pieces - host first, then containers
16:44:48 <michaelgugino> I was thinking, start at host level and work up
16:44:52 <michaelgugino> ok, cool.
16:45:03 <cloudnull> michaelgugino:  i did some work a while back on rhel support, which included systemd, https://github.com/cloudnull/os-ansible-deployment/tree/master-rhel but there wasn't enough interest in bringing that in as something OSA supports.
16:45:21 <cloudnull> but with more interested folks maybe we can get it though
16:45:23 <odyssey4me> michaelgugino it sounds to me like you have enough motivation and could lead the charge
16:45:30 <mattt> it's going to be tricky if we support multiple ubuntu releases, red hat, etc.
16:45:43 <odyssey4me> the details so far are in https://etherpad.openstack.org/p/openstack-ansible-multi-os-support
16:45:59 <michaelgugino> my org will be running ubuntu only for now, so while I don't have much interest in RHEL support directly, I believe both will be using systemd, so two birds with one stone, mostly
16:46:14 <cloudnull> michaelgugino: they will both use systemd
16:46:27 <odyssey4me> ok, so at least part of the work - ok, that's good
16:46:30 <cloudnull> so if we support one, we will mostly have support for the other
16:46:46 <odyssey4me> how do you feel about putting together a spec to outline how you expect to do the work?
16:47:04 <michaelgugino> I think I can do that.
16:47:10 <odyssey4me> awesome :)
16:47:18 <palendae> We've talked before that 16.04's gonna need systemd
16:47:25 <palendae> So multi-OS is great for even just Ubuntu
16:47:26 <odyssey4me> #action michaelgugino to put together a spec to add systemd support
16:47:36 <cloudnull> we have this spec for systemd, it may need to be updated https://github.com/openstack/openstack-ansible-specs/blob/master/specs/mitaka/add-support-for-systemd.rst
16:48:00 <odyssey4me> cloudnull good point - perhaps the spec just needs a patch to update it with a little more meat
16:48:08 <cloudnull> ++
16:48:16 <cloudnull> maybe a new spec altogether.
16:48:17 <michaelgugino> I'm assuming we would want it fact based, not user var based.
16:48:32 <michaelgugino> support for hybrid deployment, some systemd, some upstart, etc.
16:48:43 <odyssey4me> michaelgugino yes, I think so
16:48:49 <prometheanfire> as much as possible
16:49:06 <odyssey4me> we'll have to maintain support for Ubuntu 14.04 for another two cycles at least
16:49:10 <cloudnull> michaelgugino: yes i think so
16:49:14 <pabelanger> odyssey4me: okay, no rush. We can talk about it after the meeting too. Just wanted to raise the topic.  I have to drop in about 5 mins
16:49:29 <odyssey4me> ok, let's switch briefly to pabelanger's topic then
16:49:43 <michaelgugino> after pabelanger, I wanted to bring up dvr support for neutron :)
16:49:48 <prometheanfire> I do think switching as much as we can to systemd would be good (agnostic wise)
16:50:09 <odyssey4me> pabelanger has been working on a variety of roles which implement OpenStack-CI tooling
16:50:27 <pabelanger> indeed
16:50:32 <odyssey4me> pabelanger can you tell us a bit about what you've done
16:51:06 <pabelanger> so, far I have 4 projects that I have imported upstream, but they are unofficial at the moment. That include ansible-role-nodepool, ansible-role-zuul, ansible-role-jenkins-job-builder and ansible-role-diskimage-builder
16:51:12 <cloudnull> michaelgugino:  this had been my approach in the pash https://github.com/cloudnull/os-ansible-deployment/blob/master-rhel/playbooks/roles/os_glance/tasks/glance_init.yml#L16-L34
16:51:15 <cloudnull> *past
16:51:38 <pabelanger> I have more roles locally, but holding off on moving them upstream until I can figure out the best place to have them become official projects.
16:51:57 <pabelanger> So, because we both use ansible, I thought it might be a good place to create a sub team or add them to this team
16:52:13 <odyssey4me> pabelanger do they need to be official, or are you just looking for more participants in the development and review process?
16:52:53 <pabelanger> odyssey4me: Ya, so I would like them to be under big tent, which like you said adds more reviewers and users.
16:53:24 <pabelanger> So, don't feel you need to include them here, if they are not a good fit. I just wanted to have a little discussion about seeing if it is a good idea or not
16:53:38 <odyssey4me> any thoughts from everyone about this?
16:53:46 <pabelanger> I suspect I will need to go to TC eventually and see what works better for the OpenStack project in general
16:53:57 <pabelanger> Since more and more people are consuming ansible and more roles will be uploaded
16:54:12 <odyssey4me> I'd like to look into how other projects have implemented sub-teams, and I'd also like to ensure that we define the roles in such a way that we don't conflict with -infra.
16:54:14 <michaelgugino> I'm sure my team would be interested in deploying Openstack-CI with those playbooks.
16:54:53 <pabelanger> odyssey4me: right, last I talked to -infra, they didn't want to include the roles there, since they use puppet
16:55:04 <pabelanger> but I agree
16:55:07 <odyssey4me> generally I think it's useful to have these tools in the toolbox and they're especially useful for anyone who wants to deploy their own CI infrastructure in a way that's similar to OpenStack-CI
16:55:33 <odyssey4me> so if we frame the roles for use in external CI, then I think we remove the conflict
16:56:02 <pabelanger> Right, and I don't know if that means a new project (PTL) or moving it under some sort of sub team here
16:56:43 <odyssey4me> pabelanger I think perhaps we should let the idea bake for a week and discuss it again next week.
16:56:54 <pabelanger> WFM
16:57:11 <pabelanger> thanks for talking about it!
16:57:12 <odyssey4me> meanwhile, let's get more familiar with how sub teams work and all that, so that we're a little more informed
16:57:59 <odyssey4me> we're almost out of time - does anyone else want to raise something specific before we end?
16:58:03 <michaelgugino> Does anyone have any problems with supporting dvn neutron networking?
16:58:15 <michaelgugino> I'd like to submit some blueprints and start working on that soon as well.
16:58:16 <odyssey4me> I encourage everyone to head back to #openstack-ansible to continue discussions
16:58:22 <cloudnull> dvn?
16:58:28 <michaelgugino> *dvr
16:58:32 <odyssey4me> michaelgugino as far as I know, DVR doesn't work with linuxbridge
16:58:35 <cloudnull> w/ ovs
16:58:38 <odyssey4me> (yet)
16:59:00 <michaelgugino> My team is willing to put in the work to make DVR work, if you guys are willing to merge the patches
16:59:06 <cloudnull> michaelgugino: I have no issues with that being done.
16:59:17 <odyssey4me> we are, most definitely, happy to merge the patches
16:59:29 <odyssey4me> if OVS support is added as part of the process, that's cool too
16:59:35 <michaelgugino> great.  We've already started manually integrating with OSA, but haven't done anything with playbooks.
16:59:46 <odyssey4me> alright, we're out of time - continue in #openstack-ansible
16:59:51 <odyssey4me> thank you all for your time
17:00:00 <cloudnull> cheers!
17:00:01 <odyssey4me> #endmeeting