16:04:44 <mhayden> #startmeeting openstack_ansible_meeting
16:04:45 <openstack> Meeting started Thu Nov  3 16:04:44 2016 UTC and is due to finish in 60 minutes.  The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:49 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:04:52 <adreznec> Ah
16:04:53 <adreznec> Nice
16:04:54 <mgariepy> LOL
16:04:55 <adreznec> That's awesome
16:05:00 <mhayden> #topic Roll Call
16:05:08 <adreznec> o/
16:05:09 <mhayden> #agreed stevelle wins the internet for today
16:05:29 <adreznec> Who? stevelle? You mean qwebirc78377?
16:06:35 <logan-> o/
16:06:38 <drifterza> o/
16:06:55 <jmccrory> o/
16:06:56 <admin0> p/
16:06:58 <admin0> o/
16:07:00 <admin0> :D
16:07:02 <yolanda> o/
16:07:04 * mhayden woots
16:07:17 <admin0> go go go
16:07:25 <stevelle> o/
16:07:28 <admin0> give  me monitoring .. give me alerting .. give me logging ..
16:07:35 <mhayden> #topic Review action items
16:07:37 <odyssey4me> o/
16:08:05 <michaelgugino> o/
16:08:20 <mhayden> last week was the summit -- so we're good to go on these AFAICT
16:08:31 <mhayden> #topic Project Mascot
16:09:24 <admin0> animals ?
16:09:26 <michaelgugino> I thought the proposed mascot drawing was unoriginal and plain.
16:09:27 <admin0> plants ?
16:09:36 <mhayden> odyssey4me: you want to pretend to be andymccr here since he's out in wine country?
16:09:37 * mhayden notes that the meetboot is laggy
16:09:38 <mhayden> so has everyone seen it?
16:09:43 <admin0> nope
16:09:46 <palendae> mhayden, Have a link?
16:09:53 <odyssey4me> mhayden can you post the sample somewhere?
16:10:13 <odyssey4me> and perhaps link the survey for it
16:10:34 <admin0> still time to draw/submit ideas ?
16:10:51 <mhayden> http://imgur.com/a/hMRAD
16:10:51 <mhayden> survey: http://tinyurl.com/OSmascot
16:10:57 <mhayden> #link Proposed mascot image: http://imgur.com/wub7aro
16:11:06 <mhayden> #link Survey for mascot image: http://tinyurl.com/OSmascot
16:11:12 <odyssey4me> TBH I find it a little disappointing too, but I can't really think of any specific suggestions for improvement
16:11:19 <mhayden> so yeah, i agree on being a little plain
16:11:30 <odyssey4me> admin0 the animal is set, we need to provide feedback on the drawing given
16:11:32 <mhayden> i was hoping for more of a brownish color
16:11:48 <odyssey4me> yeah, some sort of color would be nice
16:12:11 <admin0> i was thinking to photoshop and submit more ideas :(
16:12:17 <odyssey4me> I *think* I'd also prefer more of a head-and-shoulders image, rather than just a head
16:12:18 <adreznec> It's not that it's bad so much as it doesn't really stand out at all
16:12:29 <odyssey4me> admin0 no, this is being done by the foundation
16:12:32 <admin0> oh
16:12:40 <admin0> and this is what they came up with :D
16:12:41 <admin0> ok
16:12:54 <michaelgugino> it's plain.  The 'artist' phoned it in.  They need to create something original IMO, not a vector drawing of what looks like a goat with horns.
16:13:20 <admin0> we cannot reject and come up wtih our own alternatives  .. ..
16:13:25 <admin0> ?
16:13:26 * mhayden makes a note to always ask michaelgugino when i need honest feedback :)
16:13:32 <odyssey4me> also, the team name is 'OpenStack-Ansible' - I think just 'Ansible' will cause a problem with copyright
16:13:35 <michaelgugino> ;)
16:13:51 <palendae> Criticize the work, not the person
16:14:09 <odyssey4me> admin0 the animal was decided in the community meeting, so no - no other animal options
16:14:25 <admin0> ok
16:14:36 <odyssey4me> and no - we cannot draw anything ourselves - we have a survey to complete, that's our feedback mechanism
16:14:37 <admin0> well, if the animal was decided, (is it a water buffalo btw ) .. ?
16:14:48 <admin0> cow ?
16:14:49 * stevelle is trying to find the link for the guidelines foundation gave re: mascots and the art
16:14:59 <odyssey4me> it quite clearly states 'cape buffalo' at the bottom of the picture
16:15:03 <admin0> :D
16:15:06 <michaelgugino> the buffalo is fine, it's just a really plain and uninspiring graphic, IMO
16:15:10 <admin0> sorry .. i was hypnotized by the eyes
16:15:13 <odyssey4me> yeah, agreed
16:15:25 <odyssey4me> ok, I suggest that we all complete the survey and move on with the meeting
16:15:31 <mhayden> sounds good
16:15:35 <mhayden> survey link is ^^^
16:15:52 <stevelle> #link reference discussion for the mascot/logo topic http://lists.openstack.org/pipermail/openstack-dev/2016-July/099046.html
16:15:56 <odyssey4me> as per palendae's suggestion - keep the criticism constructive and impersonal
16:16:07 <mhayden> okay, moving right along
16:16:15 <mhayden> #topic PTG Atlanta Feb 20-24
16:16:34 <mhayden> so i'm told this is a gathering of the technical projects
16:16:37 <odyssey4me> I have no idea what andymccr wanted to cover for this. :/
16:16:56 * mhayden looks through andymccr's email once more
16:17:09 <stevelle> probably just the reminder to work on finding budget and schedule to go
16:17:11 <odyssey4me> yes, it's basically the new place where the design workshops are held... no fishbowls
16:17:12 <mhayden> it sounds like andymccr is planning to send some emails soon
16:17:22 <mhayden> i've heard the limit is 500 people
16:17:32 <palendae> Huh, the seems a little odd
16:17:40 <stevelle> heard that, and yes, odd
16:17:44 <palendae> Then again, only devs
16:17:50 <palendae> Or rather,contributors
16:17:58 <mhayden> i heard the number was small because the Atlanta airport is tiny
16:18:01 <odyssey4me> the 'forum' now happens at the summit, which is where the latest release is discussed with operators once they've had a chance to try it out
16:18:11 <palendae> mhayden, Not sure if joking
16:18:17 * mhayden toots
16:18:24 <mhayden> okay, let's move on and catch up with andymccr later
16:18:36 <mhayden> #topic OPNFV
16:18:41 <yolanda> hi
16:18:43 * mhayden hands the mic to hwoarang and yolanda
16:18:49 <mhayden> hello yolanda!
16:19:05 <hwoarang> hello
16:19:07 <yolanda> so we are considering in using openstack-ansible for some cloud deployments in OPNFV, and wanted to get your feedback
16:19:28 <yolanda> in general, we need: support for ubuntu/centos, ha, openvswitch... and ability to contribute
16:19:46 <hwoarang> and suse :)
16:19:46 <michaelgugino> we have most of that
16:19:49 <mhayden> well we do support ubuntu 14.04/16.04, and centos support is coming along
16:19:51 <yolanda> oh, sorry!
16:19:55 <admin0> osa is mostly linuxbridge .?
16:19:58 * yolanda says sorry to hwoarang
16:20:00 <mhayden> and we have OVS support
16:20:20 <mhayden> we're missing SUSE support though
16:20:20 <yolanda> will patches for suse be well received?
16:20:28 <hwoarang> i can take care of suse support it's ok
16:20:29 <odyssey4me> hwoarang yolanda well, we're always happy to accept contributions
16:20:45 <yolanda> we would like also to deploy from master, not from stable branches
16:20:45 <odyssey4me> suse has been discussed before, although no-one has stepped up to contribute for it
16:21:10 <mhayden> centos support is a bit of a best effort thing right now too
16:21:13 <odyssey4me> I would guess that the centos support work will help suse come along
16:21:22 <yolanda> how does openstack-ansible deals with branches? is there a possibility to just use latest master?
16:21:24 <hwoarang> yes they are similar in most areas
16:21:39 <odyssey4me> but the patterns are pretty much set now, so it should be relatively straightforward to figure out how to make that go
16:21:58 <odyssey4me> yolanda our master tests against openstack master, and master from some other projects too
16:22:17 <odyssey4me> once we carve out a stable branch, then we fix SHA's and bump them every two weeks
16:22:36 <yolanda> nice
16:22:44 <odyssey4me> so, briefly, yes - we chase master all the way
16:23:07 <hwoarang> that's good
16:23:12 <yolanda> odyssey4me, our idea is to use bifrost to deploy the baremetal servers, then run openstack-ansible on top of it, is that a common workflow? or how are you dealing with baremetal?
16:23:53 <odyssey4me> we specifically don't deal with bare metal, as most deployers have a preferred solution
16:24:07 <palendae> We have requirements for a host that we deploy on
16:24:09 <odyssey4me> that said, we have an ironic role which can deploy in standalone mode - which is what bifrost is
16:24:10 <palendae> Up to deployers to meet that
16:24:41 <palendae> http://docs.openstack.org/developer/openstack-ansible/install-guide/overview-requirements.html
16:24:41 <yolanda> odyssey4me, so an ironic role different than bifrost itself?
16:25:13 * palendae notes that link doesn't mention CentOS requirements
16:25:37 <odyssey4me> palendae yep, CentOS isn't yet done, so that stuff isn't taken care of yet
16:26:09 <odyssey4me> yolanda yes, our ironic role does both standalone and integrated deployment
16:26:16 <palendae> Figured, fair enough
16:26:27 <odyssey4me> the bifrost team only does a standalone deployment
16:26:54 <yolanda> yep, we are ok with bifrost but it's worth looking at openstack-ansible role as well
16:26:56 <odyssey4me> they're predominantly focused on TripleO's needs
16:27:46 <odyssey4me> yolanda sure, how you end up implementing your resulting build is really up to you
16:27:50 <yolanda> our idea is to deploy a basic openstack cloud and then add nfv features on top
16:28:03 <odyssey4me> we obviously just have to manage our scope within reason :)
16:28:06 <yolanda> so at some point, we'll need to contribute to openstack-ansible with nfv features if we end using it
16:28:42 <yolanda> will it that be ok for your side?
16:28:56 <odyssey4me> sure - if you look through the ongoing dragonflow work that's happening, and also the calico/nuage/plumgrid implementations you'll see where the integration points are
16:29:05 <odyssey4me> I doubt there'll be much more than that needed
16:29:28 <odyssey4me> it will depend on the architecture though, and we can help you through it when you get stuck
16:29:53 <yolanda> hwoarang, do you know more about NFV requirements we could have?
16:30:06 <hwoarang> hmm
16:30:13 <odyssey4me> sure, we hang out in #openstack-ansible as you know - so just ask in the channel and if anyone can help, they will
16:30:37 <hwoarang> yolanda: not off the top of my head
16:30:55 <yolanda> so i think we are ok to start with some POC first
16:31:27 <yolanda> odyssey4me, so as far as i know, it supports both lxc and baremetal right?
16:31:35 <odyssey4me> yep
16:31:38 <yolanda> so we can first try virtualized deploy, then switch to baremetal
16:32:29 <yolanda> odyssey4me, and as it's used in production... i guess everything can be configured so easily, in terms of network settings right?
16:32:39 <odyssey4me> containers on the control plane, bare metal for compute/swift/storage - the control plane containers are optional, but there are some caveats if you take that path
16:32:59 <odyssey4me> those are implementation details we can take to the channel
16:33:05 <evrardjp> agreed
16:33:55 <drifterza> can we move on ?
16:34:02 <yolanda> fine for me
16:34:05 <odyssey4me> yolanda yep, config changes are straightforward - the openstack-ansible-ops repo has a multi-node-aio which deploys a production-like environment in VM's - you may wish to look at that and help work on it to cater to your needs
16:34:09 <hwoarang> thank you for the info
16:34:14 <yolanda> thanks!
16:34:19 <mhayden> thanks for coming by!
16:34:26 <mhayden> moving right along!
16:34:33 <mhayden> #topic Release planning & decisions
16:34:40 * mhayden hands the mic to odyssey4me
16:34:50 <odyssey4me> hmm, oh yeah - this week is release week
16:35:07 <odyssey4me> so before I push the release request through, are there any glaring bugs which need addressing?
16:35:36 <stevelle> I have one thing I'd note regarding bumping SHAs on master
16:35:57 <cloudnull> o/
16:36:29 <odyssey4me> stevelle yeah?
16:36:55 <stevelle> bumping SHAs on master will break glance and possibly some other projects because of some upstream stuff
16:37:12 <palendae> ^ that's generally the case when things are in flux, no?
16:37:17 <stevelle> I don't have the link handy
16:37:17 <odyssey4me> hmm, that's possibly why the last sha bump attempt didn't work
16:37:17 <spotz> I'm late don't hate me
16:37:35 <evrardjp> stevelle: a link would be great
16:37:37 <palendae> Not that it always willl, but that it certainly can
16:38:20 <odyssey4me> well, the role tests are vaguely stable right now... with this SHA bump I'll look more into why it fails
16:38:24 <stevelle> https://bugs.launchpad.net/ceilometer/+bug/1638323
16:38:24 <openstack> Launchpad bug 1638323 in Ceilometer "gate fails reporting 'No module named vine.five'" [Undecided,Invalid] - Assigned to Hanxi Liu (hanxi-liu)
16:38:40 <odyssey4me> but it might be a good idea to do the bump on the weekend when there are less patches flying around
16:38:43 <stevelle> there is another bug I can't find ATM that is general, but it's all about Kombu 4.0
16:38:51 <evrardjp> #link https://bugs.launchpad.net/ceilometer/+bug/1638323
16:39:04 <evrardjp> for the record :)
16:40:24 <stevelle> just something to be aware of
16:40:31 <odyssey4me> ok, that's useful - with that info we can do a temporary u-c override
16:40:34 <odyssey4me> thanks stevelle
16:40:37 <mhayden> anything else on releases?
16:40:46 <odyssey4me> no, I think we're good to continue
16:40:49 <mhayden> good stuff
16:40:53 <mhayden> #topic Open floor
16:41:02 <mhayden> i proposed a spec for Octavia
16:41:11 <mhayden> https://review.openstack.org/#/c/392205/
16:41:17 <mhayden> feedback definitely welcome
16:42:14 <stevelle> I have a couple things to note
16:42:30 <stevelle> if there is no discussion following Octavia
16:42:59 <stevelle> RE: This msg on the dev list: http://lists.openstack.org/pipermail/openstack-dev/2016-November/106649.html
16:43:17 <odyssey4me> mhayden will try to take a peek through it asap - I've been a little stuck in the weeds
16:43:26 <stevelle> we will need to get this review in soon to accommodate it https://review.openstack.org/#/c/326748/
16:43:42 <mhayden> more fernets!
16:43:47 <stevelle> but heads-up that the default will switch to fernet
16:44:10 <odyssey4me> well, we've had fernet as the default since kilo :)
16:44:23 <evrardjp> stevelle: after this patch, we would probably have to change openstack-ansible to properly configure memcached
16:44:31 <stevelle> yup
16:44:35 <logan-> so our default implementation is currently fernet without memcache, am I understanding corectly?
16:44:41 <stevelle> sadly yes
16:44:56 <odyssey4me> I might be wrong, but I don't think that's right.
16:44:58 <stevelle> or at least it isn't set up quite right
16:45:06 <odyssey4me> IIRC we deploy memcache containers, and keystone is configured to use it.
16:45:31 <stevelle> I poked a little while ago and was having probs with the memcache always generating misses, maybe I had something else going on
16:45:48 <odyssey4me> thanks for the heads-up though - will need to dig into that review
16:45:50 <stevelle> it might have been resolved
16:45:51 <evrardjp> odyssey4me: if we use kvs storage to memcache we deploy it
16:45:54 <evrardjp> sorry for the ping odyssey4me :p
16:46:09 <logan-> yeah thats good to know. thanks.. good thing to dig into and fix if it is broken
16:46:16 <evrardjp> For me the review looks good now that the keystone page was updated
16:46:18 <evrardjp> http://docs.openstack.org/developer/keystone/configuration.html#caching-layer
16:46:25 <odyssey4me> ah https://github.com/openstack/openstack-ansible-os_keystone/blob/master/defaults/main.yml#L243
16:46:45 <evrardjp> yes indeed odyssey4me
16:47:00 <logan-> candidate for newton bp perhaps?
16:47:04 <evrardjp> but on top of it
16:47:05 <evrardjp> https://github.com/openstack/openstack-ansible-os_keystone/blob/master/meta/main.yml#L45-L47
16:47:19 <jmccrory> that's set in integrated deployment though: https://github.com/openstack/openstack-ansible/blob/master/playbooks/inventory/group_vars/keystone_all.yml#L18
16:47:43 <evrardjp> odyssey4me: the default is definitely what should be updated in a subsequent commit in openstack-ansible/
16:47:46 <jmccrory> think integrated deploy is doing the right thing, it just needs to be the role default also
16:47:47 <odyssey4me> ok, then it seems that this is actually something that needs implementing - and we should add a known issue to stable branches highlighting this and how to configure caching
16:47:49 <evrardjp> with proper group vars
16:48:18 <evrardjp> well first things first, reviewing the first patch would be fine for keystone
16:48:18 <odyssey4me> jmccrory ah, good point
16:48:31 <logan-> yeah i'm seeing it configured on my mitaka dev cluster http://cdn.pasteraw.com/p3eay0yaewymgk1welyjwn8digseh2b
16:48:35 <stevelle> sorry, that was what I was talking about ^ thanks jmccrory
16:48:53 <stevelle> role issue, not integrated
16:48:56 <odyssey4me> yeah, so the issue here is that the keystone guys are using the keystone role without the group vars
16:49:10 <logan-> ah ok
16:49:18 <evrardjp> jmccrory: are you talking about this? https://github.com/openstack/openstack-ansible/blob/master/playbooks/inventory/group_vars/all.yml#L74
16:49:25 <evrardjp> I am not sure we are doing enough there
16:49:33 <odyssey4me> I'm not a fan of making the role install memcache on the keystone containers by default
16:49:44 <stevelle> imo it should for functional testing
16:49:54 <odyssey4me> evrardjp no https://github.com/openstack/openstack-ansible/blob/master/playbooks/inventory/group_vars/keystone_all.yml#L18
16:49:57 <jmccrory> evrardjp : no, linked above. it's a group var
16:50:05 <evrardjp> odyssey4me: I'm not fan either, but it is recommended by keystone guys, they probably know it best, right?
16:50:19 <odyssey4me> keystone, in an integrated build, is already configured to use the memcache backend properly
16:50:23 <evrardjp> ok if we have both it's fine
16:50:25 <spotz> Or just make it a recommended configuration option?
16:50:30 <logan-> stevelle: unless the functional test fails if memcached is not working whats the value though? like if memcached settings are misconfigured or broken, it will just silently fallback right?
16:50:40 <odyssey4me> evrardjp no, I think we need to educate them about how we do this and figure out a suitable solution
16:50:49 <mhayden> #chair odyssey4me mhayden
16:50:50 <openstack> Current chairs: mhayden odyssey4me
16:50:57 <mhayden> odyssey4me: i have to depart -- lots of goings on at castle today
16:51:04 <evrardjp> thanks mhayden
16:51:05 <logan-> might be something to target for testing improvements in the role
16:51:07 <odyssey4me> ah ok mhayden - have a great day !
16:51:14 * mhayden tips his hat to odyssey4me
16:51:29 <odyssey4me> sure, we can take the discussion to the channel and ping them directly to discuss
16:51:45 <stevelle> agreed. thanks for the attention
16:51:49 <stevelle> secondly, I have been trying to help in the dynamic inventory area, so I have some reviews up. I am not asking for those to get +A attention yet, but would like anyone interested in inventory to take a few minutes to consider the questions in https://etherpad.openstack.org/p/osa-dynamicinventory-plugins and offer feedback or ping to discuss it
16:51:51 <evrardjp> odyssey4me: if we already have safe defaults in openstack-ansible, I am not sure what's the problem here.
16:52:29 <odyssey4me> evrardjp the issue is one of education and independent role usage - we'll discuss in the channel/review
16:52:39 <evrardjp> you want to make sure keystone doesn't have memcached by default while possible contributors would definitely prefer it that way?
16:53:01 <palendae> stevelle, Plan to go through those reviews again today after our discussions
16:53:05 <odyssey4me> evrardjp we'll take it to the channel, stevelle has raised another topic for discussion
16:54:18 <evrardjp> agreed
16:55:50 <drifterza> We done ?
16:57:35 <odyssey4me> yeah, I think that discussion can happen in the etherpad
16:57:39 <odyssey4me> anything else stevelle ?
16:57:42 <odyssey4me> or anyone else?
16:57:47 <stevelle> no that's all I have. thanks
16:59:25 <odyssey4me> ok cool, thanks all
16:59:29 <odyssey4me> have a great day/eve
16:59:32 <odyssey4me> #endmeeting