16:00:00 <mhayden> #startmeeting openstack_ansible_meeting
16:00:00 <openstack> Meeting started Thu Dec  1 16:00:00 2016 UTC and is due to finish in 60 minutes.  The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:13 <mhayden> #topic Roll Call
16:00:24 <mhayden> ooh, i got it right at 16:00:00
16:00:41 <andymccr> thats why you're the best mhayden
16:00:56 <Xeregin> I noticed that lol
16:00:58 <adreznec> mhayden, professional meeting starter
16:01:26 <asettle> andymccr: woah bro
16:01:31 <cathrichardson> o/
16:01:34 <asettle> Guys I'm RIGHT HERE
16:01:37 <asettle> And i'm hurt
16:01:39 <palendae> Hello
16:02:32 <automagically> o/
16:02:36 <stevelle> spicy
16:02:39 <mhayden> so it looks like the last meeting was on 2016-11-17, right?
16:02:55 <palendae> Yeah, skipped last week
16:02:59 <palendae> US Thanksgiving
16:03:03 <andymccr> ^ what palendae said :D
16:03:10 <adreznec> Busy eating turkey, etc
16:03:11 <mhayden> got it
16:03:23 <mhayden> or as the UK calls it: "Thursday without Americans"
16:03:27 <mhayden> :)
16:03:32 <evrardjp> o/
16:04:15 <mhayden> small group today
16:04:19 <mhayden> let's get rolling
16:04:30 <mhayden> #topic Review action items
16:04:34 <rromans> .
16:04:40 <mhayden> first one was signing up for the PTG -- is there an etherpad for that?
16:04:47 <mhayden> i know it's early
16:04:51 <andymccr> mhayden: not really - its more just a reminder at this point
16:04:54 <mhayden> got it
16:05:11 <palendae> I know internally we just ordered and will request refunds if we can't go
16:05:11 <mhayden> next was odyssey4me adding a prototype experimental integrated build upgrade test
16:05:26 <andymccr> i think add that to action items again - we have setup the testing infra for that though
16:05:28 <andymccr> so some progress!
16:05:42 <palendae> Nice!
16:05:47 <odyssey4me> apologies, carry that item please
16:06:03 <mhayden> #action Need more work on the prototype experimental integrated build upgrade as a periodic task
16:06:12 <mhayden> next was feedback on the upgrade blueprint
16:06:16 <andymccr> ok so
16:06:19 <andymccr> some patches have merged
16:06:26 <andymccr> we're left with Swift (currently working - needs a +w)
16:06:27 <mhayden> #link https://blueprints.launchpad.net/openstack-ansible/+spec/upgrade-testing
16:06:39 <andymccr> Neutron (fixed it today, its a bit different because of the use of modules... but its working now!)
16:06:47 <mhayden> awesome
16:06:47 <andymccr> and Nova (not working quite right at the moment)
16:06:54 <odyssey4me> andymccr do we have upgrade jobs running now?
16:07:02 <odyssey4me> if not, we should get them in ASAP
16:07:11 <andymccr> odyssey4me: yeah i agree - i'll promote them
16:07:16 <odyssey4me> by that I mean running as on-commit jobs, not experimental
16:07:21 <stevelle> I'm working on the swift review
16:07:24 <andymccr> stevelle: thanks :)
16:07:25 <mhayden> #action andymccr to promote the upgrade jobs
16:07:27 <stevelle> it's looking good, just hitting edge cases
16:07:41 <mhayden> next action item was -> spotz to work alongside team to write release note for the removal of trusty from the master branch
16:07:49 <mhayden> spotz: how is that one?
16:08:15 <spotz> mhayden: hope to work on it today, shouldn't be that bad, just need to find the repo it's in:)
16:08:21 <mhayden> cool!
16:08:35 <mhayden> #action spots to complete release note for removal of trusty from master
16:08:36 <spotz> it is officially bugged and evrardjp marked it medium
16:08:39 <mhayden> #undo
16:08:40 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7fbb943fb310>
16:08:47 <mhayden> #action spotz to complete release note for removal of trusty from master
16:08:55 <mhayden> next item: everyone to review the Operations Guide draft proposal
16:09:03 <andymccr> asettle:  ^
16:09:08 <andymccr> how did that go
16:09:12 <mhayden> #link https://blueprints.launchpad.net/openstack-ansible/+spec/create-ops-guide
16:09:25 <asettle> andymccr: honestly? Not much from the community other than odyssey4me and evrardjp
16:09:27 <asettle> Thanks guys
16:09:52 <evrardjp> yw, but I really think the new ppl in the community should step in for this one
16:09:53 <asettle> We'll be going forward with what we have, and we will be looking at coming up with a direction by the end of this week
16:10:01 <asettle> evrardjp: I agree. But nobody seems interested.
16:10:02 <evrardjp> it could help them learn and give valuable input
16:10:03 <mhayden> sounds good, asettle -- thanks for the update
16:10:09 <mhayden> next item: logan- to do core things with vigor
16:10:14 <mhayden> i assume we've done this for logan- already
16:10:21 <asettle> I really should not be in charge of action items
16:10:21 <odyssey4me> maybe registering bugs for new content needed would work
16:10:25 <andymccr> more vigor, more vigor!
16:10:27 <odyssey4me> we seem to have people picking up bugs
16:10:27 <evrardjp> Who's vigor?
16:10:29 <mhayden> hah
16:10:40 <odyssey4me> so basically put a structure down, then register a bug for each TODO item
16:10:41 <asettle> odyssey4me: we'll work on a direction shortly
16:10:55 <mhayden> the rest of the action items are done
16:11:16 <mhayden> ready to move on past action items?
16:11:41 <evrardjp> go ahead you're the chair!
16:11:42 <cloudnull> o/
16:11:46 <palendae> No objection
16:12:02 <mhayden> #topic Release planning and decisions - andymccr
16:12:06 <mhayden> andymccr: you're up!
16:12:29 <andymccr> so, i'll be releasing the next release for mitaka/newton this week (tomorrow basically)
16:12:45 <andymccr> is there anything outstanding
16:12:46 <andymccr> that is urgent?
16:12:56 <andymccr> (any urgent backports - to shorten the 2 sentences)
16:12:57 <odyssey4me> nothing that I know of
16:13:31 <andymccr> ok cool - the next Ocata milestone is the week after next, so that is a bigger one - but assuming there are no issues i'll go ahead releasing newton/mitaka tomorrow then
16:14:05 <evrardjp> looks fine to me. Ocata is indeed a little different
16:14:18 <andymccr> one thing i had thought
16:14:22 <mhayden> cool -- anything else on this?
16:14:29 <andymccr> im not sure on peoples feelings, but im tempted to push the SHA's on master tomorrow
16:14:44 <mhayden> andymccr: my feelings would not be harmed
16:14:51 <andymccr> just to keep it rolling with the upstream projects - so we don't do bigger sha bumps closer to release time
16:14:54 <andymccr> mhayden: haha good to hear
16:15:16 <andymccr> if nobody has any objections to that i'll take care of that tomorrow too :)
16:15:27 <evrardjp> andymccr: it's better that way, I agree
16:15:37 <andymccr> ok cool - done with that topic then mhayden!
16:15:42 <mhayden> woot
16:15:51 <mhayden> #topic Blueprint work
16:16:13 <odyssey4me> andymccr yeah, historically we've bumped all SHA's in sync for all branches
16:16:19 <odyssey4me> ie every two weeks
16:16:30 <andymccr> odyssey4me: ok cool - sounds good
16:19:11 <andymccr> ok mhayden: blueprints? :)
16:19:19 <mhayden> hah, sorry, i'm in a vc meeting right now too
16:19:30 <mhayden> so the security work is 65% done as of this morning
16:19:34 <mhayden> thanks to everyone for the help there
16:19:37 <andymccr> nice!
16:19:54 <mhayden> about 83 of 236 controls left to implement/document
16:20:05 <mhayden> then i will work through upgrades and beg for testing help :)
16:20:35 <andymccr> sounds good
16:20:48 <mhayden> for now, just need help on reviews
16:20:55 <mhayden> any other blueprints to discuss?
16:20:58 <andymccr> ok so
16:21:07 <andymccr> the upgrade one - as i mentioned Swift/Neutron PRs need reviews
16:21:17 <andymccr> and nova needs a bit of work and then reviews
16:21:25 <andymccr> #link https://blueprints.launchpad.net/openstack-ansible/+spec/upgrade-testing
16:21:57 <andymccr> Secondly, the testing has changed now so we can start removing trusty support from roles. I've created the BP for that, but we'll need to actually start removing trusty now
16:22:04 <mhayden> hooray!
16:22:06 <andymccr> #link https://blueprints.launchpad.net/openstack-ansible/+spec/trusty-removal
16:22:36 <andymccr> i've listed each of the repositories in our deliverable - as a list there, so we can work through that as a work list for now.
16:23:03 <odyssey4me> maybe register a bug per repo to make it easier to self assign and do?
16:23:16 <odyssey4me> the bug can also be linked to the blueprint
16:23:17 <mhayden> not a bad idea, odyssey4me
16:23:30 <mhayden> should reduce people trampling on each other :)
16:23:37 <andymccr> odyssey4me: yeah i probably will, i might take a stab at one repo first - just to give a method of how to do it, so it becomes a more "low-hanging-fruit" style thing.
16:23:52 <odyssey4me> cool, sounds good
16:24:05 <andymccr> ok the other blueprint listed in the meeting is the Ops guide bp --> asettle
16:24:13 <andymccr> #link https://blueprints.launchpad.net/openstack-ansible/+spec/create-ops-guide
16:24:19 <asettle> andymccr: ongoing
16:24:20 <asettle> doing
16:24:24 <asettle> as discussed
16:24:26 <andymccr> yeah i guess we already kinda talked about that one
16:26:07 <mhayden> okay, good with blueprints for now?
16:26:12 <andymccr> si si
16:26:20 <mhayden> #topic Organize a regular bug killing day - evrardjp
16:26:24 <mhayden> evrardjp: you're up! :)
16:26:29 <evrardjp> oh
16:26:31 <evrardjp> so
16:26:57 <evrardjp> In short, our bug triage is working fine, and we do generally good
16:27:34 <evrardjp> However, I'd like to reduce the overall list of bugs we have pending, like the long lasting ones
16:28:04 <evrardjp> I think if we say that we organise bug killing on a regular basis, this could help produce better deliverables
16:28:20 <evrardjp> so I think we should organise bug killing sessions before releases/large milestones
16:28:31 <odyssey4me> ie work on fixing up bugs that are already triaged?
16:28:32 <mhayden> perhaps we do it right before milestone releases?
16:28:44 <odyssey4me> or working on confirming any bugs not yet triaged?
16:28:50 <evrardjp> fixing
16:29:05 <evrardjp> on already triaged but still opened
16:29:13 <jmccrory> there's some old incompletes out there, do they automatically close after some time?
16:29:15 <odyssey4me> and yeah, I agree with mhayden - a good time would be maybe the friday a week ahead of a milestone
16:29:26 <odyssey4me> jmccrory 180 days I think
16:29:36 <evrardjp> mhayden: that was my plan indeed
16:29:37 <odyssey4me> 180 days after the last comment
16:29:41 <evrardjp> jmccrory: yes they close
16:29:49 <andymccr> that would probably work - there is a milestone around once a month
16:29:50 <evrardjp> I think it's not that long
16:29:59 <odyssey4me> andymccr only for this cycle ;)
16:30:06 <evrardjp> andymccr: I don't think we are forced to do it once a month
16:30:08 <odyssey4me> usually milestones are 3 months apart
16:30:15 <evrardjp> odyssey4me: which is fine!
16:30:23 <odyssey4me> oh wait - not 3
16:30:29 <evrardjp> I think every 2 months is fine
16:30:34 <evrardjp> it's every 2 month
16:30:45 <evrardjp> IIRC
16:31:14 <evrardjp> 3 milestones
16:31:15 <odyssey4me> uh yeah, I think it's every 6 weeks
16:31:16 <odyssey4me> 3 milestones, then the RC
16:31:25 <odyssey4me> anyway, details
16:31:39 <evrardjp> question 1: do you agree?
16:31:53 <evrardjp> (on having these)
16:32:09 <evrardjp> question 2: Who would be able to participate on the next one? :D
16:32:15 <andymccr> yeah i think thats the key one
16:33:16 <evrardjp> anyway, if no one is against it, I'll come back with the next one schedule?
16:33:21 <mhayden> let's do it
16:33:29 <andymccr> if mhayden says it - its gonna happen
16:33:32 <jmccrory> good idea, i like it
16:33:34 <mhayden> uh oh
16:33:41 <evrardjp> mhayden: leeeeerrrooooooyyyyyyyy jenkins!
16:33:47 <mhayden> wonderful
16:33:55 <mhayden> okay, are we good on this one JP?
16:34:00 <evrardjp> yup
16:34:02 <mhayden> woot
16:34:06 <mhayden> #topic Open Floor
16:34:24 <mhayden> i missed the October WHOA due to the summit and various things, but it's time to write one for nov
16:34:28 <mhayden> #link https://etherpad.openstack.org/p/whoa
16:34:39 <odyssey4me> I'd like to discuss and hopefully resolve the impasse in the two approaches https://review.openstack.org/#/c/400579/ and https://review.openstack.org/#/c/404125/
16:34:41 <mhayden> please add things! it really helps me save time on cobbling together the report
16:35:14 <evrardjp> I've lost my etherpad to haproxy improvements, if someone could give me the link back that would be great.
16:35:46 <evrardjp> or I will fetch it from archives
16:35:57 <andymccr> #link https://etherpad.openstack.org/p/openstack-ansible-haproxy-improvements
16:36:07 <evrardjp> thanks andymccr!
16:37:37 <mhayden> anything else for today?
16:37:50 <stevelle> one more item, I noticed the other day that the glance role isn't testing properly. there was a script error I was able to reproduce. Seems fairly recent breakage, in the last 2 wks. haven't had time to look
16:37:51 <palendae> https://review.openstack.org/#/q/project:openstack/openstack-ansible+topic:%5Einventory.*+status:open has a few outstanding patches to review
16:37:59 <evrardjp> mhayden: odyssey4me wants to discuss apparently
16:38:00 <stevelle> it's just a problem with the role tests though, the role is working
16:38:15 <mhayden> evrardjp: oh, i missed the impasse line there
16:38:26 <evrardjp> oh it's my fault on top of it!
16:38:28 <evrardjp> :p
16:38:54 <andymccr> stevelle: i'll take a look
16:39:09 <mhayden> evrardjp / odyssey4me: can we get a TL;DR summary of the problem and the approaches?
16:39:27 <odyssey4me> yeah, I'd just like more eyes on the reviews and votes applied
16:39:32 <evrardjp> he loves tasks, I think this should be done by group vars :p
16:39:42 <evrardjp> and overrides
16:39:46 <mhayden> relevant bug: https://bugs.launchpad.net/openstack-ansible/+bug/1633105
16:39:46 <openstack> Launchpad bug 1633105 in openstack-ansible "Improve offline/near-offline installations" [Wishlist,In progress] - Assigned to Jesse Pretorius (jesse-pretorius)
16:39:48 <evrardjp> it does different things
16:39:50 <odyssey4me> I've outlined the problem and all reasoning in my commit msg
16:40:04 <andymccr> ahh yeah we were meant to discuss this today
16:40:06 <evrardjp> same for me :p
16:41:03 <evrardjp> I think there are many ways to solve this bug, but I'd like to avoid the addition of tasks and conditional wiring if possible, that was my rationale
16:41:14 <mhayden> i do like that odyssey4me's has a test in there to verify we don't get a 503
16:41:42 <evrardjp> mhayden: if you get a 503, you'd fallback into the fallback url
16:41:51 <evrardjp> which could still make the role not fail
16:42:16 <andymccr> i liked the idea of installing pip from apt in that case and then performing a pip install pip / apt-remove pip - if that would work
16:42:27 <evrardjp> but I understand this is different implementations, so different features
16:42:27 <odyssey4me> and I would like the repo to be used if it's there instead of always going upstream, and I'd also like to ensure that we still have two fallbacks
16:42:46 <automagically> odyssey4me: ++ Will review
16:42:48 <evrardjp> odyssey4me: which makes sense to me too odyssey4me
16:42:53 <odyssey4me> andymccr we did actually try that to solve the SNI issues, but it backfired badly
16:43:12 <andymccr> it just seems we are trying hard to put machinery in to work around get-pip.py not being versioned
16:43:13 <evrardjp> andymccr: I tried this on my 16.04 and it worked
16:43:25 <odyssey4me> the pip in the distro doesn't have upper constraints and couldn't do something else I can't recall - so we backed out quite quickly
16:43:52 <evrardjp> I also thought of an alternative approach, just ship the get-pip everywhere, regarding of presence of repo or not
16:44:07 <odyssey4me> no - not really, just making sure that we artifact get-pip.py into the repo and re-use it internally so that all hosts don't have to reach out to the internet
16:44:38 <evrardjp> every single thingy could bootstrap pip as part of the initial process
16:44:51 <andymccr> that sounds kinda horrible too :P
16:44:51 <odyssey4me> the distro method might work fine, but next time we need to test it more carfully because it broke our gates quite badly
16:46:11 <odyssey4me> I didn't want to hold up the meeting - just wanted to ask for more eyes.
16:47:25 * mhayden adds it to his list
16:48:19 <mhayden> about 11 minutes left
16:48:31 <palendae> https://review.openstack.org/#/q/project:openstack/openstack-ansible+topic:%5Einventory.*+status:open has a few outstanding patches to review, just looking for eyes
16:48:49 <mhayden> #action everyone to review https://review.openstack.org/#/c/400579/ and https://review.openstack.org/#/c/404125/
16:49:07 <mhayden> #action reviews needed for inventory improvements https://review.openstack.org/#/q/project:openstack/openstack-ansible+topic:%5Einventory.*+status:open
16:49:31 <mhayden> any last comments/questions?
16:50:33 <evrardjp> none
16:50:38 <mhayden> okay, i'm closing it up
16:50:41 <evrardjp> thanks for the meeting
16:50:41 <mhayden> thanks everyone! :)
16:50:45 <mhayden> #endmeeting