16:00:00 <mhayden> #startmeeting openstack_ansible_meeting
16:00:01 <openstack> Meeting started Thu Dec 8 16:00:00 2016 UTC and is due to finish in 60 minutes. The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:09 <mhayden> #topic Roll Call
16:00:13 <palendae> o/
16:00:13 * mhayden toots
16:00:14 <asettle> o/
16:00:25 <andymccr> o/
16:01:12 * mhayden starts banging pots and pans together
16:01:30 <mhayden> JOIN THE MEETING OR I'LL REBASE 20 MORE PATCHES
16:01:33 <mhayden> :P
16:01:44 <mgariepy> o/
16:02:05 <andymccr> mhayden: i've cleaned my hands of that :P i believe i have reviewed all of them now
16:02:31 <logan-> o/
16:02:46 <jmccrory> o/
16:02:56 * mhayden will give it til 16:05
16:02:57 <cathrichardson> o/
16:03:21 <mhayden> perhaps asettle can bestow a GIF upon us to warm things up
16:03:26 <asettle> Oh
16:03:27 <asettle> hold up
16:03:53 <evrardjp> o/
16:04:16 <asettle> https://media.giphy.com/media/m80Q4HTDNPFHq/giphy.gif
16:04:20 <asettle> DANG IT GIPHY
16:04:26 <mhayden> nicely done
16:04:36 <mhayden> okay, let's get rolling
16:04:44 <mhayden> #topic Review action items
16:04:57 <mhayden> first up is -- andymccr to promote the upgrade jobs
16:05:01 <andymccr> done!
16:05:05 <asettle> http://www.pbh2.com/wordpress/wp-content/uploads/2013/06/funny-gif-nobody-got-time-for-that.gif
16:05:05 <mhayden> woot
16:05:08 <asettle> HA PERFECT
16:05:11 <asettle> Here all week
16:05:17 <mhayden> asettle: the time for gifs has passed -- my business socks are on
16:05:23 <asettle> I'm sorry :(
16:05:29 <mhayden> asettle: i'm kidding :P
16:05:37 <evrardjp> I am not
16:05:41 <mhayden> okay, next is everyone to review https://review.openstack.org/#/c/400579/ and https://review.openstack.org/#/c/404125/
16:05:43 <asettle> :P
16:05:44 <evrardjp> :p
16:05:49 <andymccr> done, since one merged
16:05:53 <andymccr> the battle of mergery has completed
16:05:58 <mhayden> it appears that the battle has completed
16:06:13 <mhayden> two patches enter, one patch leaves with workflow ;)
16:06:31 <mhayden> next is reviewing the inventory patches -> https://review.openstack.org/#/q/project:openstack/openstack-ansible+topic:%5Einventory.*+status:open
16:06:44 <mhayden> looks like there's one in the queue with a -1 from stevelle
16:07:16 <mhayden> palendae replied, so we might need more comments from stevelle and neillc
16:07:25 <andymccr> and git-harry
16:07:30 <palendae> Yep
16:07:31 <mhayden> yup
16:07:42 <palendae> A lot of them merged last week
16:07:51 <mhayden> last one is spotz to add a reno for removing trusty
16:07:51 <andymccr> another great success then
16:08:02 <mhayden> spotz: i thought i saw that one go in
16:08:18 <spotz> mhayden: It merged, we were talking about a newton patch as well
16:08:49 <mhayden> cool beans
16:09:10 <mhayden> rolling to the next agenda item... https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:09:21 <mhayden> #topic Release Planning & Decisions - andymccr
16:09:26 <andymccr> ok!
16:09:35 <andymccr> so next week is milestone 2 for Ocata, and another release for newton/mitaka
16:09:51 <andymccr> Liberty is being EOL'd (there is an email from Tony B regarding that)
16:09:57 <andymccr> so that'll happen soon
16:10:04 <andymccr> but as always, if there are urgent prs let me know
16:10:05 <mhayden> lots of changes
16:10:15 <andymccr> I'm going to try get the milestone 2 in mid week as opposed to the end of week rush :)
16:10:24 <mhayden> FWIW, 14.0.3 works great from upgrading from 13.3.9 ;)
16:10:39 <andymccr> but so far, aside from Ceilometer we have had SHA bumps go in successfully for all other projects in the integrated build
16:10:58 <andymccr> mhayden: excellent. on trusty i assume?
16:11:03 <mhayden> right
16:11:10 <mhayden> the trusty -> xenial upgrade was... painful
16:11:18 <mhayden> and i have a control plane node that needs to be reinstalled :|
16:11:19 <andymccr> yeah we found a bug (thanks to upgrade tests) in xenial for nova
16:11:20 <andymccr> which is now fixed
16:11:34 <andymccr> will be in the release next week
16:11:48 <mhayden> anything else on releases? anyone have any patches that need merging prior to next release?
16:12:11 <logan-> https://review.openstack.org/#/c/408677/ will need to go in the next newton tag
16:12:35 <andymccr> ok
16:12:49 <andymccr> #action review and backport https://review.openstack.org/#/c/408677/ (and review the backport!)
16:13:11 <andymccr> if some cores could star that to review it later so we can get it in for next week that'd be appreciated
16:14:07 <adreznec> I wouldn't mind landing this one as well https://review.openstack.org/#/c/407607/
16:14:22 <adreznec> It already has one +2, so if another core could take a look I'd appreciate it!
16:14:48 <andymccr> #action review https://review.openstack.org/#/c/407607/ before release
16:14:53 <andymccr> will take a look at both those
16:15:30 <mhayden> okay, anything else?
16:16:21 <palendae> https://launchpad.net/bugs/1643680 and https://review.openstack.org/#/c/407655/ will need some eyes as potential issues for upgrading
16:16:21 <openstack> Launchpad bug 1643680 in openstack-ansible "Shift to using dashes instead of underscores for container names" [Wishlist,In progress] - Assigned to Nolan Brubaker (nolan-brubaker)
16:16:49 <palendae> The review I'm still working on, but the bug overall will require renaming all the groups in the environment...I think we could use some more thoughts on that
16:18:09 <andymccr> palendae: im not sure that one will make the release next week
16:18:15 <palendae> andymccr: Nor am I
16:18:22 <palendae> In fact I'm sure it won't
16:18:27 <odyssey4me> palendae I've posed a question about why the group rename is required in the bug.
16:18:30 <palendae> I'm fine with deferring, but it's also a huge change
16:18:35 <andymccr> hahah ok good just ensuring its not deemed critical for next release
16:19:03 <palendae> odyssey4me: Ah, ok
16:20:14 <mhayden> good on this topic for now?
16:20:39 <andymccr> gonna go with yes in that case :)
16:20:42 <mhayden> WOOT
16:20:49 <mhayden> #topic Blueprint work
16:21:01 <mhayden> on the security role front, there are 6 controls left to propose
16:21:13 <mhayden> 57 are pending review -> https://review.openstack.org/#/q/status:open+project:openstack/openstack-ansible-security+branch:master+topic:bp/security-rhel7-stig
16:21:45 <mhayden> once that's done, i'll go backt through and look for missing tags and other random broken things
16:21:47 <mhayden> and i'll need testers
16:22:04 <mhayden> #link https://review.openstack.org/#/q/status:open+project:openstack/openstack-ansible-security+branch:master+topic:bp/security-rhel7-stig
16:22:23 <mhayden> any review help there would be awesome... merge conflicts might pop up but i'll try to get those resolved quickly
16:23:11 <logan-> thanks mhayden. will start looking thru them
16:23:20 <mhayden> logan-: thanks mucho!
16:23:30 <mhayden> and thanks to everyone who has been working through those
16:23:40 <mhayden> i'll likely start getting onto octavia once this settles down
16:23:58 <mhayden> asettle: anything to talk about here with regard to the ops guide?
16:24:29 <andymccr> mhayden: she's not about atm - but i know they're going ahead after tomorrow - so any feedback on the ops guide "outline" needs to be in by end of play tomorrow!
16:24:44 <andymccr> thanks to those who have, i know evrardjp and jmccrory put some feedback in.
16:25:23 <mhayden> sounds good
16:25:26 <mhayden> anything else on blueprints?
16:25:38 <andymccr> so on the ugprade testing
16:25:40 <andymccr> there are 2 reviews left
16:25:48 <mhayden> andymccr: got a link?
16:25:55 <andymccr> #link https://review.openstack.org/#/q/topic:bp/upgrade-testing
16:26:05 <andymccr> they are working now, so any reviews would be appreciated
16:26:50 <andymccr> oh and on trusty removal
16:27:17 <andymccr> i know odyssey4me added a PR for the main repo, I've added a "POC" for swift: https://review.openstack.org/#/q/topic:bp/trusty-removal
16:28:24 <mhayden> nice
16:28:28 <mhayden> okay...
16:28:31 <mhayden> #topic Open floor
16:28:38 <mhayden> anything else anyone wants to bring up?
16:29:12 <odyssey4me> IT'd be nice to have some review on these backports: https://review.openstack.org/408540 & https://review.openstack.org/406803
16:30:03 <andymccr> there is one topic of discussion around the OVS.dvr work and the groups assignments for that
16:30:20 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1645979
16:30:20 <openstack> Launchpad bug 1645979 in openstack-ansible "neutron_l3_agent and neutron_l3_metadata groups include physical host" [Undecided,New]
16:30:42 <andymccr> ahh yeah - automagically isn't here, so we might have to table that until we can get Travis involved
16:31:05 <evrardjp> k
16:31:33 <evrardjp> we cannot postpone for too long, so let's give a deadline for this discussion
16:31:59 <andymccr> short version - we'd like to remove the grouping by default, and anybody using OVS.dvr should add it manually (like we do for cinder in a container and a few others) - which we add docs for
16:32:14 <evrardjp> alextricity25: would like to have input on this if I'm not mistaken :p
16:32:40 <alextricity25> +1
16:33:01 <alextricity25> Thanks evrardjp
16:33:08 <evrardjp> hehe yw
16:33:31 <michaelgugino> just wanted to say hello. I've been mia for the last few weeks, busy with internal stuff. But I'm still here
16:33:41 <andymccr> i know a lot of the discussion has happened in the bug, so perhaps we can continue this there, and I'll ping automagically to review once more
16:33:52 <odyssey4me> :) I've been somewhat tied up mysefl
16:33:53 <odyssey4me> *myself
16:33:54 <andymccr> michaelgugino: nice to see you back
16:34:04 <evrardjp> michaelgugino: good to hear, there is nova-lxd that was missing some love :p
16:34:15 <evrardjp> joke aside, glad to see you here michaelgugino :D
16:34:27 <michaelgugino> :) What's happening with nova-lxd?
16:34:42 <michaelgugino> We're going to start a poc internally at some point in the near future, or so I'm told
16:35:06 <evrardjp> andymccr: if we agree with the approach, we can go for a patch and fix it, and discuss in the review with Travis
16:35:51 <andymccr> evrardjp: im ok with that, im just concerned there are others using that - and we need to make sure we're not creating an upgrade nightmare
16:36:54 <logan-> evrardjp: i agree it would be good to get a review in asap so we can try to get something in the ocata milestone and into a newton tag soon after that
16:37:04 <andymccr> it'd have to wait for ocata m3
16:37:21 <andymccr> the turn around is too short, but thats ok since we're just doing milestones at the moment (in my opinion)
16:38:07 <andymccr> ok so is there a volunteer to propose the patch for that?
16:38:15 <andymccr> i mean its a simple one really - depending on the approach
16:39:25 <logan-> i'll work on it.
16:39:51 <andymccr> thanks logan-!
16:39:52 <logan-> the group change is easy, will have to work up some docs in the neutron role as well
16:39:58 <evrardjp> oh thanks for devoting yourself on this one logan- :D
16:40:02 <evrardjp> I'll review it then
16:41:09 <andymccr> logan-: we're adding some comments to the bug
16:41:15 <andymccr> i think i have a new idea that may work for that
16:41:15 <odyssey4me> can always just use an add_host task to add the host to the group conditionally
16:41:52 <odyssey4me> ie if you're using dvr, then add the compute host into the grou
16:41:53 <odyssey4me> *group
16:43:05 <andymccr> ok i think we're done on that
16:43:13 <logan-> that might work well. i'll look at that odyssey4me
16:43:14 <evrardjp> agreed andymccr
16:43:38 <evrardjp> add_host seem the best, you can do it based on facts and all funsies
16:43:47 <andymccr> seems cleanest and simplest if possible
16:43:58 <evrardjp> the hardest in that patch is the release note
16:45:45 <andymccr> ok i think we're done here - mhayden do the honours?
16:45:53 <mhayden> WOOT
16:45:56 <mhayden> thanks everyone
16:45:57 <mhayden> #endmeeting