16:00:00 <mhayden> #startmeeting openstack_ansible_meeting
16:00:01 <openstack> Meeting started Thu Mar  9 16:00:00 2017 UTC and is due to finish in 60 minutes.  The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:07 <mhayden> #topic Roll Call
16:01:07 <andymccr> o/
16:02:04 <andymccr> its just me and you major ;)
16:02:30 <mgariepy> i'm here
16:02:41 <mhayden> it is close to spring break in many parts ofthe US
16:02:58 <antonym> o/
16:03:27 <evrardjp> o/
16:03:30 <jmccrory> o/
16:03:41 <asettle> o/
16:04:00 * mhayden will wait til :05 after
16:04:05 <evrardjp> I still think I should do \o
16:04:31 <evrardjp> at least it's not o? this time
16:05:12 <evrardjp> or maybe \o/ because I'm super enthusiastic!
16:05:25 <mhayden> #topic Review action items
16:05:25 <evrardjp> it's :05
16:05:46 <mhayden> looks like we didn't have any
16:05:59 <asettle> Hooray
16:06:02 <mhayden> or wait
16:06:10 <mhayden> we need a name for the OSA inventory python package
16:06:14 <mhayden> palendae: any updates there?
16:06:40 <palendae> mhayden: None yet; I didn't get to sending an email to the mailing list. Last I checked there weren't a ton of votes for anything
16:06:51 <palendae> Maybe 1-2 for each name https://etherpad.openstack.org/p/osa-python-package-name
16:07:21 <mhayden> i still think openstack-ansible-palendae-inventory-improvement-thing-2017 has a nice ring to it
16:07:36 <andymccr> hahahahahaha
16:07:40 <andymccr> yeah that is pretty good
16:07:44 <mhayden> ship it
16:07:57 <palendae> Dashes aren't allowed ;)
16:08:01 <mhayden> palendae: could you send a few final candidates to the ML and we can sort it out?
16:08:05 <andymccr> with your name on it you'll still be fielding questions for many years to come :P
16:08:08 <palendae> And I think that goes over the line limit ;)
16:08:08 <evrardjp> palendae: replace with underscores
16:08:11 <asettle> osai
16:08:12 <asettle> really
16:08:14 <asettle> who came up with osai?
16:08:20 * palendae shrugs
16:08:24 <palendae> I proposed none of these fwiw
16:08:32 <palendae> mhayden: Yes, I will try to get that done this week
16:08:39 <mhayden> palendae: woot
16:08:54 <mhayden> #action palendae to email a list of a few final names to the list for discussion/voting
16:09:09 <mhayden> the other action item was for logan- --> "add ceph_client version bump to development cycle checklist"
16:09:27 <logan-> o/
16:09:30 <logan-> still on todo
16:09:31 <spotz> sorry was trying to catch up on dev list:)
16:11:20 <mhayden> hah okay
16:11:26 <mhayden> we'll keep it then
16:11:36 <mhayden> #action logan- to add ceph_client version bump to development cycle checklist
16:11:51 <mhayden> #topic Ops Guide - asettle
16:11:55 * mhayden hands the mic to asettle
16:12:02 <asettle> Not much!
16:12:03 <asettle> REviews :)
16:12:04 <asettle> Content
16:12:08 <asettle> You konw the drill hoomans
16:12:17 <asettle> Those who have signed up for content, add it in
16:12:20 <asettle> We have until May
16:12:51 <asettle> I think that's all mhayden :)
16:13:00 <mhayden> asettle: woot!
16:13:26 <mhayden> next up is naming the python package -- i think we've covered that
16:13:32 <mhayden> moving along...
16:13:37 <mhayden> #topic New periodic jobs - odyssey4me
16:13:41 * mhayden hands the mic to odyssey4me
16:13:49 <odyssey4me> howdy folks
16:13:51 <andymccr> excitement inc!
16:14:01 <odyssey4me> so, we have a periodic upgrade test for xenial which runs once a day
16:14:05 <andymccr> \o/
16:14:09 <odyssey4me> it's the first of many periodics planned
16:14:43 <odyssey4me> I'd like to ask that we try to figure out how we expose the results a little more actively
16:14:49 <odyssey4me> the results are posted here: http://logs.openstack.org/periodic/
16:15:02 <evrardjp> #link http://logs.openstack.org/periodic/
16:15:14 <odyssey4me> we only have one right now, but once there are more the folder is the job name
16:15:21 <mhayden> http://logs.openstack.org/periodic/periodic-openstack-ansible-upgrade-aio-master-ubuntu-xenial/
16:15:32 <mhayden> odyssey4me: can we get a notification via IRC bot perhaps?
16:15:33 <odyssey4me> I was thinking maybe that we could add a dev-docs page which shows where they are
16:15:49 <odyssey4me> mhayden not to my knowledge, but I can ask
16:15:59 <odyssey4me> that's a good idea
16:16:09 <odyssey4me> make me an action maestro
16:16:22 <mhayden> YARLY
16:16:34 <odyssey4me> I've been bashing in a bunch of fixes to try and make it succeed
16:16:35 <mhayden> we could hack something up, but it wouldn't be as good most likely
16:17:00 <odyssey4me> ideally I'd like to see it exposed in the OpenStack Health Dashboard
16:17:18 <mhayden> http://status.openstack.org/openstack-health/#/
16:17:22 <odyssey4me> I've asked cloudnull if he can try and make ARA output subunit streams instead of just junit
16:17:27 * mhayden hasn't looked at this fancy thing in a while
16:17:39 <odyssey4me> not sure if anyone has some time to sinnk into doing that
16:18:10 <odyssey4me> our automated upgrade script is a bit of a shambles, to be honest
16:18:14 <odyssey4me> we need an overhaul
16:18:48 <odyssey4me> any volunteers to work with me to work on a conprehensive improvement?
16:18:56 <odyssey4me> *comprehensive
16:19:22 * odyssey4me looks at logan- and jmccrory
16:19:30 <jmccrory> sure
16:19:36 <andymccr> logan-: jmccrory when you are finished fighting over who gets to do it :P
16:19:39 <evrardjp> :D
16:19:44 <logan-> lol
16:19:44 <andymccr> voluntold!
16:20:02 <mhayden> internet just dropped here
16:20:05 <mhayden> back now
16:20:26 <evrardjp> mhayden: we decided that jmccrory would rehaul the upgrade bits
16:20:26 <odyssey4me> ok, logan- and jmccrory I'll setup an etherpad to discuss what we want and break it into pieces
16:20:30 <evrardjp> you can help
16:20:41 <evrardjp> lol
16:20:47 <logan-> ok thanks odyssey4me
16:20:58 <mhayden> evrardjp: success!
16:21:02 <andymccr> best ever.
16:21:03 <odyssey4me> no, thank you for volunteering logan- and jmccrory :)
16:21:16 * mhayden goes and orders upgrade fixes for pickup at walmart
16:21:36 <mhayden> okay, are we good on this topic ?
16:21:41 <odyssey4me> right, but back to the periodics
16:21:54 <odyssey4me> are there any other tests we want to add to the list of periodics?
16:22:08 <andymccr> odyssey4me: telemetry is the obvious one right now (since we removed it from the integrated build)
16:22:37 <odyssey4me> I was thinking of backporting the upgrade test to Newton->Ocata as well to prevent further bitrot
16:22:44 <odyssey4me> also Ironic
16:22:59 <odyssey4me> PErhaps some sort of scenario that involves Magnum, Sahara
16:23:19 <andymccr> yeah ironic. smh - i need to try find some time. because this: https://review.openstack.org/#/c/392959/ is now passing so we should be able to reverse engineer that into our ironic gates
16:24:04 <odyssey4me> ok, once the upgrade test is working I'll troll for ideas in channel
16:24:11 <odyssey4me> I think we're good here.
16:24:38 <andymccr> boom - and thanks for the work, its awesome to see the upgrade test up and running (and almost passing)
16:24:49 <logan-> +1
16:25:07 <andymccr> speaking of - i will be fixing up our in role upgrade tests and making them voting
16:25:26 <odyssey4me> yeah, there are a bunch of tests that should be promoted
16:25:35 <odyssey4me> otherwise patches merge which break them
16:25:42 <andymccr> yeah basically
16:25:45 <odyssey4me> the ceph AIO job should be made voting IMO
16:25:51 <andymccr> currently i think neutron/nova are broken the others are mostly working so going to get that set up
16:25:53 <odyssey4me> the xenial one I mean
16:25:58 <andymccr> yeah happy with that too
16:26:50 <andymccr> ok i think we're good to move on mhayden!
16:26:53 <mhayden> woot
16:27:21 <mhayden> #topic Release planning and decisions - andymccr
16:27:24 * mhayden hands it to andymccr
16:27:50 <andymccr> ahh yeah
16:27:50 <andymccr> so
16:27:52 <andymccr> drum roll
16:27:57 <andymccr> Ocata 15.0.0 was released this week!
16:28:05 <mhayden> WOOT
16:28:11 <andymccr> i know, i know.
16:28:17 <mhayden> #success OpenStack-Ansible 15.0.0 Ocata released this week
16:28:46 <andymccr> but genuinely, thanks for all the work during the cycle - aside from the rc1 hiccups it really was pretty smooth (and those werent necessarily our messups)
16:28:51 <andymccr> so onward and upward to Pike!
16:28:54 <odyssey4me> gratz andymccr - it's looking pretty good, we fixed up a lot of upgrade things and should be doing plenty more
16:29:14 <evrardjp> thanks andymccr
16:29:23 <andymccr> Newton/Mitaka are being released as usual, so next week will be another released, I'll SHA bump for Ocata but only do a release 15.0.1 2 weeks after (so we can keep them all released at the same cadence)
16:29:50 <evrardjp> "give back to caesar what belongs to caesar"
16:30:07 * mhayden wants a caesar salad
16:30:24 <andymccr> ahhaha
16:30:27 <andymccr> yeah that!
16:30:38 <evrardjp> give that back!
16:30:45 <andymccr> there are a few critical bugs up still, the keystone one and a high one around mysql upgrades  - so we still have some bits to do
16:31:16 <andymccr> that's all i got on releases!
16:31:20 <asettle> \o/
16:32:48 <andymccr> mhayden: next!
16:32:59 <mhayden> #topic Blueprints
16:33:08 <mhayden> xgerman: want to give us a brief on octavia?
16:33:17 <xgerman> sure
16:34:16 <xgerman> Octavia is an operator grade load balancer… and I put together some playbooks to install it
16:34:56 <xgerman> the main advantage is that it is HA as opposed to the previous one which didn;t have redundancy
16:35:27 <xgerman> I set it up that if Octavia isinstalled Neutron will make it the default load balancer in the system
16:35:45 <mhayden> nice -- what do you need from us to finish up the work?
16:35:58 <xgerman> the missing two patches merged
16:36:12 <xgerman> #link https://review.openstack.org/#/c/428979/
16:36:44 <xgerman> #link #link https://review.openstack.org/#/c/422062/13
16:37:01 <xgerman> the lat one has some jenkins problem I don't understand
16:37:34 <xgerman> Once I have it running on. a multnode cluster I will write up some installation guide
16:37:52 <mhayden> that will be great -- docs on octavia are a little sparse ;)
16:38:08 <xgerman> it’s a major push for the Octavia team this cycle
16:38:14 <asettle> xgerman: feel free to tag me in the review, happy to watch your docs :)
16:38:17 <asettle> 'watch' sigh
16:38:18 <asettle> Review them
16:38:22 <xgerman> thx
16:38:32 <xgerman> also I am planning to keep up with the milestone releases
16:38:39 <mhayden> xgerman: looks like tempest is angry in the gate
16:38:44 <odyssey4me> xgerman getting reviews for those is a bit hard because not many people understand networking well enough to review properly
16:38:45 <mhayden> http://logs.openstack.org/62/422062/13/check/gate-openstack-ansible-openstack-ansible-aio-ubuntu-xenial/9d149ab/console.html#_2017-03-09_15_13_14_900543
16:38:46 <xgerman> yep
16:38:54 <xgerman> but I couldn;t see why
16:39:01 <xgerman> that formatting is crazy
16:39:34 <mhayden> i can try to build an AIO from that patch later and see what's happening
16:39:37 <odyssey4me> xgerman does it work if you test locally?
16:39:56 <odyssey4me> Binding failed for port 52dd82ba-6e57-45c0-9ae5-bbe3cfe13682, please check neutron logs for more information.
16:40:03 <xgerman> mmh
16:40:30 <xgerman> I will run it locally and see if I have more luck
16:41:41 <xgerman> also do you need Octavia backported to Ocata?
16:42:07 <andymccr> xgerman: we wouldn't backport a feature
16:42:16 <xgerman> ok, that’s what I thought
16:42:21 <odyssey4me> a major feature
16:42:35 <andymccr> si si :)
16:44:19 <odyssey4me> especially with such a small user/dev base
16:44:50 <odyssey4me> it also is entirely unproven - we need to grow a user base and hopefully pick up more than one maintainer for the role
16:45:16 <andymccr> yeah ideally - that'll happen with time though, so its not really a stress
16:45:53 <jmccrory> there's interest where i work, i'm pushing to get them to test the patches out there for review now instead of the manual install they've been doing
16:46:09 <andymccr> jmccrory: sounds awesome
16:46:11 <xgerman> +1
16:46:45 <andymccr> excellent :)
16:46:55 <xgerman> I also have some interest from other people in the community - once it works it could be quite popular
16:47:02 <odyssey4me> excellent, if we can get more than one org maintaining it then we can encourage its use
16:47:09 <odyssey4me> it can mature a bit and release in pike properly
16:47:16 <mhayden> woot!
16:47:26 <andymccr> yeah agreed
16:47:29 <mhayden> such collaboration, much happy
16:47:32 <xgerman> yeah, it’s in early…
16:47:34 <evrardjp> "once it works" doesn't sound motivating
16:47:58 <mhayden> the glass is half-full, darnit!
16:48:25 <xgerman> yeah, my installations work but I haven’t tried with everything merged properly
16:48:27 <mhayden> in other news, cloudnull and i have been working on the monitoring plugin PoC as part of the monitoring spec
16:48:31 <andymccr> ahh yeah
16:48:32 <mhayden> https://github.com/major/monitorstack
16:48:32 <andymccr> awesome
16:48:45 <evrardjp> mhayden: glass is always full!
16:48:57 <mhayden> test coverage is increasing and it's easily buildable in pypi
16:49:17 <mhayden> i'd like to bring it under the openstack namespace at some point
16:49:24 <andymccr> mhayden: yeah i like that idea
16:49:26 <mhayden> i've been talking to mrhillsman about that
16:49:35 <mhayden> he said the ops folks would be interested
16:50:12 <mhayden> would it make sense to have it under openstack-ansible's responsibility for a bit until it finds a forever home?
16:50:13 <andymccr> mhayden: would end goal to test it using OSA (and perhaps vice-versa?)
16:50:19 <mhayden> andymccr: yeah
16:50:23 <andymccr> mhayden: yeah im happy with that
16:50:30 <andymccr> not sure if there are any objections
16:50:34 <andymccr> the aim would be to have it be generic
16:50:40 <andymccr> but we are maintaining it for now, similar to the security role
16:50:46 <mhayden> i just called it monitorstack because i couldn't find anything big in Google for that
16:51:36 <andymccr> mhayden: in OpenStack-Ansible we have a rich tradition of inventing smart and fanciful names - i expect you to uphold that tradition
16:52:13 <odyssey4me> I'd just suggest that we don't prefix the repo name with openstack-ansible
16:52:30 <odyssey4me> It'll need to be a more universal name.
16:52:48 <mhayden> hah
16:52:49 <odyssey4me> Perhaps it should be its own project name, but we curate it initially.
16:52:52 <mhayden> odyssey4me: current name is 'monitorstack'
16:53:21 <andymccr> i dont mind either way - if its more work to create a separate project now, then happy to just include it in the openstack-ansible namespace for now
16:54:00 <mhayden> okay, we can talk on that one later in the channel
16:54:05 <mhayden> #topic Open floor
16:54:08 <mhayden> anything else?
16:54:13 <andymccr> all good from my side
16:54:57 <odyssey4me> mhayden andymccr I'm suggesting that it just be another repo in our deliverables, but not with our prefix
16:55:06 <andymccr> ahh that works
16:55:09 <mhayden> odyssey4me: totally agreed
16:55:17 <andymccr> agreement has been reached!
16:55:17 <odyssey4me> therefore it can move out of our deliverables at another time without the hassle of renaming the repo
16:55:45 <mhayden> woot
16:55:50 <mhayden> okay, i'll close this meeting up
16:55:53 <odyssey4me> it could possibly actually fit under the oslo umbrella, but let's not even try
16:55:53 <mhayden> thanks everyone! :)
16:56:01 <mhayden> #endmeeting