16:00:23 <asettle> #startmeeting openstack_ansible_meeting
16:00:28 <openstack> Meeting started Thu Mar 16 16:00:23 2017 UTC and is due to finish in 60 minutes. The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:32 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:43 <asettle> #topic Roll callllllllll
16:00:45 <palendae> Hello
16:00:51 <asettle> I'll give it 5 :)
16:01:22 <spotz> \o/
16:01:56 <odyssey4me> o/
16:02:55 <asettle> If we don't have quorum (5 people) by 5 past, I'm going to call it quits :)
16:03:22 <spotz> We have 4!:)
16:03:42 <asettle> And evrardjp is about to grace us with his presence
16:03:57 <evrardjp> o/
16:04:01 <asettle> Ohhhh what a surprise
16:04:01 <spotz> woot!
16:04:14 <cloudnull> o/
16:04:15 <evrardjp> you had a hint asettle.
16:04:20 <asettle> Woah 6 people
16:04:23 <asettle> Slow downnnnnn
16:04:24 <evrardjp> that's cheating!
16:04:27 <palendae> Also DST
16:04:29 <evrardjp> hehe
16:04:36 <evrardjp> DST?
16:04:36 <palendae> So it's noon eastern time now =\
16:04:48 <evrardjp> daylight saving or dst port?
16:04:50 <spotz> yeah which reminds me need to send a reminder out for the WoO meeting on Monday:)
16:04:52 <asettle> evrardjp: daylight savings
16:04:53 <palendae> Savings
16:04:56 <asettle> Alright dudes
16:04:58 <asettle> Let's rocket
16:04:59 <ediardo> o/
16:05:03 <asettle> #topic Review action items from last week
16:05:22 <xgerman> o/
16:05:33 <asettle> Woah stop guys, that's a whole 8 of us, including the imposter, ediardo
16:05:39 <asettle> Right, moving on
16:05:44 <odyssey4me> lol
16:05:45 <evrardjp> :)
16:05:49 <evrardjp> he is undercover.
16:05:50 <asettle> Did we have any action items? I can't see anything
16:05:55 <evrardjp> welcome ediardo!
16:06:02 <evrardjp> now that your cover is blewn
16:06:04 <ediardo> "_
16:06:05 <ediardo> :)
16:06:09 <palendae> I was supposed to send a mail out to the openstack-dev list for a python package name - http://lists.openstack.org/pipermail/openstack-dev/2017-March/114084.html
16:06:22 <palendae> I'll start flipping coins for names tomorrow
16:06:24 <asettle> You sure were
16:06:26 <asettle> Thank you palendae
16:06:40 <jmccrory> o/
16:06:44 <asettle> And logan- you were supposed to add ceph_client version bump to dev cycle checklist
16:06:51 <asettle> A wild jmccrory appears
16:06:58 <cloudnull> palendae: ++ erator :)
16:06:58 <palendae> #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/114084.html
16:07:01 <evrardjp> woot!
16:07:22 <asettle> #action palendae will flip coins for names tomorrow for the python package. Stay tuned
16:07:27 <asettle> logan-: guessing you're avoiding us, how could you
16:07:44 <asettle> Onwards and upwards humans, no time for chat here
16:07:49 <asettle> #topic Discussion
16:07:51 <asettle> Item one!
16:07:53 <asettle> #topic Operations guide
16:07:56 <asettle> Which is me, what a shock
16:08:03 <asettle> EVeryone the ops guide is fine, please commit, etc etc
16:08:07 <asettle> Review, etc etc
16:08:30 <asettle> We will keep the summit as teh official 'edit' target
16:08:36 <asettle> But evrardjp you're being painful, right your firewall stuff
16:08:40 <asettle> :p
16:08:44 <odyssey4me> *write ;)
16:08:45 <asettle> write* omg how embarrasment
16:08:48 <asettle> I have to quit
16:08:57 <asettle> MOVING ON
16:09:05 <asettle> #topic Python package naming
16:09:06 <asettle> palendae:
16:09:20 <palendae> See http://lists.openstack.org/pipermail/openstack-dev/2017-March/114084.html and https://etherpad.openstack.org/p/osa-python-package-name
16:09:22 <palendae> :)
16:09:34 <evrardjp> Right. I will not tell louder what I think anymore. The walls have ears.
16:09:37 <palendae> erator currently has the most +1s
16:09:53 <asettle> Omg you're joking
16:09:56 <palendae> I am not
16:10:00 <asettle> I really hate this shit
16:10:01 <asettle> :p
16:10:16 <evrardjp> I will propose another name
16:10:26 <odyssey4me> horde
16:10:28 <asettle> evrardjp: if it ends in 'ator' or 'ization' i'll murder you
16:10:35 <odyssey4me> pity there's another open source project by that name
16:10:39 <asettle> Oh noooo
16:10:41 <evrardjp> elbisna-kcatsnepo
16:10:47 <asettle> OH yes very catchy evrardjp
16:10:49 <asettle> Just slips off the tongue
16:10:52 <palendae> evrardjp: 👍
16:10:55 <cloudnull> erator is a win !
16:11:00 <asettle> cloudnull: don't you start.
16:11:01 <evrardjp> it has cats in it.
16:11:07 <asettle> evrardjp: oh well in that case...
16:11:08 <evrardjp> and it's an anagram.
16:11:13 <evrardjp> YES ofc!
16:11:14 <asettle> Your mum is an anagram!
16:11:17 <cloudnull> asettle: you love our engrish
16:11:23 <asettle> Okay fo real moving on
16:11:25 <spotz> heheh
16:11:27 <evrardjp> not really.
16:11:27 <asettle> erator is the new stupid name
16:11:35 <asettle> #topic New periodic jobs
16:11:37 <asettle> odyssey4me: go
16:11:58 <odyssey4me> ah yes, I think I forgot to remove this
16:12:09 <odyssey4me> but basically we have a periodic upgrade job, the first of many
16:12:27 <odyssey4me> see http://logs.openstack.org/periodic/periodic-openstack-ansible-upgrade-aio-master-ubuntu-xenial/ for results, please check daily
16:12:29 <evrardjp> \o/
16:12:31 <odyssey4me> it runs once per day
16:12:38 <evrardjp> is there an rss feed?
16:12:40 <asettle> Like ... your... mum?
16:12:58 <evrardjp> You know that makes me sad.
16:13:07 <odyssey4me> I've used 'upgrade-fix' as a topic to implement fixes to make it work
16:13:18 <odyssey4me> one went in today, we'll see tomorrow how far it takes us
16:13:35 <odyssey4me> once ocata->master works, I'll add newton->ocata
16:13:47 <odyssey4me> any questions on how this works? or suggestions for improvement?
16:14:19 <evrardjp> none it's a great idea to start with that
16:14:30 <odyssey4me> see https://review.openstack.org/#/q/topic:upgrade-fix for the fixes made so far
16:14:51 <odyssey4me> also see https://etherpad.openstack.org/p/osa-upgrade-improvements for the discussion on upgrade improvements
16:15:41 <asettle> Sweet :) thanks odyssey4me
16:15:48 <asettle> #link http://logs.openstack.org/periodic/periodic-openstack-ansible-upgrade-aio-master-ubuntu-xenial/
16:15:54 <asettle> #link https://review.openstack.org/#/q/topic:upgrade-fix
16:15:59 <asettle> #link https://etherpad.openstack.org/p/osa-upgrade-improvements
16:16:05 <asettle> Anything else there? :)
16:17:02 <asettle> Silence is compliance
16:17:09 <evrardjp> indeed.
16:17:14 <asettle> #topic Release planning and decisions
16:17:28 <asettle> Which, is odyssey4me again while our fearless leader, andymccr is swanning around in Milan for the ops midcycle
16:17:36 <odyssey4me> yup yup
16:17:41 <spotz> asettle what's he brining us back?:)
16:17:45 <odyssey4me> tight, andymccr did the release requests this morning
16:17:53 <asettle> spotz: nothing at the moment, how rude is that?
16:18:06 <spotz> asettle: geez, no love for us!
16:18:07 <odyssey4me> newton is released, mitaka is still on hold
16:18:18 <odyssey4me> the ocata/newton sha bumps are up and gating
16:18:25 <odyssey4me> buuut
16:19:07 <odyssey4me> due to the need to support both trusty and xenial for newton, we need to restructure the repo
16:19:09 <spotz> buut....
16:19:27 <evrardjp> that's the french term for a goooooooal.
16:19:32 <odyssey4me> this has merged to master, which incidentally allows both centos and xenial in the same environment
16:19:53 <odyssey4me> but we will have to backport the restructure to newton/ocata asap to allow people to transition
16:20:00 <odyssey4me> it's a major restructure: https://review.openstack.org/446256
16:20:22 <odyssey4me> so, we'll likely do another minor revision jump to announce that
16:20:34 <asettle> Cool cool :)
16:20:41 <asettle> #link https://review.openstack.org/446256
16:20:44 <odyssey4me> just a heads up for those who may not be aware
16:20:54 <asettle> odyssey4me: should we maybe put an announcement in the chan topic?
16:20:58 <asettle> Just as an FYI
16:21:12 <odyssey4me> asettle that'll be up to andymccr - I don't think it's needed
16:21:19 <asettle> Okay fair enough :)
16:21:30 <odyssey4me> the only people who need be concerned are those using the repo structure in downstream tooling
16:21:42 <asettle> Ah right!
16:21:42 <odyssey4me> the upgrade will take care of everything for all the stuff we ship
16:21:47 <asettle> Sounds good :)
16:22:17 <asettle> Okay, let's move on
16:22:24 <asettle> #topic Blueprint work
16:22:35 <asettle> #link https://blueprints.launchpad.net/openstack-ansible/+spec/upgrade-testing
16:22:41 <asettle> Current Status: Active Development
16:22:45 <asettle> This one is andymccr but he's still swanning
16:22:47 <asettle> And not buying us presents
16:22:58 <asettle> #link https://blueprints.launchpad.net/openstack-ansible/+spec/create-ops-guide
16:23:05 <spotz> :)
16:23:07 <asettle> Current Status: Active Development - me
16:23:09 <asettle> Things are fine ;)
16:23:14 <asettle> Any questions on those? :0
16:23:15 <asettle> :) *
16:23:38 <asettle> #topic Open discussion
16:23:40 <asettle> SOmeone has left a note here
16:23:44 <asettle> What to do for: ceph_client: on ubuntu 16.04 default Ceph version (hammer) causes conflicts?
16:23:47 <asettle> Old news or new news?
16:24:01 <evrardjp> old news.
16:24:02 <odyssey4me> I *think* we discussed this last week?
16:24:24 <asettle> Okay, anyone got some new news?
16:24:46 <spotz> Do we want an on-boarding room at summit? I didn't see us on the list for one
16:25:04 <asettle> The rooms look finalised, but ti might be worth if andymccr or someone put their feelers out and asked for one
16:25:09 <asettle> I think it would be a good idea for osa to have one
16:25:12 <asettle> You might be ablet o share with kolla
16:25:16 <asettle> to share*
16:26:16 <spotz> It can't hurt to ask:)
16:26:20 <asettle> I'll ask andymccr to poke
16:26:34 <asettle> #action andymccr to look into getting an on-boarding room at the summit
16:26:34 <evrardjp> action :p
16:26:37 <evrardjp> woot
16:27:19 <asettle> Alright dudes, I'm not going to hold you around for no good reason
16:27:25 <asettle> Let's end this!
16:27:33 <asettle> Anything else?
16:27:36 <asettle> Before I chop it?
16:27:43 <odyssey4me> nothing from me
16:27:48 <evrardjp> nothing, thanks for the meeting asettle!
16:27:50 <spotz> presents from Milan!:)
16:27:53 <asettle> #endmeeting