16:03:41 <evrardjp> #startmeeting openstack_ansible_meeting
16:03:42 <openstack> Meeting started Thu Mar 23 16:03:41 2017 UTC and is due to finish in 60 minutes.  The chair is evrardjp. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:42 <d34dh0r53> o/
16:03:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:45 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:03:48 <odyssey4me> o/
16:04:12 <evrardjp> The agenda for today is
16:04:15 <evrardjp> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:04:16 <xgerman> o/
16:04:30 <evrardjp> Is there someone against the agenda for today?
16:04:47 <evrardjp> or in english, everyone agrees with the topics?
16:04:49 <evrardjp> :D
16:04:56 <odyssey4me> it looks like the agenda is the same as the last two weeks - we haven't cleaned up :/
16:05:29 <evrardjp> Yes. Let me clean that up.
16:06:24 <evrardjp> I propose we keep the topics for discussion, except the Operations guide that we'll skip for this time
16:07:15 <evrardjp> Ok let's assume the roll call is over, and everyone agrees
16:07:24 <evrardjp> PS: I miss asettle gifs.
16:07:36 <evrardjp> so
16:07:37 <odyssey4me> lol
16:07:44 <evrardjp> #topic Review action items from last week
16:07:58 <evrardjp> palendae will flip coins for names tomorrow for the python package ?
16:08:09 <palendae> evrardjp: Chosen!\
16:08:13 <palendae> https://review.openstack.org/#/c/418076/
16:08:14 <evrardjp> woot!
16:08:17 <palendae> osa_toolkit
16:08:22 <evrardjp> #link https://review.openstack.org/#/c/418076/
16:08:22 <palendae> And hopefully we'll get a passing gate
16:08:36 <evrardjp> good
16:08:42 <odyssey4me> gate passing will require that we have a general master passing gate, which we do not
16:08:56 <palendae> odyssey4me: Ah. In that case, I'll just keep rebasing :)
16:09:00 <evrardjp> odyssey4me: let's talk about this in open discussion?
16:09:11 <palendae> Anyway, the name was chosen and in that review
16:09:16 <evrardjp> \o/
16:09:23 <odyssey4me> tempest tests are failing, and no-one except andymccr has taken the time to look into it, but I think he's been swamped so volunteers to resolve it are welcome
16:09:40 <evrardjp> ^ ^ ^ ^
16:09:53 <evrardjp> #action help andymccr to unblock gates
16:09:54 <odyssey4me> a general sha bump doesn't help because the powervm driver has an issue with incompatible requirements
16:10:08 <odyssey4me> that's on the way to being resolved
16:10:33 <evrardjp> there is also work on ocata
16:10:48 <evrardjp> cinder/tempest
16:10:52 <evrardjp> but let's talk about that later
16:10:59 <evrardjp> first let's finish last week action points
16:11:11 <evrardjp> #action andymccr to look into getting an on-boarding room at the summit
16:11:19 <evrardjp> that's gonna be for next week.
16:11:28 <evrardjp> ok next topic!
16:11:46 <evrardjp> #topic Discussion - Operations guide
16:12:05 <evrardjp> asettle: being away let's skip this, except if someone wants to add something for her?
16:12:21 <evrardjp> (only friendly messages are allowed)
16:12:30 <palendae> I've nothing to add
16:12:31 <odyssey4me> nope, except that anyone able should keep reviewing and patching
16:12:43 <evrardjp> ok, next topic
16:12:58 <evrardjp> #topic Discussion - New periodic jobs
16:13:02 <evrardjp> odyssey4me: ?
16:13:15 <odyssey4me> it's running, it's failing for the same reason as the current master: http://logs.openstack.org/periodic/periodic-openstack-ansible-upgrade-aio-master-ubuntu-xenial/e58e9cf/console.html#_2017-03-23_08_33_38_361490
16:13:43 <odyssey4me> so basically the upgrade happens from ocata to master, there's nothing except a broken master stopping it from passing as far as I know
16:14:00 <odyssey4me> I was thinking of adding another test for newton->ocata - thoughts?
16:14:30 <evrardjp> it has value for me
16:14:56 <evrardjp> making sure we can upgrade to latest official stable is good.
16:15:06 <odyssey4me> ok, I'll push up the infra change to add it
16:15:13 <odyssey4me> once that's going right I'll do the mitaka->newton one too
16:15:26 <evrardjp> that's fancy :)
16:15:44 <jmccrory> can you still get trusty image for mitaka-newton?
16:15:57 <evrardjp> that will be a problem
16:16:02 <evrardjp> if not now, it oculd
16:16:06 <evrardjp> could*
16:16:13 <evrardjp> same for N trusty
16:16:14 <odyssey4me> jmccrory yeah, until mitaka's EOL'd that won't be an issue
16:16:27 <jmccrory> ok cool
16:16:53 <evrardjp> in the meantime it's not a problem, so let's do it :)
16:17:06 <odyssey4me> jmccrory logan- we need to revisit the upgrade improvements etherpad and figure out where to go with it
16:17:19 <odyssey4me> but that's another topic, this one is done :)
16:17:23 <evrardjp> ok
16:17:32 <evrardjp> #topic Release Planning and Decisions
16:17:34 <evrardjp> odyssey4me: ?
16:17:53 <odyssey4me> releases will happen next week (which will be a minor version bump due to the repo build changes in Newton +)
16:18:09 <odyssey4me> the repo build changes necessitated a minor revision bump to signal it
16:18:21 <odyssey4me> that's a minor rev bump for newton and ocata
16:18:46 <odyssey4me> Integrated build is broken on master, but the sha bump PR should be fixed by https://review.openstack.org/#/c/448674/ - once the dependent patch merges and the SHA is bumped for nova-powervm.
16:19:06 <odyssey4me> We have some tempest issues in stable/ocata causing cinder jobs to fail, but the PR to bump tempest SHA in the role is broken atm (thinking about that I need to actually edit the tests repo instead – will fix quickly.
16:19:17 <odyssey4me> by 'I' it means andymccr :) I'm literally copying and pasting his update
16:19:27 <odyssey4me> Upgrade jobs are all working except cinder on Ocata (which should merge once the above fixes) and then they’ll be set to voting.
16:19:36 <odyssey4me> The cinderv3 work is still pending, the nova patch needs to merge: https://review.openstack.org/#/c/446508/ - then backports
16:20:07 <evrardjp> it's a complete update from andymccr,  including non release conversations :)
16:20:14 <evrardjp> I feel like he is here.
16:20:37 <evrardjp> Anyway, please have a look!
16:20:54 <evrardjp> ok next topic
16:20:57 <evrardjp> #topic Blueprint work
16:21:30 <evrardjp> Any information to give there? Nothing pending except upgrade testing and operations guide?
16:22:12 <evrardjp> ok let's move to something else
16:22:28 <evrardjp> #topic Open discussion
16:22:47 <evrardjp> Has anyone something to say? I feel like it's only odyssey4me and me talking today
16:22:56 <odyssey4me> :p
16:23:00 <palendae> I don't really have anything today
16:23:08 <palendae> Seems like a lot of people are busy with other things
16:23:09 <evrardjp> We are sitting next to each other at the office, I don't need that to talk to him. :p
16:23:28 <xgerman> waiting my turn
16:23:36 <evrardjp> now would be it.
16:23:46 <palendae> evrardjp: Talking there wouldn't be documented though :)
16:23:46 <odyssey4me> xgerman it's open discussion, so it's anyone's turn
16:24:04 <evrardjp> palendae: fair point, fair point!
16:24:10 <xgerman> ok, #link https://review.openstack.org/447151
16:24:58 <xgerman> the trove people have some questions about the communities stance on networks bridging vm and control plane.
16:25:06 <evrardjp> Massive commit scope :p
16:25:51 <evrardjp> the communities, you mean general trove users, or our deployers?
16:25:52 <xgerman> I am wondering if I need to add things for Octavia besides the iptables firewall?
16:26:05 <xgerman> community he means OSA
16:26:12 <xgerman> developers
16:27:13 <stevelle> I am generally supportive of the solution xgerman is persuing here but we need folks to look and think hard about it
16:27:17 <evrardjp> so the question is how to bring consensus on the two roles "way of integrating with osa"?
16:27:35 <xgerman> yep
16:27:35 <odyssey4me> this looks like it's working towards the ideal we discussed at the PTG
16:28:18 <xgerman> yeah, I laid my thinking out in the response that there should be a security guide so operators can judge for themselves which risks they are taking
16:28:55 <evrardjp> I agree
16:29:03 <kylek3h> xgerman: agreed.  i just was pointing out the roles should be doing similar things
16:29:14 <evrardjp> I will review this, but I don't think it's a bad starting point
16:29:19 <evrardjp> agreed with kylek3h too there
16:29:37 <evrardjp> kylek3h: do you see other roles except trove that could have issues?
16:29:56 <kylek3h> not at the moment.  our focus has been on trove
16:30:05 <evrardjp> that could be a "osa community goal" in the future to move the role to this standard
16:30:14 <evrardjp> whatever the "this" means.
16:30:16 <xgerman> I knew cue had similar issues but that project has been abandoned
16:30:44 <evrardjp> ok
16:31:06 <odyssey4me> xgerman this is looking way, way better and seems to address the concerns we raised early on
16:31:38 <odyssey4me> kylek3h from what I see so far, this is a good approach which provides the right flexibility between doing the nasty things for testing or small environments, but being able to break it out for larger environments
16:31:57 <evrardjp> #action review https://review.openstack.org/#/c/447151 and talk about shared "osa community goals" for network integration best practices next week (useful for trove and octavia)
16:32:24 <odyssey4me> I would be very interested in you guys tying a similar approach and helping to fix up the model to be responsibly secure for the small/test environments
16:32:47 <xgerman> when I looked at the OSA docs there were chapters on networking but no text - so I assume that will be filled and I can go light on detals in my doc
16:32:51 <kylek3h> odyssey4me: yeah.  i have Ravi working on a similar approach for trove
16:33:05 <evrardjp> kylek3h: woot
16:33:06 <evrardjp> good
16:33:09 <odyssey4me> xgerman what docs are you referring to?
16:34:13 <odyssey4me> xgerman if you're browsing the docs through github you will miss many things - make sure you're browsing the *published* docs
16:34:27 <xgerman> #link https://docs.openstack.org/developer/openstack-ansible/draft-operations-guide/maintenance-tasks/network-maintain.html
16:34:47 <odyssey4me> ah, but that's the *draft* operations guide
16:34:51 <odyssey4me> it's still being populated
16:35:07 <odyssey4me> the deploy guide has networking info in it
16:35:21 <evrardjp> Probably work to be done there, in a different section than the existing one
16:35:23 <odyssey4me> as does the neutron role, and others
16:35:23 <evrardjp> #link https://docs.openstack.org/developer/openstack-ansible/draft-operations-guide/maintenance-tasks/firewalls.html
16:35:50 <odyssey4me> but, to be clear, the intent it never to duplicate any upstream information
16:36:19 <odyssey4me> all we ever decribe is how we lay things out and how to interact with OSA's deployment... any details about how octavia works should be submitted upstream
16:36:37 <odyssey4me> we should only ever do a basic intro and point to upstream docs
16:36:41 <xgerman> yes, I was more thinking how networks are defined in OSA. kyle3h had a comment and my thinking was to defer that to upcoming network guides
16:36:44 <evrardjp> agreed
16:36:57 <evrardjp> and agreed
16:37:06 <odyssey4me> networks being defined in OSA should be something in our docs
16:37:19 <odyssey4me> https://docs.openstack.org/project-deploy-guide/openstack-ansible/draft/overview-network-arch.html
16:37:25 <odyssey4me> https://docs.openstack.org/project-deploy-guide/openstack-ansible/draft/app-networking.html
16:38:09 <odyssey4me> that brings me to another topic actually - we currently have two examples in the docs, but I think we'll need to have more
16:38:21 <xgerman> +1
16:38:38 <odyssey4me> we have a 'test' and 'production' example - I think we're going to have to rename those and add a 'ceph' example, and probably others
16:38:39 <xgerman> I was able to figure it out but I also had some help ;-)
16:38:59 <xgerman> Octavia example?
16:39:29 <odyssey4me> I think perhaps an octavia example should perhaps be combined with something like autoscaling or whatever
16:39:40 <xgerman> k
16:39:43 <odyssey4me> perhaps ironic, magnum, ocatavia
16:40:12 <evrardjp> + heat, telemetry for autoscaling
16:40:17 <odyssey4me> the point with the examples is to illustrate how to adjust based on the special things we can do
16:40:29 <evrardjp> it makes sense to me
16:40:45 <odyssey4me> the 'test' and 'prod' examples were trying to illustrate different configs needed for the amount of NIC's and the storage subsystem
16:42:24 <evrardjp> ok I think we are drifting from xgerman main topic, but it's good !
16:42:29 <evrardjp> productivitay
16:42:32 <evrardjp> \o/
16:43:13 <xgerman> yeah, documentation is a priority for the Octavia team
16:43:22 <evrardjp> anyone else? logan- jmccrory? Need to add something to the agenda for next week, or need help on anything?
16:44:00 <logan-> nope i've got nothing. good first stab at the iptables work xgerman, thanks. going to think about that some and compare to how i've got mine setup now
16:44:39 <evrardjp> great.
16:45:00 <evrardjp> you're also using it for octavia? Else generic work can also be documented
16:45:02 <jmccrory> would be good to get this in https://review.openstack.org/#/c/445334/ rally is broken in newton without it
16:45:16 <evrardjp> #action review https://review.openstack.org/#/c/445334/
16:45:21 <logan-> no mine is generic across all of the other basic osa containers
16:46:04 <evrardjp> logan-: do you want to move it to ops, this way you don't have to maintain it alone, or is specific?
16:46:04 <odyssey4me> there are a bunch of small reviews in play, it'd be great if we could plow through those asap
16:46:27 <odyssey4me> don't forget to look at the next page of reviews ;)
16:46:35 <xgerman> :-)
16:46:39 <logan-> i wouldn't mind pushing it to ops. will take a look at getting it into a review
16:47:48 <evrardjp> I don't force anything logan-, I'm just trying to help.
16:48:28 <logan-> yeah i think it would at the very least be helpful to have a port mapping of everything to reference later if we get a role template together
16:48:37 <evrardjp> yeah
16:48:46 <evrardjp> 2.3 is gonna make role templates really easy btw
16:49:15 <evrardjp> it's gonna be without any code change, as there is a env var for the boilerplate path.
16:49:57 <evrardjp> ok, anything to wrap up?
16:49:58 <logan-> interesting
16:50:25 <jmccrory> oh that's one more than, the lxc connection plugin in 2.3 blows up. i did some digging and will added what i found in the review testing it, but basically they moved to using a constant for the remote file and use that more consistently
16:50:31 <evrardjp> 2.3 is gonna be an interesting one with long running connections, etc.
16:51:44 <evrardjp> jmccrory: well that's not a bad thing to be more consistent. If you have a link I'd be happy to have a look at it.
16:52:11 <jmccrory> sure, i'll add more details later today here https://review.openstack.org/#/c/446173/
16:52:21 <odyssey4me> cloudnull ^
16:52:28 <evrardjp> jmccrory: the refactor of connection systems in ansible 2.3 is a proof we may need to focus more on our plugins.
16:52:34 * cloudnull looking
16:54:01 <evrardjp> ok anything else?
16:54:16 <odyssey4me> looks like we're pretty much out of time to discuss this - I'd say we move it to the channel
16:54:55 <evrardjp> ok thank you everyone!
16:54:57 <evrardjp> #endmeeting