16:01:36 <evrardjp> #startmeeting openstack_ansible_meeting
16:01:37 <openstack> Meeting started Tue Mar 28 16:01:36 2017 UTC and is due to finish in 60 minutes.  The chair is evrardjp. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:40 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:02:04 <evrardjp> last week action points where
16:02:20 <evrardjp> review https://review.openstack.org/#/c/446508/
16:02:36 <evrardjp> odyssey4me have a look at https://bugs.launchpad.net/openstack-ansible/+bug/1670632
16:02:36 <openstack> Launchpad bug 1670632 in openstack-ansible "ceilometer error because gnocchiclient > 3.0 for stable/newton " [Medium,Confirmed] - Assigned to Jesse Pretorius (jesse-pretorius)
16:02:42 <andymccr> boom! :)
16:03:02 <evrardjp> odyssey4me: what's the status there?
16:03:33 <evrardjp> It looks triaged at least
16:03:39 <openstackgerrit> German Eichberger proposed openstack/openstack-ansible-os_octavia master: Adds anti affinity hint and az configuration option  https://review.openstack.org/450475
16:03:41 <evrardjp> good we can continue
16:03:56 <evrardjp> so for this week
16:04:18 <evrardjp> first one is ... (insert drum sound here)
16:04:23 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1675804
16:04:23 <openstack> Launchpad bug 1675804 in openstack-ansible "Newton: oslo.messaging Bad address when CONFIG_AMQP_ENABLE_SSL=y" [Undecided,New]
16:05:41 <andymccr> doesnt that imply that hte issue is with oslo.messaging - what are we using in newer tags for newton?
16:05:54 <evrardjp> is there a bump to be done ? It sounds like we cannot really change things there, maybe pins?
16:06:09 <evrardjp> yeah it sounds like upstream
16:06:15 <andymccr> evrardjp: i'll take that
16:06:16 <andymccr> and find out
16:06:19 <evrardjp> cool
16:06:21 <evrardjp> thanks
16:06:32 <evrardjp> #action andymccr triage https://bugs.launchpad.net/openstack-ansible/+bug/1675804
16:06:32 <openstack> Launchpad bug 1675804 in openstack-ansible "Newton: oslo.messaging Bad address when CONFIG_AMQP_ENABLE_SSL=y" [Undecided,New]
16:06:44 <evrardjp> next
16:06:47 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1675097
16:06:47 <openstack> Launchpad bug 1675097 in openstack-ansible "Indicate which version of Ansible itself is considered supported" [Undecided,New]
16:07:21 <evrardjp> Should we consider this as something missing or something we shouldn't do?
16:07:37 <palendae> I'd say it's worth documenting
16:08:09 <evrardjp> well it will open the doors to issues if ppl try with newer versions of ansible than what's tested with, but it could be interesting
16:08:26 <palendae> I think people are already trying that
16:08:33 <evrardjp> yeah
16:09:00 <evrardjp> As long as we set the minimum version in our roles + docs page it could be fine
16:09:06 <palendae> Yeah
16:09:16 <evrardjp> I'm just asking general opinion, it opens a door IMO
16:09:26 <evrardjp> andymccr: ?
16:09:26 <palendae> I'd even say something like "Tested with version x.y.z only"
16:10:08 <odyssey4me> I guess we could extract the version we currently use and publish that automatically.
16:10:09 <evrardjp> palendae: for that we could basically include the bootstrapped ansible version from the repository.
16:10:16 <evrardjp> odyssey4me: haha :)
16:10:18 <palendae> Yep
16:10:20 <andymccr> hmm yeah maybe we could put "tested with" that seems ok
16:10:26 <evrardjp> ok
16:10:37 <evrardjp> so I guess it becomes a confirmed wishlist item
16:10:42 <evrardjp> thanks
16:10:43 <andymccr> although
16:10:48 <andymccr> if we move to use a sha again that'd break taht :P
16:11:02 <evrardjp> yeah, ansible.
16:11:03 <odyssey4me> well, I was thinking that we could do something along the lines of 'OpenStack-Ansible deploys Ansible x.x.x' when you use the bootstrap-ansible.sh script.
16:11:04 <palendae> andymccr: Tested with SHA #...
16:11:16 <andymccr> palendae: yeah i mean it still "works" but it's not so user friendly
16:11:21 <palendae> Yeah
16:11:29 <odyssey4me> I'll take it and figure something out.
16:11:48 <evrardjp> This is why I didn't want to classify this as a confirmed on my own :p
16:11:56 <evrardjp> cool thanks odyssey4me!
16:12:09 <evrardjp> #action odyssey4me triage https://bugs.launchpad.net/openstack-ansible/+bug/1675097
16:12:10 <openstack> Launchpad bug 1675097 in openstack-ansible "Indicate which version of Ansible itself is considered supported" [Undecided,New]
16:12:28 <evrardjp> next
16:12:34 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1674947
16:12:34 <openstack> Launchpad bug 1674947 in openstack-ansible "play_hosts is deprecated" [Undecided,New]
16:12:43 <evrardjp> I can confirm this.
16:13:00 <evrardjp> we are not dependant on it
16:13:06 <evrardjp> it was for logging purposes
16:13:15 <evrardjp> We can have it as low.
16:13:23 <evrardjp> ok everyone?
16:13:26 <andymccr> yeah that sounds good
16:13:31 <andymccr> issue dodged ;D
16:14:05 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1674742
16:14:05 <openstack> Launchpad bug 1674742 in openstack-ansible "keepalived haproxy check script too simple" [Undecided,New]
16:14:42 <evrardjp> I'd be enclined to mark this as medium (because it's impacting) and low hanging fruit
16:14:46 <evrardjp> I can take it
16:14:55 <evrardjp> ok everyone?
16:15:08 <evrardjp> except if some newcomer want to patch it?
16:15:48 <andymccr> sounds good to me
16:15:53 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1662865
16:15:53 <openstack> Launchpad bug 1662865 in openstack-ansible "nova-compute: inconsistent qemu packages installed" [Undecided,New]
16:16:25 <andymccr> ok
16:16:29 <andymccr> is there a way we can figure out if this is fixed? :P
16:16:40 <evrardjp> I don't even remember answering there.
16:16:46 <evrardjp> Oh it was one month ago
16:16:52 <evrardjp> it's gonna expire soon!
16:16:53 <evrardjp> :D
16:17:07 <andymccr> i feel like ive said "yeah i think that's fixed" like 100 times on this bug haha
16:17:13 <andymccr> but i dont know for sure
16:17:26 <evrardjp> well we don't know that's why it's still open
16:17:30 <evrardjp> but that's part of the game
16:17:32 <andymccr> i think the belief was qemu isnt in uca/rdo so therefore it isn't managed that way
16:17:47 <evrardjp> it's because today there is not many bugs, which is good, so we can review older ones :)
16:17:58 <evrardjp> yeah, I think it should be fixed
16:18:01 <evrardjp> let's move on
16:18:05 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1662545
16:18:05 <openstack> Launchpad bug 1662545 in openstack-ansible "osa: file /etc/init.d/rc does not exist" [Undecided,New] - Assigned to Major Hayden (rackerhacker)
16:18:09 <andymccr> we can cover it again next week :P
16:18:19 <evrardjp> depends !
16:18:36 <evrardjp> maybe I should mark them as incomplete
16:18:46 <andymccr> mhayden: should we race to fix this? winner gets a beer?
16:18:49 <evrardjp> but I don't want it's gonna lengthen them
16:19:03 <evrardjp> andymccr: sounds good.
16:19:04 <mhayden> andymccr: lawl
16:19:06 <evrardjp> I'm paying.
16:20:21 <evrardjp> All the other bugs have not been updated excepted:
16:20:23 <andymccr> mhayden: could you give us a prio on that one?
16:20:40 <evrardjp> (sorry let's finish the previous one before)
16:20:41 <mhayden> looking ...
16:20:45 <mgariepy> https://github.com/openstack/openstack-ansible/blob/master/tests/roles/bootstrap-host/vars/redhat.yml#L35
16:20:59 <mgariepy> something like this.
16:21:00 <mgariepy> :P
16:21:13 <evrardjp> It looks it's gonna be a race.
16:21:23 <mgariepy> not from me.
16:21:27 <mgariepy> haha
16:21:28 <mhayden> andymccr: i'd say low since the RHEL 6 content is currently deprecated
16:21:33 <andymccr> mhayden: sweet
16:21:34 <andymccr> thanks :)
16:21:43 <evrardjp> ok thanks
16:21:46 <evrardjp> so next one
16:21:47 <evrardjp> and last one
16:21:49 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1675810
16:21:49 <openstack> Launchpad bug 1675810 in openstack-ansible "inventory overrides causing dynamic_inventory.py to stacktrace" [Medium,New]
16:21:57 <evrardjp> confirmed?
16:22:07 <evrardjp> palendae: ?
16:22:10 <palendae> I haven't run the scenario, but it seems probable
16:22:16 <evrardjp> ok
16:22:46 <evrardjp> could we triage this for its importance?
16:22:56 <evrardjp> oh it's already medium
16:23:11 <palendae> I think cloudnull did some of that already
16:23:15 <evrardjp> palendae: cloudnull which one of you are gonna be assigned to it?
16:23:17 <evrardjp> ok
16:23:23 <evrardjp> I'll assign it to him
16:23:39 <palendae> I think he was gonna hand it to me, but I didn't assign it yet
16:23:46 <palendae> I can take it
16:24:03 <evrardjp> ok take it if you want, it's assigned to him right now :p
16:24:10 <palendae> k
16:24:11 <evrardjp> ok that's all for today
16:24:24 <evrardjp> no critical bugs, 2 high bugs that are not that hard, we are in a good state
16:24:38 <evrardjp> we are cumulating low level bugs, but that's something we can deal later
16:24:46 <evrardjp> thanks everyone!
16:24:54 <evrardjp> #endmeeting