16:00:37 <evrardjp> #startmeeting openstack_ansible_meeting
16:00:38 <openstack> Meeting started Tue Apr  4 16:00:37 2017 UTC and is due to finish in 60 minutes.  The chair is evrardjp. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:42 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:54 <cloudnull> o/
16:01:00 <evrardjp> #topic rollcall and asettle gifs
16:01:08 <alextricity25> o/
16:01:09 <asettle> I HAVENT HAD TIME TO PREP
16:01:22 <evrardjp> haha :)
16:01:29 <evrardjp> for next time :)
16:01:40 <evrardjp> leaving 2 minutes for the roll call
16:02:11 <andymccr> o/
16:02:24 <evrardjp> ok let's go
16:02:39 <evrardjp> #topic action items of last week
16:02:51 <evrardjp> none to declare, everyone did their job, thanks andymccr and odyssey4me!
16:03:06 <evrardjp> #topic this week bugs
16:03:18 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1679707
16:03:19 <openstack> Launchpad bug 1679707 in openstack-ansible ""cpu_mode = host-model" does not work in virtualized setup " [Undecided,New]
16:03:26 <evrardjp> odyssey4me: you had a look at this right?
16:04:01 <evrardjp> it makes sense, and it could be using a fact for is_metal
16:04:14 <odyssey4me> actually we should not set cpu_mode at all - the code detects things right, we should let the code do it
16:04:25 <odyssey4me> ie the nova code, not our code
16:04:27 <evrardjp> ok
16:04:48 <odyssey4me> this is low hanging fruit, it requires the removal of the value from the template and the default with a simple release note
16:04:52 <evrardjp> confirmed, low, low hanging fruit?
16:05:29 <evrardjp> Agreed with odyssey4me.
16:05:29 <odyssey4me> I'm happy with that
16:05:44 <evrardjp> next
16:05:55 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1678165
16:05:55 <openstack> Launchpad bug 1678165 in openstack-ansible "dynamic_inventory.py container_mtu bug" [Undecided,New]
16:06:48 <openstackgerrit> Andrey Grebennikov proposed openstack/openstack-ansible-os_cinder master: Added open-iscsi package to Cinder container.  https://review.openstack.org/452254
16:07:40 <evrardjp> My knowledge is lacking there. I should spend more time with neutron and our mappings :p
16:07:53 <evrardjp> cloudnull: ?
16:08:26 <evrardjp> I will investigate for next meeting
16:08:26 <palendae> I skimmed it, but I haven't touched that code much
16:08:43 <evrardjp> #action evrardjp triage https://bugs.launchpad.net/openstack-ansible/+bug/1678165
16:08:43 <openstack> Launchpad bug 1678165 in openstack-ansible "dynamic_inventory.py container_mtu bug" [Undecided,New]
16:08:54 <evrardjp> next
16:08:56 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1678073
16:08:56 <openstack> Launchpad bug 1678073 in openstack-ansible "lxd init with nova-lxd should support other backend" [Undecided,New]
16:09:58 <evrardjp> it looks like a wishlist item
16:10:02 <evrardjp> confirmed wishlist?
16:10:39 <andymccr> evrardjp: seems right!
16:10:52 <evrardjp> ok
16:10:55 <evrardjp> next
16:11:04 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1677632
16:11:04 <openstack> Launchpad bug 1677632 in openstack-ansible "QoS agent extension not loaded when QoS is enabled" [Undecided,New]
16:12:30 <andymccr> hmm
16:13:00 <andymccr> jamesdenton isnt about
16:14:06 <evrardjp> makes sense
16:14:24 <evrardjp> https://github.com/openstack/openstack-ansible-os_neutron/blob/master/templates/plugins/ml2/linuxbridge_agent.ini.j2#L29
16:14:49 <andymccr> yeah it makes sense
16:15:26 <andymccr> mark as confirmed and low?
16:15:30 <evrardjp> ciritcallity?
16:15:35 <evrardjp> woh
16:15:39 <evrardjp> criticality*
16:15:41 <andymccr> hahaha
16:16:03 <evrardjp> low is good enough for me
16:16:05 <andymccr> im not sure about the importance but yeah - it seems an easy fix though - since we already do similar in the ml2_conf etc
16:16:18 <evrardjp> also config template temporarily fixing
16:16:34 <evrardjp> worth better docs maybe
16:16:43 <evrardjp> worth better code at least!
16:16:52 <asettle> Wow
16:16:58 <asettle> Righto
16:17:05 <evrardjp> :)
16:17:36 <evrardjp> I knew I could have a reaction there.
16:17:55 <evrardjp> Anyway, we should probably adapt the template and maybe improve the neutron role docs on how to enable qos.
16:18:02 <evrardjp> But that's another conversation.
16:18:05 <evrardjp> Let's move on
16:18:09 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1677304
16:18:09 <openstack> Launchpad bug 1677304 in openstack-ansible "Documentation bug: Rebuilding an AIO" [Undecided,New]
16:18:14 <asettle> I commented on this one
16:18:21 <evrardjp> yup I see
16:18:35 <asettle> Also, this makes me keenly aware that OSA has our bug template...
16:18:38 <asettle> Anywayyyy
16:18:52 <asettle> Also, I realised that comment makes no sense
16:18:55 <evrardjp> haha it's not the first one :)
16:19:01 <asettle> OSA now supposed Ubuntu - OSA now supports CentOS*
16:19:07 <asettle> I dunno how I did that
16:19:41 <andymccr> i think low and confirmed?
16:20:01 <asettle> I would have gone for wishlist, it's not a item that we need, really, is it?
16:20:03 <asettle> It's just AIO
16:20:19 <asettle> If it were for updating hte deploy guide for CentOS, then I'd go with low/medium
16:20:30 <andymccr> well yeah but it is actually a bug - since we support centos
16:20:35 <andymccr> but im happy with either tbh
16:20:53 <asettle> Confirmed, low it is
16:20:58 <evrardjp> agreed
16:21:18 <evrardjp> thx for the updating ;)
16:21:20 <jmccrory> we need more people testing centos AIOs
16:21:29 <evrardjp> +1 jmccrory
16:21:39 <evrardjp> next
16:21:42 <andymccr> jmccrory: agreed.
16:21:43 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1677007
16:21:43 <openstack> Launchpad bug 1677007 in openstack-ansible "Documentation bug - proxy config" [Undecided,New]
16:23:15 <odyssey4me> I'll take that one - it's an easy fix and I did some work there already
16:23:26 <andymccr> boom progress
16:23:27 <evrardjp> ok
16:23:31 <evrardjp> confirmed low?
16:23:37 <odyssey4me> yep
16:23:56 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1507915
16:23:56 <openstack> Launchpad bug 1507915 in openstack-ansible "libguestfs launch image failed in ubuntu" [Undecided,New]
16:24:26 <andymccr> so it looks like this has already been proposed as a fix in OSA at least: https://review.openstack.org/#/c/451971/
16:25:02 <evrardjp> Related-Bug instead of Fixes-Bug
16:25:20 <evrardjp> maybe we need more work there?
16:25:24 <odyssey4me> well, it actually works around the bug
16:25:40 <evrardjp> yes that's what it looks like
16:25:50 <evrardjp> so maybe we shouldn't target this bug to us
16:25:52 <odyssey4me> so it will fix it for us, but it's a workaround
16:26:17 <odyssey4me> Once it merges, just mark it closed for us I think\
16:26:26 <evrardjp> ok.
16:26:42 <evrardjp> let's see, I'll move it to in progress, this way it's not marked as new for next triage
16:27:07 <evrardjp> everyone ok?
16:27:22 <evrardjp> someone has a bug that needs attention?
16:27:40 <evrardjp> should we wrap this meeting up?
16:27:48 <andymccr> i think we're good!
16:27:52 <andymccr> thanks evrardjp and everybody else for helping
16:27:58 <spotz> thanks!
16:28:58 <evrardjp> #endmeeting