16:04:57 <evrardjp> #startmeeting openstack_ansible_meeting
16:04:59 <openstack> Meeting started Tue Apr 25 16:04:57 2017 UTC and is due to finish in 60 minutes. The chair is evrardjp. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:02 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:05:14 <evrardjp> #topic Last week AP
16:05:23 <evrardjp> andymccr triage https://bugs.launchpad.net/openstack-ansible/+bug/1682169
16:05:24 <openstack> Launchpad bug 1682169 in openstack-ansible "Upgrade N->O nova-manage cell_v2 issue" [Undecided,New] - Assigned to Andy McCrae (andrew-mccrae)
16:05:35 <andymccr> still working on it
16:05:38 <evrardjp> ok
16:05:43 <openstackgerrit> Merged openstack/openstack-ansible-security master: Skip ClamAV db update in gate https://review.openstack.org/458949
16:05:43 <evrardjp> #action andymccr triage https://bugs.launchpad.net/openstack-ansible/+bug/1682169
16:05:44 <andymccr> but leave it with me i think i have an idea so i'll take it forward
16:05:57 <evrardjp> ok next
16:06:00 <evrardjp> hwoarang cloudnull investigate on https://bugs.launchpad.net/openstack-ansible/+bug/1682108 with infra
16:06:01 <openstack> Launchpad bug 1682108 in openstack-ansible "[vagrant] openstack-ansible-lxc_hosts: The `lxc` module is not importable. Check the requirements."" [Undecided,Fix released] - Assigned to Markos Chandras (hwoarang)
16:06:11 <evrardjp> sounds good
16:06:21 <evrardjp> #topic this week triage
16:06:42 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1685770
16:06:43 <openstack> Launchpad bug 1685770 in openstack-ansible "can not attach ceph backed cinder volumes to running instance" [Undecided,New]
16:06:52 <openstackgerrit> Major Hayden proposed openstack/openstack-ansible-security master: Fix warnings about jinja2 in when https://review.openstack.org/459716
16:08:02 <evrardjp> yeah that sounds legit
16:08:05 <evrardjp> It was the case before
16:08:07 <openstackgerrit> Markos Chandras (hwoarang) proposed openstack/openstack-ansible-tests master: test-prepare-keys: Use ansible_user_gid for user's group https://review.openstack.org/459775
16:08:08 <andymccr> hmm evrardjp - does the bug imply its fixed upstream?
16:09:19 <andymccr> ahh i see
16:09:24 <andymccr> its an addition of support for nova/cinder keys
16:09:28 <andymccr> ok seems legit
16:09:48 <evrardjp> we'll need to adapt our roles right ?
16:09:58 <andymccr> yeah i thinkso
16:10:06 <andymccr> that seems quite high - since ceph is a common use case
16:10:11 <andymccr> logan-: have you run into that?
16:10:14 <andymccr> (if you're about)
16:10:23 <evrardjp> (if using different users)
16:10:35 <logan-> on phone but no same cephx
16:10:51 <andymccr> logan-: sweet - thanks for the confirmation
16:10:57 <andymccr> evrardjp: given that, thoughts on prio?
16:11:16 <evrardjp> medium because it's not Breaking anything
16:11:20 <evrardjp> ?
16:11:23 <evrardjp> not so sure
16:11:24 <andymccr> yeah
16:11:25 <andymccr> sounds reasonable
16:11:26 <evrardjp> let me check
16:12:34 <evrardjp> that would be high
16:12:37 <evrardjp> "schedule to fix
16:12:38 <evrardjp> "
16:12:41 <evrardjp> soon*
16:13:10 <andymccr> ok cool
16:13:11 <evrardjp> let's confirm at least
16:13:12 <andymccr> can anybody work on it?
16:13:30 <evrardjp> yeah that would be nice.
16:13:40 <evrardjp> but we have other highs today :/
16:13:44 <evrardjp> IMO
16:13:50 <andymccr> yeah i saw the next one o_O
16:13:51 <evrardjp> let's move on
16:14:00 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1685677
16:14:01 <openstack> Launchpad bug 1685677 in openstack-ansible "Xenial containers fail to apply sysctl (procps)" [Undecided,New]
16:14:17 <andymccr> that sounds critical to me.
16:14:20 <evrardjp> yup.
16:14:37 <evrardjp> expectations!
16:14:43 <evrardjp> ok that was simple to triage then
16:14:54 <andymccr> do we ahve anybody able to look at that?
16:15:19 <andymccr> will need backports to newton
16:15:31 <evrardjp> I will spend time on this if nobody wants it. But we need plenty of eyes
16:15:44 <andymccr> yeah i can force time on that tomorrow if needed
16:16:11 <evrardjp> I've assigned to me, and let see in a few days if it advanced. Hopefully gates are not blocked by this.
16:16:18 <evrardjp> next
16:16:20 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1685309
16:16:21 <openstack> Launchpad bug 1685309 in openstack-ansible "Newton: Empty openstack_user_config or conf.d shouldn't throw errors." [Undecided,New]
16:16:26 <evrardjp> confirmed wishlist
16:16:29 <andymccr> i dont think its blocking gates, but the functionality is broken for an end user imo.
16:16:33 <openstackgerrit> Markos Chandras (hwoarang) proposed openstack/openstack-ansible-tests master: bindep.txt: Use RedHat and SUSE platforms in bindep.txt https://review.openstack.org/459779
16:16:34 <andymccr> sounds good to me
16:16:55 <evrardjp> andymccr: I just said that because critical classification "Fix now or as soon as possible. Gates are blocked."
16:17:07 <evrardjp> details :)
16:17:07 <andymccr> yeah true but i think its critical in terms of messing up deploys :P
16:17:11 <evrardjp> yup!
16:17:14 <andymccr> anyway lets continue!
16:17:26 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1685194
16:17:27 <openstack> Launchpad bug 1685194 in openstack-ansible "openstack-ansible-security: Logic fails for 'security_sshd_permit_root_login'" [Undecided,New]
16:18:39 <evrardjp> confirmed medium low hanging fruit?
16:19:07 <andymccr> yeah
16:19:09 <andymccr> agreed
16:19:16 <andymccr> the bug makes total sense
16:19:21 <evrardjp> Any beginner wants it? If not I'll take it.
16:19:56 <evrardjp> next
16:19:58 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1682169
16:20:00 <openstack> Launchpad bug 1682169 in openstack-ansible "Upgrade N->O nova-manage cell_v2 issue" [Undecided,New] - Assigned to Andy McCrae (andrew-mccrae)
16:20:03 <andymccr> thats me
16:20:09 <andymccr> imo its linked to the other one above
16:20:14 <andymccr> (my action item)
16:20:17 <evrardjp> yes indeed.
16:20:21 <andymccr> or at least my suspicion is that it is - so im going to do them together
16:20:23 <andymccr> leave those with me!
16:20:27 <evrardjp> ok
16:20:29 <andymccr> or action item them up rather :P
16:20:43 <evrardjp> yeah, it was just in case someone wants to talk about it
16:20:49 <evrardjp> I did that last week
16:20:51 <andymccr> si si :D
16:20:54 <evrardjp> I may need to improve my process.
16:20:58 <evrardjp> for next week I guess!
16:21:04 <evrardjp> thanks everyone then
16:21:10 <andymccr> thanks evrardjp
16:21:12 <andymccr> always a pleasure
16:21:13 <evrardjp> someone has anything to add?
16:21:17 <logan-> off the phone now.. back on the sysctl thing
16:21:21 <andymccr> ahh
16:21:39 <logan-> I think it might be worth booting up a base lxc xenial container on a vanilla config and see what happens with that service
16:21:40 <evrardjp> #link https://etherpad.openstack.org/p/osa-bugtriage
16:21:43 <evrardjp> woops
16:21:50 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1685677
16:21:51 <openstack> Launchpad bug 1685677 in openstack-ansible "Xenial containers fail to apply sysctl (procps)" [Critical,Confirmed] - Assigned to Jean-Philippe Evrard (jean-philippe-evrard)
16:21:56 <logan-> maybe it is never meant to start in the container
16:22:34 <logan-> as a workaround in some of my containers i just dropped a systemd unit that execstarts 'sysctl -p'
16:22:43 <jmccrory> delegate roles' use of sysctl to physical host?
16:23:07 <evrardjp> cloudnull: opinion?
16:23:09 <logan-> certain sysctl applies to containers, like network namespace modifications (nonlocal_bind is an example)
16:23:24 <logan-> others might not be container-local and that's why it doesn't start? i dk
16:23:24 <evrardjp> yeah
16:24:00 <evrardjp> also depends on its profile I guess.
16:24:25 <andymccr> i think we do some sysctl in swift role too - so i thinkt here are a few
16:24:34 <andymccr> although probably not in proxy container so yeah i guess that doesnt impact
16:24:40 <mgariepy> maybe related to : https://bugs.launchpad.net/ubuntu/+source/procps/+bug/1419554
16:24:42 <openstack> Launchpad bug 1419554 in procps (Ubuntu Vivid) "Can't upgrade procps in LXC 1.1" [High,Fix released] - Assigned to Stéphane Graber (stgraber)
16:26:02 <evrardjp> we have a higher version
16:26:03 * mgariepy poking stgraber on lxc stuff.
16:26:25 <evrardjp> :)
16:26:40 <evrardjp> ok let's close this meeting and talk in the bug
16:26:44 <andymccr> yeah
16:26:50 <evrardjp> thanks everyone
16:26:51 <logan-> thanks evrardjp
16:26:52 <andymccr> thanks thanks
16:26:57 <evrardjp> #endmeeting