16:01:00 <odyssey4me> #startmeeting openstack_ansible_meeting
16:01:01 <openstack> Meeting started Tue May  2 16:01:00 2017 UTC and is due to finish in 60 minutes.  The chair is odyssey4me. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:04 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:08 <odyssey4me> Here is our bug list for today https://etherpad.openstack.org/p/osa-bugtriage
16:01:22 <odyssey4me> #topic Last week AP
16:01:34 <odyssey4me> andymccr triage https://bugs.launchpad.net/openstack-ansible/+bug/1682169
16:01:34 <openstack> Launchpad bug 1682169 in openstack-ansible "Upgrade N->O nova-manage cell_v2 issue" [Undecided,New] - Assigned to Andy McCrae (andrew-mccrae)
16:02:28 <odyssey4me> andymccr are you around?
16:02:43 <odyssey4me> is anyone around and paying attention? :)
16:02:50 <DimGR> i am
16:02:56 <cloudnull> o/
16:02:57 <cloudnull> :)
16:04:00 <odyssey4me> ok, it looks like andymccr hasn't yet found a working connection at his new desk
16:04:06 <odyssey4me> so I guess the action carries
16:04:19 <odyssey4me> #action andymccr triage https://bugs.launchpad.net/openstack-ansible/+bug/1682169
16:04:19 <openstack> Launchpad bug 1682169 in openstack-ansible "Upgrade N->O nova-manage cell_v2 issue" [Undecided,New] - Assigned to Andy McCrae (andrew-mccrae)
16:04:25 <andymccr> still carrying!
16:04:36 <odyssey4me> haha :)
16:04:40 <odyssey4me> next up https://bugs.launchpad.net/openstack-ansible/+bug/1687447
16:04:41 <openstack> Launchpad bug 1687447 in openstack-ansible "neutron-ha-tool running of outdated venv when upgrading intra release" [Undecided,New]
16:04:43 <andymccr> 4 mins late :P not bad.
16:05:22 <andymccr> hmm
16:05:24 <cloudnull> humm.
16:05:28 <andymccr> hahah
16:05:37 <cloudnull> is this a matter of us needing to respawn the cron?
16:06:04 <andymccr> surely the cron should point to the correct place?
16:06:09 <cloudnull> its executed via cron, maybe that's not getting recreated
16:07:06 <cloudnull> https://github.com/openstack/openstack-ansible-os_neutron/blob/master/tasks/neutron_l3_ha.yml#L19
16:07:10 <odyssey4me> it should be: https://github.com/openstack/openstack-ansible-os_neutron/blob/master/tasks/neutron_l3_ha.yml#L22
16:07:24 <cloudnull> so the cron calls that script so it should be pointed to the right place
16:08:21 <cloudnull> so maybe Bjoern was seeing an old process still being executed ?
16:08:32 <cloudnull> when cron refires post upgrade it will have the right path
16:08:45 <cloudnull> but this does call in a good point
16:08:52 <cloudnull> maybe its time to let that tool go
16:08:53 <cloudnull> ?
16:09:01 <odyssey4me> it would seem sensible to me that we hould disable the cron job and kill any running process while an upgrade is being executed
16:09:13 <cloudnull> its technically been deprecated since kilo
16:09:15 <cloudnull> https://github.com/openstack/openstack-ansible-os_neutron/blob/master/tasks/neutron_l3_ha.yml#L16-L17
16:09:32 <cloudnull> but we've kept it around due to bugs in l3ha ?
16:10:14 <cloudnull> maybe we should standardize on l3ha and leave this alone ?
16:10:46 <odyssey4me> well, it's still part of mitaka, newton and ocata
16:11:01 <odyssey4me> we could perhaps remove it from pike, but the issue still stands, assuming that it gets confirmed
16:11:05 <cloudnull> yea i mean its there. but in pike should we drop it?
16:11:12 <cloudnull> ok
16:11:33 <cloudnull> yea. as for the issue at hand, i dont see how the script would not have been updated
16:11:36 <andymccr> could we adjust the cron somehow?
16:11:49 <andymccr> hmm
16:11:49 <cloudnull> the cron calls the script and the script is a template file.
16:11:58 <cloudnull> so it should be pointed all to the right place
16:12:02 <andymccr> cloudnull: but the cron runs a bash script htat may not have changed
16:12:03 <odyssey4me> yep
16:12:24 <odyssey4me> the bash script doesn't need changing as it doesn't refer to the venv
16:12:29 <andymccr> yeah
16:13:29 <odyssey4me> ok, so it sounds like we need more details or someone needs to try and replicate the issue
16:13:55 <andymccr> yeah seems so
16:14:07 <cloudnull> so here's the tool https://github.com/openstack/openstack-ansible-os_neutron/blob/master/templates/neutron-ha-tool.py.j2#L1
16:14:16 <cloudnull> which would have the right pathing assuming the playbook ran
16:14:35 <cloudnull> the job is set here https://github.com/openstack/openstack-ansible-os_neutron/blob/master/tasks/neutron_l3_ha.yml#L37
16:14:43 <cloudnull> and then executed https://github.com/openstack/openstack-ansible-os_neutron/blob/master/templates/neutron_ha_tool.sh.j2
16:15:08 <cloudnull> so on a minor upgrade there'd be a new venv and that venv path is based on the release version
16:15:10 <andymccr> yeah. hmm
16:15:28 <andymccr> but it would still point to the correct location once that file is retemplated which it would be because that var has changed
16:15:40 <andymccr> well assuming it ran successfully
16:15:42 <mgariepy> I have this issue on upgrade from mitaka to newton !
16:15:50 <andymccr> hmm
16:15:51 <cloudnull> which is defined here https://github.com/openstack/openstack-ansible-os_neutron/blob/master/defaults/main.yml#L61 and set in the playbooks.
16:16:08 <cloudnull> mgariepy: what did you need to do to solve it ?
16:16:21 <mgariepy> did dig into it yet.
16:16:25 <mgariepy> didn't dig into it yet.
16:16:40 <andymccr> mgariepy: do you think you'll get a chance to look into it?
16:16:51 <mgariepy> yeah i can take a look
16:16:59 <cloudnull> I wonder if the script is changed but the job is just running in memory ?
16:17:19 <odyssey4me> for mitaka to newton makes sense, because the default changed from this being enabled to this being disabled
16:17:30 <mgariepy> the script isn't modified
16:17:41 <mgariepy> hmm
16:18:01 <mgariepy> ha..
16:18:02 <andymccr> mgariepy: the shell wouldnt be but it should just call the py script which should change
16:18:05 <cloudnull> ah, that's a good point. maybe the option is disabled?
16:18:26 <mgariepy> if disabled, maybe it should be removed then ?
16:18:43 <cloudnull> https://github.com/openstack/openstack-ansible-os_neutron/blob/master/tasks/main.yml#L89-L94
16:19:31 <andymccr> ok so maybe the issue is its disabled now
16:19:34 <andymccr> and it should just be removed
16:19:53 <odyssey4me> ok, I've asked for confirmation of the value of the legacy tool enablement
16:19:53 <andymccr> we could run a cleanup that removes the cron job if not legacy_ha_tool_enabled | bool
16:20:05 <odyssey4me> yes, that is a good idea
16:20:35 <odyssey4me> remove the cron job and the scripts related to it
16:21:03 <mgariepy> ok i'll make a patch for this one.
16:21:39 <odyssey4me> awesome, thanks mgariepy
16:22:12 <odyssey4me> #action mgariepy to create neutron-ha-tool cleanup if neutron_legacy_ha_tool_enabled is false
16:22:20 <openstackgerrit> Kevin Carter (cloudnull) proposed openstack/openstack-ansible-os_neutron master: Clean up cron if l3ha legacy tool is not enabled  https://review.openstack.org/461843
16:22:26 <andymccr> hhahahahaha
16:22:28 <odyssey4me> hahaha
16:22:33 <odyssey4me> next up https://bugs.launchpad.net/openstack-ansible/+bug/1687369
16:22:33 <openstack> Launchpad bug 1687369 in openstack-ansible "ocata installation fails for aodh,ceilometer and designate when sqlalchemy version is 1.1.9 version " [Undecided,New]
16:22:35 <cloudnull> oh... my bad. was not watching the screen
16:22:43 <andymccr> i think there is a patch in for this
16:22:59 <andymccr> alextricity25: ^
16:23:19 <cloudnull> sorry mgariepy ...
16:23:41 <andymccr> its ok cloudnull you can buy him a beer next week to say sorry :P
16:23:49 <cloudnull> done.
16:23:52 <cloudnull> beers all around .
16:25:01 <mgariepy> lol
16:25:33 <odyssey4me> it looks like there's an outstanding question for this already
16:27:00 <odyssey4me> ok, let me look into this
16:27:03 <andymccr> yeah i know alextricity25 did some fixes on master for sqlalchemy
16:27:06 <andymccr> but i dont htink it applies to stable/ocata
16:27:13 <odyssey4me> yep, when I tried them they didn't work ;)
16:27:24 <odyssey4me> I'll take another look and see what I can find.
16:27:44 <andymccr> hmm
16:27:48 <odyssey4me> #action odyssey4me to confirm/triage https://bugs.launchpad.net/openstack-ansible/+bug/1687369
16:27:48 <openstack> Launchpad bug 1687369 in openstack-ansible "ocata installation fails for aodh,ceilometer and designate when sqlalchemy version is 1.1.9 version " [Undecided,New] - Assigned to Jesse Pretorius (jesse-pretorius)
16:27:50 <andymccr> weird it should've worked based on constraints still
16:28:11 <odyssey4me> yep, it should have - no idea why he's trying to increase the constraint
16:28:18 <odyssey4me> anyway, next up https://bugs.launchpad.net/openstack-ansible/+bug/1687594
16:28:18 <openstack> Launchpad bug 1687594 in openstack-ansible "no configuration for osa neutron to configure external dns yet" [Undecided,New]
16:28:42 <odyssey4me> pjm6 you around?
16:28:53 <openstackgerrit> Kevin Carter (cloudnull) proposed openstack/openstack-ansible-os_neutron master: Clean up cron if l3ha legacy tool is not enabled  https://review.openstack.org/461843
16:29:43 <odyssey4me> this should be pretty easy to fix up
16:29:54 <cloudnull> interesting. i didn't know neutron configs were needed for designate.
16:30:01 <cloudnull> wishlist?
16:30:06 <odyssey4me> it's just a conditional portion of neutron's conf
16:30:19 <andymccr> you could use config overrides atm?
16:30:38 <andymccr> i mean it would be cool to enable it if you are deploying designate by default - but right now if you wanted there is an option so yeah wishlist
16:30:39 <odyssey4me> yeah, of course - but as we ship designate we should auto-wire it if you have it
16:31:31 <spotz_> Hey no ping?:)
16:31:44 <cloudnull> odyssey4me: +1
16:31:48 <odyssey4me> ok, marked low hanging fruit and wishlist
16:32:25 <odyssey4me> that looks like it for the new bugs
16:32:33 <andymccr> easy
16:32:36 <andymccr> thanks all
16:32:41 <odyssey4me> anyone got a bug to raise that needs more attention?
16:33:27 <odyssey4me> spotz_ the ping was for spotz - somehow you've gained a trailing underscore
16:33:30 <andymccr> reviews on https://review.openstack.org/#/c/461802/ would be appreciated :D
16:33:52 <spotz_> odyssey4me: Yeah when I changed bouncers. Let me see if I can fix
16:35:37 <odyssey4me> okie dokey, SHA's confirmed GTG
16:35:40 <spotz_> grrr
16:35:48 <andymccr> thanks!
16:35:50 <odyssey4me> right, thanks all!
16:35:53 <odyssey4me> #endmeeting