16:01:58 <evrardjp> #startmeeting openstack_ansible_meeting
16:01:59 <openstack> Meeting started Tue May 16 16:01:58 2017 UTC and is due to finish in 60 minutes. The chair is evrardjp. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:03 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:02:24 <evrardjp> #topic last week AP
16:02:37 <andymccr> its gonna be me still :P
16:02:45 <andymccr> sorry - im slack on that bug but will still get to it!
16:02:54 <andymccr> i do love nova upgrades i promise
16:02:58 <evrardjp> you're not the only one
16:03:02 <evrardjp> haha
16:03:12 <evrardjp> I will still link it for record
16:03:20 <evrardjp> I postpone to next week right
16:03:23 <evrardjp> #link andymccr triage https://bugs.launchpad.net/openstack-ansible/+bug/1682169
16:03:25 <openstack> Launchpad bug 1682169 in openstack-ansible "Upgrade N->O nova-manage cell_v2 issue" [Undecided,New] - Assigned to Andy McCrae (andrew-mccrae)
16:03:29 <andymccr> hahah
16:03:32 <evrardjp> next one was
16:03:35 <andymccr> yeah do link it - thanks!
16:03:37 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1687369
16:03:38 <openstack> Launchpad bug 1687369 in openstack-ansible "ocata installation fails for aodh,ceilometer and designate when sqlalchemy version is 1.1.9 version " [Undecided,New] - Assigned to Jesse Pretorius (jesse-pretorius)
16:03:42 <evrardjp> odyssey4me: ?
16:04:05 <odyssey4me> I haven't had a chance to look into it yet
16:04:08 <evrardjp> ok
16:04:26 <evrardjp> #action odyssey4me to confirm/triage https://bugs.launchpad.net/openstack-ansible/+bug/1687369
16:04:38 <evrardjp> #action andymccr triage https://bugs.launchpad.net/openstack-ansible/+bug/1682169
16:04:39 <openstack> Launchpad bug 1682169 in openstack-ansible "Upgrade N->O nova-manage cell_v2 issue" [Undecided,New] - Assigned to Andy McCrae (andrew-mccrae)
16:04:45 <evrardjp> ok next
16:04:54 <evrardjp> #topic this week's bugs!
16:05:10 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1691130 fails at repo_build : Build package requirements file
16:05:10 <openstack> Launchpad bug 1691130 in openstack-ansible "fails at repo_build : Build package requirements file" [Undecided,New] - Assigned to Jesse Pretorius (jesse-pretorius)
16:06:42 <evrardjp> We won't get more feedback in this task, it's really the templating that failed
16:07:01 <evrardjp> we need to know why, which requires reproducing it
16:07:29 <evrardjp> I can spend some cycles on it if nobody is busy
16:07:35 <evrardjp> available*
16:07:53 <andymccr> hmm
16:08:23 <andymccr> odyssey4me: may already be looking at it
16:08:25 <evrardjp> odyssey4me: will have a look too, anyone welcome
16:08:27 <evrardjp> :)
16:08:28 <andymccr> he's assigned and its only an hour old
16:08:38 <evrardjp> yeah
16:09:00 <evrardjp> let's go to next bug
16:09:12 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1690088
16:09:13 <openstack> Launchpad bug 1690088 in openstack-ansible ""Permission denied" when create a cinder volume with NFS backend" [Undecided,New]
16:10:06 <evrardjp> sounds odd we never got that issue
16:10:11 <andymccr> hmm
16:10:14 <andymccr> yeah
16:10:57 <evrardjp> pjm6: you were doing NFS right?
16:11:07 <odyssey4me> we don't setup the NFS share, so we can't do changes there
16:11:31 <odyssey4me> I suppose we could change perms on the mount point
16:11:41 <evrardjp> do we handle the mount odyssey4me?
16:11:50 <odyssey4me> that's a good question
16:12:08 <evrardjp> mount doesn't seem to appear in os_cinder
16:12:40 <odyssey4me> no, I think all we do is tell cinder about them
16:12:56 <odyssey4me> so the mounts have to be pre-configured by the deployer
16:13:05 <evrardjp> yeah
16:13:08 <evrardjp> I see this: https://github.com/openstack/openstack-ansible/blob/849ad71ce2a26408665a15ab5bc6d5a81e73f674/etc/openstack_deploy/openstack_user_config.yml.prod.example#L264
16:15:30 <evrardjp> no control then
16:16:04 <evrardjp> I guess we can file this as invalid
16:16:37 <pjm6> evrardjp, i'm doing NFS for glance image
16:16:50 <pjm6> *glance images
16:17:13 <pjm6> for cinder i'm using dell equallogic driver
16:17:34 <evrardjp> everyone agrees on invalid?
16:17:54 <evrardjp> different case then pjm6, thanks for the input
16:18:02 <pjm6> evrardjp, no problem
16:18:10 <evrardjp> ok I marked it invalid
16:18:12 <evrardjp> next bug
16:18:15 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1689283
16:18:16 <openstack> Launchpad bug 1689283 in openstack-ansible "Venv check download downloads from a different place than the actual download occurs due to - "lookup" usage" [Undecided,New]
16:19:12 <evrardjp> odyssey4me: do you have an update on this?
16:19:29 <evrardjp> I think there are work being done, it doesn't seem to track this bug
16:19:49 <evrardjp> boxrick1 are you there?
16:20:15 <evrardjp> it looks like the topic of the change is there: https://review.openstack.org/#/q/topic:venv_checksum_fix
16:20:20 <evrardjp> reviews welcome I guess :)
16:22:11 <evrardjp> Confirmed Medium, ok?
16:22:29 <evrardjp> 5
16:22:30 <evrardjp> 4
16:22:30 <evrardjp> 3
16:22:31 <evrardjp> 2
16:22:33 <evrardjp> 1
16:22:37 <evrardjp> next!
16:22:40 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1689231
16:22:41 <openstack> Launchpad bug 1689231 in openstack-ansible "cannot ssh into the containers" [Undecided,New]
16:23:52 <evrardjp> Our Newton builds seem fine, I doubt it's a global problem, more a support request
16:26:35 <andymccr> sorry got a call - checking now!
16:26:36 <evrardjp> I mark it as incomplete
16:26:55 <andymccr> ok yeah
16:26:56 <evrardjp> haha no worries andymccr "we" continued
16:26:58 <andymccr> i think we need more info on that
16:27:10 <andymccr> like is the container up and getting an ip etc etc
16:27:32 <evrardjp> Well our connection plugin changed recently, that's why I think we shouldn't mark it as invalid quite right away
16:27:35 <andymccr> also that venvcheck sum one is almost all merged i think
16:27:44 <andymccr> yeah agreed, lets ask for more feedback and debug info
16:27:48 <evrardjp> agreed.
16:27:50 <andymccr> anyway i think that is the correct approach
16:28:01 <evrardjp> next
16:28:02 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1688014
16:28:03 <openstack> Launchpad bug 1688014 in openstack-ansible "Neutron role fails to properly disable neutron agents" [Undecided,New]
16:28:35 <evrardjp> it looks like we need to adapt the conditionals
16:28:38 <evrardjp> sounds legit
16:28:58 <andymccr> hmm
16:29:08 <evrardjp> the question is
16:29:25 <evrardjp> should we do this, or should the configuration of nuage be more explicit
16:30:05 <andymccr> hmm
16:30:43 <evrardjp> the release notes mentions ml2, and we don't have that in our conditionals
16:31:06 <evrardjp> but they are for different agents.
16:31:21 <evrardjp> I guess it's a decision we have to take on "user friendliness"
16:31:24 <andymccr> so is the issue that we dont have support directly for nuage?
16:31:37 <evrardjp> well nuage would need more than one override
16:32:05 <andymccr> e.g. the neutron_plugin_base would change depending on the plugin_type but we dont have builtins for nuage
16:32:56 <evrardjp> https://github.com/openstack/openstack-ansible-os_neutron/blob/master/vars/main.yml#L187-L190
16:33:09 <evrardjp> we kinda have facilities for nuage
16:33:26 <andymccr> ahh ok then id say we should support that yeah
16:33:49 <evrardjp> I think we should treat this as: Do we want to make configuration of nuage smarter, or document it properly. :D
16:34:02 <evrardjp> In any case there is work to do
16:34:11 <andymccr> yeah agreed
16:34:17 <andymccr> i think its a bug but low since you can work around it
16:34:29 <evrardjp> yes.
16:34:53 <evrardjp> We should discuss this in a larger audience, to see if that's asked by deployers in-general.
16:34:59 <evrardjp> then we can refactor if need be
16:35:31 <evrardjp> confirmed low it is!
16:35:34 <andymccr> sweet
16:35:44 <evrardjp> oh
16:35:45 <evrardjp> next
16:35:46 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1688011
16:35:48 <openstack> Launchpad bug 1688011 in openstack-ansible "Neutron plugin name wrong for nuage deployment" [Undecided,New]
16:35:51 <andymccr> hahaha
16:36:04 <evrardjp> I think we got our nuage user :p
16:36:04 <andymccr> fair enough
16:36:10 <andymccr> yeah it'd be cool to get that working then
16:36:18 <andymccr> but theyre pretty easy fixes
16:36:24 <evrardjp> confirmed medium low-hanging-fruit ?
16:36:31 <andymccr> yeah ++
16:36:35 <andymccr> low-hanging-fruit tag is great for those
16:37:06 <evrardjp> new contributors, don't hesitate to pick this one up!
16:37:08 <evrardjp> :D
16:37:23 <evrardjp> last one
16:37:33 <evrardjp> #link https://bugs.launchpad.net/openstack-ansible/+bug/1687447
16:37:34 <openstack> Launchpad bug 1687447 in openstack-ansible "neutron-ha-tool running of outdated venv when upgrading intra release" [Undecided,New] - Assigned to Marc GariƩpy (mgariepy)
16:37:34 <evrardjp> mgariepy: ?
16:37:47 <evrardjp> are we ok with the current fixes?
16:38:58 <andymccr> did fixes go in for that?
16:39:07 <andymccr> ahh yeah cloudnull fixed it up
16:39:08 <evrardjp> "related" ones
16:39:39 <andymccr> hmm
16:39:45 <evrardjp> https://review.openstack.org/#/c/462849/ should be good enough I think
16:40:02 <andymccr> yeah agreed
16:40:04 <evrardjp> I'm willing to mark it fixed released, ok for you?
16:40:04 <andymccr> i think its ok
16:40:06 <andymccr> yeah
16:40:08 <andymccr> good with that
16:40:14 <evrardjp> ok
16:40:18 <evrardjp> thanks everyone!
16:40:25 <andymccr> sweet
16:40:26 <andymccr> thanks evrardjp!
16:40:30 <evrardjp> has anyone anything to add?
16:40:33 <evrardjp> 5
16:40:34 <evrardjp> 4
16:40:35 <evrardjp> 3
16:40:36 <evrardjp> 2
16:40:37 <evrardjp> 1
16:40:39 <evrardjp> #endmeeting