16:01:57 <spotz> #startmeeting openstack_ansible_meeting
16:01:59 <openstack> Meeting started Thu Jun  8 16:01:57 2017 UTC and is due to finish in 60 minutes.  The chair is spotz. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:02 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:02:08 <spotz> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:02:15 <spotz> #topic Roll Call
16:02:18 <andymccr> o/
16:02:43 <d34dh0r53> o/
16:02:52 <spotz> d34dh0r53: Hey!
16:02:54 <odyssey4me> o/
16:02:59 <jmccrory> o/
16:02:59 <d34dh0r53> hiya spotz
16:03:15 <spotz> Someone poke cloudnull - he's up first
16:03:55 <spotz> #topic Review action items from 2 weeks ago
16:04:16 <spotz> cloudnull to fix up upgrades/spec for hyperconverge path - our only action item
16:04:20 <andymccr> yeah!
16:04:31 <andymccr> I know odyssey4me has reverted some of it already
16:04:43 <spotz> Yeah odyssey4me!
16:04:45 <andymccr> cloudnull:  we're gonna just have to revert some of that, we're at m2 now, so there is a bit of time
16:04:46 <odyssey4me> it's still in review
16:05:05 <andymccr> but if we hit m3 and are still pending this we're gonna have to just get it reverted
16:05:26 <andymccr> which is the last week or so in july (24-28)
16:05:40 <andymccr> but cloudnull isn't here, im sure he'll get the backscroll - gonna add it again as an action item
16:05:45 <odyssey4me> doing the hyperconvergance will force us to re-think how we do service restarts across multiple hosts, especially when they need to be done in a specific order and we're serialising the deployments to cater for rolling upgrades
16:05:57 <andymccr> #action cloudnull to fix up upgrades/spec for hyperconverge path - our only action item
16:06:01 <odyssey4me> so right now I've proposed the revert as a safety measure
16:06:10 <andymccr> odyssey4me: yeah agreed although we don't force service locations, its designed to be flexible i guess
16:06:28 <odyssey4me> yep, but we need to cater to our defaults
16:06:47 <andymccr> well either way, its impossible to upgrade cleanly in the current method
16:07:13 <andymccr> so im thinking
16:07:18 <andymccr> we revert and talk about it at the PTG a bit more
16:08:13 <spotz> Ok moving on before we get talking PTG here!
16:08:17 <andymccr> yeah
16:08:18 <andymccr> hahaha
16:08:20 <spotz> #topic Developer mode changes
16:08:34 <andymccr> ok yes! so this was meant for last weeks meeting, but since i wasnt available - i'll talk about it here
16:08:55 <spotz> Be honest you stood us up...
16:09:03 <andymccr> we've merged a new dev mode path, that will allow upstream roles to use our tests
16:09:09 <andymccr> for example keystone are implementing our upgrade tests now
16:09:13 <andymccr> here is a blog about it: http://blog.andy.mc.it/osa-dev-env/
16:09:21 <andymccr> i'll be adding some docs in the dev docs but just as a point of interest
16:09:25 <andymccr> and yeah sorry about that spotz :((
16:10:04 <spotz> uh huh... Any questions? Or go read the blog first and then hit andymccr up:)
16:10:16 <andymccr> spotz: yeah i mean more just to let people know thats happened :)
16:10:32 <andymccr> and that we'll start having some more testing in other projects (i know nova-lxd are looking at it, and ara already has it)
16:10:37 <spotz> Ok moving on to our favorite then:)
16:10:43 <spotz> #topic PTG - 11-15 September - Denver, Colorado
16:10:47 <andymccr> haha
16:10:50 <andymccr> ok PTG you know what to do people :D
16:11:11 <andymccr> we still have quite a bit of time, so for now just start looking at getting there if possible!
16:11:16 <spotz> Still waiting to hear the status of my talk that week in LA, then I'll know if I can go
16:11:26 <andymccr> excellent!
16:12:08 <spotz> We have an ether started or anything? Folks will need to know what days and such to help with planning
16:12:17 <xgerman_> +1
16:12:23 <andymccr> nope not yet - we have some time, so maybe at m3 we can start that
16:12:51 <andymccr> since it's still 3 months away or so
16:12:53 <andymccr> but yeah!
16:13:03 <andymccr> i'll leave it on for the meetings
16:13:04 <spotz> Ok sooner folks know how many days the sooner they can ask work
16:13:12 <andymccr> ahh you mean from a day perspective
16:13:14 <andymccr> ok lemme dig into that
16:13:16 <spotz> yeah
16:13:25 <andymccr> i'll investigate and get back to you
16:13:40 <andymccr> #action andymccr to look into specific OSA dates for the PTG
16:13:41 <spotz> First 2 days are cross project I read, but they said to talk to your PTL about the other days:)
16:14:03 <spotz> So get on it!:)
16:14:11 <andymccr> will do
16:14:16 <spotz> #topic Release Planning and Decisions
16:14:28 <andymccr> ok! SO - we have milestone 2 released! yay
16:14:53 <spotz> woot
16:15:05 <andymccr> as an FYI that means nothing can be added to the official release - so no new repos, although they will still be branched/tagged etc.
16:15:29 <andymccr> other than that, im out next week - but evrardjp will be doing the release for Ocata/Newton next week.
16:15:52 <spotz> We want to cancel this meeting?
16:16:00 <andymccr> spotz: yeah maybe for next week.
16:16:10 <andymccr> i think at the PTG we should discuss the meeting in general, perhaps once every 2 weeks is fine
16:16:14 <spotz> ok I'll send a mail out when we're done
16:16:15 <andymccr> or it seems to be at least
16:16:18 <andymccr> thanks spotz!
16:16:34 <spotz> Yeah we're definitely going faster and having less people:(
16:16:48 <spotz> #topic uWSGI/NGinx Blueprint: https://review.openstack.org/#/c/458595/
16:16:57 <andymccr> spotz: yeah i think i keep it going because people can read the notes etc later, so it makes sense. but yeah
16:17:08 <andymccr> ok so - i updated the blueprint, i see i have more comments now so ineed to go through that ;D
16:17:19 <evrardjp> Will review latest.
16:17:20 <andymccr> so i'll add that as a todo item for me
16:17:24 <spotz> Did you already split it?
16:17:59 <andymccr> i'll update it soon and get another round of feedback, and i need to update the patch so thats on me :P
16:18:34 <spotz> Ok
16:18:45 <spotz> So last topic then
16:18:52 <spotz> #topic Open Discussion
16:18:57 <andymccr> sweet :)
16:19:05 <andymccr> as an fyi - we're adding some bits to do a translation checksite
16:19:13 <andymccr> https://review.openstack.org/#/c/472296/
16:19:24 <andymccr> & https://review.openstack.org/#/c/467222/
16:19:34 <andymccr> which will allow the i18n team to use OSA as their testing infrastructure for a release
16:19:43 <andymccr> nothing to do right now - just for those interested :)
16:19:56 <spotz> That'll make ianychoi happy:)
16:19:56 <evrardjp> that's good
16:20:12 <odyssey4me> :)
16:20:18 <evrardjp> for i18n will we go that far as nova consoles?
16:20:32 <evrardjp> (just for curiosity)
16:20:47 <odyssey4me> you're doing great work connecting OSA to other teams andymccr - that's just what I think will help grow the community
16:21:38 <andymccr> odyssey4me: hoping so - if we can get the keystone patch merged to show how to integrate testing that'd help
16:21:46 <evrardjp> agreed. Congrats
16:21:56 <spotz> Now if only we could look at conf files without having to go into the lxc:)
16:22:00 <andymccr> evrardjp: not sure. i think they could use nova: no-op driver
16:22:42 <spotz> We've got 35 minutes of meeting time. Keep chatting here or want to end?
16:23:05 <andymccr> i dont have anything else right now. happy to leave it open for a bit incase anybody has other points of conversation!
16:23:35 <evrardjp> yeah this was fast
16:24:26 <evrardjp> we have many bugs, please have a look at them. I will add the organisation of a bug smash somewhere in our timeline maybe?
16:24:37 <evrardjp> I think nobody was against
16:24:37 <andymccr> evrardjp: yeah thats probably a good idea
16:25:22 <odyssey4me> evrardjp I think that rickbox and jrosser_ might be interested in hosting that.
16:28:31 <evrardjp> would be great
16:31:35 <andymccr> ok so i think we're good then :)
16:31:47 <evrardjp> thanks everyone!
16:31:51 <andymccr> thanks everybody
16:31:55 <andymccr> spotz: feel free to close itup!
16:35:29 <spotz> #end-meeting
16:35:36 <spotz> #endmeeting