16:00:56 <andymccr> #startmeeting openstack_ansible_meeting
16:00:57 <openstack> Meeting started Thu Jun 22 16:00:56 2017 UTC and is due to finish in 60 minutes. The chair is andymccr. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:00 <andymccr> #topic Roll call
16:01:01 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:05 <alextricity25> o/
16:01:20 <alextricity25> Can't stay for the whole, time though
16:01:30 <andymccr> no worries
16:01:33 <alextricity25> Can't stay for the whole time, though
16:01:33 <andymccr> how's it going anyway? :)
16:01:36 <andymccr> we'll wait a few mins for a few ppl
16:02:25 <alextricity25> Pretty good! Trying to dig deeper into the bug list and currenty issues we have with the telemetry stack roles
16:02:30 <alextricity25> current*
16:04:42 * mhayden is in a mtg but trying to multi-task
16:04:50 * hwoarang is on listening-only mode
16:05:18 <andymccr> well should be a short one then ;) i know evrardjp is out today and odyssey4me is at ansible fest so i'll just provide an update on some things (e.g. the PTG) and then we can move along :)
16:05:21 <andymccr> also - cloudnull if you're about!
16:05:32 <andymccr> oh and spotz_ is busy today too.
16:05:38 <andymccr> (hence me hosting!)
16:06:00 <andymccr> ok so lets get this going
16:06:08 <andymccr> #topic action items from last week
16:06:15 <andymccr> Ok first one! cloudnull to fix up upgrades/spec for hyperconverge path - our only action item
16:06:19 <andymccr> #action cloudnull to fix up upgrades/spec for hyperconverge path - our only action item
16:06:21 <alextricity25> I just have one thing. Would it be possible to do open-mic first since I have to jet soon?
16:06:31 <andymccr> alextricity25: sure!
16:06:42 <andymccr> #topic openmic intro session
16:06:47 <andymccr> go for it
16:07:00 <alextricity25> Thanks! cloudnull and I were talking about decommissioning the telemetry stack roles
16:07:22 <andymccr> what does the process involve?
16:07:24 <alextricity25> I currently don't have the bandwidth to fully maintain them, plus gnocchi moved out of the openstack namespace.
16:07:36 <andymccr> yeah
16:07:49 <andymccr> i think we have a few roles like that, what are your thoughts on the approach to doing that?
16:08:29 <alextricity25> We'll have to remove the roles(with or without alternative). Remove docs(or update them), and remove other references
16:08:48 <odyssey4me> we'd have to make up our own
16:09:07 <odyssey4me> we could just push up a patch to the docs/readme which says that the roles are looking for maintainers
16:09:18 <andymccr> can we just remove them from integrated build and mark them as out-dated.
16:09:22 <odyssey4me> we then pull them out of the integrated build in master until maintainers are found
16:09:30 <andymccr> like they worked at some point so there is some groundwork there that could be fixed up at a later point
16:09:32 <odyssey4me> and we move them back to being independent roles
16:09:48 <alextricity25> yeah, that could work
16:10:04 <odyssey4me> that way they're in the same state as cloudkitty, etc
16:10:11 <alextricity25> The roles are already pulled out of the integrated build in master
16:10:12 <andymccr> ^ this
16:10:54 <alextricity25> I can touch base with the right people offline to move that along
16:11:02 <andymccr> alextricity25: sounds good
16:11:05 <alextricity25> That's all I had for now. If you all are okay with that
16:11:07 <odyssey4me> no they're not
16:11:13 <odyssey4me> they're still in the ansible-role-requirements
16:11:25 <alextricity25> odyssey4me: Ah right. I meant that they aren't considered in the AIO builds
16:11:27 <odyssey4me> I'm talking about pulling them out entirely, not just from active testing.
16:11:41 <alextricity25> odyssey4me: Gotcha
16:12:01 <jmccrory> do they still work for ocata/newton?
16:12:19 <alextricity25> I *think* it works for newton. I'm pretty sure it doesn't work in ocata
16:12:45 <odyssey4me> well, those are stable branches so we can't really just pull them
16:12:50 <odyssey4me> and we should try to get that working
16:14:30 <alextricity25> I wouldn't waste your time on that. The ceilometer in the stable branches uses the legacy store(mongodb) which is really bad and not recommended
16:14:35 <andymccr> agreed although there is an argument that if they are not working and nobody has noticed that nobody is using them
16:14:47 <cloudnull> o/
16:14:49 <cloudnull> sorry late
16:16:15 <alextricity25> EOF
16:16:16 <alextricity25> :)
16:16:19 <andymccr> ok so alextricity25 do you have an idea of what to do on master at least?
16:17:10 <andymccr> gonna take the EOF as a yes ;P
16:17:12 <andymccr> ok
16:17:14 <andymccr> #topic action items
16:17:20 <alextricity25> andymccr: We can do what odyssey4me suggested for master. Move the roles to be independent, and make some doc notes explaining the situation
16:17:24 <alextricity25> :)
16:17:27 <andymccr> cloudnull: cloudnull to fix up upgrades/spec for hyperconverge path
16:17:32 <andymccr> alextricity25: sounds good.
16:17:37 <cloudnull> yea that s a thing
16:17:49 <cloudnull> i will work on that spec tonogight
16:17:58 <cloudnull> **tonight
16:18:30 <andymccr> ok cool
16:18:40 <andymccr> #action item cloudnull doing the hyperconverge spec
16:18:46 <andymccr> ok so the other was about the PTG and dates
16:19:05 <andymccr> so we have a room for Wed-thur-friday
16:19:25 <andymccr> the format is a bit diff in that last time we were cross project, now i think its more infra projects on mon-tue allowing teams like us to talk to them
16:19:43 <andymccr> so hope that helps!
16:19:49 <andymccr> and on that note!
16:19:55 <andymccr> #topic Cross repo testing
16:20:22 <andymccr> ok so - we have keystone almost merged https://review.openstack.org/#/c/476168/
16:20:38 <andymccr> which will be our 2nd cross repo test for OSA (ara is already doing a similar thing)
16:20:47 <andymccr> additionally, depends-on: id-patch will now work for upstream repos
16:20:56 <andymccr> e.g. in an os_nova patch you can use "depends-on: nova-patch-id"
16:21:15 <andymccr> or even "depends-on: keystone-patch-id" "depends-on: nova-patch-id" etc. and it'll integrate any of those by using zuul-cloner
16:21:17 <cloudnull> andymccr: whats the date of the PTG?
16:21:23 <andymccr> 11-15 sept cloudnull!
16:21:35 <andymccr> i think you will be in europe :'(
16:21:47 <cloudnull> yea.
16:21:49 <cloudnull> sorry.
16:22:01 <odyssey4me> I need to leave this room - they're wanting to lock up.
16:22:02 <andymccr> all good :)
16:22:07 <odyssey4me> chat tomorrow!
16:22:10 <andymccr> odyssey4me: ok sure!
16:22:19 <andymccr> which is the other topic!
16:22:23 <andymccr> #topic PTG 11-15 sept
16:22:44 <andymccr> so the dates we have a room, as i said before are the wed-friday
16:22:53 <andymccr> its in Denver, and its a good idea to start planning now if you haven't alreayd!
16:23:19 <cloudnull> ++
16:23:39 <andymccr> other than that no new info we'll do more planning closer to the time i think
16:23:41 <andymccr> #topic releases
16:23:46 <cloudnull> also there's some effort from folks at red hat/suse/rackspace to get together at the ptg and talk about leap upgrades
16:23:53 <andymccr> cloudnull: ahh yeah
16:24:01 <cloudnull> so if folks will be there itd be great to capture that work
16:24:03 <andymccr> i think we'll have a few of those
16:24:12 <andymccr> agreed
16:24:20 <cloudnull> a lot of that will be based on https://github.com/openstack/openstack-ansible-ops/tree/master/leap-upgrades
16:24:31 <andymccr> si si
16:24:39 * cloudnull steps back into the corner
16:24:49 <andymccr> cloudnull: this is why you should be there :)
16:24:56 <andymccr> but im sure we can figure something out
16:25:03 <cloudnull> I will be there in spirit
16:25:07 <cloudnull> :P
16:25:28 <andymccr> ok SO! last week was a release week, thanks to evrardjp for doing the releases :)
16:25:33 <andymccr> so next release will come out next week
16:25:51 <andymccr> our next milestone is in aug 07-11 which is a feature freeze.
16:26:05 <andymccr> so we need to be finishing up features that are in flight to get htem in by that point.
16:26:29 <andymccr> other than that - business as usual! :)
16:26:39 <andymccr> #topic blueprint work
16:26:58 <andymccr> so the uWSGI work is coming along, i have a test patch almost ready - just trying to figure out one bug and then i'll push that up for comments, and adjust the spec as needed
16:27:12 <andymccr> but gonna be badgering a few of you next week or maybe even tomorrow - because we need to start making tracks on that goal
16:27:29 <andymccr> the py3 work will come straight after that - but based on some conversations i think it'll be not too bad
16:27:56 <andymccr> #topic bug triage
16:28:20 <andymccr> JP is away, last week i triaged the new bugs (mostly because forgot to host the meeting!) but next week i'll try host that if nobody else is about to do that.
16:28:29 <andymccr> as an fyi :)
16:28:30 <andymccr> and lastly
16:28:33 <jmccrory> do you know how service projects are moving along with both of those? https://governance.openstack.org/tc/goals/pike/index.html seems empty for most
16:28:33 <andymccr> #topic open discussion
16:29:01 <andymccr> jmccrory: atm not really - i need to dig into it once i have a pattern for doing it in nova (wsgi) and perhaps the same again for py35
16:29:18 <andymccr> but yeah we're dependent on the other projects to get that done and im sure some havent
16:30:33 <andymccr> lemme look into that
16:30:54 <andymccr> otherwise any other discussion points this week?
16:31:15 <jmccrory> thanks. i didn't have anything
16:32:05 <andymccr> ok cool. i think most ppl are out this week anyway :) so if there is anything drop me a msg or just msg in #openstack-ansible
16:32:07 <andymccr> thanks everybody!
16:32:09 <andymccr> #endmeeting