16:00:23 <spotz> #startmeeting openstack_ansible_meeting
16:00:24 <openstack> Meeting started Thu Jul 13 16:00:23 2017 UTC and is due to finish in 60 minutes.  The chair is spotz. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:27 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:37 <spotz> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:00:37 <spotz> #topic Roll Call
16:00:39 <asettle> o/
16:00:49 <spotz> Hey!
16:01:30 <evrardjp> o/
16:01:32 <palendae> o/
16:02:03 * hwoarang is around
16:02:29 <evrardjp> woot hwoarang \o/
16:02:33 * mhayden hellos
16:02:58 <spotz> Sweet, I'm assuming andymccr updated the agenda so we'll just go with that:)
16:03:01 <jmccrory> o/
16:03:18 <spotz> #topic review action items
16:03:22 <andymccr> o/
16:03:30 <spotz> #topic cloudnull doing the hyperconverge spec (and some work)
16:03:35 <spotz> You're up cloudnull
16:03:36 <andymccr> i havnt seen cloudnull around
16:03:42 <andymccr> so im guessing hes not about :(
16:03:47 <asettle> He's been quiet af today
16:03:56 <andymccr> i will action item it again, but as i said as we get closer to milestone 3 - its gonna get reverted unfortunatley
16:04:01 <spotz> He's been about later
16:04:07 <spotz> #action cloudnull doing the hyperconverge spec (and some work)
16:04:14 <andymccr> thanks spotz!
16:04:20 <spotz> #topic spotz look at the doc changes needed for OSA, will give andymccr an update for next meeting
16:04:29 * andymccr waits for update
16:04:46 <spotz> hwoarang: You've actually done the work if you want to update?
16:05:01 <hwoarang> i did?
16:05:11 <spotz> I thought it was you, dammits:)
16:05:15 <hwoarang> ;p
16:05:28 <asettle> spotz: that would be odyssey4me who did the work
16:05:30 <asettle> After all the links broke
16:05:31 <andymccr> haha spotz i think we did get the docs stuff moved - although it might be worthwhile still going through that spec/patch to confirm?
16:05:36 <odyssey4me> oh that :) yes
16:05:36 <asettle> Yes, it would be
16:05:40 <palendae> Links broke again D:
16:05:43 <asettle> There's a lot of stuff still... er... not right
16:05:44 <odyssey4me> I renamed some folders, that happened
16:05:47 <asettle> palendae: they broke because of the migration
16:05:51 <palendae> Yeah
16:05:56 <palendae> Makes sense
16:06:04 <andymccr> on the docs things
16:06:06 <spotz> Ok odyssey4me update please:)
16:06:07 <odyssey4me> now that there's a more structured set of documentation types, we should probably try to make the content sensibly match
16:06:13 <andymccr> we should talk about the mitaka docs, because i havnt EOL'd the openstack-ansible repo just yet
16:06:15 <andymccr> but i would like to
16:06:25 <evrardjp> odyssey4me: I agree
16:06:36 <evrardjp> the spec from docs is more clear on what should be where
16:06:39 <odyssey4me> andymccr you're going to have to EOL it - the jobs have been removed, I thinkk
16:06:50 <evrardjp> so we can move content progressively
16:06:56 <asettle> evrardjp: content has been moved
16:07:03 <evrardjp> I've seen
16:07:05 <odyssey4me> infra has been removing mitaka-related jobs
16:07:19 <evrardjp> but there are still things that are improvable
16:07:21 <evrardjp> IMO
16:07:28 <andymccr> odyssey4me: ahh ok
16:07:32 <evrardjp> I'll submit patches
16:07:37 <spotz> I haven't seen any bugs come in for broken docs for us, though I have heard of some after the migration day(s)
16:08:19 <spotz> I'll give things a click about when I catch up after being gone for a week:)
16:08:38 <spotz> #action spotz click about the docs site
16:08:48 <asettle> spotz: would be beneficial just to go through the spec and ensure that all the deliverables have been met too
16:08:59 <spotz> asettle okie
16:09:04 <spotz> #topic evrardjp opinion bugs according to schedule
16:09:10 <asettle> Thanks spotz :)
16:09:35 <spotz> evrardjp: You're up!
16:09:38 <andymccr> evrardjp: i dont even remember what that sentence meant :D
16:09:57 <evrardjp> that was not a topic, that was an AP.
16:10:09 <evrardjp> I didn't do it, you can postpone to next week
16:10:16 <spotz> #action evrardjp opinion bugs according to schedule
16:10:17 <evrardjp> well anyone could do it too
16:10:30 <spotz> You're still up though:)
16:10:32 <spotz> #topic evrardjp schedule a hack day to go through old reviews and possibly bugs
16:10:47 <evrardjp> the idea is starting from a certain age, the bugs should be classifide as "opinion"
16:10:59 <andymccr> evrardjp: we should be slowing down on developing new things after like m3 so i think maybe that is a good time to start doing a bug smash
16:11:01 <evrardjp> didn't got the chance to advance on that too. Next week.
16:11:05 <andymccr> evrardjp: ahhh yeah ok i remmeber
16:12:01 <spotz> #action evrardjp schedule a hack day to go through old reviews and possibly bugs
16:12:06 <odyssey4me> evrardjp I'd suggest just proposing your suggested changes to the docs https://docs.openstack.org/openstack-ansible/latest/contributor/bug-triage.html then we can discuss in review
16:12:07 <evrardjp> ok andymccr, maybe we should organise it not only remotely
16:12:32 <spotz> Letting the convo catchup:)
16:12:46 <andymccr> all good
16:13:05 <spotz> #topic Topics for Discussion
16:13:14 <spotz> #topic Proposing new core reviewers andymccr
16:13:18 <spotz> You're up boss
16:13:29 <andymccr> yes!
16:13:55 <andymccr> ok so - i've spoken with hwoarang and after the awesome work with reviews and patches - i'd like to propose hwoarang as a core reviewer
16:14:06 <evrardjp> +1
16:14:08 <spotz> +1
16:14:17 <jmccrory> +1
16:14:28 <andymccr> i'll send out an email to the ML and we can confirm it next week - but if there are any major concerns let us know
16:15:06 <andymccr> sweet sounds good so far ;P
16:15:16 <andymccr> excellent! and thanks hwoarang for all the hard work so far
16:15:30 <hwoarang> thank you too
16:15:38 <spotz> #topic PTG - 11-15 September - Denver, Colorado
16:15:44 <spotz> You're up still:)
16:15:57 <andymccr> ok! SO - i am finally confirmed going to the PTG, so myself mhayden odyssey4me and evrardjp will be there
16:16:07 <andymccr> i'll start puting up an etherpad probably right after m3 (once we get that out!)
16:16:12 <odyssey4me> +1 for hwoarang as core :)
16:16:32 <spotz> I'm still up in the air:( Last I heard the still wanted me in LA even though my talk didn't get accepted
16:16:34 <andymccr> but if you havnt planned yet, start planning, would be awesome to get some good topics for discussion that are already well thought out and have some ground work done.
16:17:05 <odyssey4me> yeah, I'd like us to actually put some time aside to hack together - not just talk
16:17:08 <andymccr> as with the last one and any others, if you cant attend and have something to discuss let us know - we will do our best to try adapt to that
16:17:10 <odyssey4me> so it'd be useful to do that
16:17:21 <xgerman_> odyssey4m3 +!
16:17:34 <andymccr> agreed
16:17:49 <spotz> And we can find out about maybe video access as well
16:18:25 <andymccr> yeah so last time we were very "ad hoc" but if there are specific topics for people who cant attend i'll do my best to plan it better time wise and arrange something
16:19:26 <evrardjp> I like the hack session idea, maybe worth planning too, say x hours for that, y hours for another topic...
16:20:02 <andymccr> i think the point is also to have some work done - e.g. "here is an idea id like to see implemented and here is how it could be implemented or some groundwork that has already been done"
16:20:07 <spotz> yeah I always enjoyed the bug squash type days when folks were all in a room even if working on different projects
16:20:07 <andymccr> rather than just an idea that we can talk about and never do :P
16:20:17 <andymccr> maybe we can use the friday as a hack day
16:20:24 <andymccr> anyway planning to come
16:20:51 <spotz> Moving on then:)
16:20:55 <spotz> #topic Release Planning and Decisions andymccr
16:21:15 <andymccr> ok so.
16:21:19 <andymccr> its release week this week
16:21:32 <andymccr> but we're holding off for a bit - we have had some instability in the builds due to the upgrade work that is happening
16:22:01 <andymccr> i'd like to get that all sorted and solid before we release again, i want to avoid a broken release
16:22:26 <andymccr> any help to fix up the bugs that have come about as a result of the upgrade approach changes would be greatly appreciated
16:22:35 <andymccr> but hopefully we can release early next week
16:23:24 <andymccr> milestone 3 is in 2 weeks, but our feature freeze is officially in a months time.
16:23:27 <andymccr> so just keep that in mind
16:24:39 <andymccr> that is all! thanks to everybody who has helped out this week - its a tricky time atm - but once we're through we can focus on stabilizing!
16:25:40 <evrardjp> Yeah.
16:25:57 <evrardjp> I'd like to thanks odyssey4me for the massive effort he is doing too.
16:26:29 <andymccr> ^ definitely this
16:26:37 <spotz> +2:)
16:26:48 <evrardjp> it's not an easy job this change
16:26:51 <evrardjp> anyway
16:27:01 <andymccr> although until we get a solid release out we are not allowed to be friends :P
16:27:09 <spotz> :(
16:27:11 <andymccr> hahaha
16:27:17 <evrardjp> haha
16:27:34 <spotz> Ok last topic before open discussion
16:27:37 <spotz> #topic uWSGI/NGinx Blueprint: pending some changes (andmyccr)
16:27:43 <spotz> Still holding?
16:27:53 <andymccr> ahha
16:27:54 <andymccr> ok!
16:27:55 <andymccr> SO
16:28:06 <andymccr> https://review.openstack.org/#/c/451425/ patch is up for comments
16:28:08 <andymccr> and it is working
16:28:13 <spotz> nice!
16:28:27 <andymccr> please take a look if you get a chance - its still WIP because its not perfect/ready to merge
16:28:41 <andymccr> its just a straight drop of uwsgi instead of an eventlet service and removes the nginx bits
16:29:12 <spotz> Which leads us to....
16:29:18 <spotz> #topic Open Discussion
16:30:18 <spotz> Nobody has anything?:(
16:30:31 <andymccr> haha aww :(
16:30:40 <xgerman_> I am making some improvements on Ocatvia
16:30:49 <xgerman_> so pleaae have a look: https://review.openstack.org/#/q/openstack-ansible-os_octavia+status:open,n,z
16:31:18 <xgerman_> they are all in preparation for an Octavia AIO scenario
16:31:51 <andymccr> xgerman_: ahh nice will take a look
16:32:13 <xgerman_> thx more to come…
16:33:48 <spotz> Thanks xgerman_!
16:34:14 <spotz> Anyone else have reviews or anything else they want to bring up?
16:35:08 <spotz> Any one? Otherwise we'll get 25 minutes back:)
16:35:25 <andymccr> sounds good:)
16:35:27 <spotz> #endmeeting