16:01:46 <spotz> #startmeeting openstack_ansible_meeting
16:01:47 <spotz> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:01:47 <spotz> #topic Roll Call
16:01:48 <openstack> Meeting started Thu Jul 27 16:01:46 2017 UTC and is due to finish in 60 minutes. The chair is spotz. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:51 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:02:35 <andymccr> o/
16:02:38 <andymccr> yay :D
16:02:40 <odyssey4me> o/
16:02:58 <hwoarang> o/
16:03:09 <spotz> That's better
16:03:49 <spotz> Looks like today is the evrardjp and andymccr show:)
16:03:53 <evrardjp> o/
16:03:57 <cloudnull> o/
16:04:02 <spotz> #topic Previous Items
16:04:12 <spotz> #topic evrardjp opinion bugs according to schedule
16:04:14 <andymccr> yay evrardjp is here :P
16:04:28 <admin0> \o
16:04:36 * mhayden woots
16:04:40 <evrardjp> yeah, so I looked into that, and we don't have this schedule written into our docs
16:04:58 <spotz> evrardjp: Bad docs! Bad bad!
16:05:03 <evrardjp> I will add this into our docs, because right now I am following nova practices for triage
16:05:15 <evrardjp> spotz: ahah
16:05:44 <spotz> So I'll keep that as an action
16:05:49 <evrardjp> when it will be accepted, I fill phase out these bugs according to our approved schedule
16:06:23 <evrardjp> you can transform that into write docs for phasing out bugs as opinions :)
16:07:01 <spotz> #action evrardjp working on doc for a phasing out bugs as opinion schedule
16:07:04 <spotz> :)
16:07:14 <spotz> #topic evrardjp schedule a hack day to go through old reviews and possibly bugs
16:07:22 <andymccr> oh man evrardjp is busy again! :P
16:07:29 <spotz> This has been on the list if no one has seen it
16:07:36 <evrardjp> so, for that there was a mail on the list indeed.
16:07:43 <evrardjp> There was a few votes already.
16:08:08 <evrardjp> here is the link
16:08:10 <evrardjp> #link https://framadate.org/osa-pike-bug-smash
16:08:33 <evrardjp> thanks to spotz and mhayden to already have put time there :)
16:08:39 <spotz> :)
16:08:45 <evrardjp> See also the ML for the full mail
16:08:53 <evrardjp> that's it.
16:09:15 <odyssey4me> link to the ML post?
16:09:34 <evrardjp> just a sec
16:09:58 <andymccr> ahh!
16:10:24 <andymccr> so wait is the plan to do bug smash after community meeting?
16:10:27 <andymccr> (s)
16:10:32 <evrardjp> #link http://lists.openstack.org/pipermail/openstack-dev/2017-July/120118.html
16:10:59 <odyssey4me> hmm, those times are all quite late for me
16:11:00 <evrardjp> well that's true I didn't think that far because it will be late.
16:11:23 <evrardjp> ok let's modify this by "before" then?
16:11:34 <andymccr> evrardjp: we could "follow the sun"
16:11:35 <odyssey4me> why not have them all day - then we can hand over to the US crew
16:11:39 <andymccr> yeah
16:11:41 <andymccr> that sounds good to me
16:11:43 <spotz> +1
16:11:54 <evrardjp> ok will remove the time notation
16:11:54 <hwoarang> +1
16:11:58 <andymccr> sounds good
16:12:58 <spotz> #action evrardjp to update the 'hack day' to be follow the sun
16:13:04 <andymccr> thanks for arranging jp - i'll update that list once i double check im available on those dates
16:13:34 <evrardjp> done :)
16:13:39 <odyssey4me> oh dear, previous votes are gone
16:13:39 <spotz> #topic Topics for Discussion
16:13:42 <evrardjp> spotz: mhayden could you revote?
16:13:47 <spotz> evrardjp: will do
16:14:07 <spotz> #topic PTG - 11-15 September - Denver, Colorado
16:14:11 <evrardjp> or I force you to follow the sun :p
16:14:19 <spotz> #link https://etherpad.openstack.org/p/osa-denver-PTG-planning
16:15:41 <andymccr> yay
16:15:41 <andymccr> so
16:15:43 <andymccr> etherpad is up
16:15:47 <spotz> woot!
16:15:49 <evrardjp> \o/
16:16:14 <andymccr> start putting some ideas in there - it's usually best if you can have some form of POC or more detail about whatever it is you're interested in implenting/discussing
16:16:29 <andymccr> we'll put focus on that as we get closer to the PTG which is in about 6 weeks
16:17:04 <evrardjp> After the bug smash, if we have time, we could maybe use wishlist items here.
16:17:13 <andymccr> works for me
16:17:16 <evrardjp> s/use/list/
16:18:39 <andymccr> might badger ppl around the PTG in the next week or 2 :) look forward to that!
16:18:50 <evrardjp> :D
16:19:00 <evrardjp> Maybe we can already list attendees
16:19:13 <andymccr> yeah if you think/know you're going put your name down on the list - would be useful
16:19:52 <evrardjp> filled a few already
16:19:54 <spotz> and video:)
16:20:28 <spotz> So moving on
16:20:32 <spotz> #topic Release Planning and Decisions
16:20:46 <andymccr> ok
16:20:47 <andymccr> so
16:20:47 <spotz> I noticed Pike wasn't there and poor little Mitaka was gone:(
16:20:52 <andymccr> hahaha
16:20:56 <andymccr> yeah :( mitaka is gone
16:20:57 <andymccr> but
16:21:00 <andymccr> pike milestone-3 is out!
16:21:24 <andymccr> we have just short of 2 months to get the stable/pike all ready to go
16:21:27 <andymccr> for the first pike release
16:21:31 <andymccr> (which is actually the week of the PTG!)
16:21:50 <andymccr> we have released a new stable/newton & stable/ocata so hopefully we will see a lot fewer problems
16:22:06 <andymccr> the last release for both was pretty unstable,but we've ironed out the issues so we should be in a good place again!
16:22:55 <mhayden> yay!
16:22:59 <andymccr> but from releases that is all - feature freeze is in 2 weeks - so i expect a stronger focus now on testing/bug fixes and just general stabilization
16:23:10 <spotz> andymccr: speaking of newton say some issues go past in the channel last night with repos
16:23:16 <spotz> err ocata actually
16:23:35 <andymccr> spotz: ahh - which issues?
16:25:04 <spotz> don't see it any ore in my scroll, but it was calling a repo I hadn't heard of before
16:25:47 <odyssey4me> maybe to do with the calico/felix thing which just came up?
16:26:05 <spotz> Yes!!!!
16:26:12 <evrardjp> oh, what changed?
16:26:13 <odyssey4me> yeah, that fix is in the next release
16:26:15 <spotz> I knew it was something catty:)
16:26:26 <andymccr> hahaha
16:26:27 <andymccr> ok cool
16:26:31 <andymccr> that should be fixed now with the new release
16:26:40 <andymccr> thanks to logan- for fixing it before i even noticed :P
16:27:20 <spotz> Yeah logan-!!!!
16:27:34 <spotz> So that brings us to....
16:27:38 <spotz> #topic Blueprint work
16:28:00 <andymccr> ok so i think we're doing ok - i started getting some of the wsgi work moving last week, thanks for the reviews
16:28:06 <andymccr> more to come - i anticipate to finish it before feature freeze
16:28:15 <mhayden> i pushed up a new rev of the firewall spec and asked for firewalld/iptables/nftables feedback on the ML
16:28:32 <mhayden> https://review.openstack.org/479415
16:28:37 <andymccr> #link https://review.openstack.org/#/c/479415/
16:28:57 <mhayden> no real consensus so far on the path to implementation
16:29:28 <mhayden> logan- leans towards plain iptables, evrardjp is on the fence, and nftables was brought up on the ML
16:29:39 <mhayden> i'd prefer firewalld or iptables
16:29:48 <mhayden> nftables seems a bit too modern at the moment
16:29:56 <spotz> I lean towards iptables but that's cause I'm old school:)
16:30:08 <mhayden> it is tried and true (to logan-'s point)
16:30:12 <evrardjp> nftables isn't the future?
16:30:14 <evrardjp> oh ok
16:30:21 * odyssey4me sucks at iptables - anything that's easier to follow wins in my books.
16:30:22 <mhayden> nftables is probably the future
16:30:39 <evrardjp> odyssey4me: haha welcome to the club. I'm a pf guy :p
16:30:41 <andymccr> haha yes that for me too
16:30:47 <mhayden> my money is on firewalld supporting nftables as a backend at some point
16:31:21 <evrardjp> systemd-nspawn requires nftables! <-- fake dependency just created because it is hotness.
16:31:30 <hwoarang> my only concern (which I am going to write it on the list too) is that different distros have different firewalld
16:31:40 <hwoarang> which means we get different bugs/behavior as firewalld matures
16:31:56 <odyssey4me> hmm, but will ansible mask those?
16:32:02 <evrardjp> I like the idea of being closer to core technology
16:32:12 <mhayden> odyssey4me: not necessarily
16:32:12 <odyssey4me> ie if we use the ansible module, will is disguise those issues and make life simpler for us?
16:32:22 <mhayden> i noted on the ML that different distros have different base rulesets
16:32:24 <hwoarang> depends on where this module is tested
16:32:24 <mhayden> and zones
16:32:34 <evrardjp> the problem of the ansible module is ... that it's untested on debian based distros.
16:32:41 <mhayden> and flushing a base ruleset is nontrivial
16:32:43 <evrardjp> we'll hit the bugs.
16:32:48 <odyssey4me> well, perhaps we're going to have to put this into some sort of non-voting test and drive changes upstream until it's all stabilised
16:32:49 <hwoarang> and how much maintainance we will end up doing on that module on top of our playbooks
16:33:12 <logan-> o/ oops late
16:33:12 <spotz> Should we (ok not me personally:)) maybe add the missing pieces to the module?
16:33:27 <mhayden> i might take an expedition to compare opensuse/ubuntu/centos default firewalld rulesets/zones
16:33:33 <odyssey4me> if we can play a part in improving the upstream module, that woud be best
16:33:38 <evrardjp> +1
16:34:11 <odyssey4me> even if that means we carry our fork for a while - we just make sure that every modification we have has a corresponding PR upstream
16:34:30 <odyssey4me> or mhayden carries the fork in his github org ;)
16:34:41 <evrardjp> haha, it can be included in the role
16:34:46 <evrardjp> it will automatically be loaded
16:34:54 <spotz> :)
16:35:39 <logan-> as far as the iptables stuff, i have done a lot of work on this recently for some other ansible things here. im putting together a little POC role with that stuff, probably hear more from me in the next day or so as I get it pushed up here mhayden https://github.com/logan2211/ansible-iptables
16:36:07 <evrardjp> I guess we have a winner.
16:36:09 <logan-> (dont look now it doesn't do anything)
16:36:15 <evrardjp> oh.
16:36:19 <spotz> hehe
16:37:46 <mhayden> okay, nothing else from me on the BPs ;)
16:38:05 <kysse> how about ferm?
16:38:06 <logan-> ill ping the ML and channel later today or tomorrow once its ready to look at
16:38:17 <kysse> clean and understandable syntax
16:39:04 <logan-> kysse: ++ id say ferm is the most fleshed out of the firewalld/ufw similar things
16:39:41 <spotz> Any more blueprint stuffage? cloudnull?
16:40:00 <mhayden> haven't heard of ferm til today!
16:40:01 * cloudnull is a bad person, didn't finish his spec and will be removing the hyperconverged bits.
16:40:23 <mhayden> interesting DSL
16:40:47 <spotz> Ok cloudnull is a bad boy and we'll move on
16:40:49 <andymccr> cloudnull: sad panda :(
16:40:51 <spotz> #topic Open discussion
16:40:58 <andymccr> there is always next season/cycle
16:41:11 <andymccr> ok so
16:41:14 <logan-> debops has a pretty extensive ferm role that does a nice job of abstracting the ferm config into ansible var stuff, thats worth taking a look at for ideas
16:41:21 <evrardjp> I never heard of ferm, interesting
16:42:18 <logan-> im not sure whether its preferable to work with ferm or template out iptables-save output directly though. lots of options to look at :)
16:42:39 <evrardjp> yeah, mhayden will have an interesting spike work :D
16:44:37 <mhayden> this ferm stuff does look more ansible/template friendly
16:44:55 <spotz> Keep chatting just giving a 16 minute warning:)
16:45:18 <andymccr> one note - with the PTL announcements coming up next week, i wanted to say I will not be standing for PTL for Queens cycle - I think 2 terms is a good amount of time, and it's probably good time for somebody else to give it a go and bring a new perspective.
16:45:53 <evrardjp> thanks andymccr for your PTLing!
16:46:22 <hwoarang> thank you andymccr
16:46:46 <odyssey4me> yeah, thanks andymccr - you've done well to bring us more exposure to other projects, grow our legend and keep us being talked about
16:47:18 <evrardjp> \o/
16:47:25 <logan-> yes thank you!
16:47:47 <spotz> Thanks andymccr!
16:48:39 <spotz> I guess you should officially email the list for those not here:(
16:50:29 <andymccr> spotz: perhaps :)
16:51:21 <spotz> Or you could just run again...
16:52:00 <andymccr> haha i could - at least i will still be around of course ;P
16:52:25 <evrardjp> that's good news :D
16:53:16 <hwoarang> fyi i am on holidays for the next 2 weeks so don't be alarmed if you don't see any suse patches ;p
16:53:28 <andymccr> hwoarang: enjoy!
16:53:43 <hwoarang> thank you sir
16:53:52 <logan-> hwoarang: well earned :) enjoy
16:53:56 <evrardjp> enjoy indeed!
16:54:16 <hwoarang> of course that shoudn't stop you from merging my patches in the meantime :D
16:54:21 <hwoarang> lol
16:59:20 <evrardjp> :)
16:59:22 <spotz> have a good vacation hwoarang
16:59:34 <spotz> 1 minute so I'm gonna go ahead and shut this down
16:59:36 <odyssey4me> have a great holiday hwoarang - well deserved!
16:59:40 <spotz> #endmeeting