16:10:25 <evrardjp> #startmeeting openstack_ansible_meeting
16:10:26 <openstack> Meeting started Thu Oct  5 16:10:25 2017 UTC and is due to finish in 60 minutes.  The chair is evrardjp. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:10:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:10:29 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:10:40 <evrardjp> #topic rollcall
16:11:23 <hwoarang> #info hwoarang
16:12:10 <evrardjp> am I at the right time?
16:12:24 <evrardjp> or did I confuse timezones again?
16:12:41 <evrardjp> The agenda for the meeting is set at https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:12:59 <evrardjp> Has someone something to add to the agenda?
16:13:12 <evrardjp> I'll take that as a no.
16:13:27 <evrardjp> #topic summit sydney
16:13:45 <evrardjp> don't hesitate to add your stuff on the etherpad
16:13:47 <evrardjp> #link  https://etherpad.openstack.org/p/osa-sydney-summit-planning
16:13:54 <evrardjp> anything else for the summit?
16:15:03 <evrardjp> ok next topic.
16:15:08 <evrardjp> #topic Release Planning and Decisions
16:16:11 <andymccr> o/ missed the start - sorry
16:16:14 <evrardjp> so, openstack-ansible-security and zuul v3 has delayed us since last week
16:16:32 <evrardjp> releases just merged a patch that would allow us to release
16:16:52 <evrardjp> so now the next step is getting the last +2 +w on our releases by stable team
16:17:08 <evrardjp> (we'll discuss that part in the open discussion)
16:17:32 <evrardjp> On the topic of releases still, my toolkit works and is branch independant
16:17:38 <andymccr> nice!
16:17:40 <evrardjp> I used it for releasing Newton
16:17:56 <evrardjp> it works same for master if anyone wants to do a milestone
16:18:33 <cloudnull> o/
16:18:35 <evrardjp> I didn't work on the role file sync, because it's kinda messy, and I expect this to be done either manually or we have to patch it on a case by case basis
16:18:43 <odyssey4me> o/
16:18:46 <hwoarang> o/
16:18:48 <cloudnull> yo yo.
16:18:50 <evrardjp> the work of odyssey4me in the future could help there
16:19:02 <odyssey4me> stable team? the stable team shouldn't have to review our release patches
16:19:12 <evrardjp> that's not technically true
16:19:30 <odyssey4me> it is - we do not assert the stable tag, therefore they do not need to be involved
16:19:33 <hwoarang> evrardjp: i didn't get your comment about the role file sync
16:19:36 <odyssey4me> andymccr sorted that out last cycle
16:19:50 <evrardjp> odyssey4me: oh
16:19:52 <evrardjp> I thought we had
16:20:02 <evrardjp> that's good then
16:20:03 <andymccr> yeah - they should just merge it but there is a new releases PTL so maybe just have the conversations
16:20:27 <evrardjp> I've seen tripleO just removed their stable policy too
16:20:30 <odyssey4me> if we want to assert the stable tag, that's different - but then we only assert it from this cycle forward and it doesn't affect older releases as far as I know
16:20:32 <evrardjp> ok I thought we had
16:20:42 <evrardjp> no let's keep it that way.
16:21:13 <evrardjp> hwoarang: the file sync is some code we run when we bump upstream project shas.
16:21:32 <evrardjp> basically we bump their included files in the appropriate roles (like templates)
16:21:42 <hwoarang> do you mean the sources-branch-updater?
16:21:43 <evrardjp> that could change with odyssey4me's latest changes
16:21:55 <evrardjp> hwoarang: yes it's in the sources-branch-updater script right now
16:22:01 <hwoarang> ok
16:22:13 <hwoarang> do what's the way forward
16:22:20 <hwoarang> because as you know we use that in opnfv
16:22:31 <hwoarang> we want to be able to bump roles&projects
16:22:39 <odyssey4me> evrardjp the reason that stuff was branch specific is because each series has differing files to copy to templates, and differing things to edit in those files
16:22:43 <evrardjp> that's why I'd like to have odyssey4me's opinion on the file inclusion in wheels
16:22:56 <evrardjp> odyssey4me: yes. I agree.
16:23:13 <hwoarang> *s/do/so/
16:23:23 <odyssey4me> but yeah, https://bugs.launchpad.net/nova/+bug/1718356 is trying to bring the files into the wheel instead
16:23:24 <openstack> Launchpad bug 1718356 in Ironic "Include default config files in python wheel" [Wishlist,In progress] - Assigned to Jesse Pretorius (jesse-pretorius)
16:23:25 <evrardjp> odyssey4me: could you update us on the file inclusion in wheels?
16:23:45 <evrardjp> what's the status there? I saw there were more comments
16:24:01 <odyssey4me> if you could all help rally support for this in the ML thread I'd appreciate it - http://lists.openstack.org/pipermail/openstack-dev/2017-September/122794.html
16:24:17 <odyssey4me> if you have any RDO/SUSE/Ubuntu packager contacts, please have them respond
16:24:47 * hwoarang is making a mental note
16:24:49 <odyssey4me> evrardjp right now nothing has changed - we need packagers to agree that including these files is fine
16:25:26 <hwoarang> odyssey4me: will fwd that to our cloud team, hopefully someone will reply back
16:25:47 <odyssey4me> awesome, thanks hwoarang
16:25:48 <evrardjp> odyssey4me: ok. Do we need a WG/SIG to be formed as a valid instance of that? or would an OK from each PTL/responsible would be enough?
16:26:09 <odyssey4me> an OK on the ML will do
16:26:15 <evrardjp> ok.
16:26:45 <evrardjp> #action ask RDO/SUSE/Ubuntu packager contacts to reply "OK" on http://lists.openstack.org/pipermail/openstack-dev/2017-September/122794.html
16:26:53 <evrardjp> next
16:26:56 <hwoarang> wait wait
16:26:58 <odyssey4me> I don't have the time to run a SIG for packaging, and every packager has different ways of doing things so it seems it'd be a bit of a time waster anyway.
16:27:01 * hwoarang puts his opnfv hat back
16:27:20 <hwoarang> so, in the future, will we still be able to bump packages&roles as we do today?
16:27:21 <evrardjp> still on releases topic
16:27:24 <evrardjp> yes
16:27:28 <hwoarang> ok
16:27:37 * hwoarang takes his opnfv hat off
16:27:39 <odyssey4me> yes, that will just remove some of the machinery for keeping the templates up to date
16:28:02 <hwoarang> ok thank you for the clarification
16:28:31 <evrardjp> hwoarang: the idea of writing this release toolkit was 1) refresh for me while andymccr was not there :p 2) simplifying this 3) make sure it could be externally re-used by anyone without real complexity 4) document it
16:28:49 * cloudnull is picturing what an opnfv hat looks like
16:29:08 <odyssey4me> like a cloud hat, but with more clouds
16:29:20 <evrardjp> the only part missing is a gap that odyssey4me could be filling, else we'd just keep the source branch updater for that, and fix it appropriately.
16:29:22 <hwoarang> fair enough
16:29:32 <evrardjp> so
16:29:33 <evrardjp> for releases
16:29:42 <cloudnull> https://i.pinimg.com/originals/9f/29/f4/9f29f4176afaa6fe7f20e2f3885bea8b.jpg got it
16:29:43 <evrardjp> Newton EOL is next week
16:29:53 <odyssey4me> haha
16:29:56 <evrardjp> cloudnull: that could be worse
16:30:25 <odyssey4me> RIP newton :(
16:30:44 <cloudnull> death to newton.
16:30:45 <evrardjp> so I'll try to follow our idea of 2 weeks, but like I said last week, special events mandate for a release, so this is one
16:30:47 <odyssey4me> glad to be rid of ansible 2.1 though :)
16:30:57 <evrardjp> odyssey4me: we're not at 2.4 yet :p
16:31:03 <cloudnull> glad to be rid of trusty
16:31:07 <evrardjp> cloudnull: +1
16:31:09 <odyssey4me> ah yes, that too
16:31:43 <evrardjp> so technically the next days we should have a release for "last month end of month"
16:31:51 <odyssey4me> I was surprised to still see quite a  few upstream patches going into newton still
16:32:17 <odyssey4me> evrardjp I'm not sure I understand what you mean.
16:32:21 <evrardjp> anyway, let's continue our discussion for today, you are just informed that newton will get something new.
16:32:36 <odyssey4me> Now I'm even more confused.
16:32:50 <evrardjp> let me rephrase all this conversation, without interruptions:
16:33:43 <evrardjp> 1) We should have released end of september. We didn't due to Zuul and many other issues. 2) These are on the way to get resolved. In the next days, we should have a release for all our branches
16:34:22 <odyssey4me> ah ok, so we're back on the release train is what you're saying
16:34:23 <evrardjp> 3) A few days even after that, we're gonna hit Newton-EOL. We're gonna issue yet again another release, just for newton this time, to include all the EOL tags
16:34:25 <odyssey4me> okie dokey :)
16:34:46 <evrardjp> 4) Then we can continue the release train like nothing happened, unless Zuul v3 come strike again
16:35:00 <evrardjp> that's the summary
16:35:09 <evrardjp> ok let's move to a different topic
16:35:18 <evrardjp> #topic Blueprint work
16:35:22 <evrardjp> any update here?
16:35:36 <evrardjp> or should we continue?
16:35:49 <odyssey4me> I have no particular updates at this time.
16:35:49 <evrardjp> ok let's move to a new topic
16:35:54 <cloudnull> me neither
16:36:13 <evrardjp> #topic Open discussion - Liaisons Appointement
16:36:23 <cloudnull> oooo. can someone go review https://review.openstack.org/#/c/476121/?
16:36:50 <evrardjp> After a discussion with a few of you already, I got a few liaisons in stable, vulnerability management/security, infra
16:37:05 <odyssey4me> cloudnull looks like that need evrardjp's eye?
16:37:20 <cloudnull> ++
16:37:26 <cloudnull> that's my only spec update.
16:37:31 <cloudnull> anyway, carry on
16:37:35 <evrardjp> I'd be happy if ppl interested by doing a liaison in Release/Docs/Product/I18n/Cross-Project Spec would come forward
16:37:48 <evrardjp> that's it for that topic
16:38:05 <evrardjp> (please contact me on irc)
16:38:12 <evrardjp> #topic Open Discussion - Role maturity
16:38:34 <evrardjp> conforming to what was discussed at the PTG, I need some votes on
16:38:38 <evrardjp> #link https://review.openstack.org/#/c/504279/
16:38:44 <evrardjp> thanks cloudnull for already voting on that
16:39:34 <evrardjp> When this merges, I can go forward with the list of "bad sheep" (if that translates) and send an email to the ML for a call to contributions
16:39:52 <evrardjp> the role maturity would then be updated too
16:40:06 <evrardjp> anyone has anything to add there?
16:40:18 <evrardjp> I think we can discuss in the review
16:40:28 <evrardjp> #topic Open Discussion - Meetings reduction
16:41:06 <cloudnull> I think it'd be a good idea to start working on zuulv3 configs
16:41:10 <evrardjp> I've sent a mail on the ML about the meeting reductions, nobody was strongly against, nobody talked to me against it
16:41:11 <cloudnull> for the IRR
16:41:30 <cloudnull> basically after the first switch, everything was busted.
16:41:33 <evrardjp> cloudnull: (I agree, but could we discuss that later... it's almost done)
16:41:41 <cloudnull> if we can get ahead of that for the next switch it'd be great
16:42:05 <cloudnull> even if its all still busted, it'd be good to have a head start on the busted-ness.
16:42:20 <evrardjp> #link http://lists.openstack.org/pipermail/openstack-dev/2017-October/123028.html
16:42:55 <evrardjp> we have a few cores that didn't vote on that, I am sad.
16:43:08 <evrardjp> see also
16:43:09 <evrardjp> #link https://etherpad.openstack.org/p/osa-meetings-planification
16:43:32 <evrardjp> So I suggest, starting from next week, we meet only on Tuesday 16:00 to 17:00
16:43:38 <evrardjp> UTC
16:43:45 <evrardjp> (current bug triage timeslot)
16:43:56 <hwoarang> sounds good
16:44:11 <evrardjp> next week will be bug triage as usual
16:44:49 <evrardjp> so as a reminder, we'll have bug triages every week, except last week of the month, where a community meeting would happen instead
16:45:17 <evrardjp> still on that topic, if you're interested by running those meetings (all of them), please contact me
16:45:34 <evrardjp> I'd be happy to have someone with me :)
16:46:01 <evrardjp> #action propose yourself as our next meeting organiser!
16:46:03 <evrardjp> next
16:46:15 <evrardjp> #topic Open Discussion -- for real this time
16:46:19 <evrardjp> cloudnull: ?
16:48:52 <evrardjp> cloudnull: on the Zuul v3 I agree that we should spend some cycles on it.
16:49:02 <evrardjp> The sooner the better, same as ansible 2.4
16:49:14 <cloudnull> ++
16:49:16 <cloudnull> also re: 2.4
16:49:42 <cloudnull> it looks like "- include: $playbook" is no longer supported
16:49:46 <evrardjp> yes
16:49:50 <evrardjp> import vs include
16:50:04 <evrardjp> import for static include (fast) and include for dynamic
16:50:04 <cloudnull> include still works, but yes they want us to use import now
16:50:27 <cloudnull> include: it throws a deprecation warning now.
16:50:29 <evrardjp> well we'll do with what we have. jmccrory already had a look on 2.4 with me on the ptg
16:50:36 <cloudnull> cool
16:50:46 <evrardjp> at the ptg*
16:50:57 <evrardjp> did you have anything to add?
16:51:08 <evrardjp> maybe re: hyper converged or anything?
16:52:21 <evrardjp> ok let's close the meeting if no-one has anything to add
16:52:39 <evrardjp> thanks everyone for your participation
16:52:48 <odyssey4me> thanks evrardjp
16:52:52 <evrardjp> and that's all folks!
16:52:54 <evrardjp> #endmeeting