16:29:05 <cloudnull> #startmeeting openstack_ansible_meeting
16:29:06 <openstack> Meeting started Tue May 29 16:29:05 2018 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:29:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:29:09 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:29:19 <cloudnull> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:29:32 <cloudnull> #topic roll call
16:29:36 <mnaser> o/
16:29:36 <cloudnull> o/
16:30:02 <cmart> o/
16:30:42 <cloudnull> lets give folks a couple min to roll in, i was late on getting started.
16:30:57 <odyssey4me> johnsom ah, sorry - wrong ref - it's this one: https://review.openstack.org/570914
16:32:01 <d34dh0r53> o/
16:32:08 <cloudnull> Lets get started.
16:32:09 <cloudnull> #topic Topics for Discussion
16:32:15 <cloudnull> #link https://etherpad.openstack.org/p/YVR-openstack-ansible
16:32:33 <cloudnull> ^ Summit discussion from last week
16:32:51 <cloudnull> as most should know, the summit was last week so I'm sure many of us are still recovering from that :)
16:32:57 <andymccr> o/
16:33:05 <hwoarang> o/
16:33:11 <cloudnull> topics will be a little light given the fact taht many of us were away
16:33:27 <andymccr> did we get anything out of the forum sessions etc?
16:34:06 <cloudnull> in the previous meeting we talked about the PTG, if folks can continue to add to the PTG planning etherpad it'd be great to keep momentum there
16:34:07 <cloudnull> #link https://etherpad.openstack.org/p/osa-denver-PTG-planning
16:34:27 <cloudnull> before we dive into bugs lets have a round of open discussion.
16:34:28 <andymccr> thats last denvrs :D
16:34:34 <andymccr> we'll need a denver2-PTG-planning :)
16:34:49 <mnaser> denver 2.0
16:35:00 <andymccr> Denver PTG 2 - too train, too choo.
16:35:09 <cloudnull> ops, fair enough, I'll make a new etherpad.
16:35:24 <openstackgerrit> Merged openstack/openstack-ansible-os_rally stable/ocata: Pin cmd2 to the last python2 version of the library  https://review.openstack.org/570930
16:35:43 <cloudnull> andymccr the forum discussions were good, we heard back from a few users. I think there are a acouple things we can do to help make onboarding better.
16:36:00 <andymccr> excellent!
16:36:12 <cloudnull> also there seems to be a lot of interest in documenting a brownfield deployment process
16:36:18 <cloudnull> mnaser ^
16:36:27 <cloudnull> something we talked about a the feedback session
16:36:34 <andymccr> thats pretty consistent feedback too
16:37:33 <cloudnull> we also talked to a couple users wanting a zun role for deployment.
16:37:40 <cloudnull> we worked on that while at the summit
16:37:58 <cloudnull> #link https://github.com/os-cloud/os_zun
16:38:06 <cloudnull> hopefully we can get that imported this cycle
16:38:17 <cloudnull> anyone have anything they want to talk about ?
16:38:25 <cloudnull> #topic open discussion
16:39:40 <cloudnull> Denver PTG 2.0 link
16:39:43 <cloudnull> #link https://etherpad.openstack.org/p/osa-denver-PTG-planning-2.0
16:39:44 <andymccr> haha
16:39:46 <andymccr> nice
16:40:02 <jrosser> i had very good results with the ELK stack from the ops repo, would encourage anyone else interested to give it a try
16:40:09 <cloudnull> ++
16:40:25 <jrosser> it's pretty functional with queens too
16:40:38 <cloudnull> d34dh0r53 and I were talking at the summit and discovered that most services have a profiler section
16:40:53 <cloudnull> and we should be able to publish notifications naively into ELK
16:40:54 <d34dh0r53> yes, osprofiler looks interesting
16:41:12 <cmart> (on the topic of ELK, i'm curious if anyone has connected Graylog to OSA-deployed OpenStack)
16:41:13 <cloudnull> which fits nicely into the new ELK stack
16:41:14 <d34dh0r53> https://docs.openstack.org/osprofiler/latest/
16:41:17 <odyssey4me> oh very nice :)
16:41:42 <odyssey4me> cmart I think evrardjp has done something, although he's not pushed it up as a user story yet
16:42:05 <cloudnull> example profiler config in OS services https://github.com/os-cloud/os_zun/blob/master/templates/zun.conf.j2#L2054-L2164
16:42:05 <jrosser> cmart: yes we have graylog consuming rsyslog from OSA but tbh i'm preferring the elk stuff
16:42:29 <cmart> cool. jrosser curious why, but we can take that out of band
16:42:37 <jrosser> sure, np
16:42:49 <cloudnull> this is a perfectly good time to chat about that if you want :)
16:43:03 <cloudnull> next topic is bug triage
16:43:14 <cloudnull> so we can talk about ops things for a min more or we can move right in to taht
16:43:16 <cloudnull> **that
16:43:22 <cmart> ok then. jrosser why do you prefer ELK to Graylog?
16:43:41 <jrosser> it was purely that people were more familiar wth Kibana than Graylog, nothing more than that
16:44:02 <jrosser> could get going immediatley rather than learning something new
16:44:38 <jrosser> but it seems very much a matter of personal taste
16:45:14 <cmart> yeah. IIRC Graylog now uses Elasticsearch under the hood, so the main difference would be the sorting/filtering UI
16:47:40 <cloudnull> within the recent releases of greeylog it doesn't loook like it works with ELK6
16:47:46 <cloudnull> yet
16:47:56 <odyssey4me> it'd be good to perhaps transition the elk ops playbooks to use a good elasticsearch role than can be commonly used across both implementations, and that supports building a cluster properly
16:48:26 <cloudnull> the ELK things that we've been using are all ELK 6 at this time
16:48:37 <jrosser> i did see there was a blueprint for ELK in OSA?
16:48:45 <cloudnull> odyssey4me: it]
16:48:49 <cloudnull> bah...
16:49:11 <cloudnull> odyssey4me it'd be great if there was such a role. the one from Elastic seems neglected.
16:49:27 <cloudnull> however the playbooks in the ops repo does do clustering
16:49:32 <odyssey4me> ja, I found a few that looked reasonable - but didn't spend enough time evaluating them properly
16:49:58 <odyssey4me> if there really isn't a good one, then perhaps we could curate one
16:50:07 <cloudnull> I have a 5 node cluster humming along, I think jrosser has something similar
16:50:16 <odyssey4me> very cool :)
16:50:34 <cloudnull> I do think it'd be great get some user stories published around these tools in the ops repo
16:50:47 <cloudnull> its a bit tribal knowledge at this time
16:50:49 <jrosser> yes, i just rolled the ops repo stuff straight out
16:51:15 <jrosser> i have some pending reviews to make it better in queens, it's very journal oriented atm
16:51:57 <cloudnull> #action cloudnull to review the open prs to the ELK bits in the ops repo
16:52:25 <cloudnull> anything else we want to talk about regarding the ops things?
16:52:45 <cloudnull> any other topics of conversation we want to tackle right now
16:52:51 <d34dh0r53> Yeah, the ELK spec is basically being handled in the ops repo at this point, although I think we should consider moving it out given the nature of the ops repo :)
16:53:07 <d34dh0r53> Or do some more thorough reviews of commits to the ops repo
16:53:50 <odyssey4me> well, actually we'll discuss this at the PTG, but I think we should not move anything into the integrated repo unless it's openstack and we should use user-stories and the ops repo for non-openstack things
16:53:51 <cloudnull> we cloud host the ELK things outside of the openstack namespace, or potentially setup a selective CI within ops repo to better test some of the components ?
16:54:22 <odyssey4me> otherwise the integrated repo just get jammed with more and more things which really have very little to do with the deployment of openstack
16:54:27 <d34dh0r53> Yes odyssey4me I totally agree, perhaps more CI in ops is the answer
16:54:54 <d34dh0r53> CI + documentation :)
16:55:18 <cloudnull> ok lets move on to cover some of these open bugs
16:55:42 <odyssey4me> yep, seems better to me - a basic high level view in user stories with a referral to the ops repo which contains stuff useful for multiple series
16:55:57 <cloudnull> #topic Bug Triage
16:56:01 <cloudnull> #link https://bugs.launchpad.net/openstack-ansible
16:56:29 <cloudnull> first up https://bugs.launchpad.net/openstack-ansible/+bug/1773925
16:56:30 <openstack> Launchpad bug 1773925 in openstack-ansible "ceph_client: client commands should be executed by non-root user" [Undecided,New]
16:57:13 <cloudnull> looks like we need to do some work in the ceph client role to remove root assumptions
16:57:49 <odyssey4me> well, that's true for all our playbooks actually
16:58:03 <cloudnull> I'm thinking wishlist
16:58:22 <cloudnull> given the fact we know root is documented as a requirement at this point.
17:00:40 <cloudnull> ok nextr
17:00:41 <cloudnull> https://bugs.launchpad.net/openstack-ansible/+bug/1773854
17:00:42 <openstack> Launchpad bug 1773854 in openstack-ansible "Package rdo-release-queens is not signed" [Undecided,New]
17:01:10 <cloudnull> I think there was some chatter in the channel for this today ?
17:01:17 <cloudnull> something we know about ?
17:02:45 <cloudnull> mnaser ^ ?
17:03:20 <cloudnull> I'm inclined to mark this incomplete, but i really don't know given that I dont do much with cent
17:04:15 <cloudnull> #link http://eavesdrop.openstack.org/irclogs/%23openstack-ansible/latest.log.html#t2018-05-29T08:32:23
17:04:21 <cloudnull> maybe related?
17:04:25 <cloudnull> odyssey4me >?
17:05:34 <odyssey4me> sorry, had to go to the door then the dog ran out :p
17:07:02 <odyssey4me> I have no idea - not much info provided there - no branch/tag/whatever
17:07:15 <cloudnull> yea, asked for more details.
17:07:30 <cloudnull> moving on https://bugs.launchpad.net/openstack-ansible/+bug/1773793
17:07:30 <openstack> Launchpad bug 1773793 in openstack-ansible "User Guide in OpenStack-Ansible has wrong IP address for haproxy_keepalived_internal_vip_cidr " [Undecided,New]
17:08:35 <odyssey4me> I don't really know whether that's right or not, personally. I don't know much about how that all works.
17:09:02 <odyssey4me> The var says it's a CIDR, so it seems to me the docs are right?
17:09:06 <cloudnull> I think the examples are being interpreted as literals
17:09:24 <cloudnull> we might need to add some words around that.
17:09:37 <cloudnull> looks like there's a patch provided in the bug text
17:10:08 <odyssey4me> if it works and makes people understand better, then LGTM and seems like a low-hanging-fruit thing
17:10:25 <cloudnull> ++
17:10:38 <odyssey4me> the docs source those example files, but obviously the bug reporter doesn't know that :p
17:11:08 <cloudnull> ++ confirmed and tagged
17:11:30 <cloudnull> next https://bugs.launchpad.net/openstack-ansible/+bug/1772778
17:11:31 <openstack> Launchpad bug 1772778 in openstack-ansible "skipping: no hosts matched" [Undecided,New]
17:12:00 <openstackgerrit> Maksim Malchuk proposed openstack/openstack-ansible-os_tempest master: Pin cmd2 to the last python2 version of the library  https://review.openstack.org/570960
17:12:10 <cloudnull> I assume this is something to do with the openstack_user_config
17:12:31 <cloudnull> if it works with a couple hosts then it stands to reason that its generally "working"
17:13:42 <jrosser> will --limit to the host hit any of the containers at all?
17:14:08 <odyssey4me> it won't, and that's the issue here
17:14:23 <odyssey4me> I helped this guy out on friday I think
17:14:27 <odyssey4me> lemme find the eavesdrop
17:14:39 <mnaser> I think that’s an infra issue
17:14:51 <mnaser> Regarding the rdo stuff
17:15:07 <cloudnull> mnaser orly
17:15:18 <cloudnull> something in the infra mirrors ?
17:16:28 <mnaser> No maybe like user déployer error cloudnull
17:17:02 <evrardjp> are we still talking about 1772778?
17:17:02 <cloudnull> oh, that makes a lot of sense
17:19:59 <cloudnull> yes
17:20:27 <cloudnull> marked incomplete and moving on :)
17:20:27 <evrardjp> I think it's invalid
17:20:35 <evrardjp> incomplete is fine for now
17:21:05 <cloudnull> https://bugs.launchpad.net/openstack-ansible/+bug/1706301
17:21:07 <openstack> Launchpad bug 1706301 in openstack-ansible "nova-spicehtml5proxy.service is missing exec reload and task fail" [Undecided,Incomplete] - Assigned to Major Hayden (rackerhacker)
17:21:09 <openstackgerrit> Merged openstack/openstack-ansible-tests stable/pike: Use upper constraints when installing ARA  https://review.openstack.org/570909
17:21:09 <openstackgerrit> Merged openstack/openstack-ansible-tests stable/queens: Use upper constraints when installing ARA  https://review.openstack.org/570907
17:21:10 <odyssey4me> ok, for 1772778 there's a bunch of discussion between tux__ , myself and jrosser in http://eavesdrop.openstack.org/irclogs/%23openstack-ansible/%23openstack-ansible.2018-05-23.log.html
17:21:25 <cloudnull> cool
17:21:27 <odyssey4me> perhaps a ref to that is best added to the bug for context
17:21:30 <cloudnull> will add that the bug
17:21:46 <cloudnull> last one for the day is 1706301
17:22:31 <odyssey4me> oh, when I tested a bunch of that some time ago - the vnc/spice proxies did not support reload
17:23:16 <evrardjp> ok
17:23:16 <odyssey4me> oh the real bug is further below - when you switch from one to the other, the old thing stays behind
17:23:18 <odyssey4me> I still think we should change it to run them all, and just have one as primary
17:23:43 * odyssey4me adds that to my TODO for rage patching :p
17:23:57 <tux__> I think this has been resolved https://bugs.launchpad.net/openstack-ansible/+bug/1772778
17:23:58 <openstack> Launchpad bug 1772778 in openstack-ansible "skipping: no hosts matched" [Undecided,Incomplete]
17:23:59 <odyssey4me> but yes, it'd be nice for us to do clean-up if it's switched
17:24:02 <evrardjp> I still don't know how can it be done, but okay, I trust you won't break everything :)
17:24:34 <cloudnull> odyssey4me ++ I have to agree that having the consoles just be generally available would be ideal
17:24:56 * cloudnull assigns bug to odyssey4me
17:25:01 <evrardjp> :)
17:25:58 <cloudnull> ok thats enough bugs for the day
17:26:04 <odyssey4me> evrardjp they all listen on different ports, so they can easily all run together
17:26:09 <cloudnull> #topic open discussion
17:26:10 <evrardjp> cloudnull: and the other bugs?
17:26:13 <cloudnull> anything else we ant to talk about
17:26:28 <evrardjp> https://bugs.launchpad.net/openstack-ansible/+bugs?search=Search&field.status=New
17:26:37 <cloudnull> evrardjp they're there, we're kinda running short on time
17:26:42 <evrardjp> k
17:27:43 <cloudnull> ok, welp, with that, thanks everyone!
17:27:57 <cloudnull> Have a great rest of your day
17:28:00 <cloudnull> #endmeeting