16:00:14 <mnaser> #startmeeting openstack_ansible_meeting
16:00:15 <openstack> Meeting started Tue Feb 19 16:00:14 2019 UTC and is due to finish in 60 minutes. The chair is mnaser. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:18 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:18 <guilhermesp> o/
16:00:21 <mnaser> #topic rollcall
16:00:22 <mnaser> o/
16:00:24 <evrardjp> o/
16:00:25 <admin0> \o
16:00:28 <chandankumar> \o/
16:00:39 <jrosser> hello!
16:00:54 <fnpanic> hi
16:02:38 <mnaser> #topic highlights from last week
16:02:47 <mnaser> anyone want to start sharing some of the work they did last week ? :)
16:02:59 <prometheanfire> o/
16:03:59 <guilhermesp> I think the bug squash days were a success. We should keep the mood
16:04:17 <mnaser> i think so too, it was awesome, we burned down through so much stuff
16:04:30 <mnaser> unfortunately i couldnt participate as much as i would have but hey that's life
16:04:41 <evrardjp> sorry I couldn't attend to that
16:04:49 <evrardjp> it's been epic here
16:05:08 <jrosser> the bug day was great
16:05:25 <mnaser> i think it was just fun as well because we got to hack on plenty of things and i twas pretty feel-good overall :p
16:05:25 <evrardjp> other highlights is that releasing will be easier in the future
16:05:42 <evrardjp> mnaser: damn you're hitting my FOMO nerve
16:05:42 <guilhermesp> are we going to keep the idea?
16:05:59 <mnaser> guilhermesp: i think maybe one every few weeks or so is better than like
16:06:07 <mnaser> a bug triage every meeting
16:06:15 <guilhermesp> sounds good
16:06:16 <mnaser> i dunno, thoughts?
16:06:36 <guilhermesp> I think once a month and keep the bug triage every meeting
16:07:27 <mnaser> yeah maybe we could do that
16:07:46 <evrardjp> guilhermesp: some bugs need fast triaging
16:07:46 <mnaser> other than that, any other last week updates to talk about?
16:08:05 <jrosser> i have been digging at heat/magnum after a few folks had trouble with all the endpoint stuff
16:08:07 <guilhermesp> yes evrardjp that's why is important to keep in the meeting too every week
16:08:29 <evrardjp> guilhermesp: sorry I don't know why I pinged you.. We were agreeing with each other :)
16:08:45 <guilhermesp> evrardjp: np!
16:09:13 <guilhermesp> jrosser: I saw you asked a question in openstack-containers
16:09:22 <jrosser> yes, it's all a bit quiet in there
16:09:24 <guilhermesp> but no reply till now
16:09:45 <guilhermesp> maybe tag strigazi
16:09:45 <mnaser> jrosser: can i help?
16:09:52 <mnaser> i have contributed a bunch to magnum
16:09:58 <mnaser> i can help make the appropriate fixes if they need to be done
16:10:11 <jrosser> i'm sure, can we catch up after the meeting, i've found a few things i don't understand in the code
16:10:17 <mnaser> sure
16:10:20 <mnaser> happy to
16:10:30 <jrosser> i think i've found a bug in heat about the endpoints too
16:10:36 <odyssey4me> o/
16:10:57 <mnaser> ok, i'd be happy to ping the right people to get those fixed up
16:11:43 <chandankumar> jrosser: http://logs.openstack.org/94/630694/13/check/openstack-ansible-deploy-aio_metal_heat-centos-7/bb028ec/job-output.txt.gz#_2019-02-19_09_22_50_865174
16:12:00 <chandankumar> jrosser: is it somehthing like that on heat
16:12:36 <chandankumar> i can discuss after meeting
16:12:49 <mnaser> cool cool
16:13:22 <mnaser> #topic open discussion
16:13:42 <mnaser> i've been slowly trying to make this more office hoursy and looks like we have more .. people showing up and sticking around :)
16:14:00 <mnaser> PTG is approaching, anyone wanna volunteer setup the initial etherpad? :)
16:15:01 <guilhermesp> If I have a previous layout to be based on I can start this new etherpad mnaser
16:15:39 <mnaser> guilhermesp: https://etherpad.openstack.org/p/osa-stein-ptg => osa-train-ptg ?
16:16:48 <cloudnull> o/
16:16:56 * cloudnull late but here
16:17:30 <mnaser> #action guilhermesp create ptg etherpad
16:17:53 <mnaser> any other subjects that we wanna bring up? maybe someone can help finish the last steps of aio nspawn in gate so we can maybe do the switch this cycle?
16:17:53 <guilhermesp> ok mnaser
16:17:55 <mnaser> we're running out of time
16:20:12 <chandankumar> mnaser: are we going to built container of tempest on nspawn?
16:22:03 <odyssey4me> chandankumar we have all the bits in place, but there are a few outstanding issues with it which need addressing
16:22:19 <odyssey4me> The general plan is to move OSA to use nspawn instead of LXC for machine containers.
16:22:41 <guilhermesp> https://etherpad.openstack.org/p/osa-train-ptg WIP
16:22:56 <chandankumar> odyssey4me: is it possible to run docker temepst container with nspawn? as tripleo uses kolla container so
16:23:30 <cloudnull> chandankumar: docker no. but app container yes.
16:23:41 <odyssey4me> chandankumar it is already, yes - we already do that with lxc - however, we use it as a machine container so we add systemd into it
16:23:59 <cloudnull> systemd-nspawn is the basis for rkt, which can run application containers.
16:24:01 <odyssey4me> as cloudnull said, we could move to use an app container model
16:24:11 <odyssey4me> but that's a fair way off at this stage
16:24:19 <cloudnull> ^
16:24:19 <chandankumar> tempest is just an app, not a service, so I think it will work
16:24:29 <chandankumar> ok
16:24:50 <odyssey4me> we have a *lot* of assumptions around the services running on a full host, so the app container model does not work with OSA at this time
16:24:51 <cloudnull> that said, chandankumar if you have cycles to poke at it I'd be happy to help where I can
16:25:13 <evrardjp> I am not sure we should outright kill that idea, it's just a binary blob after all :p
16:25:14 <chandankumar> cloudnull: we are thinking to work on container support may be next cycle
16:25:15 <cloudnull> sadly my time to focus on a lot of those things has largely evaporated
16:25:35 <evrardjp> but we are basically alone though
16:25:36 <chandankumar> on os_tempest side
16:25:48 <odyssey4me> yes, doing app containers is absolutely something we've talked about, but no-one has had the cycles to put into it
16:26:11 <odyssey4me> chandankumar so if you folks have cycles to figure out a model, that'd be fantastic
16:26:17 <cloudnull> +1
16:26:57 <chandankumar> sure!
16:27:05 <jamesdenton> folks, i have to bounce out for a bit. bbiaf
16:27:12 <cloudnull> chao
16:33:34 <odyssey4me> FYI I've made some more progress on the python build simplification - just ironing out a few things before releasing them for review. Unfortunately my changes break the integrated build, so a few tweaks are still needed.
16:35:15 <odyssey4me> It's an issue with stackviz building left, which I just need a little more time on to get done.
16:37:13 <odyssey4me> Heh, I see the issue and should have a patch up to solve it a bit later.
16:40:39 <chandankumar> jrosser: still around?
16:40:51 <jrosser> yes i am
16:40:58 <chandankumar> jrosser: http://logs.openstack.org/94/630694/13/check/openstack-ansible-deploy-aio_metal_heat-centos-7/bb028ec/job-output.txt.gz#_2019-02-19_09_22_50_865174
16:41:14 <mnaser> odyssey4me: cool, when we're almost done, it would be good to get some info on that so we can replicate things across
16:41:25 <chandankumar> jrosser: can you take a look at this failure, it is related to heat endpoint
16:41:38 <jrosser> chandankumar: it is the same as other folks were seeing
16:41:46 <jrosser> after the meeting we can discuss some more
16:43:04 <chandankumar> jrosser: https://github.com/openstack/heat-tempest-plugin/blob/9ca1fc2c55bceba078a6066d6d81447b1c8644d3/heat_tempest_plugin/tests/api/test_heat_api.py#L57
16:43:18 <chandankumar> jrosser: sure
16:45:39 <mnaser> I think finding some more time to do reviews would be good too
16:49:06 <mnaser> i need to do more as well
16:49:51 <jrosser> it would be great to get more of us on the case - we've all got different experience to bring
16:54:11 <odyssey4me> mnaser yep, I'll get the standard AIO done - then work up an etherpad for the rest for everyone to climb in while I shift focus to getting the AIO used for all tests
16:54:25 <mnaser> odyssey4me: awesome
16:54:47 <chandankumar> odyssey4me: is it possible to clone only those repo which are needed for a particular scenario?
16:54:54 <chandankumar> in AIO
16:56:01 <odyssey4me> chandankumar for now, no - but I have some ideas around how we could achieve that which we can discuss at the PTG, assuming I'm able to get there - unfortunately my travel is not yet approved
16:56:22 * chandankumar is not going due to us visa issue :-)
16:56:49 <odyssey4me> chandankumar :( At the next one then.
16:57:03 <chandankumar> odyssey4me: yes for sure :-)
17:13:52 <odyssey4me> mnaser did I miss the end of the meeting?
17:14:01 <mnaser> #endmeeting