15:00:34 <noonedeadpunk> #startmeeting openstack_ansible_meeting
15:00:34 <opendevmeet> Meeting started Tue Dec 14 15:00:34 2021 UTC and is due to finish in 60 minutes.  The chair is noonedeadpunk. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:34 <opendevmeet> The meeting name has been set to 'openstack_ansible_meeting'
15:00:46 <noonedeadpunk> #topic office hours
15:00:55 <noonedeadpunk> o/
15:00:57 <damiandabrowski[m]> hey!
15:01:08 <jrosser> o/ hello
15:02:30 <noonedeadpunk> tbh I don't have too much things to discuss:)
15:02:49 <noonedeadpunk> except maybe if it's worth doing rc2 just for gitreview files...
15:03:20 <spatel> hey
15:03:23 <noonedeadpunk> I actually talked to releases team and from their POV we can just have stable tag based just on RC1
15:03:44 <spatel> are we safe with apache log4j ?
15:03:59 <noonedeadpunk> openstack doesn't use java, so...
15:04:27 <noonedeadpunk> can't say so regarding ELK or graylog, but that's quite different stories
15:04:47 <noonedeadpunk> Oh, also I think we should finally EOL ocata https://review.opendev.org/c/openstack/openstack-ansible/+/795690
15:05:20 <noonedeadpunk> And I'm also thinking that time for pike and might be queens?
15:06:28 <mgariepy> graylog have some fixes.
15:07:26 <noonedeadpunk> ah, and gerrit ofc
15:08:41 <noonedeadpunk> Once https://review.opendev.org/c/openstack/openstack-ansible/+/821476 land we should be able to land upcoming changes. jrosser has started with dropping CentOS 8, Debian 10 and Ubuntu bionic support
15:08:51 <noonedeadpunk> Which is really good and worthy cleanup
15:09:03 <damiandabrowski[m]> actually i wonder how many releases are we obligated to support? or it depend entirely on us?
15:09:44 <noonedeadpunk> Eventually we follow https://releases.openstack.org/ for maintained state
15:09:53 <noonedeadpunk> regarding EOL - it's up to projects
15:09:56 <jrosser> we need to have some sort of decision / "words in a release note" about what we do with centos-8 on stable branches
15:10:22 <jrosser> as i think the infra people are talking about removing the ci images soon
15:10:58 <noonedeadpunk> I'd say we just stop testing it there
15:12:06 <noonedeadpunk> and reno could be also like that "With CentOS 8 EOL we stop completing CI testing for this Operating System. It is highly recommended to upgrade to one of the supported systems"
15:12:09 <damiandabrowski[m]> ah, so IMO we may mark pike and queens EOL ;)
15:13:18 <noonedeadpunk> damiandabrowski[m]: I believe that Octavia have already EOLed even stein
15:13:35 <noonedeadpunk> they're kind of leaders for keeping minimal releases even in EM state
15:16:09 <noonedeadpunk> jrosser: mgariepy wdyt about eoling pike/queens?
15:16:33 <jrosser> i would be OK with that - we don't see anyone submitting fixes
15:17:09 <mgariepy> i'm also ok with this. and if we do see some stuff that really need fixing we can always fix it..
15:17:33 <noonedeadpunk> we won't be able to backport, but I doubt we will anyway
15:17:52 <noonedeadpunk> looking at review dashboard we have some fixes for Rocky that we can't merge for quite a while
15:18:44 <noonedeadpunk> mainly because tempest is broken... https://review.opendev.org/c/openstack/openstack-ansible-os_tempest/+/782990
15:19:14 <noonedeadpunk> #agreed EOL Pike and Queens
15:20:31 <noonedeadpunk> oh, eventually with that I was also thinking that we should change landing page of our docs for stable branches
15:20:54 <damiandabrowski[m]> maybe it's the right time to announce how many releases we're going to support? just to make it official and predictable
15:20:59 <noonedeadpunk> and leave there only current release data
15:21:59 <noonedeadpunk> We _really_ support only releases that OpenStack considers as maintained
15:22:12 <noonedeadpunk> As for EM, it's more like security patching
15:23:04 <noonedeadpunk> So we jsut follow openstack state here https://docs.openstack.org/project-team-guide/stable-branches.html#maintenance-phases
15:23:28 <noonedeadpunk> as for number of releases in EM - that's good question. I won't them call supported though :D
15:23:43 <jrosser> its a good time to clean up - there are relatively few outstanding stable branch patches
15:24:39 <noonedeadpunk> I'd say we can probably carry 3 releases in EM for sure?
15:25:19 <noonedeadpunk> or actually 4 I guess now (as U is in EM now)
15:25:28 <noonedeadpunk> it's a bit harder as we're trailing
15:26:19 <noonedeadpunk> jrosser: the obvious problem is with https://review.opendev.org/c/openstack/openstack-ansible-os_almanach/+/658585
15:26:25 <noonedeadpunk> as we've retired repo
15:26:33 <noonedeadpunk> so we don't have access to abandon it...
15:26:43 * noonedeadpunk reaching infra-rrot
15:26:46 <jrosser> we can ask in #opendev to get those patches abandoned
15:26:47 <noonedeadpunk> *root
15:26:53 <jrosser> yep
15:27:21 <noonedeadpunk> Would be also great to clean-up master but well...
15:27:30 <noonedeadpunk> we have tons of leftovers there...
15:27:52 <damiandabrowski[m]> keeping 3-4 EM releases is fine to me
15:30:56 <noonedeadpunk> ok, great
15:31:01 <noonedeadpunk> will prepare patches then
15:37:58 <noonedeadpunk> eventually I hope that with left focal and debian 11 (and centos 8-stream) we will be able to have ansible-core 2.12....
15:38:37 <noonedeadpunk> not sure if 8-stream does have libselinux for py38 but we can probably have some nasty workaround for it....
15:38:53 <jrosser> there was a pip module i think?
15:39:14 <jrosser> https://pypi.org/project/selinux/
15:39:55 <noonedeadpunk> well it doesn't look too promising tbh....
15:40:21 <noonedeadpunk> unfortunatelly zbr is not around to ask...
15:47:46 <opendevreview> Dmitriy Rabotyagov proposed openstack/openstack-ansible stable/xena: [doc] Clean out project index page for stable branches  https://review.opendev.org/c/openstack/openstack-ansible/+/821720
15:49:50 <opendevreview> Dmitriy Rabotyagov proposed openstack/openstack-ansible stable/wallaby: [doc] Clean out project index page for stable branches  https://review.opendev.org/c/openstack/openstack-ansible/+/821723
15:51:09 <opendevreview> Dmitriy Rabotyagov proposed openstack/openstack-ansible stable/xena: [doc] Clean out project index page for stable branches  https://review.opendev.org/c/openstack/openstack-ansible/+/821720
15:51:30 <opendevreview> Dmitriy Rabotyagov proposed openstack/openstack-ansible stable/wallaby: [doc] Clean out project index page for stable branches  https://review.opendev.org/c/openstack/openstack-ansible/+/821723
15:51:33 <noonedeadpunk> sorry, updated a bit
15:52:04 <noonedeadpunk> as we already have that format for R->V
15:52:16 <noonedeadpunk> only missed that for W and X
15:54:16 <opendevreview> Dmitriy Rabotyagov proposed openstack/openstack-ansible master: [doc] Update stable releases support status  https://review.opendev.org/c/openstack/openstack-ansible/+/821726
15:59:58 <noonedeadpunk> #endmeeting